RDC port change

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

On my internal network (not dealing with routers or 'extra'net at all....

I need to change the listening port for RDC on this xp pro system. (I have 2
of the exact same systems, btw. On the second system, the problem I am
having here does not exist, I can change the port and it works just fine)

I know how to change the listening port. I have done so on several systems..
On this system, I change the port and then reboot it. I go back into regedit
and it says the port is changed.
But I cannot connect to it on that port. It simply times out with no
connection.
If I change the port back to the default (3389) and make NO other changes,
then it works just fine.

If I go to the other system and change the port in exactly the same way, it
works fine.. I can open the RDC client and connect with no issue (the
connection is in the form of "this-PC:3391" ) where 3391 is the
# of the port I have changed it to and this-pc is the name of the PC I am
attaching to...

I have also tried using the IP address of the system to no avail.
I can ping this-pc with no problem. This-pc attaches to the network and is
fine..

It simply will not work if I am using any other than the default port.

Everything IS configured right.

I do the exact same thing on 2 different systems. One works correctly, one
does not. (attaching from a 3rd system)

The 'bad' system works with the default port of 3389 but does not work with
any other port.

I change the port.. I then reboot the system.
It IS configured to allow remote access
it is XP pro, SP2 with all the updates.

Anyone ever hear of something like this? Any ideas how to fix it?

thanks
11 answers Last reply
More about port change
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Reply to message from "markus" <mark@nospam.com> (Thu, 09 Jun 2005 20:29:58) about "RDC
    port change":

    > On my internal network (not dealing with routers or 'extra'net at all....

    > I need to change the listening port for RDC on this xp pro system. (I have 2 of the
    > exact same systems, btw. On the second system, the problem I am having here does not
    > exist, I can change the port and it works just fine)

    > I know how to change the listening port. I have done so on several systems.. On this
    > system, I change the port and then reboot it. I go back into regedit and it says the
    > port is changed. But I cannot connect to it on that port. It simply times out with no
    > connection. If I change the port back to the default (3389) and make NO other changes,
    > then it works just fine.

    > If I go to the other system and change the port in exactly the same way, it works
    > fine.. I can open the RDC client and connect with no issue (the connection is in the
    > form of "this-PC:
    > 3391" ) where 3391 is the
    > # of the port I have changed it to and this-pc is the name of the PC I am attaching
    > to...

    > I have also tried using the IP address of the system to no avail. I can ping this-pc
    > with no problem. This-pc attaches to the network and is fine..

    > It simply will not work if I am using any other than the default port.

    > Everything IS configured right.

    > I do the exact same thing on 2 different systems. One works correctly, one does not.
    > (attaching from a 3rd system)

    > The 'bad' system works with the default port of 3389 but does not work with any other
    > port.

    > I change the port.. I then reboot the system. It IS configured to allow remote access
    > it is XP pro, SP2 with all the updates.

    > Anyone ever hear of something like this? Any ideas how to fix it?

    > thanks

    Are you running the Windows Firewall on the failing Pc? If so, did you modify the firewall
    "Exceptions" window to account for the new listening port?

    ------
    Al Jarvi (MS-MVP Windows Networking)

    === Posted with Qusnetsoft NewsReader 3.3 for the PocketPC
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    thanks for the response.
    As I said, it works correctly when the port is the default port 3389. So
    the firewall must be allright..and in fact it is turned off, and has been
    all thru testing. (just as a addition.. I can use VNC to connect to the
    system. The windows firewall will definately block VNC if it is turned on.
    Since VNC works, I am sure that the firewall is in fact off)

    Really, everything is configured correctly. I've done this many, many times.
    I've redone this one several times now. I can even do a netstat -a on the
    affected system, and it shows the system listening on whatever port I have
    set. There is no earthly reason the damn thing won't work.....lol I'm
    inside the corporate firewall, so that is out of the pic too...
    sometimes, I just hate computers....

    "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
    news:1118385672@SoonerAl.somewhere.net.invalid...
    > Reply to message from "markus" <mark@nospam.com> (Thu, 09 Jun 2005
    > 20:29:58) about "RDC
    > port change":
    >
    > > On my internal network (not dealing with routers or 'extra'net at
    > > all....
    >
    > > I need to change the listening port for RDC on this xp pro system. (I
    > > have 2 of the
    > > exact same systems, btw. On the second system, the problem I am having
    > > here does not
    > > exist, I can change the port and it works just fine)
    >
    > > I know how to change the listening port. I have done so on several
    > > systems.. On this
    > > system, I change the port and then reboot it. I go back into regedit and
    > > it says the
    > > port is changed. But I cannot connect to it on that port. It simply
    > > times out with no
    > > connection. If I change the port back to the default (3389) and make NO
    > > other changes,
    > > then it works just fine.
    >
    > > If I go to the other system and change the port in exactly the same way,
    > > it works
    > > fine.. I can open the RDC client and connect with no issue (the
    > > connection is in the
    > > form of "this-PC:
    > > 3391" ) where 3391 is the
    > > # of the port I have changed it to and this-pc is the name of the PC I
    > > am attaching
    > > to...
    >
    > > I have also tried using the IP address of the system to no avail. I can
    > > ping this-pc
    > > with no problem. This-pc attaches to the network and is fine..
    >
    > > It simply will not work if I am using any other than the default port.
    >
    > > Everything IS configured right.
    >
    > > I do the exact same thing on 2 different systems. One works correctly,
    > > one does not.
    > > (attaching from a 3rd system)
    >
    > > The 'bad' system works with the default port of 3389 but does not work
    > > with any other
    > > port.
    >
    > > I change the port.. I then reboot the system. It IS configured to allow
    > > remote access
    > > it is XP pro, SP2 with all the updates.
    >
    > > Anyone ever hear of something like this? Any ideas how to fix it?
    >
    > > thanks
    >
    > Are you running the Windows Firewall on the failing Pc? If so, did you
    > modify the firewall
    > "Exceptions" window to account for the new listening port?
    >
    > ------
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > === Posted with Qusnetsoft NewsReader 3.3 for the PocketPC
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Why do you need to change the listening port? The reason I ask is that you can address the PC
    internally over your local LAN using TCP Port 3389 and it works... So, are you changing because you
    need remote access? If so, why not VPN into your corporate network and access the PC using the
    default port.

    Beyond that it still, at least to me, sounds like there is a software firewall, or some other
    security software program, running on that PC that is blocking the RDP connection...

    --

    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...


    "markus" <mark@nospam.com> wrote in message news:ODycdRXbFHA.3032@TK2MSFTNGP10.phx.gbl...
    > thanks for the response.
    > As I said, it works correctly when the port is the default port 3389. So the firewall must be
    > allright..and in fact it is turned off, and has been all thru testing. (just as a addition.. I can
    > use VNC to connect to the system. The windows firewall will definately block VNC if it is turned
    > on. Since VNC works, I am sure that the firewall is in fact off)
    >
    > Really, everything is configured correctly. I've done this many, many times. I've redone this one
    > several times now. I can even do a netstat -a on the affected system, and it shows the system
    > listening on whatever port I have set. There is no earthly reason the damn thing won't
    > work.....lol I'm inside the corporate firewall, so that is out of the pic too...
    > sometimes, I just hate computers....
    >
    > "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
    > news:1118385672@SoonerAl.somewhere.net.invalid...
    >> Reply to message from "markus" <mark@nospam.com> (Thu, 09 Jun 2005 20:29:58) about "RDC
    >> port change":
    >>
    >> > On my internal network (not dealing with routers or 'extra'net at all....
    >>
    >> > I need to change the listening port for RDC on this xp pro system. (I have 2 of the
    >> > exact same systems, btw. On the second system, the problem I am having here does not
    >> > exist, I can change the port and it works just fine)
    >>
    >> > I know how to change the listening port. I have done so on several systems.. On this
    >> > system, I change the port and then reboot it. I go back into regedit and it says the
    >> > port is changed. But I cannot connect to it on that port. It simply times out with no
    >> > connection. If I change the port back to the default (3389) and make NO other changes,
    >> > then it works just fine.
    >>
    >> > If I go to the other system and change the port in exactly the same way, it works
    >> > fine.. I can open the RDC client and connect with no issue (the connection is in the
    >> > form of "this-PC:
    >> > 3391" ) where 3391 is the
    >> > # of the port I have changed it to and this-pc is the name of the PC I am attaching
    >> > to...
    >>
    >> > I have also tried using the IP address of the system to no avail. I can ping this-pc
    >> > with no problem. This-pc attaches to the network and is fine..
    >>
    >> > It simply will not work if I am using any other than the default port.
    >>
    >> > Everything IS configured right.
    >>
    >> > I do the exact same thing on 2 different systems. One works correctly, one does not.
    >> > (attaching from a 3rd system)
    >>
    >> > The 'bad' system works with the default port of 3389 but does not work with any other
    >> > port.
    >>
    >> > I change the port.. I then reboot the system. It IS configured to allow remote access
    >> > it is XP pro, SP2 with all the updates.
    >>
    >> > Anyone ever hear of something like this? Any ideas how to fix it?
    >>
    >> > thanks
    >>
    >> Are you running the Windows Firewall on the failing Pc? If so, did you modify the firewall
    >> "Exceptions" window to account for the new listening port?
    >>
    >> ------
    >> Al Jarvi (MS-MVP Windows Networking)
    >>
    >> === Posted with Qusnetsoft NewsReader 3.3 for the PocketPC
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    yep, I need to change the listening port because we have 3 remote users who
    need to remote into their PC's. VPN is just not an option.
    another kicker is that I can telnet into the affected pc on whatever port I
    setup and that works fine. It's not a firewall problem... maybe time to
    reinstall windows, as it makes no sense.

    "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
    news:eKihaLbbFHA.1456@TK2MSFTNGP15.phx.gbl...
    > Why do you need to change the listening port? The reason I ask is that you
    > can address the PC internally over your local LAN using TCP Port 3389 and
    > it works... So, are you changing because you need remote access? If so,
    > why not VPN into your corporate network and access the PC using the
    > default port.
    >
    > Beyond that it still, at least to me, sounds like there is a software
    > firewall, or some other security software program, running on that PC that
    > is blocking the RDP connection...
    >
    > --
    >
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual
    > benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights...
    >
    >
    > "markus" <mark@nospam.com> wrote in message
    > news:ODycdRXbFHA.3032@TK2MSFTNGP10.phx.gbl...
    >> thanks for the response.
    >> As I said, it works correctly when the port is the default port 3389. So
    >> the firewall must be allright..and in fact it is turned off, and has been
    >> all thru testing. (just as a addition.. I can use VNC to connect to the
    >> system. The windows firewall will definately block VNC if it is turned
    >> on. Since VNC works, I am sure that the firewall is in fact off)
    >>
    >> Really, everything is configured correctly. I've done this many, many
    >> times. I've redone this one several times now. I can even do a netstat -a
    >> on the affected system, and it shows the system listening on whatever
    >> port I have set. There is no earthly reason the damn thing won't
    >> work.....lol I'm inside the corporate firewall, so that is out of the
    >> pic too...
    >> sometimes, I just hate computers....
    >>
    >> "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
    >> news:1118385672@SoonerAl.somewhere.net.invalid...
    >>> Reply to message from "markus" <mark@nospam.com> (Thu, 09 Jun 2005
    >>> 20:29:58) about "RDC
    >>> port change":
    >>>
    >>> > On my internal network (not dealing with routers or 'extra'net at
    >>> > all....
    >>>
    >>> > I need to change the listening port for RDC on this xp pro system. (I
    >>> > have 2 of the
    >>> > exact same systems, btw. On the second system, the problem I am having
    >>> > here does not
    >>> > exist, I can change the port and it works just fine)
    >>>
    >>> > I know how to change the listening port. I have done so on several
    >>> > systems.. On this
    >>> > system, I change the port and then reboot it. I go back into regedit
    >>> > and it says the
    >>> > port is changed. But I cannot connect to it on that port. It simply
    >>> > times out with no
    >>> > connection. If I change the port back to the default (3389) and make
    >>> > NO other changes,
    >>> > then it works just fine.
    >>>
    >>> > If I go to the other system and change the port in exactly the same
    >>> > way, it works
    >>> > fine.. I can open the RDC client and connect with no issue (the
    >>> > connection is in the
    >>> > form of "this-PC:
    >>> > 3391" ) where 3391 is the
    >>> > # of the port I have changed it to and this-pc is the name of the PC I
    >>> > am attaching
    >>> > to...
    >>>
    >>> > I have also tried using the IP address of the system to no avail. I
    >>> > can ping this-pc
    >>> > with no problem. This-pc attaches to the network and is fine..
    >>>
    >>> > It simply will not work if I am using any other than the default port.
    >>>
    >>> > Everything IS configured right.
    >>>
    >>> > I do the exact same thing on 2 different systems. One works correctly,
    >>> > one does not.
    >>> > (attaching from a 3rd system)
    >>>
    >>> > The 'bad' system works with the default port of 3389 but does not work
    >>> > with any other
    >>> > port.
    >>>
    >>> > I change the port.. I then reboot the system. It IS configured to
    >>> > allow remote access
    >>> > it is XP pro, SP2 with all the updates.
    >>>
    >>> > Anyone ever hear of something like this? Any ideas how to fix it?
    >>>
    >>> > thanks
    >>>
    >>> Are you running the Windows Firewall on the failing Pc? If so, did you
    >>> modify the firewall
    >>> "Exceptions" window to account for the new listening port?
    >>>
    >>> ------
    >>> Al Jarvi (MS-MVP Windows Networking)
    >>>
    >>> === Posted with Qusnetsoft NewsReader 3.3 for the PocketPC
    >>
    >>
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    What kind of router is your network front end to the internet? The reason I ask is you might try
    port redirection through the router...

    Example:

    TCP Port 3389 -> TCP Port 3389 PC1
    TCP Port 3390 -> TCP Port 3389 PC2
    TCP Port 3391 -> TCP Port 3389 PC3
    Etc...

    See this illustrated on this page for both the old Windows ICF and a Linksys BEFSR41...

    http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html

    Another alternative, and one which I use, is through a SSH tunnel...

    http://theillustratednetwork.mvps.org/RemoteDesktop/SSH-RDP-VNC/RemoteDesktopVNCandSSH.html

    --

    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...


    "markus" <mark@nospam.com> wrote in message news:e%23RxrQebFHA.3492@TK2MSFTNGP14.phx.gbl...
    > yep, I need to change the listening port because we have 3 remote users who need to remote into
    > their PC's. VPN is just not an option.
    > another kicker is that I can telnet into the affected pc on whatever port I setup and that works
    > fine. It's not a firewall problem... maybe time to reinstall windows, as it makes no sense.
    >
    > "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
    > news:eKihaLbbFHA.1456@TK2MSFTNGP15.phx.gbl...
    >> Why do you need to change the listening port? The reason I ask is that you can address the PC
    >> internally over your local LAN using TCP Port 3389 and it works... So, are you changing because
    >> you need remote access? If so, why not VPN into your corporate network and access the PC using
    >> the default port.
    >>
    >> Beyond that it still, at least to me, sounds like there is a software firewall, or some other
    >> security software program, running on that PC that is blocking the RDP connection...
    >>
    >> --
    >>
    >> Al Jarvi (MS-MVP Windows Networking)
    >>
    >> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    >> The MS-MVP Program - http://mvp.support.microsoft.com
    >> This posting is provided "AS IS" with no warranties, and confers no rights...
    >>
    >>
    >> "markus" <mark@nospam.com> wrote in message news:ODycdRXbFHA.3032@TK2MSFTNGP10.phx.gbl...
    >>> thanks for the response.
    >>> As I said, it works correctly when the port is the default port 3389. So the firewall must be
    >>> allright..and in fact it is turned off, and has been all thru testing. (just as a addition.. I
    >>> can use VNC to connect to the system. The windows firewall will definately block VNC if it is
    >>> turned on. Since VNC works, I am sure that the firewall is in fact off)
    >>>
    >>> Really, everything is configured correctly. I've done this many, many times. I've redone this
    >>> one several times now. I can even do a netstat -a on the affected system, and it shows the
    >>> system listening on whatever port I have set. There is no earthly reason the damn thing won't
    >>> work.....lol I'm inside the corporate firewall, so that is out of the pic too...
    >>> sometimes, I just hate computers....
    >>>
    >>> "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
    >>> news:1118385672@SoonerAl.somewhere.net.invalid...
    >>>> Reply to message from "markus" <mark@nospam.com> (Thu, 09 Jun 2005 20:29:58) about "RDC
    >>>> port change":
    >>>>
    >>>> > On my internal network (not dealing with routers or 'extra'net at all....
    >>>>
    >>>> > I need to change the listening port for RDC on this xp pro system. (I have 2 of the
    >>>> > exact same systems, btw. On the second system, the problem I am having here does not
    >>>> > exist, I can change the port and it works just fine)
    >>>>
    >>>> > I know how to change the listening port. I have done so on several systems.. On this
    >>>> > system, I change the port and then reboot it. I go back into regedit and it says the
    >>>> > port is changed. But I cannot connect to it on that port. It simply times out with no
    >>>> > connection. If I change the port back to the default (3389) and make NO other changes,
    >>>> > then it works just fine.
    >>>>
    >>>> > If I go to the other system and change the port in exactly the same way, it works
    >>>> > fine.. I can open the RDC client and connect with no issue (the connection is in the
    >>>> > form of "this-PC:
    >>>> > 3391" ) where 3391 is the
    >>>> > # of the port I have changed it to and this-pc is the name of the PC I am attaching
    >>>> > to...
    >>>>
    >>>> > I have also tried using the IP address of the system to no avail. I can ping this-pc
    >>>> > with no problem. This-pc attaches to the network and is fine..
    >>>>
    >>>> > It simply will not work if I am using any other than the default port.
    >>>>
    >>>> > Everything IS configured right.
    >>>>
    >>>> > I do the exact same thing on 2 different systems. One works correctly, one does not.
    >>>> > (attaching from a 3rd system)
    >>>>
    >>>> > The 'bad' system works with the default port of 3389 but does not work with any other
    >>>> > port.
    >>>>
    >>>> > I change the port.. I then reboot the system. It IS configured to allow remote access
    >>>> > it is XP pro, SP2 with all the updates.
    >>>>
    >>>> > Anyone ever hear of something like this? Any ideas how to fix it?
    >>>>
    >>>> > thanks
    >>>>
    >>>> Are you running the Windows Firewall on the failing Pc? If so, did you modify the firewall
    >>>> "Exceptions" window to account for the new listening port?
    >>>>
    >>>> ------
    >>>> Al Jarvi (MS-MVP Windows Networking)
    >>>>
    >>>> === Posted with Qusnetsoft NewsReader 3.3 for the PocketPC
    >>>
    >>>
    >>
    >>
    >
    >
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    For port redirectioin to work, UpnP has to be turned on. No experience with
    that, except I've always heard to be very very leary about it......? look
    at this.. http://www.goland.org/Tech/upnp_security_flaws.htm

    As for the SSH, I use SSh myself and for my clients where I can. I like
    WINSSH from bitvise. not free, but nice and a very nice client too.
    Supports tftp, automatically opens an RDC connection for you... etc.

    But these guys don't want to spend any money.....
    and, the real kicker, and maybe you can give some advice on this, is that
    the owner uses a Powerbook at home and needs to attach (rdc) to his work
    system. There is a mac client, so that works fine....
    But I can't find a MAC client to connect to the SSH server (Im no expert on
    SSH)....
    nor can i find a way, using SBS2003 and RWW, for a mac to to be able to do
    remote control...... It requires an active x control and I know of no way to
    get a mac to use an active x control. Is there a way to this?

    By the way lol, the problem with the RDC port is fixed, it seems....
    Today, I connected to the server at the problem office. used WINSSH. From
    there I VNC'd to the problem PC.
    I also downloaded portQuery from MS. A useful little program... anyway, i
    VNC'd to the bad PC, changed the port number and then rebooted
    it........................I then VNC'd back into it and logged on as the
    regular user.
    back at my home PC, i then tried to connect to it via RDC...... no go.
    back at the w/s, at command prompt, I ran netstat -a It told
    me the system was listening on 3391 Hmmm
    back at the server, at a command prompt, I type telnet thatpc
    3391 I'm attached, no problem.. ok, then it's working, right?
    back at home, tried RDC in again.... no go, times out, cant connect....

    Back at the server, I run portquery, put in the IP and
    port...................cant connect....
    I say WTF????? and other colorful epethets (sp)... and try portquery
    again..... it works........wow
    back at home, i rdc in. it works.. from other pc's, it
    works................the sun comes out, the flowers bloom...........and mine
    is not to wonder why. end of story.


    "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
    news:u0y%23WVebFHA.1044@TK2MSFTNGP10.phx.gbl...
    > What kind of router is your network front end to the internet? The reason
    > I ask is you might try port redirection through the router...
    >
    > Example:
    >
    > TCP Port 3389 -> TCP Port 3389 PC1
    > TCP Port 3390 -> TCP Port 3389 PC2
    > TCP Port 3391 -> TCP Port 3389 PC3
    > Etc...
    >
    > See this illustrated on this page for both the old Windows ICF and a
    > Linksys BEFSR41...
    >
    > http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html
    >
    > Another alternative, and one which I use, is through a SSH tunnel...
    >
    > http://theillustratednetwork.mvps.org/RemoteDesktop/SSH-RDP-VNC/RemoteDesktopVNCandSSH.html
    >
    > --
    >
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual
    > benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights...
    >
    >
    > "markus" <mark@nospam.com> wrote in message
    > news:e%23RxrQebFHA.3492@TK2MSFTNGP14.phx.gbl...
    >> yep, I need to change the listening port because we have 3 remote users
    >> who need to remote into their PC's. VPN is just not an option.
    >> another kicker is that I can telnet into the affected pc on whatever port
    >> I setup and that works fine. It's not a firewall problem... maybe time to
    >> reinstall windows, as it makes no sense.
    >>
    >> "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
    >> news:eKihaLbbFHA.1456@TK2MSFTNGP15.phx.gbl...
    >>> Why do you need to change the listening port? The reason I ask is that
    >>> you can address the PC internally over your local LAN using TCP Port
    >>> 3389 and it works... So, are you changing because you need remote
    >>> access? If so, why not VPN into your corporate network and access the PC
    >>> using the default port.
    >>>
    >>> Beyond that it still, at least to me, sounds like there is a software
    >>> firewall, or some other security software program, running on that PC
    >>> that is blocking the RDP connection...
    >>>
    >>> --
    >>>
    >>> Al Jarvi (MS-MVP Windows Networking)
    >>>
    >>> Please post *ALL* questions and replies to the news group for the mutual
    >>> benefit of all of us...
    >>> The MS-MVP Program - http://mvp.support.microsoft.com
    >>> This posting is provided "AS IS" with no warranties, and confers no
    >>> rights...
    >>>
    >>>
    >>> "markus" <mark@nospam.com> wrote in message
    >>> news:ODycdRXbFHA.3032@TK2MSFTNGP10.phx.gbl...
    >>>> thanks for the response.
    >>>> As I said, it works correctly when the port is the default port 3389.
    >>>> So the firewall must be allright..and in fact it is turned off, and has
    >>>> been all thru testing. (just as a addition.. I can use VNC to connect
    >>>> to the system. The windows firewall will definately block VNC if it is
    >>>> turned on. Since VNC works, I am sure that the firewall is in fact off)
    >>>>
    >>>> Really, everything is configured correctly. I've done this many, many
    >>>> times. I've redone this one several times now. I can even do a
    >>>> netstat -a on the affected system, and it shows the system listening on
    >>>> whatever port I have set. There is no earthly reason the damn thing
    >>>> won't work.....lol I'm inside the corporate firewall, so that is out
    >>>> of the pic too...
    >>>> sometimes, I just hate computers....
    >>>>
    >>>> "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
    >>>> news:1118385672@SoonerAl.somewhere.net.invalid...
    >>>>> Reply to message from "markus" <mark@nospam.com> (Thu, 09 Jun 2005
    >>>>> 20:29:58) about "RDC
    >>>>> port change":
    >>>>>
    >>>>> > On my internal network (not dealing with routers or 'extra'net at
    >>>>> > all....
    >>>>>
    >>>>> > I need to change the listening port for RDC on this xp pro system.
    >>>>> > (I have 2 of the
    >>>>> > exact same systems, btw. On the second system, the problem I am
    >>>>> > having here does not
    >>>>> > exist, I can change the port and it works just fine)
    >>>>>
    >>>>> > I know how to change the listening port. I have done so on several
    >>>>> > systems.. On this
    >>>>> > system, I change the port and then reboot it. I go back into regedit
    >>>>> > and it says the
    >>>>> > port is changed. But I cannot connect to it on that port. It simply
    >>>>> > times out with no
    >>>>> > connection. If I change the port back to the default (3389) and make
    >>>>> > NO other changes,
    >>>>> > then it works just fine.
    >>>>>
    >>>>> > If I go to the other system and change the port in exactly the same
    >>>>> > way, it works
    >>>>> > fine.. I can open the RDC client and connect with no issue (the
    >>>>> > connection is in the
    >>>>> > form of "this-PC:
    >>>>> > 3391" ) where 3391 is the
    >>>>> > # of the port I have changed it to and this-pc is the name of the PC
    >>>>> > I am attaching
    >>>>> > to...
    >>>>>
    >>>>> > I have also tried using the IP address of the system to no avail. I
    >>>>> > can ping this-pc
    >>>>> > with no problem. This-pc attaches to the network and is fine..
    >>>>>
    >>>>> > It simply will not work if I am using any other than the default
    >>>>> > port.
    >>>>>
    >>>>> > Everything IS configured right.
    >>>>>
    >>>>> > I do the exact same thing on 2 different systems. One works
    >>>>> > correctly, one does not.
    >>>>> > (attaching from a 3rd system)
    >>>>>
    >>>>> > The 'bad' system works with the default port of 3389 but does not
    >>>>> > work with any other
    >>>>> > port.
    >>>>>
    >>>>> > I change the port.. I then reboot the system. It IS configured to
    >>>>> > allow remote access
    >>>>> > it is XP pro, SP2 with all the updates.
    >>>>>
    >>>>> > Anyone ever hear of something like this? Any ideas how to fix it?
    >>>>>
    >>>>> > thanks
    >>>>>
    >>>>> Are you running the Windows Firewall on the failing Pc? If so, did you
    >>>>> modify the firewall
    >>>>> "Exceptions" window to account for the new listening port?
    >>>>>
    >>>>> ------
    >>>>> Al Jarvi (MS-MVP Windows Networking)
    >>>>>
    >>>>> === Posted with Qusnetsoft NewsReader 3.3 for the PocketPC
    >>>>
    >>>>
    >>>
    >>>
    >>
    >>
    >
    >
  7. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Interesting...

    Personally I have no issues with UPnP and have my router configured with UPnP enabled...

    Your right the pay SSH packages, like this one...

    http://www.wissh.com/

    ....are nice. Being a home user I look for free solutions first...:-)

    --

    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...


    "markus" <mark@nospam.com> wrote in message news:eezk5tfbFHA.3416@TK2MSFTNGP09.phx.gbl...
    > For port redirectioin to work, UpnP has to be turned on. No experience with that, except I've
    > always heard to be very very leary about it......? look at this..
    > http://www.goland.org/Tech/upnp_security_flaws.htm
    >
    > As for the SSH, I use SSh myself and for my clients where I can. I like WINSSH from bitvise. not
    > free, but nice and a very nice client too. Supports tftp, automatically opens an RDC connection
    > for you... etc.
    >
    > But these guys don't want to spend any money.....
    > and, the real kicker, and maybe you can give some advice on this, is that the owner uses a
    > Powerbook at home and needs to attach (rdc) to his work system. There is a mac client, so that
    > works fine....
    > But I can't find a MAC client to connect to the SSH server (Im no expert on SSH)....
    > nor can i find a way, using SBS2003 and RWW, for a mac to to be able to do remote control...... It
    > requires an active x control and I know of no way to get a mac to use an active x control. Is
    > there a way to this?
    >
    > By the way lol, the problem with the RDC port is fixed, it seems....
    > Today, I connected to the server at the problem office. used WINSSH. From there I VNC'd to the
    > problem PC.
    > I also downloaded portQuery from MS. A useful little program... anyway, i VNC'd to the bad PC,
    > changed the port number and then rebooted it........................I then VNC'd back into it and
    > logged on as the regular user.
    > back at my home PC, i then tried to connect to it via RDC...... no go.
    > back at the w/s, at command prompt, I ran netstat -a It told me the system was
    > listening on 3391 Hmmm
    > back at the server, at a command prompt, I type telnet thatpc 3391 I'm
    > attached, no problem.. ok, then it's working, right? back at home, tried RDC in again.... no go,
    > times out, cant connect....
    >
    > Back at the server, I run portquery, put in the IP and port...................cant connect....
    > I say WTF????? and other colorful epethets (sp)... and try portquery again..... it
    > works........wow
    > back at home, i rdc in. it works.. from other pc's, it works................the sun comes out,
    > the flowers bloom...........and mine is not to wonder why. end of story.
    >
    >
    > "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
    > news:u0y%23WVebFHA.1044@TK2MSFTNGP10.phx.gbl...
    >> What kind of router is your network front end to the internet? The reason I ask is you might try
    >> port redirection through the router...
    >>
    >> Example:
    >>
    >> TCP Port 3389 -> TCP Port 3389 PC1
    >> TCP Port 3390 -> TCP Port 3389 PC2
    >> TCP Port 3391 -> TCP Port 3389 PC3
    >> Etc...
    >>
    >> See this illustrated on this page for both the old Windows ICF and a Linksys BEFSR41...
    >>
    >> http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html
    >>
    >> Another alternative, and one which I use, is through a SSH tunnel...
    >>
    >> http://theillustratednetwork.mvps.org/RemoteDesktop/SSH-RDP-VNC/RemoteDesktopVNCandSSH.html
    >>
    >> --
    >>
    >> Al Jarvi (MS-MVP Windows Networking)
    >>
    >> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    >> The MS-MVP Program - http://mvp.support.microsoft.com
    >> This posting is provided "AS IS" with no warranties, and confers no rights...
    >>
    >>
    >> "markus" <mark@nospam.com> wrote in message news:e%23RxrQebFHA.3492@TK2MSFTNGP14.phx.gbl...
    >>> yep, I need to change the listening port because we have 3 remote users who need to remote into
    >>> their PC's. VPN is just not an option.
    >>> another kicker is that I can telnet into the affected pc on whatever port I setup and that works
    >>> fine. It's not a firewall problem... maybe time to reinstall windows, as it makes no sense.
    >>>
    >>> "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
    >>> news:eKihaLbbFHA.1456@TK2MSFTNGP15.phx.gbl...
    >>>> Why do you need to change the listening port? The reason I ask is that you can address the PC
    >>>> internally over your local LAN using TCP Port 3389 and it works... So, are you changing because
    >>>> you need remote access? If so, why not VPN into your corporate network and access the PC using
    >>>> the default port.
    >>>>
    >>>> Beyond that it still, at least to me, sounds like there is a software firewall, or some other
    >>>> security software program, running on that PC that is blocking the RDP connection...
    >>>>
    >>>> --
    >>>>
    >>>> Al Jarvi (MS-MVP Windows Networking)
    >>>>
    >>>> Please post *ALL* questions and replies to the news group for the mutual benefit of all of
    >>>> us...
    >>>> The MS-MVP Program - http://mvp.support.microsoft.com
    >>>> This posting is provided "AS IS" with no warranties, and confers no rights...
    >>>>
    >>>>
    >>>> "markus" <mark@nospam.com> wrote in message news:ODycdRXbFHA.3032@TK2MSFTNGP10.phx.gbl...
    >>>>> thanks for the response.
    >>>>> As I said, it works correctly when the port is the default port 3389. So the firewall must be
    >>>>> allright..and in fact it is turned off, and has been all thru testing. (just as a addition.. I
    >>>>> can use VNC to connect to the system. The windows firewall will definately block VNC if it is
    >>>>> turned on. Since VNC works, I am sure that the firewall is in fact off)
    >>>>>
    >>>>> Really, everything is configured correctly. I've done this many, many times. I've redone this
    >>>>> one several times now. I can even do a netstat -a on the affected system, and it shows the
    >>>>> system listening on whatever port I have set. There is no earthly reason the damn thing won't
    >>>>> work.....lol I'm inside the corporate firewall, so that is out of the pic too...
    >>>>> sometimes, I just hate computers....
    >>>>>
    >>>>> "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
    >>>>> news:1118385672@SoonerAl.somewhere.net.invalid...
    >>>>>> Reply to message from "markus" <mark@nospam.com> (Thu, 09 Jun 2005 20:29:58) about "RDC
    >>>>>> port change":
    >>>>>>
    >>>>>> > On my internal network (not dealing with routers or 'extra'net at all....
    >>>>>>
    >>>>>> > I need to change the listening port for RDC on this xp pro system. (I have 2 of the
    >>>>>> > exact same systems, btw. On the second system, the problem I am having here does not
    >>>>>> > exist, I can change the port and it works just fine)
    >>>>>>
    >>>>>> > I know how to change the listening port. I have done so on several systems.. On this
    >>>>>> > system, I change the port and then reboot it. I go back into regedit and it says the
    >>>>>> > port is changed. But I cannot connect to it on that port. It simply times out with no
    >>>>>> > connection. If I change the port back to the default (3389) and make NO other changes,
    >>>>>> > then it works just fine.
    >>>>>>
    >>>>>> > If I go to the other system and change the port in exactly the same way, it works
    >>>>>> > fine.. I can open the RDC client and connect with no issue (the connection is in the
    >>>>>> > form of "this-PC:
    >>>>>> > 3391" ) where 3391 is the
    >>>>>> > # of the port I have changed it to and this-pc is the name of the PC I am attaching
    >>>>>> > to...
    >>>>>>
    >>>>>> > I have also tried using the IP address of the system to no avail. I can ping this-pc
    >>>>>> > with no problem. This-pc attaches to the network and is fine..
    >>>>>>
    >>>>>> > It simply will not work if I am using any other than the default port.
    >>>>>>
    >>>>>> > Everything IS configured right.
    >>>>>>
    >>>>>> > I do the exact same thing on 2 different systems. One works correctly, one does not.
    >>>>>> > (attaching from a 3rd system)
    >>>>>>
    >>>>>> > The 'bad' system works with the default port of 3389 but does not work with any other
    >>>>>> > port.
    >>>>>>
    >>>>>> > I change the port.. I then reboot the system. It IS configured to allow remote access
    >>>>>> > it is XP pro, SP2 with all the updates.
    >>>>>>
    >>>>>> > Anyone ever hear of something like this? Any ideas how to fix it?
    >>>>>>
    >>>>>> > thanks
    >>>>>>
    >>>>>> Are you running the Windows Firewall on the failing Pc? If so, did you modify the firewall
    >>>>>> "Exceptions" window to account for the new listening port?
    >>>>>>
    >>>>>> ------
    >>>>>> Al Jarvi (MS-MVP Windows Networking)
    >>>>>>
    >>>>>> === Posted with Qusnetsoft NewsReader 3.3 for the PocketPC
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>
    >>>
    >>
    >>
    >
    >
  8. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Markus,

    Thanks for pointing me to the Bisvise Tunnelier SSH client. That is a great program, particularly
    with the auto launch of Remote Desktop...

    http://www.bitvise.com/tunnelier.html

    I need to figure out if I can configure it for a private/public key pair now...

    Thanks again...

    --

    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...


    "markus" <mark@nospam.com> wrote in message news:eezk5tfbFHA.3416@TK2MSFTNGP09.phx.gbl...
    > For port redirectioin to work, UpnP has to be turned on. No experience with that, except I've
    > always heard to be very very leary about it......? look at this..
    > http://www.goland.org/Tech/upnp_security_flaws.htm
    >
    > As for the SSH, I use SSh myself and for my clients where I can. I like WINSSH from bitvise. not
    > free, but nice and a very nice client too. Supports tftp, automatically opens an RDC connection
    > for you... etc.
    >
  9. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I understand the private / public key exchange is on the 'to-do' agenda but
    is not available now......
    "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
    news:%23xfTh2nbFHA.3048@TK2MSFTNGP12.phx.gbl...
    > Markus,
    >
    > Thanks for pointing me to the Bisvise Tunnelier SSH client. That is a
    > great program, particularly with the auto launch of Remote Desktop...
    >
    > http://www.bitvise.com/tunnelier.html
    >
    > I need to figure out if I can configure it for a private/public key pair
    > now...
    >
    > Thanks again...
    >
    > --
    >
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual
    > benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights...
    >
    >
    > "markus" <mark@nospam.com> wrote in message
    > news:eezk5tfbFHA.3416@TK2MSFTNGP09.phx.gbl...
    >> For port redirectioin to work, UpnP has to be turned on. No experience
    >> with that, except I've always heard to be very very leary about it......?
    >> look at this.. http://www.goland.org/Tech/upnp_security_flaws.htm
    >>
    >> As for the SSH, I use SSh myself and for my clients where I can. I like
    >> WINSSH from bitvise. not free, but nice and a very nice client too.
    >> Supports tftp, automatically opens an RDC connection for you... etc.
    >>
    >
    >
  10. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Markus,

    Actually it is available and it works well...I found this thread on their support forums...

    http://forums.bitvise.com/index.php?showtopic=397

    I have a private/public key pair setup and working using the OpenSSH for Windows server on an XP Pro
    box and the Tunnelier client...

    Cool...

    --

    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...


    "markus" <mark@nospam.com> wrote in message news:ukBtxwpbFHA.2980@TK2MSFTNGP10.phx.gbl...
    >I understand the private / public key exchange is on the 'to-do' agenda but is not available
    >now......
    >
    > "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
    > news:%23xfTh2nbFHA.3048@TK2MSFTNGP12.phx.gbl...
    >> Markus,
    >>
    >> Thanks for pointing me to the Bisvise Tunnelier SSH client. That is a great program, particularly
    >> with the auto launch of Remote Desktop...
    >>
    >> http://www.bitvise.com/tunnelier.html
    >>
    >> I need to figure out if I can configure it for a private/public key pair now...
    >>
    >> Thanks again...
    >>
    >> --
    >>
    >> Al Jarvi (MS-MVP Windows Networking)
    >>
    >> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    >> The MS-MVP Program - http://mvp.support.microsoft.com
    >> This posting is provided "AS IS" with no warranties, and confers no rights...
    >>
  11. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Oh Al, if you want a copy of WiSSH you only had to ask!
    Hit http://www.wissh.com/Contact.htm and let me know that you want a
    free eval copy. But only if you put WiSSH on your terminal server
    reference page!

    Chad

    Sooner Al [MVP] wrote:
    > Interesting...
    >
    > Personally I have no issues with UPnP and have my router configured with UPnP enabled...
    >
    > Your right the pay SSH packages, like this one...
    >
    > http://www.wissh.com/
    >
    > ...are nice. Being a home user I look for free solutions first...:-)
    >
Ask a new question

Read More

Windows XP