Sign in with
Sign up | Sign in
Your question

port 3389 Not listening remote desktop connection

Last response: in Windows XP
Share
Anonymous
July 15, 2005 12:13:37 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Im running XP Pro with SP2. I cannot get port 3389 to listen when using
Remote Desktop Connection. At this point I am at a loss. I have checked
Terminal Service Reg KEYs (all fine), Disabled Norton 2005 (made no
difference), and checked firewall settings. I am confident that it is a
problem with this particular machine, as I have no problem setting up
any of the other computers on my network. I'm guessing that for SOME
reason The remote desktop connection is not telling Terminal Services
to listen on that port. Should I reinstal SP2? Repair xp? Is there some
way to force that port to listen on an XP Pro machine?

As to my knowledge there is no TSCC availible on an XP Pro machine as
it is simply there to work with RDC.

Another thing is that I have ran RDC on this machine before, with the
same OS though another hard drive. Somewhere in the upgrade there must
have been a glitch and now i seem to be screwed. Any suggestions are
MUCH appreciated, I've spent way too many hours on this already.
Anonymous
July 15, 2005 9:23:44 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Is "Terminal Services" running on the PC?

http://theillustratednetwork.mvps.org/RemoteDesktop/Rem...

--

Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual
benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no
rights...


"coxwj" <coxwj@msn.com> wrote in message
news:1121397217.796103.311780@g43g2000cwa.googlegroups.com...
> Im running XP Pro with SP2. I cannot get port 3389 to listen when using
> Remote Desktop Connection. At this point I am at a loss. I have checked
> Terminal Service Reg KEYs (all fine), Disabled Norton 2005 (made no
> difference), and checked firewall settings. I am confident that it is a
> problem with this particular machine, as I have no problem setting up
> any of the other computers on my network. I'm guessing that for SOME
> reason The remote desktop connection is not telling Terminal Services
> to listen on that port. Should I reinstal SP2? Repair xp? Is there some
> way to force that port to listen on an XP Pro machine?
>
> As to my knowledge there is no TSCC availible on an XP Pro machine as
> it is simply there to work with RDC.
>
> Another thing is that I have ran RDC on this machine before, with the
> same OS though another hard drive. Somewhere in the upgrade there must
> have been a glitch and now i seem to be screwed. Any suggestions are
> MUCH appreciated, I've spent way too many hours on this already.
>
Anonymous
July 15, 2005 7:45:09 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

But of course.
Related resources
Anonymous
July 15, 2005 7:50:40 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Yes it's running. Thanks for that link...but I've been through it a
million times.
Anonymous
July 16, 2005 10:36:46 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Well, you might try...

1. Re-registering Remote Desktop using the command line that
follows...Reboot the PC after doing this...

regsvr32 remotepg.dll

2. Otherwise do a repair install of Windows XP.

http://michaelstevenstech.com/XPrepairinstall.htm

NOTE the warnings on the page...

--

Al Jarvi (MS-MVP Windows Networking)


Please post *ALL* questions and replies to the news group for the mutual
benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no
rights...


"coxwj" <coxwj@msn.com> wrote in message
news:1121467840.770987.43200@o13g2000cwo.googlegroups.com...
> Yes it's running. Thanks for that link...but I've been through it a
> million times.
>
Anonymous
July 18, 2005 4:21:58 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Rebooting regsvr32 had no affect. Any other suggestions before I do a
repair? I would really like to use that as a last option, as the rest
of computer has no problems at all, not to mention it is a server that
I use on a daily basis.

What about my original thread, is there a way to force that port to
listen?

Also, is this a problem that other folks do not have? I seem to find
many threads on "Port 3389 NOT LISTENING", but no real answers ever
surface, or they simply didn't enable Remote Desktop Connection in the
first place. I find it strange that instruction on setting up a RDC
often ask you to check netstat -a to see if 3389 is listening, but then
never tell you how to proceed if it is not. Am I alone on this?
Anonymous
July 19, 2005 10:23:24 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I think that the repair installation is your best option at this point. Note
the warnings on the page. I also recommend backing up sensitive data as a
precaution.

--

Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual
benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no
rights...


"coxwj" <coxwj@msn.com> wrote in message
news:1121714518.912290.20720@g49g2000cwa.googlegroups.com...
> Rebooting regsvr32 had no affect. Any other suggestions before I do a
> repair? I would really like to use that as a last option, as the rest
> of computer has no problems at all, not to mention it is a server that
> I use on a daily basis.
>
> What about my original thread, is there a way to force that port to
> listen?
>
> Also, is this a problem that other folks do not have? I seem to find
> many threads on "Port 3389 NOT LISTENING", but no real answers ever
> surface, or they simply didn't enable Remote Desktop Connection in the
> first place. I find it strange that instruction on setting up a RDC
> often ask you to check netstat -a to see if 3389 is listening, but then
> never tell you how to proceed if it is not. Am I alone on this?
>
Anonymous
July 22, 2005 12:34:02 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Go to a command prompt and type in the following

c:\>netstat -na |more

It should display what IP addresses and ports your machine is mapping.
Something like this:
Active Connections

Proto Local Address Foreign Address State
TCP 0.0.0.0:25 0.0.0.0:0 LISTENING
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING
TCP 0.0.0.0:135 0.0.0.0:0 LISTENING
TCP 0.0.0.0:443 0.0.0.0:0 LISTENING
TCP 0.0.0.0:445 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1040 0.0.0.0:0 LISTENING
TCP 0.0.0.0:1433 0.0.0.0:0 LISTENING
TCP 0.0.0.0:2967 0.0.0.0:0 LISTENING
TCP 0.0.0.0:3389 0.0.0.0:0 LISTENING
TCP 0.0.0.0:3908 0.0.0.0:0 LISTENING

Look for the one that says 3389 like what I have above. Is it listed on
yours? Is it listening? If it's not listed then TS isn't running. Let me
know.

"Sooner Al [MVP]" wrote:

> I think that the repair installation is your best option at this point. Note
> the warnings on the page. I also recommend backing up sensitive data as a
> precaution.
>
> --
>
> Al Jarvi (MS-MVP Windows Networking)
>
> Please post *ALL* questions and replies to the news group for the mutual
> benefit of all of us...
> The MS-MVP Program - http://mvp.support.microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no
> rights...
>
>
> "coxwj" <coxwj@msn.com> wrote in message
> news:1121714518.912290.20720@g49g2000cwa.googlegroups.com...
> > Rebooting regsvr32 had no affect. Any other suggestions before I do a
> > repair? I would really like to use that as a last option, as the rest
> > of computer has no problems at all, not to mention it is a server that
> > I use on a daily basis.
> >
> > What about my original thread, is there a way to force that port to
> > listen?
> >
> > Also, is this a problem that other folks do not have? I seem to find
> > many threads on "Port 3389 NOT LISTENING", but no real answers ever
> > surface, or they simply didn't enable Remote Desktop Connection in the
> > first place. I find it strange that instruction on setting up a RDC
> > often ask you to check netstat -a to see if 3389 is listening, but then
> > never tell you how to proceed if it is not. Am I alone on this?
> >
>
>
>
Anonymous
July 25, 2005 12:02:30 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

no, see that's the weird part. TS is running under services, but for
some reason port 3389 is not listing, actually, that's my whole
problem. I'm not sure what the deal is exactly. Obviously RDC is on, so
that should have told TS to listen on port 3389, but no dice. I've
thought about changing the port, but that seems like more trouble than
it's worth. Sooner AI told me to repair, but I'd rather not at this
point, seems to risky.

Any suggestions on how to manually configure TS? is that even possible
with XP Pro?
Anonymous
July 25, 2005 2:26:57 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

coxwj <coxwj@msn.com> wrote:

> no, see that's the weird part. TS is running under services, but for
> some reason port 3389 is not listing, actually, that's my whole
> problem. I'm not sure what the deal is exactly. Obviously RDC is on,
> so that should have told TS to listen on port 3389, but no dice.

What makes you think that port 3389 is not listening? Can you post here the
output of the command

netstat -ano

Have you enabled Remote Desktop in control panel System?

--
Robin Walker [MVP Networking]
rdhw@cam.ac.uk
Anonymous
July 26, 2005 10:27:50 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Why do I feel like I'm saying the same thing over and over. Port 3389
is not listed and yes RDC is enabled, which is the whole problem.
Following the steps to enable RDC have been followed to a "T" and I
can't figure out why this port won't enable. TS is running, so it
should just configure when i turn RDC on.

C:\Documents and Settings\Justin>netstat -ano

Active Connections

Proto Local Address Foreign Address State
PID
TCP 0.0.0.0:21 0.0.0.0:0 LISTENING
1252
TCP 0.0.0.0:25 0.0.0.0:0 LISTENING
1252
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING
1252
TCP 0.0.0.0:135 0.0.0.0:0 LISTENING
660
TCP 0.0.0.0:443 0.0.0.0:0 LISTENING
1252
TCP 0.0.0.0:445 0.0.0.0:0 LISTENING
4
TCP 0.0.0.0:1025 0.0.0.0:0 LISTENING
1252
TCP 0.0.0.0:2869 0.0.0.0:0 LISTENING
836
TCP 127.0.0.1:1026 0.0.0.0:0 LISTENING
2056
TCP 127.0.0.1:1032 0.0.0.0:0 LISTENING
2492
TCP 127.0.0.1:1052 127.0.0.1:1051 TIME_WAIT
0
TCP 127.0.0.1:1056 127.0.0.1:1057 ESTABLISHED
3996
TCP 127.0.0.1:1057 127.0.0.1:1056 ESTABLISHED
3996
TCP 192.168.1.98:139 0.0.0.0:0 LISTENING
4
TCP 192.168.1.98:1036 68.16.64.30:80 ESTABLISHED
2724
TCP 192.168.1.98:1054 66.166.189.67:80 TIME_WAIT
0
TCP 192.168.1.98:1060 216.239.57.147:80 ESTABLISHED
3996
TCP 192.168.1.98:1061 216.239.57.147:80 ESTABLISHED
3996
February 27, 2010 8:08:53 PM

I had this problem. After spending a day trying various things and reading various blog, discovered multiple solutions. One been the most simplest.
First, I have 2 nic cards in the server thus I went o terminal services configuration enables both nics, after this port 3389 became active and I was able to telnet from the client...great! Still had problem completing the connection due to terminal services licenses. Not having the cash, I simply uninstalled TS and re-enabled RDP,it worked. Hope this help someone.
April 26, 2011 5:27:14 PM

Here is another potential solution:

One thing to check for is if the Terminal Services has crashed. Interestingly enough, I had a system which required a complete reinstall. Not being setup to slipstream, we did it the hard way and installed from an original XP Pro disk and went through all the updates to SP3 and beyond.

Remote desktop would not function. Nothing listening on port 3389.
Review of the error log revealed this:

"Terminal Server session creation failed. The relevant status code was 0xC0000034."

The services admin component showed that the Terminal Services service was running, but in the log, it had crashed.

After looking through the net for what I could find in relation to this, there was no solution.
I did it the hard way, comparing the windows directories and searching for term* files.

It turns out that a driver file: termdd.sys was either not installed or removed by some update.
I extracted the latest copy which was found in a cab archive and copied it to Windows/System32/drivers and then rebooted.

Problem resolved.

It would have been nice, and quite a timesaver if the entry in the error log indicated that the driver termdd.sys could not be found...

Hopefully this will help someone else still using XP Pro... and I suspect that there are a lot of us out there.
August 31, 2011 9:26:31 PM

Developerx, I tried your suggestion and that got RDP going again for me. Thanks! I simply copied termdd.sys and tdtcp.sys from another working server of the same model and OS, rebooted, and I now I don't have to get back out of my chair again! I feel it's worth noting that termdd.sys WAS installed, but replacing those two files and rebooting solved my issue.
I also feel it's worth mentioning that depending on what OS you're using, you may not see port 3389 listening even if RDP is working. Port 3389 may also show up in a netstat -a as ms-wbt-server if you're running a variant of Windows Server.
October 11, 2011 5:32:58 PM

I had this exact same issue and found that the network adapter wasn't enabled for RDP. To fix it, go to Terminal Services Configuration Manager, double clck on the RDP protocol, network tab, then choose the active network adapter or adapters. This worked for me without a reboot.
November 18, 2011 5:06:14 PM

if RDP is not accessible.you can perform following registry changes.

fEnableWinStation under [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp] is set to 0.Set to back 1 again. This will enable network adapter.
!