Sign in with
Sign up | Sign in
Your question

Forcing DMA mode Primary IDE Hard Drive

Last response: in Windows XP
Share
April 6, 2004 6:39:19 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

OK, so I don't seem to be able to get XP to use DMA mode
for my Maxtor HDD. If I select "DMA if available", it's
still using PIO mode. I tried Microsoft manual
toglle/reboot that doesn't work.

My event log shows that there are disk errors, which leads
me to believe that XP is stepping down through the modes
and going to PIO. I tested the drive with Maxtor PowerMax
diag tool and it certifies the drive as Error Free.

Does anyone know how I can stop the auto-step down process
of force DAM mode on the HDD. I know DMA works for it,
Win98SE was using it before my upgrade.

Help/advice greatly appreciated.
Anonymous
April 7, 2004 3:37:22 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

"Paul" <poleary1@hotmail.com> wrote in message
news:1933601c41c1f$9e3342e0$a401280a@phx.gbl...
> OK, so I don't seem to be able to get XP to use DMA mode
> for my Maxtor HDD. If I select "DMA if available", it's
> still using PIO mode. I tried Microsoft manual
> toglle/reboot that doesn't work.
>
> My event log shows that there are disk errors, which leads
> me to believe that XP is stepping down through the modes
> and going to PIO. I tested the drive with Maxtor PowerMax
> diag tool and it certifies the drive as Error Free.
>
> Does anyone know how I can stop the auto-step down process
> of force DAM mode on the HDD. I know DMA works for it,
> Win98SE was using it before my upgrade.
>
> Help/advice greatly appreciated.

Make sure you have the proper chipset drivers installed. One of them is for
your ide controler. You can determine what chipset your main board has from
the manual. Then go to the mainboard makers web site and download the newest
drivers. A good tip off is in device manager the discription for the ide
controler mentions the brand of chipset the controler is. Mine for instance
says "nvidea Nforce2". If yours says something like "standard ide controler"
then they're most likely wrong.

Jo Bo
Anonymous
April 7, 2004 3:37:23 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Here is some info on DMa that might help it also tells
how to set it in the registry
To change DMA on your system with xp:

(A) Go to "Start" then Right Click on "My Computer" and
select "Manage" option.
(B) Click on the "Device Manager" and then Select "IDE
ATA/ATAPI controllers"
(C)Double click on the IDE controller that the drive is
attached to.
(D)Select "Advanced settings" tab and set the "Transfer
Mode" of the CD-WRITER and the CD-ROM to the different
settings.
(E) Click "OK" and perform a system restart

Windows XP will turn off DMA mode for a device after
encountering certain errors during data transfer
operations.
If more that six DMA transfer timeouts occur, Windows
will turn off DMA and use only PIO mode on that device.
In this case,
the user cannot turn on DMA for this device. The only
option for the user who wants to enable DMA mode is to
uninstall and
reinstall the device.

Windows XP downgrades the Ultra DMA transfer mode after
receiving more than six CRC errors. Whenever possible,
the operating system will step down one UDMA mode at a
time (from UDMA mode 4 to UDMA mode 3, and so on).
If the mini-IDE driver for the device does not support
stepping down transfer modes, or if the device is
running UDMA mode 0, Windows XP will step down to PIO
mode after encountering six or more CRC errors.
In this case, a system reboot should restore the
original DMA mode settings.

All CRC and timeout errors are logged in the system event
log. These types of errors could be caused by improper
mounting
or improper cabling (for example, 40-pin instead of 80-
pin cable). Or such errors could indicate imminent
hardware failure,
for example, in a hard drive or chipset.

To enable DMA mode using the registry editor GO to start
then run input regedit then go to the following key

"HKEY_LOCAL_MACHINE\SYSTEMS\CurrentControlSet\Control\Clas
s\{4D36E96A-E325-11CE-BFC1-08002BE10318}"
The Default Value should be "IDE ATA/ATAPI controllers"
Go to "0001" key if your device is on Primary IDE Chanel
or "0002" if your device is on Secondary IDE channel
and change the MasterDeviceTimingModeAllowed or
SlaveDeviceTimingModeAllowed to 0xffffffff depending if
your
device is master or slave close registry editor.
Go to device manager select "IDE ATA/ATAPI controllers"
and the corresponding IDE chanel go to "Advanced Settings"
Tab and Set Transfer Mode to PIO and then to DMA if
available again

Open Device Manager.

Double-click IDE ATA/ATAPI Controllers to display the
list of controllers and channels.

Right-click the icon for the channel to which the device
is connected, select Properties, and then click
the Advanced Settings tab.

In the Current Transfer Mode drop-down box, select "DMA
if Available" if the current setting is "PIO Only".

If the drop-down box already shows "DMA if Available" but
the current transfer mode is "PIO Only", then the
user must toggle the settings.

That is:
Change the selection from "DMA if available" to "PIO
only", and click OK. Then repeat the steps above to
change the selection to "DMA if Available".



>-----Original Message-----
>
>"Paul" <poleary1@hotmail.com> wrote in message
>news:1933601c41c1f$9e3342e0$a401280a@phx.gbl...
>> OK, so I don't seem to be able to get XP to use DMA
mode
>> for my Maxtor HDD. If I select "DMA if available", it's
>> still using PIO mode. I tried Microsoft manual
>> toglle/reboot that doesn't work.
>>
>> My event log shows that there are disk errors, which
leads
>> me to believe that XP is stepping down through the
modes
>> and going to PIO. I tested the drive with Maxtor
PowerMax
>> diag tool and it certifies the drive as Error Free.
>>
>> Does anyone know how I can stop the auto-step down
process
>> of force DAM mode on the HDD. I know DMA works for it,
>> Win98SE was using it before my upgrade.
>>
>> Help/advice greatly appreciated.
>
>Make sure you have the proper chipset drivers installed.
One of them is for
>your ide controler. You can determine what chipset your
main board has from
>the manual. Then go to the mainboard makers web site and
download the newest
>drivers. A good tip off is in device manager the
discription for the ide
>controler mentions the brand of chipset the controler
is. Mine for instance
>says "nvidea Nforce2". If yours says something
like "standard ide controler"
>then they're most likely wrong.
>
>Jo Bo
>
>
>.
>
!