Sign in with
Sign up | Sign in
Your question

USB Hard Drive no longer working

Last response: in Windows XP
Share
Anonymous
April 14, 2004 1:53:30 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I have just about exhausted every possiblility I can
think of to solve this problem. I have a Buslink Disk-On-
The-Go USB 2.0 20GB Hard Drive, that up until yesterday,
worked perfectly. It seems it stopped working after I
did a Windows Update. Now, the drive is shown in Device
Manager as an Unknown Device under the USB Controllers.
When I try to reinstall the driver, it alway comes up
that in can't find one, yet when I plug it into my laptop
and look up the driver details, I can find on this
computer exactly the same file, but it still doesn't
recognize it. System Restore hasn't yeilded any results,
nor has reloading XP. I'd hate to have to reformat and
reload my entire computer just to get the functionality
of that drive back, but I use it all the time. The
Buslink site is of no use, they don't make a driver for
this product because XP has it built into it. I don't
know what or which Windows update caused this problem,
that's the only thing I've done to my computer within the
timeframe that all this happened. I'm stumped. Anyone
have any ideas at all? Thanks.
April 14, 2004 6:46:02 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

uninstall all of the USB ports in device manager.

reboot the computer without the USB hard drive connected

let Windows find and reinstall the drivers forthe USB controller

connect USB hard drive
Anonymous
April 14, 2004 9:38:53 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

>-----Original Message-----
>I have just about exhausted every possiblility I can
>think of to solve this problem. I have a Buslink Disk-
On-
>The-Go USB 2.0 20GB Hard Drive, that up until yesterday,
>worked perfectly. It seems it stopped working after I
>did a Windows Update. Now, the drive is shown in Device
>Manager as an Unknown Device under the USB Controllers.
>When I try to reinstall the driver, it alway comes up
>that in can't find one, yet when I plug it into my
laptop
>and look up the driver details, I can find on this
>computer exactly the same file, but it still doesn't
>recognize it. System Restore hasn't yeilded any
results,
>nor has reloading XP. I'd hate to have to reformat and
>reload my entire computer just to get the functionality
>of that drive back, but I use it all the time. The
>Buslink site is of no use, they don't make a driver for
>this product because XP has it built into it. I don't
>know what or which Windows update caused this problem,
>that's the only thing I've done to my computer within
the
>timeframe that all this happened. I'm stumped. Anyone
>have any ideas at all? Thanks.
>.
>

hi i am sorry to tell you this but unless you know what
update that caused this problem then you are going to
have to format. the fact that this works on your laptop
make's me think that it is a sercuity update for desktops
and not laptops so that is where i am getting my
conclusion from. hopw this helps you
Anonymous
April 15, 2004 1:34:04 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Try it on another machine? (and cross your fingers)

"Ray Pomeroy" <pomeroy_r@yahoo.com> wrote in message news:1ccf201c42241$040dd310$a101280a@phx.gbl...
> I have just about exhausted every possiblility I can
> think of to solve this problem. I have a Buslink Disk-On-
> The-Go USB 2.0 20GB Hard Drive, that up until yesterday,
> worked perfectly. It seems it stopped working after I
> did a Windows Update. Now, the drive is shown in Device
> Manager as an Unknown Device under the USB Controllers.
> When I try to reinstall the driver, it alway comes up
> that in can't find one, yet when I plug it into my laptop
> and look up the driver details, I can find on this
> computer exactly the same file, but it still doesn't
> recognize it. System Restore hasn't yeilded any results,
> nor has reloading XP. I'd hate to have to reformat and
> reload my entire computer just to get the functionality
> of that drive back, but I use it all the time. The
> Buslink site is of no use, they don't make a driver for
> this product because XP has it built into it. I don't
> know what or which Windows update caused this problem,
> that's the only thing I've done to my computer within the
> timeframe that all this happened. I'm stumped. Anyone
> have any ideas at all? Thanks.
!