Sign in with
Sign up | Sign in
Your question

Help! Remote Desktop Connection Unable to Connect =( !

Last response: in Windows 7
Share
January 13, 2011 11:05:36 PM

Hi!

I’m having a problem trying to connect to my home machine via remote desktop, can anyone help me?

I have enabled remote desktop and can connect via the IP that I have assigned to my desktop from my netbook. However I can’t get this to work from school, though Teamviewer works fine from school.

I have set up port forwarding on my router to port 3389 at my desktop’s IP, but I still just get a message saying that remote desktop was not able to establish a connection…

Is there any other difference I am missing between connecting from within my home network and from at school?
January 13, 2011 11:57:16 PM

You need to first know your public ip (not your private IP)

Private IP's start with 192, 172, or 10. For example...

192 - 192.168.1.0 (Last zero can be any other number)
172 - 172.16.0.0 (Last zero can be any other number)
10 - 10.0.0.0 (Last zero can be any other number)

For public IP's, you need to find your public IP. Go to
http://www.ipchicken.com
m
0
l
January 14, 2011 12:01:55 AM

Yes, when I am attempting to connect from school I am using my public IP but I get the error. When at home I connect with my private IP and am able to use everything fine.
m
0
l
Related resources
January 14, 2011 12:03:23 AM

Maybe school blocked port 3389?
m
0
l
a b $ Windows 7
January 14, 2011 12:07:06 AM

Just use teamviewer its better any how.
m
0
l
a c 228 $ Windows 7
January 14, 2011 11:50:45 AM

Are you using the most current version of remote desktop client? Also, you may need to set the remote desktop setting on your home PC to "allow connections from pc's running any version of remote desktop".
m
0
l
January 21, 2011 12:37:08 AM

Yup, it's the most recent version of RD. I'm thinking it might be a problem with my ISP blocking the port. I have temporarily gotten around this by using team viewer to create a VPN and then used RD over that. But I rather not do that due to security issues...
m
0
l
January 26, 2011 7:44:23 PM

most school's block port 3389. i know at my university it is blocked. possibly change to another port #?
m
0
l
!