Hibernation Problems

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

When I want to set my computer to hibernate (Windows XP
Professional), it comes up with:

"The device driver for the 'Standard 101/102-Key or
Microsoft Natural PS/2 Keyboard' device is preventing the
machine from entering hibernation. Please close all
applications and try again. If the problem persists, you
may need to update this driver"

The problem does persist and the driver is fine. It
worked before but I don't know what has happened to make
it react this way. Could anyone help please?
3 answers Last reply
More about hibernation problems
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Might this be an older keyboard? Maybe the first Generation Natural
    Keyboards? Hibernating isn't that big of a deal. Some systems refuse
    to wake from it, and it may be more harm then good

    Tony


    On Mon, 26 Apr 2004 09:12:50 -0700, "Allan Turner"
    <anonymous@discussions.microsoft.com> wrote:

    >When I want to set my computer to hibernate (Windows XP
    >Professional), it comes up with:
    >
    >"The device driver for the 'Standard 101/102-Key or
    >Microsoft Natural PS/2 Keyboard' device is preventing the
    >machine from entering hibernation. Please close all
    >applications and try again. If the problem persists, you
    >may need to update this driver"
    >
    >The problem does persist and the driver is fine. It
    >worked before but I don't know what has happened to make
    >it react this way. Could anyone help please?
  2. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Hello Allan,
    There is probably a filter driver that is hooking the keyboard driver.
    So it's really the filter driver that is preventing hibernating but the
    keyboard driver is doing the reporting.
    Click " Start", and then click "Run".
    In the "Open" box, type "regedit" (without the quotation marks), and
    then click "OK".
    Click the remote computer name, and then open the registry of the
    remote computer.
    In the registry of the remote computer, locate the following key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96B-E325
    -11CE-BFC1-08002BE10318}
    In the right pane, look at the " UpperFilters " and "lowerfilters" value.
    What are under those values? Do not just remove them since this affects
    whether the keyboard might work or not.
    Thanks,
    Darrell Gorter[MSFT]

    This posting is provided "AS IS" with no warranties, and confers no rights
    --------------------
    >Content-Class: urn:content-classes:message
    >From: "Allan Turner" <anonymous@discussions.microsoft.com>
    >Sender: "Allan Turner" <anonymous@discussions.microsoft.com>
    >Subject: Hibernation Problems
    >Date: Mon, 26 Apr 2004 09:12:50 -0700
    >Lines: 12
    >Message-ID: <460101c42ba9$52a4dca0$a001280a@phx.gbl>
    >MIME-Version: 1.0
    >Content-Type: text/plain;
    > charset="iso-8859-1"
    >Content-Transfer-Encoding: 7bit
    >X-Newsreader: Microsoft CDO for Windows 2000
    >X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
    >Thread-Index: AcQrqVKiqTJ004ZVRXKbfV9zigFHbg==
    >Newsgroups: microsoft.public.windowsxp.hardware
    >Path: cpmsftngxa10.phx.gbl
    >Xref: cpmsftngxa10.phx.gbl microsoft.public.windowsxp.hardware:202686
    >NNTP-Posting-Host: tk2msftngxa08.phx.gbl 10.40.1.160
    >X-Tomcat-NG: microsoft.public.windowsxp.hardware
    >
    >When I want to set my computer to hibernate (Windows XP
    >Professional), it comes up with:
    >
    >"The device driver for the 'Standard 101/102-Key or
    >Microsoft Natural PS/2 Keyboard' device is preventing the
    >machine from entering hibernation. Please close all
    >applications and try again. If the problem persists, you
    >may need to update this driver"
    >
    >The problem does persist and the driver is fine. It
    >worked before but I don't know what has happened to make
    >it react this way. Could anyone help please?
    >
  3. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Darrell,

    This is also exactly the problem I have currently. This started when I used the Windows XP CD to effect a repair. It caused my IR port and hibernation to stop working. I fixed my IR port by uninstalling and letting the hardware wizard reinstall. I tried the same trick with the keyboard but this didn't work.

    I have looked in the registry as you asked Allan to do and find only "kbdclass" under UpperFilters. There is no LowerFilters.

    What next?
    Thanks
    Stuart Cooney


    ""Darrell Gorter[MSFT]"" wrote:

    > Hello Allan,
    > There is probably a filter driver that is hooking the keyboard driver.
    > So it's really the filter driver that is preventing hibernating but the
    > keyboard driver is doing the reporting.
    > Click " Start", and then click "Run".
    > In the "Open" box, type "regedit" (without the quotation marks), and
    > then click "OK".
    > Click the remote computer name, and then open the registry of the
    > remote computer.
    > In the registry of the remote computer, locate the following key:
    > HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96B-E325
    > -11CE-BFC1-08002BE10318}
    > In the right pane, look at the " UpperFilters " and "lowerfilters" value.
    > What are under those values? Do not just remove them since this affects
    > whether the keyboard might work or not.
    > Thanks,
    > Darrell Gorter[MSFT]
    >
    > This posting is provided "AS IS" with no warranties, and confers no rights
    > --------------------
    > >Content-Class: urn:content-classes:message
    > >From: "Allan Turner" <anonymous@discussions.microsoft.com>
    > >Sender: "Allan Turner" <anonymous@discussions.microsoft.com>
    > >Subject: Hibernation Problems
    > >Date: Mon, 26 Apr 2004 09:12:50 -0700
    > >Lines: 12
    > >Message-ID: <460101c42ba9$52a4dca0$a001280a@phx.gbl>
    > >MIME-Version: 1.0
    > >Content-Type: text/plain;
    > > charset="iso-8859-1"
    > >Content-Transfer-Encoding: 7bit
    > >X-Newsreader: Microsoft CDO for Windows 2000
    > >X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
    > >Thread-Index: AcQrqVKiqTJ004ZVRXKbfV9zigFHbg==
    > >Newsgroups: microsoft.public.windowsxp.hardware
    > >Path: cpmsftngxa10.phx.gbl
    > >Xref: cpmsftngxa10.phx.gbl microsoft.public.windowsxp.hardware:202686
    > >NNTP-Posting-Host: tk2msftngxa08.phx.gbl 10.40.1.160
    > >X-Tomcat-NG: microsoft.public.windowsxp.hardware
    > >
    > >When I want to set my computer to hibernate (Windows XP
    > >Professional), it comes up with:
    > >
    > >"The device driver for the 'Standard 101/102-Key or
    > >Microsoft Natural PS/2 Keyboard' device is preventing the
    > >machine from entering hibernation. Please close all
    > >applications and try again. If the problem persists, you
    > >may need to update this driver"
    > >
    > >The problem does persist and the driver is fine. It
    > >worked before but I don't know what has happened to make
    > >it react this way. Could anyone help please?
    > >
    >
    >
Ask a new question

Read More

Hibernation Microsoft Windows XP