Problem ejecting usb mass storage device

i can't solved it what can i do to solve it
7 answers Last reply
More about problem ejecting mass storage device
  1. espie32 said:
    i can't solved it what can i do to solve it



    Hi espie32,


    The USB Mass Storage Device are in use by another program or may be any files are open handles hence this problem is occurred.

    Follow this steps to solve this Problem -:

    1. You can Download a free utility from here -:

    http://www.sysinternals.com/Utilities/ProcessExplorer.html


    2. Click Find, Find Handle or DLL in the Tool Menu.

    3. Type the Drive Letter of the USB Storage Device in the Handle or DLL substring textbox, and Click on Search Button.
    4. Find the process and its PID in the following box.
    5. In system process tree view, find the process according to the Find Handle or DLL dialog box.
    6. Press Ctrl + H to show Handles in Lower Pane View.
    7. Find the File according with the drive letter , and right click it, choose Close Handle.


    May be it will help you.....
  2. I assume this would work, but I can't be sure because to close the handle I need to have admin privileges, which I don't.
  3. Log off windows (don't shutdown or restart), log back in, and try ejecting it.
  4. 1. right click my computer
    2. click manage
    3. under computer management click device manager> disk drives> right click on seagate external hard drive> click uninstall
    4. restart your computer
    5. open the external hard drive then safely eject the device
  5. If you have Administrator Privileges, this procedure seems to work consistently (tried in Win Vista, Win7 and Win10):
    1. Check that all applications are closed, as far as possible, including Explorer
    2. In Computer Management -> Storage -> Disk Management, find the offending drive in the list (lower central pane).
    3. Right click on its left label (where it gives the size of the physical drive, and states that it is Online) and select Offline.
    4. You should now be able to eject it, using the normal ejecting procedure, without an "in-use" warning.
    5. Wait 2-3 minutes, so that any retrying applications which were accessing the drive will have timed out.
    6. Plug the drive back in, and it will reappear on the list, but Offline this time. Right click again to set it to Online.
    7. Wait a few seconds for the usual things to happen when the drive is connected, but immediately close any applications which start up.
    8. Use the normal ejection procedure and this time it should work.

    If step 8 does not produce a clean ejection (try it more than once), then it suggests that there is a process which begins to open files on that drive the moment that it is connected. This could be any of a number of things, ranging from the Windows disk indexing, though an application written to search for and open files of a particular type whenever they are present on the system, to a virus or other malware. All I can suggest is to search for such things and shut them down one at a time, or refer the problem to a system hacker.

    Good luck.

    EB
  6. Solve with Task manager.

    To solve with task manager, first you have to go to task manager. Click "Control +all + delete" together on the desktop. then it will open task manager. after open, go to process tab in menu.
    Find "rund1132.exe" named task, and Click end process.

    source - http://www.gogorapid.com/how-to-fix-problem-ejecting-usb-mass-storage-device/
Ask a new question

Read More

Storage USB Devices Windows 7