my keyboard

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

for some strange reason i seem to have downloaded a
microsoft update that messes my whole keyboard setting up
at the moment when i type shift+2 the @ sign appears and
there is only a dollar sign not a pound sign, have i
downloaded an american update driver for my keyboard or
something by accident?
2 answers Last reply
More about keyboard
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "YO help me plz" <anonymous@discussions.microsoft.com> wrote in message
    news:61ca01c42e01$d0a5fa80$a001280a@phx.gbl...
    > for some strange reason i seem to have downloaded a
    > microsoft update that messes my whole keyboard setting up
    > at the moment when i type shift+2 the @ sign appears and
    > there is only a dollar sign not a pound sign, have i
    > downloaded an american update driver for my keyboard or
    > something by accident?

    Yes, this sounds like your keyboard has switched to US American layout,
    although it's more likely to have been accidentally via the Control Panel
    than as a result of a Microsoft update.
    Go to Control Panel, and assuming your Control Panel is still in the default
    XP "Category View", go to "Date, Time, Language and Regional Options", then
    in that category click the "Regional and Language Options" icon. In the
    ensuing dialog box, click the "Languages" tab, then the "Details..." button,
    and ensure that the correct keyboard driver for your country (I'm guessing
    "English (United Kingdom)"..) is installed and selected as the default.
    Remove any other keyboard layouts that are present. Click OK when done.

    Hope this helps..
  2. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Thank you Mr. Holloway. I used your solution on an
    English machine with a Japanese keyboard layout. (Driver
    was previously set to 106/109 layout but I was still
    getting the English key output when I typed.)


    >-----Original Message-----
    >"YO help me plz" <anonymous@discussions.microsoft.com>
    wrote in message
    >news:61ca01c42e01$d0a5fa80$a001280a@phx.gbl...
    >> for some strange reason i seem to have downloaded a
    >> microsoft update that messes my whole keyboard setting
    up
    >> at the moment when i type shift+2 the @ sign appears
    and
    >> there is only a dollar sign not a pound sign, have i
    >> downloaded an american update driver for my keyboard or
    >> something by accident?
    >
    >Yes, this sounds like your keyboard has switched to US
    American layout,
    >although it's more likely to have been accidentally via
    the Control Panel
    >than as a result of a Microsoft update.
    >Go to Control Panel, and assuming your Control Panel is
    still in the default
    >XP "Category View", go to "Date, Time, Language and
    Regional Options", then
    >in that category click the "Regional and Language
    Options" icon. In the
    >ensuing dialog box, click the "Languages" tab, then
    the "Details..." button,
    >and ensure that the correct keyboard driver for your
    country (I'm guessing
    >"English (United Kingdom)"..) is installed and selected
    as the default.
    >Remove any other keyboard layouts that are present.
    Click OK when done.
    >
    >Hope this helps..
    >
    >
    >.
    >
Ask a new question

Read More

Hardware Microsoft Keyboards Windows XP