Sign in with
Sign up | Sign in
Your question

one computer can access shared files the other can't even ..

Last response: in Wireless Networking
Share
Anonymous
a b F Wireless
December 6, 2004 1:45:02 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

i have two desktops one is on ethernet the other is wireless pci card. the
wired computer has full access of the second computer, but the wireless
cannot even access any shared files. I get this message saying I might not
have permission to
use this network resource and to contact the administrator. both desktops
are running xp pro sp2 and all availibleupdates. any help on this problem
would b great.

thanks ,

J Hamer
December 6, 2004 1:05:08 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

On Sun, 5 Dec 2004 22:45:02 -0800, "J Hamer" <JHamer@discussions.microsoft.com>
wrote:

>i have two desktops one is on ethernet the other is wireless pci card. the
>wired computer has full access of the second computer, but the wireless
>cannot even access any shared files. I get this message saying I might not
>have permission to
>use this network resource and to contact the administrator. both desktops
>are running xp pro sp2 and all availibleupdates. any help on this problem
>would b great.
>
>thanks ,
>
>J Hamer

On any XP Pro computer, check to see if Simple File Sharing (Control Panel -
Folder Options - View - Advanced settings) is enabled or disabled. With XP Pro,
you need to have SFS consistently set on each computer.

On XP Pro with SFS disabled, check the Local Security Policies (Control Panel -
Administrative Tools). Under Local Policies - Security Options, look at
"Network access: Sharing and security model", and ensure it's set to "Classic -
local users authenticate as themselves".

On XP Pro with SFS disabled, if you set the above Local Security Policy to
"Guest only", enable the Guest account, using Start - Run - "cmd" - type "net
user guest /active:yes" in the command window. If "Classic", setup and use a
common non-Guest account on all computers. Whichever account is used, give it
an identical, non-blank password on all computers.

On XP Home, and on XP Pro with Simple File Sharing enabled, make sure that the
Guest account is enabled, on each computer. Enable Guest with Start - Run -
"cmd", then type "net user guest /active:yes" in the command window.

On XP Pro, if you're going to use Guest authentication, check your Local
Security Policy (Control Panel - Administrative Tools) - User Rights Assignment,
on the XP Pro computer, and look at "Deny access to this computer from the
network". Make sure Guest is not in the list.

Do any of the computers have a software firewall (ICF / WF, or third party)? If
so, you need to configure them for file sharing. Firewall configurations are a
very common cause of (network) browser, and file sharing, problems.

Finally, look at registry key [HKLM\System\CurrentControlSet\Control\Lsa], value
restrictanonymous.
<http://www.microsoft.com/windows2000/techinfo/reskit/en...;
<http://www.jsifaq.com/subf/tip2600/rh2625.htm&gt;
http://support.microsoft.com/?id=246261
http://support.microsoft.com/?id=296403

The above articles refer to Windows 2000. Remember WinXP is NT V5.1, and Win2K
is NT V5.0.

Have you used the Registry Editor before? If not, it's a scary tool, but it's
pretty simple once you get used to it. Here are a couple articles that might
help:
<http://www.microsoft.com/windowsxp/home/using/productdo...;
<http://www.annoyances.org/exec/show/registry&gt;

Just remember to backup the key (create a registry patch) for
[HKLM\System\CurrentControlSet\Control\Lsa] before making any changes, if
appropriate.

From the Annoyances article:
You can create a Registry patch by opening the Registry Editor, selecting a
branch, and choosing Export from the File menu. Then, specify a filename, and
press OK. You can then view the Registry patch file by opening it in Notepad
(right-click on it and select Edit). Again, just double-click on a Registry
patch file (or use Import in the Registry Editor's File menu) to apply it to the
registry.

--
Cheers,
Chuck
Paranoia comes from experience - and is not necessarily a bad thing.
Anonymous
a b F Wireless
December 6, 2004 10:13:05 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

chuck , now that i think about it your statement is so true!!!

Thanks again for all your help


J Hamer
Related resources
!