CD-ROM Drives show as "Unknown" in Device Manager!

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

This is one of those bizarre situations where
all my CD-ROM drives appear at the bottom of the Device Manager listing as UNKNOWN
and should be shown under the heading CD-ROM Drives!
Tried restoring to earlier config 4 times with no difference.
Can't replace the "atapi.sys" driver with another version (XP seems to know any change
and automatically replaces the file).
Any clues to fixing this problem please post here as well as email me at:

kmcguire@NOSPAM.austin.rr.com

(remove NOSPAM)
1 answer Last reply
More about drives show unknown device manager
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    ..\3_KiT$TeR wrote:
    > This is one of those bizarre situations where
    > all my CD-ROM drives appear at the bottom of the Device Manager
    > listing as UNKNOWN and should be shown under the heading CD-ROM
    > Drives!
    > Tried restoring to earlier config 4 times with no difference.
    > Can't replace the "atapi.sys" driver with another version (XP seems
    > to know any change and automatically replaces the file).
    > Any clues to fixing this problem please post here as well as email me
    > at:

    Do NOT be afraid of the registry hack here. It is SAFE and has helped MANY
    people.
    Respect the registry, don't fear it.

    1) Log on with Administrative Privileges

    2) Open the Registry Editor:
    a) Go to Start then select Run.
    b) Type regedit and click OK.

    3) Backup you registry by:
    a) Highlight My Computer by clicking on it once.
    b) Click File (Windows XP) or Registry (Windows 2000), then Export
    Registry File.
    c) Select export range All; to ensure your entire registry is backed up
    completely.
    d) Select where you would like to save this backup, name the File, and
    Click on the SAVE button.

    4) Remove the Upperfilters and Lowerfilters values:
    a) Go to
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\
    {4D36E965-E325-11CE-BFC1-08002BE10318}
    b) Highlight this key by left clicking on it once.
    c) On the right hand side delete the values Upperfilters and Lowerfilters.

    5) Restart your computer.


    Or try this:

    http://www.dougknox.com/

    Select 'Windows Utilities' and scroll down to 'Restore CD/DVD drives to
    Windows Explorer.'
    Perhaps his utility will do the trick. =)

    --
    <- Shenan ->
    --
Ask a new question

Read More

Device Manager CD-Rom Windows XP