Sign in with
Sign up | Sign in
Your question
Solved

Cant install OS - 0x80070570

Tags:
Last response: in Windows 7
Share
January 17, 2011 11:59:51 AM

I have really big problem.. :cry: 
Let me just give you a history of what happened.
I installed 2 games, ME2 and SC Conviction.
I played ME2 first for 5hours - no problem then started playing SC, it crashed for the first 30mins. I just restarted my system, played it again then it crashed again around 45mins. I decided to just play ME2 but ME2 is now crashing every 5mins. I thought that SC has something to do with it so I uninstalled SC and did a system restore. But ME2 crashing again, same as all the other games I was able to play ok before. I tried to reinstall ME2 but now everytime I install it im getting a data error in the middle of the installation. So Im really frustated so i just decided to reinstall my OS.
I formated my drive then installed WIN 7 Ultimate 64. But on the process of expaning window files, im getting error 0x80070570. i tried multiple times and i always get that error, could be at around 25% or at 83%.
I have a brand new installer just 1 month old without any scratches and even my dvd rom and my whole sytem is fairly new.
i tried installing my old XP sp2..It installed ok till the part in removing temporary files, its shows 1min remaining but after 2 hours, it still shows that message.
I cant get a detailed info on my specs cause my pc is not working but heres what I remember.

AMD Athlon 2 x4 640 3.0
Foxconn M61PMP-K
1 Corsair 4Gig DDR3
Nvidia GTX 460
700W PSU

Thanks in advance

More about : install 0x80070570

Best solution

January 17, 2011 4:31:46 PM

Check if there is memory errors. Run Memtest.

Also could be hard drive problem. If you have a spare, try it.
Share
January 17, 2011 4:53:32 PM

Im also thinking that it could be a RAM issue since the problem started with game crashes. Im gonna run memtest first. Im really not that familiar with it but I googled it and it seems easy to run. Thanks for the suggestion.
m
0
l
Related resources
January 18, 2011 10:37:39 AM

I just removed the RAM, blew it a little to remove some dust like a NES cartridge and then put it back. Tried again. Solved..
m
0
l
January 18, 2011 10:37:57 AM

Best answer selected by waspzz.
m
0
l
!