Sign in with
Sign up | Sign in
Your question

HDD and DMA

Last response: in Windows XP
Share
Anonymous
May 30, 2004 5:21:02 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

DMA of my hard disk is disabled i.e. it's in PIO mode.
It used to be DMA now even if i select DMA if available it stays in PIO mode.

Event Viewer:

Event Type: Warning
Event Source: atapi
Event Category: None
Event ID: 26

The driver has detected that device \Device\Ide\IdePort0 has old or out-of-date firmware. Reduced performance may result.

Data:
0000: 0f 00 10 00 01 00 64 00 ......d.
0008: 00 00 00 00 1a 00 04 80 .......€
0010: 04 00 00 00 00 00 00 00 ........
0018: c6 95 05 00 00 00 00 00 ƕ......
0020: 00 00 00 00 00 00 00 00 ........
0028: 00 00 00 00 00 00 00 00 ........
0030: 00 00 00 00 09 00 00 00 ........

It went to PIO mode when recently I connected my HD on another PC running Win98 and now in my PC (WinXP) the DMA has went out although While booting my motherboard i.e. BOIS shows UDMA, mode 2 for both my HDD and CD-ROM.

The funny thing is that, When my HDD was on DMA mode, i tried many times to set DMA for CD-ROM but nothing worked.
Now when my HDD can't use DMA mode my CD-ROM got UDMA, mode 2...

Can anybody help??

PC config- P3 550MHz Gigabyte Motherboard (Intel440BX Chipset) 20GB QuantumFireball lct15 64MB RAM
16MB Nvidia Vanta External v92 Modem on COM1 A4tech 2 button mouse WinXPpro DX9b

HDD is PrimaryMaster and CDROM is Secondary Master

More about : hdd dma

Anonymous
May 30, 2004 7:15:27 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Check here
http://support.microsoft.com/default.aspx?scid=kb;en-us;817472


"Rimon" <anonymous@discussions.microsoft.com> wrote in message
news:592A8A44-F379-4406-BB46-F4CFCB73C221@microsoft.com...
> DMA of my hard disk is disabled i.e. it's in PIO mode.
> It used to be DMA now even if i select DMA if available it stays in PIO
mode.
>
> Event Viewer:
>
> Event Type: Warning
> Event Source: atapi
> Event Category: None
> Event ID: 26
>
> The driver has detected that device \Device\Ide\IdePort0 has old or
out-of-date firmware. Reduced performance may result.
>
> Data:
> 0000: 0f 00 10 00 01 00 64 00 ......d.
> 0008: 00 00 00 00 1a 00 04 80 .......€
> 0010: 04 00 00 00 00 00 00 00 ........
> 0018: c6 95 05 00 00 00 00 00 Æ•......
> 0020: 00 00 00 00 00 00 00 00 ........
> 0028: 00 00 00 00 00 00 00 00 ........
> 0030: 00 00 00 00 09 00 00 00 ........
>
> It went to PIO mode when recently I connected my HD on another PC running
Win98 and now in my PC (WinXP) the DMA has went out although While booting
my motherboard i.e. BOIS shows UDMA, mode 2 for both my HDD and CD-ROM.
>
> The funny thing is that, When my HDD was on DMA mode, i tried many times
to set DMA for CD-ROM but nothing worked.
> Now when my HDD can't use DMA mode my CD-ROM got UDMA, mode 2...
>
> Can anybody help??
>
> PC config- P3 550MHz Gigabyte Motherboard (Intel440BX Chipset) 20GB
QuantumFireball lct15 64MB RAM
> 16MB Nvidia Vanta External v92 Modem on COM1 A4tech 2
button mouse WinXPpro DX9b
>
> HDD is PrimaryMaster and CDROM is Secondary Master
!