Wheel Scroll Lines not loaded on Reboot

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

The registry entry, HKCU/Control Panel/Desktop/WheelScrollLines is not enforced when I reboot my machine. Using the Mouse Properties Dialog, I am able to change the value in this entry to one of my liking. According to what I have observed, -1 causes full page scrolling, 0 disables scrolling completely, and 1 or higher specifies the number of line scrolled with each notch of the wheel. Regardless of what value I have chosen, on reboot the value is set to 1 in the Mouse Properties dialog. However, the value in the registry is still set to the desired value. The registry seems to be updated correctly when I use the Mouse Properties dialog. Anyone know why this value would not be loaded when windows starts.
OS: Windows XP Professional SP1
PC: HP ZE5200 Pavilion Notebook
Wireless Mouse/Keyboard Combo: Logitech Mx700
3 answers Last reply
More about wheel scroll lines loaded reboot
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    I found a fix for this problem. Like many laptops, mine is equiped with a synaptic's touchpad. The touchpad driver override the wheel settings for all mouse devices. Why? I have no idea. There isn't a wheel anywhere on my laptop. If you are experiencing this problem add the following DWORD key to you registry:
    HKLM/SOFTWARE/Synaptics/SynTPenh/AllowScrollSettings DWORD value of 1
    After reboot, your mouse wheel settings will no longer be reset.
  2. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    New to this forum. Do I dare ask a question in a thread that is over a
    year old? Here goes nothing:

    You wrote to go to
    "HKLM/SOFTWARE/Synaptics/SynTPenh/AllowScrollSettings and make a DWORD
    value of 1.
    I know that in many cases there are only 2 choices '1' and '0' and they
    have special meaning. Does it in this case? or is '1' meant to mean one
    scroll line? Since I want to change my default to 5 scroll lines can I
    change it to 5 instead? I did '1' and it did nothing to my mouse scroll
    settings, whose default seems to always be the number one regardless of
    what I tried.
    To be more precise to me "HKLM is the main folder and
    /SOFTWARE/Synaptics/SynTPenh are its subfolders. and in SynTPenh I went
    to the right pane and created the Dword 'AllowScrollSettings' and set
    it's value at one.


    --
    pintree3
    ------------------------------------------------------------------------
    pintree3's Profile: http://extremetechsupport.com/forum/member.phtml?userid=1539
    View this thread: http://extremetechsupport.com/forum/showthread.phtml?t=14196
  3. I spent a lot of time trying all different options and none of the solution work. Finally, I went to synaptics site to download a new driver http://www.synaptics.com/support/drivers and magic, it fixed the resetting problem :)
Ask a new question

Read More

Registry Windows XP