Sign in with
Sign up | Sign in
Your question

Adhoc network

Last response: in Wireless Networking
Share
January 2, 2005 7:00:47 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

I have 3 machines, all with 802.11g cards, mine connected
to internet. Workgroup set up, all can access internet,I
can access their shared folders, they can access mine,
but not it would appear each others.
Have tried disabling firewalls but to no avail. Is this
the correct mode of operation?

If this is the case, how do they set up so can play LAN
games with each other. Do I have to create another SSID
on another channel for them to connect (not sure how)?

Assistance appreciated.

Dave.

More about : adhoc network

Anonymous
January 3, 2005 3:36:53 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

you should be able to play lan games by entering each machines ip in the
games' menu
mike

"Dave" <madangler@beeb.net> wrote in message
news:110a01c4f127$47443f10$a601280a@phx.gbl...
> I have 3 machines, all with 802.11g cards, mine connected
> to internet. Workgroup set up, all can access internet,I
> can access their shared folders, they can access mine,
> but not it would appear each others.
> Have tried disabling firewalls but to no avail. Is this
> the correct mode of operation?
>
> If this is the case, how do they set up so can play LAN
> games with each other. Do I have to create another SSID
> on another channel for them to connect (not sure how)?
>
> Assistance appreciated.
>
> Dave.
January 3, 2005 6:56:03 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Thanks Mike, originally tried letting wireless cards set
own IP, but then tried setting statically. Still cannot
get their machines to see each other's shared files or
join when direct addressing in games.

Regards,

Dave

>-----Original Message-----
>you should be able to play lan games by entering each
machines ip in the
>games' menu
>mike
>
>"Dave" <madangler@beeb.net> wrote in message
>news:110a01c4f127$47443f10$a601280a@phx.gbl...
>> I have 3 machines, all with 802.11g cards, mine
connected
>> to internet. Workgroup set up, all can access
internet,I
>> can access their shared folders, they can access mine,
>> but not it would appear each others.
>> Have tried disabling firewalls but to no avail. Is this
>> the correct mode of operation?
>>
>> If this is the case, how do they set up so can play LAN
>> games with each other. Do I have to create another
SSID
>> on another channel for them to connect (not sure how)?
>>
>> Assistance appreciated.
>>
>> Dave.
>
>
>.
>
Related resources
January 3, 2005 4:10:13 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

"Dave" <madangler@beeb.net> wrote in message
news:110a01c4f127$47443f10$a601280a@phx.gbl...
>I have 3 machines, all with 802.11g cards, mine connected
> to internet. Workgroup set up, all can access internet,I
> can access their shared folders, they can access mine,
> but not it would appear each others.
> Have tried disabling firewalls but to no avail. Is this
> the correct mode of operation?
>
> If this is the case, how do they set up so can play LAN
> games with each other. Do I have to create another SSID
> on another channel for them to connect (not sure how)?
>
> Assistance appreciated.
>
> Dave.

Dave,

Have you set up with static IP's? if so you may need to enable netbios.
(Advanced tab of TCP/IP properties then click on WINS tab)

Some older games need IPX/SPX

try adding IPX/SPX protocol.

Go to start>>connect to>>show all connections
right click on Local area connection and select properties
click on install then click on protocol and add
select ipx/spx

You should now have an item called NWLink IPX/SPX/NetBIOS.....

Click on it then click on properties. Change the internal network number
from F000000 to a unique number (e.g change the last digit to 1 to make it
F000001 and then on the other PC change the last digit to 2 - the number has
to be different on each PC)

Change the frame type from auto to Ethernet 802.3

The network address needs to be the same on each machine so change it to
something like 10 (it will change to 0000010 when you press okay)

HTH

Tony
January 3, 2005 4:10:14 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Cheers Tony, had checked the WINS setting but misread
the default. Will give it a go. Using new games (Dawn of
WAr) so dont want to get into IPX/SPX if can help it.
Currently got two machines upstairs linked by cable, each
bridged to wireless cards to access my machine
downstairs. Seems a lot more to this wireless network
than the experts let on. Have checked out loads of
internet links and forums, though this most useful.

Can you confirm it should be possible with ad-hoc network
that 3 machines should be able to see all shared files or
does the one with the internet access act more like an
access point?

Thanks for your advice.

Dave.

>-----Original Message-----
>
>"Dave" <madangler@beeb.net> wrote in message
>news:110a01c4f127$47443f10$a601280a@phx.gbl...
>>I have 3 machines, all with 802.11g cards, mine
connected
>> to internet. Workgroup set up, all can access
internet,I
>> can access their shared folders, they can access mine,
>> but not it would appear each others.
>> Have tried disabling firewalls but to no avail. Is this
>> the correct mode of operation?
>>
>> If this is the case, how do they set up so can play LAN
>> games with each other. Do I have to create another
SSID
>> on another channel for them to connect (not sure how)?
>>
>> Assistance appreciated.
>>
>> Dave.
>
>Dave,
>
>Have you set up with static IP's? if so you may need to
enable netbios.
>(Advanced tab of TCP/IP properties then click on WINS
tab)
>
>Some older games need IPX/SPX
>
>try adding IPX/SPX protocol.
>
>Go to start>>connect to>>show all connections
>right click on Local area connection and select
properties
>click on install then click on protocol and add
>select ipx/spx
>
>You should now have an item called NWLink
IPX/SPX/NetBIOS.....
>
>Click on it then click on properties. Change the
internal network number
>from F000000 to a unique number (e.g change the last
digit to 1 to make it
>F000001 and then on the other PC change the last digit
to 2 - the number has
>to be different on each PC)
>
>Change the frame type from auto to Ethernet 802.3
>
>The network address needs to be the same on each machine
so change it to
>something like 10 (it will change to 0000010 when you
press okay)
>
>HTH
>
>Tony
>
>
>.
>
January 3, 2005 8:15:29 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

"Dave" <madangler@beeb.net> wrote in message
news:10e501c4f1a9$334407c0$a401280a@phx.gbl...
> Cheers Tony, had checked the WINS setting but misread
> the default. Will give it a go. Using new games (Dawn of
> WAr) so dont want to get into IPX/SPX if can help it.
> Currently got two machines upstairs linked by cable, each
> bridged to wireless cards to access my machine
> downstairs. Seems a lot more to this wireless network
> than the experts let on. Have checked out loads of
> internet links and forums, though this most useful.
>
> Can you confirm it should be possible with ad-hoc network
> that 3 machines should be able to see all shared files or
> does the one with the internet access act more like an
> access point?
>
> Thanks for your advice.
>
> Dave.
>

Three PC's set-up in Adhoc mode should be able to see each other.

You shouldn't need the cable connection between the two machines upstairs.
They would have to have a different subnet for the cable connection to that
used by the wireless adhoc network. I feel that the cable connection is
complicating matter.

If you disconnect the cable (also you would have to disconnect the bridge to
the cabled connection and I would disable the NICs that the cable connection
uses) can the two upstairs ones see each other then?

I would get the wireless network working first. Without the cable
connection, you should be able to activate ICS which will allocate an IP
address to each which will come from the main PC connected to the network
January 3, 2005 8:15:30 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Tony please see original.

Have tried using Windows to setup connection using USB
flash device (which didn't work - entered details
manually) and tried using the X-MICRO WLAN software
provided with the cards. It's almost there, everyone has
internet access through mine, they can both see my shared
files, I can see both theirs, BUT, they cannot see each
others. Have tried the reset TCP/IP using netsh ip reset
and started again but same problem. Still have wireless
problem of connections dropping frequently but that's a
seperate problem probably due to WZC.

Any advice most welcome, your time appreciated.

Dave.
>-----Original Message-----
>
>"Dave" <madangler@beeb.net> wrote in message
>news:10e501c4f1a9$334407c0$a401280a@phx.gbl...
>> Cheers Tony, had checked the WINS setting but misread
>> the default. Will give it a go. Using new games (Dawn
of
>> WAr) so dont want to get into IPX/SPX if can help it.
>> Currently got two machines upstairs linked by cable,
each
>> bridged to wireless cards to access my machine
>> downstairs. Seems a lot more to this wireless network
>> than the experts let on. Have checked out loads of
>> internet links and forums, though this most useful.
>>
>> Can you confirm it should be possible with ad-hoc
network
>> that 3 machines should be able to see all shared files
or
>> does the one with the internet access act more like an
>> access point?
>>
>> Thanks for your advice.
>>
>> Dave.
>>
>
>Three PC's set-up in Adhoc mode should be able to see
each other.
>
>You shouldn't need the cable connection between the two
machines upstairs.
>They would have to have a different subnet for the cable
connection to that
>used by the wireless adhoc network. I feel that the
cable connection is
>complicating matter.
>
>If you disconnect the cable (also you would have to
disconnect the bridge to
>the cabled connection and I would disable the NICs that
the cable connection
>uses) can the two upstairs ones see each other then?
>
>I would get the wireless network working first. Without
the cable
>connection, you should be able to activate ICS which
will allocate an IP
>address to each which will come from the main PC
connected to the network
>
>
>.
>
January 4, 2005 12:12:02 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

"Dave" <madangler@beeb.net> wrote in message
news:11af01c4f1be$b06dc280$a401280a@phx.gbl...
> Tony please see original.
>
> Have tried using Windows to setup connection using USB
> flash device (which didn't work - entered details
> manually) and tried using the X-MICRO WLAN software
> provided with the cards. It's almost there, everyone has
> internet access through mine, they can both see my shared
> files, I can see both theirs, BUT, they cannot see each
> others. Have tried the reset TCP/IP using netsh ip reset
> and started again but same problem. Still have wireless
> problem of connections dropping frequently but that's a
> seperate problem probably due to WZC.
>
> Any advice most welcome, your time appreciated.
>
> Dave.

Dave,

Sorry, I can't find original.

I've just duplicated your set-up. I have three PC's all wireless networked
using Adhoc and ICS. All can see each other, connect to the internet and
share files. I then joined the two together that are not connected to the
internet using a cable connection. Strange one found an IP address using
the DHCP but the other wouldn't so I allocated it a static IP. I then tried
to bridge connections on the two that had the cable connection but wasn't
allowed - warning was cannot bridge to a connection that is using ICS. Even
without the bridge they are working fine - both can see each other as well
as the internet as well as the PC connected to the internet.

I don't understand why you need the cable connection if all your PC's are
connected using wireless? As I previously advised, disconnect the cable
connection, get the Adhoc working first with all PC's seeing each other.

Once that is working, connect the cable and manually allocate IP's and
subnets but don't bridge. Suggest that you use a different subnet such as
255.255.254.0 for the nics connected to the cable to keep it separate. Only
thought I have is that will allow the two upstairs ones to still share files
etc if the downstairs one is turned off.

All are using USB wireless adaptors, two upstairs are using Belkin and
downstairs is using a Linksys. All PC's running XP pro. All using WEP and
zonealarm although the PC with internet connection has Internet Zone
security reduced to Medium else others won't connect to the internet when
using ICS.

HTH

Tony
January 4, 2005 12:12:03 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Tony, thanks again for reply. Only introduced cable to
get around problem of the two machines upstairs not
seeing each other. Now with the extra confidence
provided from your reply that it all SHOULD work, I will
kick the kids off again and have another go soon armed
with a printout of your reply.

Thanks

Dave
>-----Original Message-----
>
>"Dave" <madangler@beeb.net> wrote in message
>news:11af01c4f1be$b06dc280$a401280a@phx.gbl...
>> Tony please see original.
>>
>> Have tried using Windows to setup connection using USB
>> flash device (which didn't work - entered details
>> manually) and tried using the X-MICRO WLAN software
>> provided with the cards. It's almost there, everyone
has
>> internet access through mine, they can both see my
shared
>> files, I can see both theirs, BUT, they cannot see each
>> others. Have tried the reset TCP/IP using netsh ip
reset
>> and started again but same problem. Still have
wireless
>> problem of connections dropping frequently but that's a
>> seperate problem probably due to WZC.
>>
>> Any advice most welcome, your time appreciated.
>>
>> Dave.
>
>Dave,
>
>Sorry, I can't find original.
>
>I've just duplicated your set-up. I have three PC's all
wireless networked
>using Adhoc and ICS. All can see each other, connect to
the internet and
>share files. I then joined the two together that are
not connected to the
>internet using a cable connection. Strange one found an
IP address using
>the DHCP but the other wouldn't so I allocated it a
static IP. I then tried
>to bridge connections on the two that had the cable
connection but wasn't
>allowed - warning was cannot bridge to a connection that
is using ICS. Even
>without the bridge they are working fine - both can see
each other as well
>as the internet as well as the PC connected to the
internet.
>
>I don't understand why you need the cable connection if
all your PC's are
>connected using wireless? As I previously advised,
disconnect the cable
>connection, get the Adhoc working first with all PC's
seeing each other.
>
>Once that is working, connect the cable and manually
allocate IP's and
>subnets but don't bridge. Suggest that you use a
different subnet such as
>255.255.254.0 for the nics connected to the cable to
keep it separate. Only
>thought I have is that will allow the two upstairs ones
to still share files
>etc if the downstairs one is turned off.
>
>All are using USB wireless adaptors, two upstairs are
using Belkin and
>downstairs is using a Linksys. All PC's running XP
pro. All using WEP and
>zonealarm although the PC with internet connection has
Internet Zone
>security reduced to Medium else others won't connect to
the internet when
>using ICS.
>
>HTH
>
>Tony
>
>
>.
>
January 4, 2005 2:52:57 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

"dave" <madangler@beeb.net> wrote in message
news:131301c4f1e9$323d03f0$a401280a@phx.gbl...
> Tony, thanks again for reply. Only introduced cable to
> get around problem of the two machines upstairs not
> seeing each other. Now with the extra confidence
> provided from your reply that it all SHOULD work, I will
> kick the kids off again and have another go soon armed
> with a printout of your reply.
>
> Thanks
>
> Dave

Dave,

Something I have noticed is that if I disconnect the internet, the other two
don't reconnect whilst in Adhoc mode. The only way I found of reconnecting
is to right click on the wireless network icon in the systray and click on
repair.

If I disable the wireless adapter on the upstairs two, it is still
connecting through the cable which I have given static IP's and changed
subnet to 255.255.254.0.

Must admit I don't like ICS and don't usually use it. A proxy server such
as CCProxy would probably do a better job but that's something you can look
at when you get the network working!

Tony
January 4, 2005 1:34:26 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Noted, thanks.

Regards

Dave.
>-----Original Message-----
>"dave" <madangler@beeb.net> wrote in message
>news:131301c4f1e9$323d03f0$a401280a@phx.gbl...
>> Tony, thanks again for reply. Only introduced cable to
>> get around problem of the two machines upstairs not
>> seeing each other. Now with the extra confidence
>> provided from your reply that it all SHOULD work, I
will
>> kick the kids off again and have another go soon armed
>> with a printout of your reply.
>>
>> Thanks
>>
>> Dave
>
>Dave,
>
>Something I have noticed is that if I disconnect the
internet, the other two
>don't reconnect whilst in Adhoc mode. The only way I
found of reconnecting
>is to right click on the wireless network icon in the
systray and click on
>repair.
>
>If I disable the wireless adapter on the upstairs two,
it is still
>connecting through the cable which I have given static
IP's and changed
>subnet to 255.255.254.0.
>
>Must admit I don't like ICS and don't usually use it. A
proxy server such
>as CCProxy would probably do a better job but that's
something you can look
>at when you get the network working!
>
>Tony
>
>
>.
>
!