Sign-in / Sign-up
Your question
Solved

Upgraded to 4GB, getting blank screen

Tags:
  • Memory
  • Windows 7
Last response: in Windows 7
January 21, 2011 6:33:57 AM

PROBLEM: Windows boots and starts up, but at some point I get a black screen from which I cannot exit unless I reboot.

EXPLANATION: Since my vid card has 512MB, and my board's maximum memory is 4GB, I suspected Windows would not have the full 4GB to play with, and, sure enough, the Windows properties screen shows I have 3584 MB available. Also, the POST screen seems to test 3670016 KB, which I believe is the same thing. In fact, even the memory test programs report only 3584 MB memory.

I have been running Win 7 x64 for several months on my Gigabyte GA-K8NSC-939 motherboard using 2GB memory (4x512MB). I decided to upgrade to 4GB (4x1GB), the max the board can handle. Installed and tested using Memtest-86, Memtest86+, and Memscope with several passes of each -- all good. On the other hand, one of the advanced tests for Win Mem Diagnostic failed, but since it was making lots of artifacts on the screen, I suspected it was confusing video memory with RAM.

So I thought Windows knows about my memory and vid card and is reserving things apprpriately, but maybe not. I boot and go into Win 7, and enter my password, but some time later the screen goes dark as if it has gone to sleep, except it will not wake up. Most of the time just before it goes dark, I see several colors on the screen, which make me think it has something to do with the video, and I wonder if the computer is getting confused about which memory it can use for what purpose.

I looked in the BIOS for something obvious, but I didnt find anything, except (maybe?) the setting for "Init Display First" which was set to "PCI slot," and which I changed to "AGP," but I don't think that helped. I looked for but did not find something about memory mapping, so maybe that is on already.

Thanks for your help.

More about : upgraded 4gb blank screen

Best solution

a b } Memory
a b $ Windows 7
January 21, 2011 6:44:36 AM

Hello steveb;

In Windows Task Manager Performance tab you see the Resource Monitor button.
Run that and go to the Memory Tab.

What is that program reporting for Hardware Reserved / In Use / Modified / Standyby / Free?


Share
January 21, 2011 8:49:43 AM

Okay, ran the resource monitor. Although I was not running anything (except Task Manager & Resource Monitor), values changed while I was writing this note. And maybe the computer was still booting too.

Hardware Reserved = 0
In Use = 828-865
Modified = 83-154
Stdby = 366-725
Free = 1872-2187

Also, it said:
Available = 2576-2600
Cached = 507-879
Total = 3583
Installed = 3583

I don't know if this is common, but I also noticed that the bottom graph, Hard Faults/sec, occasionally had numbers off the top of the scale (100), although later it settled down and had none.
m
0
l
Related resources
a b } Memory
a b $ Windows 7
January 21, 2011 9:51:57 AM

Run msconfig.exe. You can type msconfig into the Start Menu search bar and choose it from the Programs category.
That will open the System Configuration window. On the Boot tab choose the Advanced Options.
Is the Maximum Memory boxed checked and is there any RAM amount listed there? If so, uncheck that box and Apply the change.





A Hard Fault means the required data or program was not found in Memory and needed to be called from the HDD.





m
0
l
a b } Memory
a b $ Windows 7
January 21, 2011 11:05:29 AM

It appears you have 512mb of ram allocated to the video. And not a discrete "Video Card".

Since you are using 4 sticks of ram you will need to adjust memory voltages up slightly. or at least to the numbers specified by your ram.
It may boot at lower voltages but will not be stable until you correctly set the voltages in the bios.
The visual artifacts and windows instability seem to go together . Which is why you should give us more details.
Video card model. (It could be a hypermemory card. Which has a small amount of onboard memory and uses system memory for additional memory.)
m
0
l
January 22, 2011 6:06:24 AM

Hey guys, thanks for so many good ideas and tips!

Thanks, WR2, for letting me know that my hard faults are not a problem.
I had already run msconfig, but I checked again -- max mem is unchecked.

Yes, Rick, I have a separate video card -- Ati Radeon HD 2600 XT with 512 MB. No built in video. Do you really think I need to change the voltage? I did run several memory testing programs for multiple passes.

Diggle, good suggestion to get the new BIOS. However, I don't find anything in BIOS to disable. I don't have onboard video, so not sure what you want me to disable.

However, after I flashed new BIOS, I did see some difference in behavior.
The very first time the POST checked a full 4GB of memory. However, I noticed that the CMOS had been reset too -- POST has gone back to checking only 3584MB since, so I suspect the reason for the change was the CMOS reset as part of the BIOS flash, not the new BIOS, but who knows?

Also, the resource monitor now is reporting a different result from before:
Hardware Reserved = 513 MB -- this is new
In Use = 907 MB
Modified = 159 MB
Stdby = 885 MB
Free = 2187 MB

and
Available = 2520 MB
Cached = 1052 MB
Total = 3583 MB -- same as before
Installed = 4096 MB -- correct figure, first time we have had this

So I figure the flashing of BIOS (or the reset of the CMOS) did some good; however, still have the multicolor screen followed by the black screen. But it hasnt happened at startup since the new BIOS; only when using firefox with multiple tabs and video, so the system is under stress.
m
0
l
a b } Memory
a b $ Windows 7
January 22, 2011 8:44:38 AM

steveb said:
So I figure the flashing of BIOS (or the reset of the CMOS) did some good; however, still have the multicolor screen followed by the black screen. But it hasnt happened at startup since the new BIOS; only when using firefox with multiple tabs and video, so the system is under stress.
Is the multi-color to black problem only happen with Firefox AND videos running together? Not Firefox alone, or videos alone? The only thing that would be stressing your video card would be some type of 3D game. The 2D workload of Firefox and videos doesn't put a heavy load on the GPU.
How old is the 2600 XT and what driver version are you running? Can you borrow a different video card?
I'm starting to think the video issues are related to the video card itself. Have an old 3D game you can throw at the card? Otherwise try the basic free edition of 3DMark 06

Can you go back into Device Manager, from the View menu choose Resources by connection, check the Show Hidden Devices option.
Then expand the Memory section to show all the connected resources. Take a screenshot of that for us if you will.

If you need a handly print screen utility try Gadwin PrintScreen 4.5 and a good place to upload images to post in the forum is ImageShack
m
0
l
January 22, 2011 11:42:10 AM

in my experience memory crashes are usually due to being wrongly set up in the bios, check you memory makers website for exact timmings and voltage and set it up in the bios manually, is your memory all the same ie. a 4gb match pair or do you have different brands. different brands and models will use different timmings and voltages so worth checking all your timimngs
m
0
l
January 22, 2011 7:55:23 PM

Wow! you guys are good! Not solved yet, but lots of good ideas. Thank you.

WR2, I opened device manager as you suggested and took a screenie using the Win 7 snip tool. By the way, speaking of stressing vid card, I am using a dual monitor setup as you will see in this pic. Also, you see the resource monitor you suggested, too. This is the "direct link" as I typed it from image shack (I am using a different computer for this forum, so I had to type it, not copy -- hope I got it right! :??:  )

http://img3.imageshack.us/img3/7192/resourcemonitorandm...

As far as to when this error is happening, I have had occasions in the last few days where the screen goes to black just as windows starts, or after log in. But since I did the BIOS flash yesterday (thanks Diggle), the only times is when I have firefox running (when I say videos, I mean videos running in FF, like YouTube or MSNBC). I know that doesnt stress like a 3D game, but I usually have 12-40 tabs and a video or radio running in firefox, so I figure that uses a lot of memory. Anyway, I will run the 3dMark after I get the most recent vid driver -- I know I'm not using latest.

The vid card is just over two years old, so it could be the card. But it really started happening after the install of the new memory. The other thing that is happening much more often is that firefox cannot restore all 40 tabs on a restart. Not sure if that implicates my memory or my disk, or firefox. But like you suggest, I will keep looking at both memory and video.

I also have another card, so I will have to do some swapping, too.

Maddy, I have two pairs of 1GB DDR (2x 2x1GB), both same model from Mushkin. I did not set timings -- let BIOS do that. However, before running Windows I did run extensive memory tests on them, so I figure the BIOS is okay with the setup.

Diggle, looking at device manager, I see a Realtek AC'97 Audio device. Must be an onboard device. Driver is by Realtek, v6.0.1.6305. I put it into my screen capture.

Oops, just crashed while uploading screen capture to image shack! Screen dissolves into colorful horizontal lines, then black. But the screen don't say "loss of signal" or whatever it is they say when you unplug cable. Was not running firefox this time; used IE just in case FF was causing the problem.
m
0
l
a b } Memory
a b $ Windows 7
January 22, 2011 8:51:15 PM

'it really started happening after the install of the new memory'

Nothing surprising in the resources connection display. It's showing that the hardware reserved RAM is most likely due to BIOS settings.

It's probably time to start simplifying things. Update the video driver. Run a single monitor during testing.

If problems continue you'll want to think about rolling back the RAM to 2GB to see if you can get a stable system.
Once you're stable, you can start adding things back one at a time till you zero in on what's causing the problem.

I'm starting to think you might have more than one issue.
m
0
l
a b } Memory
a b $ Windows 7
January 22, 2011 8:54:38 PM

When you start using a single monitor compare the Resource Monitor report monitoring the Hardware Reserved amount.
I'm wondering if the system is grabbing RAM to use as a frame buffer for the 2nd monitor.
m
0
l
January 24, 2011 2:19:32 AM

Hmm, WR2 you may be on to something (assuming your comment about me having more than one issue referred to my computer and not me :kaola:  ).

Unable to run 3dMark06 (or Vantage). I thought I would be able to, since my card has Dx 10, and Win 7 must have DirectX 11, right? In any case, running 3dMark06 runs through the two video tests, but crashes on the first CPU test with various behaviors.

I am running with just the single ananlog monitor. The hardware reserved memory per RM still is 513MB. The other thing I discovered is that now that I look at the specs for my video card again, it is only 256 MB, not 512.

Diggle, when you say uninstall the realtek driver, won't Windows just try to put some new driver there? Should I disable the audio device before or after uninstalling the driver too?

By the way, no crashes (other than the 3dMark induced ones) since I updated the video driver and went to single monitor. I may have to load up firefox again and see what happens.

Going to give 3dMark05 a try. I've got a pretty old CPU -- Athlon 64 3200+, so maybe 05 will work better.
m
0
l
a b } Memory
a b $ Windows 7
January 24, 2011 9:12:29 AM

There is a lot going on and some of it doesn't make much sense.
That 512MB hardware reserved address space is what we'd expect to see from a 32bit OS install.
In a 64bit system those hardware address space are above the 4GB physical RAM address space.
And that 256MB GPU / 512MB RAM is also a head scratcher.
Is there any other hardware or peripherals running on your system you haven't yet mentioned?
There aren't many things besides the BIOS that can tell the OS to reserve specific memory address space, at least none I know about.

Im thinking the Firefox crashes are (were?) video encoding caused. You can try Firefox browsing without video playback for testing. And then with. Consider testing with Internet Explorer or Google Chrome as well.

m
0
l
January 27, 2011 9:33:28 PM

well, this is changing from a forum post to a blog! It seems it's time for me to start pulling modules.

Anyway, getting to the questions/answers: the only hardware installed is an extra digital audio adapter coming off the mobo. Not even sure you would call that extra. But it does provide a 2nd digital audio output.

peripherals -- just regular stuff: analog monitor, keyboard, mouse, 2.1 speakers, ethernet

As far as the 64-bit win 7, I have read elsewhere (yep, searched and read before posting :D  ) that a mobo (like mine) that supports a max of 4GB will have BIOS somewhere in the 4GB, not above it. Sounds as if you do not agree with that theory?

turning to firefox, I started using IE, no FF and no videos inside IE. But I still get crashes. Sometimes IE stops and has to restart, sometimes Windows Explorer has to restart. So probably not firefox problem.

I did notice something else I had forgotten -- the memory tests memtest-86 and memtest86+ (which are basically the same) and the POST memory check all show that they are testing 3584 MB -- which is 512MB short. On the other hand, the resource monitor shows 4096 MB installed. I had thought that the memory testers were reserving space for the vid card or some BIOS things, but I wonder if they should show the entire amount installed? When I started with only 2GB installed and ran memory tests, they showed 2048 MB installed, so that is correct.

As you said, something strange going on here. Will pull some memory modules and see what happens.
m
0
l
January 29, 2011 11:57:57 PM

Mushkin PC3200 two pairs of 1GB; all DDR400. Rated at 3-3-3-8.
Since this is dual channel memory, the mobo probably has slots in pairs, but I don't think I looked at that -- just put all four sticks in. They are running at DR333; that is a limitation of this gigabyte board when there are four sticks present.

I noticed that my BIOS had automatically set them at 2.5-3-3-3-7, so (even tho they worked fine in memtest) I reset them to 3-3-3-3-8. Ran memtest again, still works fine.

But still getting reboots, freezing cursor,able to log into Win 7, but then freezes. Since I have a ubuntu Live CD, and since the errors seem to happen in Windows, but not in the memory test programs, I am going to run ubuntu and see what happens. Won't be stressing the computer a lot, but at least we can see if we get errors.
m
0
l
January 31, 2011 12:27:29 AM

Hehe, had just done that before I saw your post, diggle!

So, safe mode with networking, twice (out of two times) got bsod, both times while in a browser (FF once, IE once). Also, before going into safe mode, I went into BIOS and disabled AC97 audio. I remember you had suggested getting rid of Realtek driver, so not sure if that does what you want. If not, I will have to go into regular (not safe mode) Windows, since the sound device does not appear in safe mode.

So I think I am not running that Realtek driver while in safe mode.

However, running the ubuntu Live CD ran for 12 hours or so without a crash. Since I was on the Live CD, it does not write anything to disk, and I could not start firefox, so I couldnt browse -- just ran some 2D games, so nothing too intense.

I have been threatening my computer that I will start pulling out memory sticks; guess it's time to do that. After I try to run in safe mode without starting a browser. Maybe run safe mode w/o networking? The saga continues ...

thanks for your help, diggle and WR2, and the rest of you reading this.

Oh, almost forgot to mention: when I got bsod, one time I was in browswer looking at page about ubuntu; the other time I was downloading an ubuntu file. Both times, Windows gave me a bsod. Coincidence or conspiracy? :heink: 
m
0
l
April 10, 2011 7:10:20 PM

hi, i think i'm having the same problem as the OP.

i ran that program and here are is the information:

ntoskrnl.exe ntoskrnl.exe+2ac6f fffff800`03067000 fffff800`03651000 0x005ea000 0x4ce7951a 11/20/2010 4:30:02 AM Microsoft® Windows® Operating System NT Kernel & System 6.1.7601.17514 (win7sp1_rtm.101119-1850) Microsoft Corporation C:\Windows\system32\ntoskrnl.exe

win32k.sys win32k.sys+c481e fffff960`00020000 fffff960`00331000 0x00311000 0x4d2415ea 1/5/2011 1:55:38 AM

m
0
l
April 19, 2011 4:09:40 AM

Interesting -- this thread is a little more difficult to understand now that all of diggle's comments have been removed. Anyway, after two months, I went ahead and took out two sticks or RAM, so now I have 2x1GB. Win7 now working fine.

So either my problem is too much RAM, or the other two sticks are bad, despite testing OK by three different memory tests. Maybe in another couple months I will swap these sticks with the other two and see what happens. In the mean time, other users of the Gigabyte GA-K8NSC-939, caveat emptor! :o 
m
0
l
April 19, 2011 4:10:45 AM

Best answer selected by steveb.
m
0
l