Old PC - ASUS P5A-B - Will not boot Linux (Ubuntu)

Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

PC Will not boot Linux

I set up my PC BIOS to like this:

size cyls heads sectors
Pri Master HD1 USER 20515 2494 255 63 LBA

Sec Master (CD) AUTO

The option for LARGE/NORMAL is: 39761 cyls, 16 heads (which I
think corresponds to the physical layout of the HDD)

I partitioned my HD:

Number type size format partition
#1 primary 63.9M ext3 /boot (bootable)
#5 logical 1G ext3 /
#6 logical 1G ext3 /home
#7 logical 6G ext3 /usr
#8 logical 10.7G ext3 /var
#9 logical 1G ext3 /tmp
#3 primary 624M swap swap

The above is a summary of the info Ubuntu partitioning utility
gives me. All partitions were formatted. Only one partition is
bootable (/boot).

Ubuntu (v4.10) installed itself without complaint after I had
finished partitioning and then instructed me to remove the CD,
which I did.

I altered the BIOS boot sequence to boot C, A [but the original
CDROM, A, C sequence won't boot from HDD either]

During bootup attempt I see the following message:

"Detecting HDD Secondary Master ... ATAPI 52x CDROM"

It hangs around there for about a minute then tells me it can't
boot.

THERE IS NO MENTION OF IT "Detecting HDD Primary Master". The
final error message is:

"DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER"

Above that error message BIOS indicates the following fixed
disks:

Primary Master: CHS, Mode 0, 20521 MB
Secondary Master: CDROM, UDMA2

The jumpers are correctly set in the HDD and CDROM (both
masters)

PS: Previously the ROM would show that the HDD was mode 3 (or 4)
not mode 0. (When running under Windows)

The Mobo BIOS is: ASUS P5A-B (bios rev 1010, 24-02-2000) with
AMD K6-II 550 MHz chip, 256 M RAM

Some BIOS settings are:

HDD SMART capability: enabled
IDE HDD Block Mode Sectors: HDD MAX
IDE Ultra DMA Mode: enabled

AGP Bus Turbo Mode enabled


Q: Did I make a fundamental mistake in partitioning my disk for
Linux. If so what should my partitions have been and why did
Ubuntu install itself without errors (if I made mistakes)?

Q: Given that I've run this HDD under Windows using Ultra DMA
mode, how suspicious is it that my computer tells me that the
HDD is "CHS, Mode 0"

Q: Is there a way to find out which particular Mobo / BIOS
versions have been tested for Ubuntu Linux?

Q: Should I burn the BIOS with an earlier version (earlier than
1010), to try to get it working? [I think I already have the
most recent BIOS]

Q: Should I change the BIOS settings for the HD (from LBA to
LARGE) ?

Q: Should I switch off "AGP Bus Turbo Mode" and try again - or
can't this possibly affect the HDD?

Q: Should I give up?
15 answers Last reply
More about asus boot linux ubuntu
  1. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    "mark4asp" <mark4asp@ntlworld.com> skrev i meddelandet
    news:cbdfo05ftvo4c9vtp90lh7am5gi8kie2oe@4ax.com...
    > PC Will not boot Linux
    >
    > I set up my PC BIOS to like this:
    >
    > size cyls heads sectors
    > Pri Master HD1 USER 20515 2494 255 63 LBA
    >
    > Sec Master (CD) AUTO
    >
    > The option for LARGE/NORMAL is: 39761 cyls, 16 heads (which I
    > think corresponds to the physical layout of the HDD)
    >
    > I partitioned my HD:
    >
    > Number type size format partition
    > #1 primary 63.9M ext3 /boot (bootable)
    > #5 logical 1G ext3 /
    > #6 logical 1G ext3 /home
    > #7 logical 6G ext3 /usr
    > #8 logical 10.7G ext3 /var
    > #9 logical 1G ext3 /tmp
    > #3 primary 624M swap swap
    >
    > The above is a summary of the info Ubuntu partitioning utility
    > gives me. All partitions were formatted. Only one partition is
    > bootable (/boot).
    >
    > Ubuntu (v4.10) installed itself without complaint after I had
    > finished partitioning and then instructed me to remove the CD,
    > which I did.
    >
    > I altered the BIOS boot sequence to boot C, A [but the original
    > CDROM, A, C sequence won't boot from HDD either]
    >
    > During bootup attempt I see the following message:
    >
    > "Detecting HDD Secondary Master ... ATAPI 52x CDROM"
    >
    > It hangs around there for about a minute then tells me it can't
    > boot.
    >
    > THERE IS NO MENTION OF IT "Detecting HDD Primary Master". The
    > final error message is:
    >
    > "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER"
    >
    > Above that error message BIOS indicates the following fixed
    > disks:
    >
    > Primary Master: CHS, Mode 0, 20521 MB
    > Secondary Master: CDROM, UDMA2
    >
    > The jumpers are correctly set in the HDD and CDROM (both
    > masters)
    >
    > PS: Previously the ROM would show that the HDD was mode 3 (or 4)
    > not mode 0. (When running under Windows)
    >
    > The Mobo BIOS is: ASUS P5A-B (bios rev 1010, 24-02-2000) with
    > AMD K6-II 550 MHz chip, 256 M RAM
    >
    > Some BIOS settings are:
    >
    > HDD SMART capability: enabled
    > IDE HDD Block Mode Sectors: HDD MAX
    > IDE Ultra DMA Mode: enabled
    >
    > AGP Bus Turbo Mode enabled
    >
    >
    > Q: Did I make a fundamental mistake in partitioning my disk for
    > Linux. If so what should my partitions have been and why did
    > Ubuntu install itself without errors (if I made mistakes)?
    >
    > Q: Given that I've run this HDD under Windows using Ultra DMA
    > mode, how suspicious is it that my computer tells me that the
    > HDD is "CHS, Mode 0"
    >
    > Q: Is there a way to find out which particular Mobo / BIOS
    > versions have been tested for Ubuntu Linux?
    >
    > Q: Should I burn the BIOS with an earlier version (earlier than
    > 1010), to try to get it working? [I think I already have the
    > most recent BIOS]
    >
    > Q: Should I change the BIOS settings for the HD (from LBA to
    > LARGE) ?
    >
    > Q: Should I switch off "AGP Bus Turbo Mode" and try again - or
    > can't this possibly affect the HDD?
    >
    > Q: Should I give up?
    >

    Seems like it's not a Linux problem, reset bios to default settings, have
    the HDD in Auto mode.
  2. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    mark4asp <mark4asp@ntlworld.com> wrote:
    > Q: Should I change the BIOS settings for the HD (from LBA to
    > LARGE) ?

    LBA Mode? I thought that it was in Normal mode. Maybe I didn't understand the
    start of your message.

    Set the mode to "Normal" in the BIOS, then partition the drive and install the
    software.

    I also recommend that you switch off "SMART" disk monitoring. This causes
    problems on some machines.

    Regards,

    Mark.

    --

    Mark Hobley
    393 Quinton Road West
    QUINTON
    Birmingham
    B32 1QE

    Reply to: markhobley at hotpop dot do_not_type_this_bit com

    http://markhobley.yi.org/
  3. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    mark4asp <mark4asp@ntlworld.com> writes:
    > I partitioned my HD:
    >
    > Number type size format partition
    > #1 primary 63.9M ext3 /boot (bootable)
    > #5 logical 1G ext3 /
    > #6 logical 1G ext3 /home
    > #7 logical 6G ext3 /usr
    > #8 logical 10.7G ext3 /var
    > #9 logical 1G ext3 /tmp
    > #3 primary 624M swap swap
    ^^^^

    Does this mean the swap partition is last on the disk? That's not a
    good idea, if swap is ever used it should be pretty fast (best put
    directly after /boot at the beginning of the disk). Unfortunately this
    output is rather short. Could you perhaps try to see what "fdisk -l"
    issued from a console tells you (should be available via Alt-F2 or
    Alt-F3 from most Linux installation media).

    > THERE IS NO MENTION OF IT "Detecting HDD Primary Master". The
    > final error message is:
    >
    > "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER"

    That probably means the boot sector in the mbr of your disk sees no
    active partition. Have you checked wether your bootable /boot partition
    is also the (only) active partition? You could check this from your
    Ubuntu boot media or any other system with partitioning utility you have
    on a bootable cd (even Windows XP cd will do).

    > Q: Did I make a fundamental mistake in partitioning my disk for
    > Linux. If so what should my partitions have been and why did
    > Ubuntu install itself without errors (if I made mistakes)?

    Not in any way to prevent booting per se.

    > Q: Given that I've run this HDD under Windows using Ultra DMA
    > mode, how suspicious is it that my computer tells me that the
    > HDD is "CHS, Mode 0"

    What part of your computer tells you this?

    > Q: Is there a way to find out which particular Mobo / BIOS
    > versions have been tested for Ubuntu Linux?

    This is mostly a question specific to the Linux kernel. Ubuntu takes
    most modifications from debian, so you might want to search both
    projects' pages. But because your system doesn't even load the boot
    loader it's not relevant to your problem. And the fact that the install
    went fine tells me that all hardware absolutely necessary is working
    fine.

    > Q: Should I burn the BIOS with an earlier version (earlier than
    > 1010), to try to get it working? [I think I already have the
    > most recent BIOS]

    Not unless you find a specific problem report.

    > Q: Should I change the BIOS settings for the HD (from LBA to
    > LARGE) ?

    Not really. I think that might one day have been useful for relatively
    old operating systems (think older than Win95).

    > Q: Should I switch off "AGP Bus Turbo Mode" and try again - or
    > can't this possibly affect the HDD?

    I don't see any obvious connection but can't give any good
    recommendation either.

    > Q: Should I give up?

    Not at all, you are probably just stuck with a very simple problem. Not
    seeing the wood for all the trees as we say in Germany is just so normal
    for human beings, that even a moment of contemplation can give you just
    the right idea how to tackle this.

    Thomas Jahns
    --
    "Computers are good at following instructions,
    but not at reading your mind."
    D. E. Knuth, The TeXbook, Addison-Wesley 1984, 1986, 1996, p. 9
  4. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    "Thomas Jahns" <Thomas.Jahns@epost.de> wrote in message
    news:87d5yvvo3a.fsf@ID-48333.user.dfncis.de...
    > mark4asp <mark4asp@ntlworld.com> writes:
    >> I partitioned my HD:
    >>
    >> Number type size format partition
    >> #1 primary 63.9M ext3 /boot (bootable)
    >> #5 logical 1G ext3 /
    >> #6 logical 1G ext3 /home
    >> #7 logical 6G ext3 /usr
    >> #8 logical 10.7G ext3 /var
    >> #9 logical 1G ext3 /tmp
    >> #3 primary 624M swap swap
    > ^^^^
    >
    > Does this mean the swap partition is last on the disk? That's not a
    > good idea, if swap is ever used it should be pretty fast (best put
    > directly after /boot at the beginning of the disk). Unfortunately this
    > output is rather short. Could you perhaps try to see what "fdisk -l"
    > issued from a console tells you (should be available via Alt-F2 or
    > Alt-F3 from most Linux installation media).
    >

    I would have thought so also, but if my memory serves me right, when you let
    the install program auto partition your drive it sets up a seemingly
    ridiculous number of partitions and puts the swap at the end. Perhaps if you
    have multiple devices you might want to mount them differently, but IMHO the
    best utilization of space on a single disk is a swap and root.
  5. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    Do not forget to disable the virus protection in the bios to give Linux
    acces to the Master Boot Record.
    The best place for Lilo is the master boot record of the first harddisk.
    You can restor the Master boot record Whith a Windows 89 floppy containing
    fdisk.
    command is fdisk /mbr
    The rest of the bios settings cen be left standard.

    "Thomas Jahns" <Thomas.Jahns@epost.de> schreef in bericht
    news:87d5yvvo3a.fsf@ID-48333.user.dfncis.de...
    > mark4asp <mark4asp@ntlworld.com> writes:
    >> I partitioned my HD:
    >>
    >> Number type size format partition
    >> #1 primary 63.9M ext3 /boot (bootable)
    >> #5 logical 1G ext3 /
    >> #6 logical 1G ext3 /home
    >> #7 logical 6G ext3 /usr
    >> #8 logical 10.7G ext3 /var
    >> #9 logical 1G ext3 /tmp
    >> #3 primary 624M swap swap
    > ^^^^
    >
    > Does this mean the swap partition is last on the disk? That's not a
    > good idea, if swap is ever used it should be pretty fast (best put
    > directly after /boot at the beginning of the disk). Unfortunately this
    > output is rather short. Could you perhaps try to see what "fdisk -l"
    > issued from a console tells you (should be available via Alt-F2 or
    > Alt-F3 from most Linux installation media).
    >
    >> THERE IS NO MENTION OF IT "Detecting HDD Primary Master". The
    >> final error message is:
    >>
    >> "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER"
    >
    > That probably means the boot sector in the mbr of your disk sees no
    > active partition. Have you checked wether your bootable /boot partition
    > is also the (only) active partition? You could check this from your
    > Ubuntu boot media or any other system with partitioning utility you have
    > on a bootable cd (even Windows XP cd will do).
    >
    >> Q: Did I make a fundamental mistake in partitioning my disk for
    >> Linux. If so what should my partitions have been and why did
    >> Ubuntu install itself without errors (if I made mistakes)?
    >
    > Not in any way to prevent booting per se.
    >
    >> Q: Given that I've run this HDD under Windows using Ultra DMA
    >> mode, how suspicious is it that my computer tells me that the
    >> HDD is "CHS, Mode 0"
    >
    > What part of your computer tells you this?
    >
    >> Q: Is there a way to find out which particular Mobo / BIOS
    >> versions have been tested for Ubuntu Linux?
    >
    > This is mostly a question specific to the Linux kernel. Ubuntu takes
    > most modifications from debian, so you might want to search both
    > projects' pages. But because your system doesn't even load the boot
    > loader it's not relevant to your problem. And the fact that the install
    > went fine tells me that all hardware absolutely necessary is working
    > fine.
    >
    >> Q: Should I burn the BIOS with an earlier version (earlier than
    >> 1010), to try to get it working? [I think I already have the
    >> most recent BIOS]
    >
    > Not unless you find a specific problem report.
    >
    >> Q: Should I change the BIOS settings for the HD (from LBA to
    >> LARGE) ?
    >
    > Not really. I think that might one day have been useful for relatively
    > old operating systems (think older than Win95).
    >
    >> Q: Should I switch off "AGP Bus Turbo Mode" and try again - or
    >> can't this possibly affect the HDD?
    >
    > I don't see any obvious connection but can't give any good
    > recommendation either.
    >
    >> Q: Should I give up?
    >
    > Not at all, you are probably just stuck with a very simple problem. Not
    > seeing the wood for all the trees as we say in Germany is just so normal
    > for human beings, that even a moment of contemplation can give you just
    > the right idea how to tackle this.
    >
    > Thomas Jahns
    > --
    > "Computers are good at following instructions,
    > but not at reading your mind."
    > D. E. Knuth, The TeXbook, Addison-Wesley 1984, 1986, 1996, p. 9
  6. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    On Tue, 02 Nov 2004 18:07:27 GMT,
    markhobley@hotpop.deletethisbit.co.uk (Mark Hobley) wrote:

    >mark4asp <mark4asp@ntlworld.com> wrote:
    >> Q: Should I change the BIOS settings for the HD (from LBA to
    >> LARGE) ?
    >
    >LBA Mode? I thought that it was in Normal mode. Maybe I didn't understand the
    >start of your message.
    >
    >Set the mode to "Normal" in the BIOS, then partition the drive and install the
    >software.
    >
    >I also recommend that you switch off "SMART" disk monitoring. This causes
    >problems on some machines.
    >
    >Regards,
    >
    >Mark.

    1) I checked the disk jumpers again - both set to Master

    2) I reset the BIOS to LOAD BIOS DEFAULTS, followed by LOAD
    SETUP DEFAULTS

    3) I switched off virus boot protection (which had been switched
    on by (2)). Note PnP BIOS setting was also switched off by (2).
    SMART was switched off by (2).

    4) Auto detected disks (& found the HDD)

    5) Set disk config for master (no secondaries present) disks to
    for HDD / CDROM to:

    type cont size cyls heads secs mode
    USER PRI 20521 39761 16 63 NORMAL
    AUTO SEC 0 0 0 0 NORMAL

    6) Booted a Win98 startup floppy, Ran FDISK, Got an ERROR:
    "No Fixed Disks Present"

    7) Reset, Booted with Partition Magic 8 floppies, Got an error:
    "Error #88, Unable to find the drive specified"

    Q: If my Linux partition software can see the disk why cant
    floppy disk utils such as FDISK and PM8 ?

    There seems to be a very serious error here if neither DOS
    "fdisk /mbr", not PM8 can see the HDD. It looks like either a
    HDD or controller error to me.

    Q: Is this a HDD / mobo controller / cable problem ?

    Perhaps I should
    a) switch the controllers so that the CDROM is on controller 0
    and the HDD on controller 1 ?
    or b) Put both HDD & CDROM on the same controller.
    or c) Change the CDROM (I can't change the HDD - it's the only
    spare I have.
  7. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    On Tue, 02 Nov 2004 16:51:59 +0000, mark4asp wrote:

    > PC Will not boot Linux
    >
    > I set up my PC BIOS to like this:
    >
    > size cyls heads sectors
    > Pri Master HD1 USER 20515 2494 255 63 LBA
    >
    > Sec Master (CD) AUTO
    >
    > The option for LARGE/NORMAL is: 39761 cyls, 16 heads (which I think
    > corresponds to the physical layout of the HDD)
    >
    > I partitioned my HD:
    >
    > Number type size format partition
    > #1 primary 63.9M ext3 /boot (bootable) #5 logical 1G ext3 / #6 logical
    > 1G ext3 /home
    > #7 logical 6G ext3 /usr
    > #8 logical 10.7G ext3 /var
    > #9 logical 1G ext3 /tmp
    > #3 primary 624M swap swap
    >
    > The above is a summary of the info Ubuntu partitioning utility gives me.
    > All partitions were formatted. Only one partition is bootable (/boot).
    >
    > Ubuntu (v4.10) installed itself without complaint after I had finished
    > partitioning and then instructed me to remove the CD, which I did.
    >
    > I altered the BIOS boot sequence to boot C, A [but the original CDROM,
    > A, C sequence won't boot from HDD either]
    >
    > During bootup attempt I see the following message:
    >
    > "Detecting HDD Secondary Master ... ATAPI 52x CDROM"
    >
    > It hangs around there for about a minute then tells me it can't boot.
    >
    > THERE IS NO MENTION OF IT "Detecting HDD Primary Master". The final
    > error message is:
    >
    > "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER"
    >
    > Above that error message BIOS indicates the following fixed disks:
    >
    > Primary Master: CHS, Mode 0, 20521 MB Secondary Master: CDROM, UDMA2
    >
    > The jumpers are correctly set in the HDD and CDROM (both masters)
    >
    > PS: Previously the ROM would show that the HDD was mode 3 (or 4) not
    > mode 0. (When running under Windows)
    Get it working in BIOS setup (read below), then reformat in linux when
    specifying LBA mode.


    > The Mobo BIOS is: ASUS P5A-B (bios rev 1010, 24-02-2000) with AMD K6-II
    > 550 MHz chip, 256 M RAM
    >
    I am not near the computers I manage which are using the P5A. I know I
    have one system with the P5A with a 40G hard disk and the onboard ALi
    chipset hard disk contoller with a 40G disk. I had to upgrade the BIOS at
    some point to cross the 32G barrier.

    > Some BIOS settings are:
    >
    > HDD SMART capability: enabled
    > IDE HDD Block Mode Sectors: HDD MAX
    > IDE Ultra DMA Mode: enabled
    >
    > AGP Bus Turbo Mode enabled
    >
    >
    > Q: Did I make a fundamental mistake in partitioning my disk for Linux.
    > If so what should my partitions have been and why did Ubuntu install
    > itself without errors (if I made mistakes)?
    >
    > Q: Given that I've run this HDD under Windows using Ultra DMA mode, how
    > suspicious is it that my computer tells me that the HDD is "CHS, Mode 0"
    That is the key.


    > Q: Is there a way to find out which particular Mobo / BIOS versions have
    > been tested for Ubuntu Linux?
    You want kernel support for the ALi chipset. I don't use Ubuntu, but I
    think it should support ALi. Look at the kernel configuration file for
    this entry: CONFIG_BLK_DEV_ALI15X3=y


    > Q: Should I burn the BIOS with an earlier version (earlier than 1010),
    > to try to get it working?
    No. If it is most recent, then it should work.


    > Q: Should I change the BIOS settings for the HD (from LBA to LARGE) ?
    No, use LBA.
    >
    > Q: Should I switch off "AGP Bus Turbo Mode" and try again - or can't
    > this possibly affect the HDD?
    Don't know.


    > Q: Should I give up?
    Not unless you're a quitter. ;-)


    Note: part of response inline.

    Within BIOS setup, specify to autodetect your hard drive type- do not
    specify CHS. There is a menu entry within the BIOS setup of this
    motherboard which will show what is presently detected. If your hard
    drive is not "detected" in that environment, then there could be a
    hardware on another problem. Usually, 32G is a BIOS limit for older
    boards, not the 20G you are using. So, I would expect the drive to be
    autodetected correctly. By specifying CHS as a "user" type, it appears to
    override any autodetected information. Also, I think that you want to
    boot/format linux in LBA mode.

    --
    Chandra: HAL was told to lie - by people who find it easy to lie.
    HAL doesn't know how.
    http://us.imdb.com/title/tt0086837/quotes
  8. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    mark4asp <mark4asp@ntlworld.com> wrote:
    >>> Q: Should I change the BIOS settings for the HD (from LBA to
    >>> LARGE) ?

    >>Set the mode to "Normal" in the BIOS, then partition the drive and install the
    >>software.
    >>
    >>I also recommend that you switch off "SMART" disk monitoring. This causes
    >>problems on some machines.
    >>
    >
    > 1) I checked the disk jumpers again - both set to Master

    Ok, Master is fine.
    >
    > 2) I reset the BIOS to LOAD BIOS DEFAULTS, followed by LOAD
    > SETUP DEFAULTS

    Ok, check that the drive configuration is "Normal". You do not want LBA.
    >
    > 4) Auto detected disks (& found the HDD)
    >

    Switch to "Normal", if this has not occured.

    > 5) Set disk config for master (no secondaries present) disks to
    > for HDD / CDROM to:
    >
    > type cont size cyls heads secs mode
    > USER PRI 20521 39761 16 63 NORMAL
    > AUTO SEC 0 0 0 0 NORMAL
    >

    Ok

    > 6) Booted a Win98 startup floppy, Ran FDISK, Got an ERROR:
    > "No Fixed Disks Present"

    Ok. How big is the hard disk ?

    I am not sure why its not seeing the hard disk. This could be a bios or
    hardware problem.

    How big is the hard disk ?

    > Q: If my Linux partition software can see the disk why cant
    > floppy disk utils such as FDISK and PM8 ?
    >

    Ok, reboot and try again.

    > There seems to be a very serious error here if neither DOS
    > "fdisk /mbr", not PM8 can see the HDD. It looks like either a
    > HDD or controller error to me.
    >
    Maybe. Check the cables and try again.

    When you boot the machine, sometimes the BIOS displays on the screen what
    drives are present.

    Have a look to see if yours is listed.

    If the Linux tools are consistently seeing the drive, but the DOS ones
    are not, I would not worry too much.

    Just drop Linux on there. Maybe create a partition at the end of the
    drive and run

    badblocks -w

    Or better still, if you have a boot CDROM with this capability run badblocks
    against the whole drive.

    If no bad blocks are order, then I'd live with it.

    Just remember to back up regularly. You should always do this anyway.

    Regards,

    Mark.

    --

    Mark Hobley
    393 Quinton Road West
    QUINTON
    Birmingham
    B32 1QE

    Reply to: markhobley at hotpop dot do_not_type_this_bit com

    http://markhobley.yi.org/
  9. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    On Wed, 03 Nov 2004 11:07:11 GMT,
    markhobley@hotpop.deletethisbit.co.uk (Mark Hobley) wrote:

    >mark4asp <mark4asp@ntlworld.com> wrote:
    >>>> Q: Should I change the BIOS settings for the HD (from LBA to
    >>>> LARGE) ?
    >
    >>>Set the mode to "Normal" in the BIOS, then partition the drive and install the
    >>>software.
    >>>
    >>>I also recommend that you switch off "SMART" disk monitoring. This causes
    >>>problems on some machines.
    >>>
    >>
    >> 1) I checked the disk jumpers again - both set to Master
    >
    >Ok, Master is fine.
    >>
    >> 2) I reset the BIOS to LOAD BIOS DEFAULTS, followed by LOAD
    >> SETUP DEFAULTS
    >
    >Ok, check that the drive configuration is "Normal". You do not want LBA.
    >>
    >> 4) Auto detected disks (& found the HDD)
    >>
    >
    >Switch to "Normal", if this has not occured.
    >
    >> 5) Set disk config for master (no secondaries present) disks to
    >> for HDD / CDROM to:
    >>
    >> type cont size cyls heads secs mode
    >> USER PRI 20521 39761 16 63 NORMAL
    >> AUTO SEC 0 0 0 0 NORMAL
    >>
    >
    >Ok
    >
    >> 6) Booted a Win98 startup floppy, Ran FDISK, Got an ERROR:
    >> "No Fixed Disks Present"
    >
    >Ok. How big is the hard disk ?
    >
    >I am not sure why its not seeing the hard disk. This could be a bios or
    >hardware problem.

    Yes. It must be a hardware problem. I downloaded the Western
    Digital disk diagnostics prorgam and that wouldn't even run it's
    2 minute test before conking out and giving an error.

    >How big is the hard disk ?

    Only 20 GB. I've already upgraded the mobo BIOS to cope with
    much bigger hard disks.

    I shall have to try this HDD with a different mobo or on a
    different controller.

    >
    >> Q: If my Linux partition software can see the disk why cant
    >> floppy disk utils such as FDISK and PM8 ?
    >>
    >
    >Ok, reboot and try again.
    >
    >> There seems to be a very serious error here if neither DOS
    >> "fdisk /mbr", not PM8 can see the HDD. It looks like either a
    >> HDD or controller error to me.
    >>
    >Maybe. Check the cables and try again.
    >
    >When you boot the machine, sometimes the BIOS displays on the screen what
    >drives are present.
    >
    >Have a look to see if yours is listed.
    >
    >If the Linux tools are consistently seeing the drive, but the DOS ones
    >are not, I would not worry too much.
    >
    >Just drop Linux on there. Maybe create a partition at the end of the
    >drive and run
    >
    >badblocks -w
    >
    >Or better still, if you have a boot CDROM with this capability run badblocks
    >against the whole drive.
    >
    >If no bad blocks are order, then I'd live with it.
    >
    >Just remember to back up regularly. You should always do this anyway.
    >
    >Regards,
    >
    >Mark.
  10. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    On Wed, 03 Nov 2004 11:07:11 GMT,
    markhobley@hotpop.deletethisbit.co.uk (Mark Hobley) wrote:

    >mark4asp <mark4asp@ntlworld.com> wrote:
    >
    >> There seems to be a very serious error here if neither DOS
    >> "fdisk /mbr", not PM8 can see the HDD. It looks like either a
    >> HDD or controller error to me.
    >>
    >Maybe. Check the cables and try again.

    I changed the cable and altered the HDD jumper to factory
    setting (neither CS nor SL nor MA). It is the only drive on that
    cable. I did change the cable yesterday when it wasn't working -
    so I've either got 2 faulty cables or it was the wrong jumper
    setting. I suspect the wrong jumper setting.

    This time, DOS FDISK did run

    I've already booted Win95 startup and run "FDISK /MBR"

    So it looks like it was a cable problem all along.

    Thanks for your help, it looks like it was actually the HDD
    jumper setting that was causing the problem (set to MA for a
    single drive on the cable).

    I shall run the WD diagnostics program I downloaded again, as
    well.

    >When you boot the machine, sometimes the BIOS displays on the screen what
    >drives are present.
    >
    >Have a look to see if yours is listed.

    WDC WD205AA, 20.5 G. My HDD diagnostics figured that out
    yesterday before it died.

    >If the Linux tools are consistently seeing the drive, but the DOS ones
    >are not, I would not worry too much.
    >
    >Just drop Linux on there. Maybe create a partition at the end of the
    >drive and run
    >
    >badblocks -w

    Thanks. I'll run that anyway.

    >Or better still, if you have a boot CDROM with this capability run badblocks
    >against the whole drive.
    >
    >If no bad blocks are order, then I'd live with it.
    >
    >Just remember to back up regularly. You should always do this anyway.
    >
    >Regards,
    >
    >Mark.

    Thanks for your help Mark, I think I've figured out the problem.

    My machine BIOS config screen, that shows during bootup, also
    reports that the drive is "CHS UDMA mode 2" whereas previously,
    when it was broke, it had been shown to be "CHS, Mode 0". Given
    that the HDD controller and HDD can both handle UDMA mode 2 -
    that is a sure sign of confidence.

    One last question. Is this scheme, below, OK for partitioning my
    20.5 G HDD?

    Number type size format partition
    #1 primary 64M ext3 /boot (bootable)
    #5 logical 1G ext3 /
    #3 primary 512M swap swap
    #6 logical 1G ext3 /home
    #7 logical 6G ext3 /usr
    #8 logical 10.8G ext3 /var
    #9 logical 1G ext3 /tmp

    I'm now loading Linux again but the default gives only 2
    partitions: 20G + .5G swap.
  11. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    On Wed, 03 Nov 2004 11:07:11 GMT,
    markhobley@hotpop.deletethisbit.co.uk (Mark Hobley) wrote:

    >mark4asp <mark4asp@ntlworld.com> wrote:
    >
    >> There seems to be a very serious error here if neither DOS
    >> "fdisk /mbr", not PM8 can see the HDD. It looks like either a
    >> HDD or controller error to me.
    >>
    >Maybe. Check the cables and try again.

    I changed the cable and altered the HDD jumper to factory
    setting (neither CS nor SL nor MA). It is the only drive on that
    cable. I did change the cable yesterday when it wasn't working -
    so I've either got 2 faulty cables or it was the wrong jumper
    setting. I suspect the wrong jumper setting.

    This time, DOS FDISK did run

    I've already booted Win95 startup and run "FDISK /MBR"

    So it looks like it was a cable problem or HDD jumper setting
    that was causing the problem (set to MA for a single drive on
    the cable). I suspect it was the jumper setting. I shall change
    the cable again later to check this.

    I shall run the WD diagnostics program I downloaded again, as
    well.

    >When you boot the machine, sometimes the BIOS displays on the screen what
    >drives are present.
    >
    >Have a look to see if yours is listed.

    WDC WD205AA, 20.5 G. My HDD diagnostics figured that out
    yesterday before it died.

    >If the Linux tools are consistently seeing the drive, but the DOS ones
    >are not, I would not worry too much.
    >
    >Just drop Linux on there. Maybe create a partition at the end of the
    >drive and run
    >
    >badblocks -w

    Thanks. I'll run that anyway.

    >Or better still, if you have a boot CDROM with this capability run badblocks
    >against the whole drive.
    >
    >If no bad blocks are order, then I'd live with it.
    >
    >Just remember to back up regularly. You should always do this anyway.
    >
    >Regards,
    >
    >Mark.

    Thanks for your help Mark, I think I've figured out the problem.

    My machine BIOS config screen, that shows during bootup, also
    reports that the drive is "CHS UDMA mode 2" whereas previously,
    when it was broke, it had been shown to be "CHS, Mode 0". Given
    that the HDD controller and HDD can both handle UDMA mode 2 -
    that is a sure sign of confidence.

    One last question. Is this scheme, below, OK for partitioning my
    20.5 G HDD?

    Number type size format partition
    #1 primary 64M ext3 /boot (bootable)
    #5 logical 1G ext3 /
    #3 primary 512M swap swap
    #6 logical 1G ext3 /home
    #7 logical 6G ext3 /usr
    #8 logical 10.8G ext3 /var
    #9 logical 1G ext3 /tmp

    I'm now loading Linux again but the default gives only 2
    partitions: 20G + .5G swap.
  12. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    mark4asp <mark4asp@ntlworld.com> wrote:
    >
    > One last question. Is this scheme, below, OK for partitioning my
    > 20.5 G HDD?
    >
    > Number type size format partition
    > #1 primary 64M ext3 /boot (bootable)
    > #5 logical 1G ext3 /
    > #3 primary 512M swap swap
    > #6 logical 1G ext3 /home
    > #7 logical 6G ext3 /usr
    > #8 logical 10.8G ext3 /var
    > #9 logical 1G ext3 /tmp
    >

    That looks fine to me.

    Regards,

    Mark.

    --

    Mark Hobley
    393 Quinton Road West
    QUINTON
    Birmingham
    B32 1QE

    Reply to: markhobley at hotpop dot do_not_type_this_bit com

    http://markhobley.yi.org/
  13. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    In article <cdngo0ppi578rouhcu9380dqgk9ib1phb3@4ax.com>, mark4asp
    <mark4asp@ntlworld.com> writes
    [...]
    >1) I checked the disk jumpers again - both set to Master
    [...]
    >or b) Put both HDD & CDROM on the same controller.

    I am out of my newb depth but have recently posted about something that
    might be relevant:

    ++++++++++++++++
    From: AC <aec$news@....>
    Newsgroups: comp.os.linux.misc
    Subject: Re: "Live" CDs wont boot.
    Date: Fri, 5 Nov 2004 06:23:04 +0000

    I am fairly new to linux and have had some similar problems. However,
    although I have not followed the problem to conclusion, I have recently
    read:
    ================
    If your atapi cd-rom is not recognised .... while reading .... most
    frequently due to incorrectly installed hardware. All devices must be
    ..... eide controller in the correct order. The first device is master on
    the first controller. The second device is slave on the first
    controller. The third device should be master on the second controller,
    ( .... etc).
    It often occurs that there is only a cd-rom besides the first device.
    The cd-rom drive is sometimes connected as master to the second
    controller (secondary ide controller). This is wrong and can cause linux
    not to know ......

    (extracted from Admin manual, Suse 9.1 Professional)
    (continues)
    ================

    ++++++++++++++++

    --
    AC
  14. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    I demand that AC may or may not have written...

    > In article <cdngo0ppi578rouhcu9380dqgk9ib1phb3@4ax.com>, mark4asp
    > <mark4asp@ntlworld.com> writes
    > [...]
    >> 1) I checked the disk jumpers again - both set to Master
    > [...]
    >> or b) Put both HDD & CDROM on the same controller.

    > I am out of my newb depth but have recently posted about something that
    > might be relevant:

    [snip]
    > I am fairly new to linux and have had some similar problems. However,
    > although I have not followed the problem to conclusion, I have recently
    > read:
    > ================
    > If your atapi cd-rom is not recognised .... while reading .... most
    > frequently due to incorrectly installed hardware. [...]

    > It often occurs that there is only a cd-rom besides the first device. The
    > cd-rom drive is sometimes connected as master to the second controller
    > (secondary ide controller). This is wrong [...]

    No; that's a correct configuration. Configuring that device as slave while
    leaving it on the second IDE bus, OTOH, would be wrong.

    --
    | Darren Salt | d youmustbejoking,demon,co,uk | nr. Ashington,
    | Debian, | s zap,tartarus,org | Northumberland
    | RISC OS | @ | Toon Army
    | <URL:http://www.youmustbejoking.demon.co.uk/> (PGP 2.6, GPG keys)

    You haven't a single redeeming vice.
  15. Archived from groups: comp.os.linux.setup,uk.comp.os.linux,alt.comp.periphs.mainboard.asus (More info?)

    In article <4D093DD88C%news@youmustbejoking.demon.cu.invalid>, Darren
    Salt <news@youmustbejoking.demon.cu.invalid> writes
    >I have recently
    >> read:
    >> ================
    >> If your atapi cd-rom is not recognised .... while reading .... most
    >> frequently due to incorrectly installed hardware. [...]
    >
    >> It often occurs that there is only a cd-rom besides the first device. The
    >> cd-rom drive is sometimes connected as master to the second controller
    >> (secondary ide controller). This is wrong [...]
    >
    >No; that's a correct configuration. Configuring that device as slave while
    >leaving it on the second IDE bus, OTOH, would be wrong.

    It was news to me when I read it, however, I was quoting from the
    published Suse 9.1 (professional) Administration Guide, 9. Edition 2004,
    Section 1.5 'ATAPI CD-ROM Hangs While Reading' (page 21)

    The manuals are in hard copy and on the distro cds, although I have not
    found them online.

    When I came across this I concluded that as suggested in this Guide,
    linux may react differently to my (previous) windowbox experiences.
    --
    AC
Ask a new question

Read More

Asus Boot Hard Drives Linux Motherboards