Sign in with
Sign up | Sign in
Your question

New drivers for Promise 20376 SATA/RAID controller on A7V8..

Last response: in Motherboards
Share
November 11, 2004 2:50:36 PM

Archived from groups: alt.comp.periphs.mainboard.asus (More info?)

This is a three-part question.
1) Can the FASTTX2K.SYS driver for the on-board Promise 20376
SATA/RAID controller be updated (from 1.00.0.8 to 1.00.1.37). The
newer driver, which is WHQL-certified, is listed on ASUS's download
site for other AMD/Via boards that use the same Promise controller. I
ask because ever since I went to a single SATA drive on my system,
Windows XP's Hibernate function causes an instant BSOD referencing the
driver and some kind of IRQL stop error. Standby works OK, by the
way.

2) If the answer to the first question is Yes, can the update be done
simply by "installing" the .INF file without messing up an otherwise
working system. In other words, can I do it without reinstalling XP?

3) Are there other possible causes for the Hibernate BSOD? My system
is A7V8X with AMP XP1700+, 512MB PC2700 RAM, XP Home w/ SP1, Maxtor
80GB SATA, no IDE hard drives, two opticals on IDE primary, and the
usual other stuff. I'm guessing that SP2 won't have any positive
effect on this problem.

Thanks, and sorry for the long post.

Mark
Anonymous
a b V Motherboard
November 12, 2004 12:08:47 PM

Archived from groups: alt.comp.periphs.mainboard.asus (More info?)

Hi Mark,

I have no idea about the error you are having, but I do have the .37 drivers
installed yesterday on a brand new system. Not in raid mode, just one single
s-ata drive. I haven't had much time to field-test it properly but
everything seems to work allright.

One question, did you *need* to install the promise drivers at the beginning
of your OS install?
I had a epox board with a normal s-ata controller and that one was properly
detected when I tried to install xp.
But with the asus board, the xp installation reported that there wasn't any
fixed drive available for installation, even if I changed the s-ata
controller settings to win9x/me/nt compatible mode.

regards,
Marcel


"Mark" <markscol@msn.com> schreef in bericht
news:276fcc55.0411111150.11c6d2aa@posting.google.com...
> This is a three-part question.
> 1) Can the FASTTX2K.SYS driver for the on-board Promise 20376
> SATA/RAID controller be updated (from 1.00.0.8 to 1.00.1.37). The
> newer driver, which is WHQL-certified, is listed on ASUS's download
> site for other AMD/Via boards that use the same Promise controller. I
> ask because ever since I went to a single SATA drive on my system,
> Windows XP's Hibernate function causes an instant BSOD referencing the
> driver and some kind of IRQL stop error. Standby works OK, by the
> way.
>
> 2) If the answer to the first question is Yes, can the update be done
> simply by "installing" the .INF file without messing up an otherwise
> working system. In other words, can I do it without reinstalling XP?
>
> 3) Are there other possible causes for the Hibernate BSOD? My system
> is A7V8X with AMP XP1700+, 512MB PC2700 RAM, XP Home w/ SP1, Maxtor
> 80GB SATA, no IDE hard drives, two opticals on IDE primary, and the
> usual other stuff. I'm guessing that SP2 won't have any positive
> effect on this problem.
>
> Thanks, and sorry for the long post.
>
> Mark
November 12, 2004 4:54:52 PM

Archived from groups: alt.comp.periphs.mainboard.asus (More info?)

"Marcel Overweel" <moverweel@hotmail.com> wrote in message news:<41946f8f$0$48933$e4fe514c@news.xs4all.nl>...
> Hi Mark,
>
> I have no idea about the error you are having, but I do have the .37 drivers
> installed yesterday on a brand new system. Not in raid mode, just one single
> s-ata drive. I haven't had much time to field-test it properly but
> everything seems to work allright.
>
> One question, did you *need* to install the promise drivers at the beginning
> of your OS install?

I switched from an IDE drive to an SATA drive (after mirroring the
contents) without re-installing the OS. I did have to interrupt the
boot process to install the SATA/RAID drivers from the ASUS CD that
came with the MBboard. I'm not using RAID either, but the Promise
20376 controller handles both SATA and RAID. Once I adjusted the
necessary BIOS settings, XP saw the new drive and I was able to remove
the IDE drive. Now I'm wondering if I can update the Promise drivers
using either F6 during boot or by installing them from the .INF file
that is part of the driver set.

> I had a epox board with a normal s-ata controller and that one was properly
> detected when I tried to install xp.
> But with the asus board, the xp installation reported that there wasn't any
> fixed drive available for installation, even if I changed the s-ata
> controller settings to win9x/me/nt compatible mode.
>
> regards,
> Marcel
November 16, 2004 3:01:33 AM

Archived from groups: alt.comp.periphs.mainboard.asus (More info?)

"Mark" <markscol@msn.com> wrote in message
news:276fcc55.0411111150.11c6d2aa@posting.google.com...
> This is a three-part question.
>
> 3) Are there other possible causes for the Hibernate BSOD? My system
> is A7V8X with AMP XP1700+, 512MB PC2700 RAM, XP Home w/ SP1, Maxtor
> 80GB SATA, no IDE hard drives, two opticals on IDE primary, and the
> usual other stuff. I'm guessing that SP2 won't have any positive
> effect on this problem.

I have the same Hibernate BSOD problem. What is your Stop Error Code? I am
getting 0x8E (KERNEL_MODE_EXCEPTION_NOT_HANDLED) with the 0xC0000005
STATUS_ACCESS_VIOLATION code. The system is however quite different. The
only common thing is that it boots from a SATA drive. Otherwise I have K8V
SE Deluxe with Athlon 64 3000+, 512MB PC3200 RAM, XP Pro w/ SP2, Maxtor
160GB SATA, another 30GB Maxtor on IDE1, DVD RW on IDE2, GeForce 4 video
card. I also have a UPS, which I connected to the machine with a serial
cable. I configured it to send a message through native windows messenger
service on power failure and on restoring power. When it comes out of
hibernate state successfully I am getting one of these messages. So, I've
been thinking this had something to do with the error... It needs networking
to send this message, so I thought if networking is late to come up it might
cause a problem... Do you have a similar setup by any chance?


/MM
!