Sign in with
Sign up | Sign in
Your question

Re-enable Hyper Threading (MPS) under XP SP1a after deacti..

Last response: in Windows XP
Share
Anonymous
July 8, 2004 3:07:04 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hello anyone,
okay, Hyper Threading is´nt reasonable for all
application. Mathematica only uses one CPU, so
deactivation makes sense, e.g. So, that´s I did three
month ago. I changed "hardware -> Computer" to ACPI-PC
and deactivated Hyper Threading in Bios. Now, I want to
re-anable Hyper Threading (Bios and Windows), but the
only I can selsct in "hardware -> computer" is ACPI-PC
and Standard PC. Also any *.inf file (acpi.inf, hal.inf,
machine.inf) has no effect. I even tried editing boot.ini
with /HAL /NumProcs /KERNEL, but no chance.
So, now the question.....how can i re-enable
MultiProcessor System to use Hyper Thrading. I read about
a Hot Fix mentioned somewhere in Ressource Centre, but I
did'nt found any HotFix to download.
What about modifying system files/registry to get a
working Multi Processor System back with Hyper Threading?

Thank's a lot for help.....I do not know how to handle
this problem.

Ralf
Anonymous
July 8, 2004 5:10:17 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

OK, here is the deal. Hyperthreading is able to be enabled in the BIOS.
It has nothing to do with ACPI (at least to the best of my knowledge).
There is nothing in Windows that you can do to activate HyperThreading
until you have turned it on in the BIOS. What happens when you enable it
in the BIOS is Windows installs the second CPU upon the first boot with
it enabled and will then ask you to reboot so the OS can make the changes.

Also, be careful when messing around with system files. That is how you
end up with a BSOD or unbootable Windows. Sometimes you can't even get
in and use System Restore, you have to resort to a Repair operation
which may or may not work properly.

http://support.microsoft.com/default.aspx?scid=kb;en-us;810231

Nathan McNulty

WaseKabbes wrote:

> Hello anyone,
> okay, Hyper Threading is´nt reasonable for all
> application. Mathematica only uses one CPU, so
> deactivation makes sense, e.g. So, that´s I did three
> month ago. I changed "hardware -> Computer" to ACPI-PC
> and deactivated Hyper Threading in Bios. Now, I want to
> re-anable Hyper Threading (Bios and Windows), but the
> only I can selsct in "hardware -> computer" is ACPI-PC
> and Standard PC. Also any *.inf file (acpi.inf, hal.inf,
> machine.inf) has no effect. I even tried editing boot.ini
> with /HAL /NumProcs /KERNEL, but no chance.
> So, now the question.....how can i re-enable
> MultiProcessor System to use Hyper Thrading. I read about
> a Hot Fix mentioned somewhere in Ressource Centre, but I
> did'nt found any HotFix to download.
> What about modifying system files/registry to get a
> working Multi Processor System back with Hyper Threading?
>
> Thank's a lot for help.....I do not know how to handle
> this problem.
>
> Ralf
Anonymous
July 8, 2004 5:10:18 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Are you aware that enabling HT will result in a general 5 to 10 percent
decrease in speed with most software? Unless you are using HT aware apps,
it is best to leave HT turned off.

Bobby

"Nathan McNulty" <525676@betaweb.com> wrote in message
news:o %23i6$LMZEHA.3492@TK2MSFTNGP10.phx.gbl...
> OK, here is the deal. Hyperthreading is able to be enabled in the BIOS. It
> has nothing to do with ACPI (at least to the best of my knowledge). There
> is nothing in Windows that you can do to activate HyperThreading until you
> have turned it on in the BIOS. What happens when you enable it in the BIOS
> is Windows installs the second CPU upon the first boot with it enabled and
> will then ask you to reboot so the OS can make the changes.
>
> Also, be careful when messing around with system files. That is how you
> end up with a BSOD or unbootable Windows. Sometimes you can't even get in
> and use System Restore, you have to resort to a Repair operation which may
> or may not work properly.
>
> http://support.microsoft.com/default.aspx?scid=kb;en-us;810231
>
> Nathan McNulty
>
> WaseKabbes wrote:
>
>> Hello anyone,
>> okay, Hyper Threading is´nt reasonable for all application. Mathematica
>> only uses one CPU, so deactivation makes sense, e.g. So, that´s I did
>> three month ago. I changed "hardware -> Computer" to ACPI-PC and
>> deactivated Hyper Threading in Bios. Now, I want to re-anable Hyper
>> Threading (Bios and Windows), but the only I can selsct in "hardware ->
>> computer" is ACPI-PC and Standard PC. Also any *.inf file (acpi.inf,
>> hal.inf, machine.inf) has no effect. I even tried editing boot.ini with
>> /HAL /NumProcs /KERNEL, but no chance.
>> So, now the question.....how can i re-enable MultiProcessor System to use
>> Hyper Thrading. I read about a Hot Fix mentioned somewhere in Ressource
>> Centre, but I did'nt found any HotFix to download.
>> What about modifying system files/registry to get a working Multi
>> Processor System back with Hyper Threading?
>>
>> Thank's a lot for help.....I do not know how to handle this problem.
>>
>> Ralf
Anonymous
July 8, 2004 6:24:12 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hello Nathan,
exact! And that´s the problem. See your submitted Link (
http://support.microsoft.com/default.aspx?scid=kb;en-
us;810231 ). It says that you only have to enable HT in
Bios. Well, I did. But XP did'nt change to
MultiProcessorSystem as described in article. XP leaves
ACPI-PC, saying ONE PROCESSOR. Under "Hardware ->
Processors" two Processors are listed, but in "Task
Manager -> Performance" or "Hardware -> Computer" only
one Processor is shown. And that´s I need... the Changing
from SingleProcessorSystem to MultiProcessorSystem. XP
does not do what it has to do in fact.
Intel describes that - for right HT functionality - a MPS
under "Hardware -> Computer" and two Processors
under "Task Manager -> Performance" have to be shown.

Any Ideas to wile XP?

Ralf

>-----Original Message-----
>OK, here is the deal. Hyperthreading is able to be
enabled in the BIOS.
>It has nothing to do with ACPI (at least to the best of
my knowledge).
>There is nothing in Windows that you can do to activate
HyperThreading
>until you have turned it on in the BIOS. What happens
when you enable it
>in the BIOS is Windows installs the second CPU upon the
first boot with
>it enabled and will then ask you to reboot so the OS can
make the changes.
>
>Also, be careful when messing around with system files.
That is how you
>end up with a BSOD or unbootable Windows. Sometimes you
can't even get
>in and use System Restore, you have to resort to a
Repair operation
>which may or may not work properly.
>
>http://support.microsoft.com/default.aspx?scid=kb;en-
us;810231
>
>Nathan McNulty
>
Anonymous
July 8, 2004 7:38:50 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Okay, I asked MS how to solve the Problem.
Only Possibility to reactivate MPS for HT is a Repair
Installation. Problem.....all Updates and Program
Settings will be overwritten.
At this Point I think I have to let HT disabled.
If anyone knows any tricks/hints to wile XP (registry,
boot.ini) I would be glad to read it here.

Thanks,

Ralf
Anonymous
July 9, 2004 7:40:56 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

After you get it fixed, turn it back on, and go to the toms hardware
website, and download his free utility "Task assignment manager"
which allows you to select which apps you DON'T want hypertreading
to run in. It works just like the ctrl-alt-del and unchecking the
affinity, but with this little app running, you don't have to do it
everytime you run the app you don't want "cpu1" ro run in.



On Wed, 7 Jul 2004 23:07:04 -0700, "WaseKabbes" <laeggaeis@gmx.de>
wrote:

>Hello anyone,
>okay, Hyper Threading is´nt reasonable for all
>application. Mathematica only uses one CPU, so
>deactivation makes sense, e.g. So, that´s I did three
>month ago. I changed "hardware -> Computer" to ACPI-PC
>and deactivated Hyper Threading in Bios. Now, I want to
>re-anable Hyper Threading (Bios and Windows), but the
>only I can selsct in "hardware -> computer" is ACPI-PC
>and Standard PC. Also any *.inf file (acpi.inf, hal.inf,
>machine.inf) has no effect. I even tried editing boot.ini
>with /HAL /NumProcs /KERNEL, but no chance.
>So, now the question.....how can i re-enable
>MultiProcessor System to use Hyper Thrading. I read about
>a Hot Fix mentioned somewhere in Ressource Centre, but I
>did'nt found any HotFix to download.
>What about modifying system files/registry to get a
>working Multi Processor System back with Hyper Threading?
>
>Thank's a lot for help.....I do not know how to handle
>this problem.
>
>Ralf
!