Sign in with
Sign up | Sign in
Your question

usb drive letter on re-connect external disk

Last response: in Windows XP
Share
Anonymous
July 9, 2004 7:45:43 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hi there!

When I connect an external usb disk and change
the drive letter using Administration/DiskManagement
everything works fine.
When I disconnect and reconnect again some time later
the system uses the first possible drive letter
(even if it's a mapped network drive...)
but it doesn't use the old drive letter
and what's worse, I cannot change the drive to the
old letter because the system still thinks the
old drive letter were occupied!?

Isn't it possible to have the system re-use a drive letter
each time one reconnects the same device
or is it just a flaw of my machine!?

Thanxalot,
Detlef
July 9, 2004 9:05:02 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

When one 'assigns' a drive letter using disk Management, that letter is 'permanently' given to that specific drive or partition.

Even when a 'rmovable' drive is not present, Windows will show the drive in 'My Computer' window.

It may be somethign peculiar to your removable drive or the way inwhich you detach it. Make sure that when it is to be unplugged; that you 'Stop' the device by clicking on the 'Safely Remove Device' icon on the system try and choosing to stop it before you power it off and then unplug it.

"Detlef Richter" wrote:

> Hi there!
>
> When I connect an external usb disk and change
> the drive letter using Administration/DiskManagement
> everything works fine.
> When I disconnect and reconnect again some time later
> the system uses the first possible drive letter
> (even if it's a mapped network drive...)
> but it doesn't use the old drive letter
> and what's worse, I cannot change the drive to the
> old letter because the system still thinks the
> old drive letter were occupied!?
>
> Isn't it possible to have the system re-use a drive letter
> each time one reconnects the same device
> or is it just a flaw of my machine!?
>
> Thanxalot,
> Detlef
>
Anonymous
July 9, 2004 2:03:02 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

"BAR" wrote:

> When one 'assigns' a drive letter using disk Management, that letter is 'permanently' given to that specific drive or partition.
>
> Even when a 'rmovable' drive is not present, Windows will show the drive in 'My Computer' window.
>
> It may be somethign peculiar to your removable drive or the way inwhich you detach it.
> Make sure that when it is to be unplugged;
> that you 'Stop' the device by clicking on the 'Safely Remove Device' icon on the system try
> and choosing to stop it before you power it off and then unplug it.

nope, nothing peculiar, just stopping, and then pluging in again.
But it is "mountvol" that does the trick, something like a unix mount,
not the assignment of drive letters by using disk management, just as you wrote.

mountvol -without argument shows all drives,
mountvol (olddriveletter):\ /d -deletes the unwanted drive letter and
mountvol (newdriveletter):\ (verylongdrivename-yougetitfrom-mountvol) -assigns a new drive letter,
and this time it stays even after stopping and plugging in again!!

Thanx anyway for making me look a little closer,
Detlef
Anonymous
July 9, 2004 3:29:46 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Detlef Richter said in news:291d401c465a1$e24b4420$a601280a@phx.gbl:
> Hi there!
>
> When I connect an external usb disk and change
> the drive letter using Administration/DiskManagement
> everything works fine.
> When I disconnect and reconnect again some time later
> the system uses the first possible drive letter
> (even if it's a mapped network drive...)
> but it doesn't use the old drive letter
> and what's worse, I cannot change the drive to the
> old letter because the system still thinks the
> old drive letter were occupied!?
>
> Isn't it possible to have the system re-use a drive letter
> each time one reconnects the same device
> or is it just a flaw of my machine!?
>
> Thanxalot,
> Detlef

Might be a problem with the disk signature written in the MBR (sector 0) of the hard drive. For info on using the DiskPart utility, read http://support.microsoft.com/?id=300415.

- Run "diskpart" from a command line (i.e., DOS shell).
- Optional: Enter "?" to see a list of directives available within the diskpart program.
- Enter the "list disk" directive to see the list of disks you have.
- Enter "select disk n" directive where n is whatever is the index number to the targeted disk drive.
- Enter "detail disk" to get details on the selected disk. You'll see the partitioning info in a table. Note the "Disk ID" field. That is the disk signature.
- Enter "exit" to exit from the diskpart program.

Open regedit and navigate to:

HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\MultifunctionAdapter

Do a search starting from that node on the "Disk ID" value to find under what subkey the disk signature is used. In my case, it was "6\DiskController\0\DiskPeripheral\0" for a data name of "Identifier" with a value of "79f51768-27992799-A" (the disk signature is just part of the identifier).

However, about 3 years ago, Microsoft had me delete some entries from the registry to remove the disk signature recorded by the Disk Management tool so on a restart of the tool (diskmgmt.msc) it would rebuild its signature list. I forget what I did but somehow the disk signature on the drive(s) didn't match what was recorded in the registry (or maybe it was that 2 drives had the same disk signature) so I had to get Disk Management to write a new signature on the drives and record them in the registry so they matched. I don't have the e-mails around to find out what they told me to delete in the registry. The above registry key does not sound familiar for the fix that I had to do back then. I thought it was some subkeys under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum that I had to delete. I did find the disk signature included in subkey names under "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum" and "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control" but still nothing stuck out as what I deleted (those brain cells have since died or new information pushed out the old).

You might try using Disk Management (diskmgmt.msc) and use its Action -> Rescan Disks menu (or use the 'rescan' directive in the diskpart program); see http://support.microsoft.com/?id=309000. Just be sure your removable drive is already plugged in before doing the rescan. When you move a hard disk to another NT-based system, it is recommended to rescan the drives. Presumably this will also ensure that no drives have the same signature and that the disk signatures have been recorded in the registry. The help for Disk Management says, "Every time you remove or import disks to a computer, you must click the Action menu, click Rescan Disks, and then verify that the disk information is correct." That's really only true when you add a new disk (never signed before under THAT instance of Windows) or you move it to a different system.

I've read that if you change the disk signature to all zeroes, Disk Management will write a new disk signature (so what is on the disk will match what is in the registry) by starting its Write Signature and Upgrade Disk wizard. http://www.jsiinc.com/subi/tip4200/rh4224.htm says that "FDISK /MBR" will remove the disk signature. Presumably then running FIXMBR from the Recovery Console will do the same thing. But that would only work on whatever is the first physical hard drive in the system found by the BIOS. There is the dumpcfg.exe (Dump Config) tool in the Windows 2000 Resource Kit (probably works on Windows XP) that is supposed to let you view and change the disk signature but I've never bothered to buy it. It isn't included in the subset of free tools from the resource kit at ftp://ftp.microsoft.com/reskit/win2000. Obviously running rescan in Disk Management sounds like the much easier and safer method - if it works.

--
____________________________________________________________
*** Post replies to newsgroup. Share with others.
*** Email domain = ".com" AND append "=NEWS=" to Subject.
____________________________________________________________
!