Sign in with
Sign up | Sign in
Your question

Removable USB Drive not reusing unit letters

Last response: in Windows XP
Share
Anonymous
July 15, 2004 8:27:42 PM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware (More info?)

Hi,

I am using Windows XP with the latest SP and patches and since some time ago
I notice that every time that I plug my removable USB Drive (a flash memory
of 256 MB) Windows XP assigns it a new letter; that is, it started with "E:"
and then "F:", "G:" and so on. It seems that for some reason it does not
reuse released letters from past sessions and yesterday it reached "Z:" and
since then the USB memory is not mapped to a letter and it is not
accessible.

I have noticed too that although Windows Explorer does not show the letters
of past sessions, some programs such some FTP clients show all the letters
("E: removable drive",..."Z:Removable drive" as if they were actually used.

I would like to know if this is a known issue and how to force the release
of used letters which indeed are no longer used. I have searched Google for
a reasonable time to no avail and most of the questions are about forcing
the mapping to a specific letter always (to keep scripts working), which is
a different issue.

Thanks in advance,

Carlos Quintero
Anonymous
July 15, 2004 8:27:43 PM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware (More info?)

I can only think of three things. First would be, have you tried
Removable dDisks in Computer Management just above where Disk Management
is? There may be something there. It is odd that it keeps assigning a
new drive letter as it is the same VID&PID where it should have
recognized. So I would check under:
HKLM\system\CurrentControlSet\ENUM\USB
To see if there are a bunch of drives that are listed very close or
identical to one another. May have to delete some registry keys. If
this works, just assign the USB Drive a drive letter. Lastly, this most
likely won't do anything, but have you tried disconnecting network
drives by right clicking on My Computer and selecting Disconnect Network
Drives? That would be a long shot, but I have had drives recognized as
network drives.

Nathan McNulty

Carlos J. Quintero [MVP] wrote:

> Hi,
>
> I am using Windows XP with the latest SP and patches and since some time ago
> I notice that every time that I plug my removable USB Drive (a flash memory
> of 256 MB) Windows XP assigns it a new letter; that is, it started with "E:"
> and then "F:", "G:" and so on. It seems that for some reason it does not
> reuse released letters from past sessions and yesterday it reached "Z:" and
> since then the USB memory is not mapped to a letter and it is not
> accessible.
>
> I have noticed too that although Windows Explorer does not show the letters
> of past sessions, some programs such some FTP clients show all the letters
> ("E: removable drive",..."Z:Removable drive" as if they were actually used.
>
> I would like to know if this is a known issue and how to force the release
> of used letters which indeed are no longer used. I have searched Google for
> a reasonable time to no avail and most of the questions are about forcing
> the mapping to a specific letter always (to keep scripts working), which is
> a different issue.
>
> Thanks in advance,
>
> Carlos Quintero
>
>
!