File Sharing on External USB Drive

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

I'm able to share files among four PCs on a wireless network. However,
although I have shared folders on an external USB hard drive connected to
the main desktop, the other three computers cannot acces the drive. All
receive a message that they may not have permission to access the drive,
which they do. The three desktops run Windows XP Pro (SP2) and the laptop
runs XP Home (SP2). One caveat is that at one time months ago, before
installing SP2, I did share the external drive successfully with the other
users but now I cannot now that I'm attempting to do it again. Any thoughts
are appreciated as I've searched for info on solving this but haven't found
anything that has hepled.
7 answers Last reply
More about file sharing external drive
  1. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    Hi,

    The permissions error message you receive could be because you are using
    different passwords on each computer.

    Can you provide some more details on how you are trying to access the
    drive (are you trying to map the drive via Explorer or are you using the
    'net use' command? ) and the exact text of the error message you receive.

    You might also want to check out this link for some basic How-To info on
    sharing folders:
    http://support.microsoft.com/kb/304040

    Thanks
    Chris Gual [MSFT]
    --
    This posting is provided "AS IS" with no warranties, and confers no rights.

    "Peter A. Stavrakoglou" <ntotrr@optonline.net> wrote in message
    news:LAhFd.4735$j12.1976@fe10.lga...
    > I'm able to share files among four PCs on a wireless network. However,
    > although I have shared folders on an external USB hard drive connected to
    > the main desktop, the other three computers cannot acces the drive. All
    > receive a message that they may not have permission to access the drive,
    > which they do. The three desktops run Windows XP Pro (SP2) and the laptop
    > runs XP Home (SP2). One caveat is that at one time months ago, before
    > installing SP2, I did share the external drive successfully with the other
    > users but now I cannot now that I'm attempting to do it again. Any
    > thoughts are appreciated as I've searched for info on solving this but
    > haven't found anything that has hepled.
    >
  2. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    "Chris Gual [MSFT]" <cgual@online.microsoftt.comm> wrote in message
    news:u2HD7WQ%23EHA.2680@TK2MSFTNGP09.phx.gbl...
    > Hi,
    >
    > The permissions error message you receive could be because you are
    > using different passwords on each computer.

    I appreciate your fast response.

    None of the computers use any passwords - could this be the problem? I know
    that I cannot use "Remote Desktop" to any of the other XP Pro computers
    unless I add a password for each, perhaps I need to do this for each
    computer. I'll give that a try.

    > Can you provide some more details on how you are trying to access the
    > drive (are you trying to map the drive via Explorer or are you using the
    > 'net use' command? ) and the exact text of the error message you receive.

    I'm trying to access the drive by both mapping and simply using Windows
    Explorer to find it under "My Network Places\Entire
    Network\Workgroup\Main\Files. Note that "Main" is the name for the desktop
    that has the drive attached and "Files" is the name of the shared folder.

    The error message reads "\\Main\Files is not accessible. You might not have
    permission to use this network resource. Contact the administrator of this
    server to find out if you have access permissions. Not enough server
    storage is available to process the command."

    I found some info regarding increasing the IRPStack size for LanmanServer
    which I did on the "Main" desktop which the USB drive is connected to.
    Actually, I had to create the registry entry and value. The drive itself is
    80 gigs with about 50% freespace.

    > You might also want to check out this link for some basic How-To info
    > on sharing folders:
    > http://support.microsoft.com/kb/304040
    >
    > Thanks
    > Chris Gual [MSFT]
    > --
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights.
  3. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    Hi Peter,

    Looking at the full error message, it looks like the it might be the
    IRPStackSize problem.

    There is a article about this in the knowledge base:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;177078

    You might want to check the Event Viewer on your 'Main' computer to see
    if the following event is in the log:

    Event ID : 2011
    Source : Srv
    Description: The Server's configuration parameter "IRPStackSize" is too
    small for the server to use a local device. Please
    increase the value of this parameter

    You can start the Event Viewer by clicking 'Start Menu -> Run' and then
    typing 'eventvwr'. Once the Event Viewer starts, click on the 'System' icon
    on the left hand pane. You can get details on event by double clicking on
    any of the events in the right hand pane.

    The Event Viewer is described in more depth in the following article:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308427

    If this doesn't fix your problem, let me know!

    Thanks,
    Chris Gual [MSFT]
    --
    This posting is provided "AS IS" with no warranties, and confers no rights.


    "Peter A. Stavrakoglou" <ntotrr@optonline.net> wrote in message
    news:QxkFd.4776$QO3.395@fe10.lga...
    > "Chris Gual [MSFT]" <cgual@online.microsoftt.comm> wrote in message
    > news:u2HD7WQ%23EHA.2680@TK2MSFTNGP09.phx.gbl...
    >> Hi,
    >>
    >> The permissions error message you receive could be because you are
    >> using different passwords on each computer.
    >
    > I appreciate your fast response.
    >
    > None of the computers use any passwords - could this be the problem? I
    > know that I cannot use "Remote Desktop" to any of the other XP Pro
    > computers unless I add a password for each, perhaps I need to do this for
    > each computer. I'll give that a try.
    >
    >> Can you provide some more details on how you are trying to access the
    >> drive (are you trying to map the drive via Explorer or are you using the
    >> 'net use' command? ) and the exact text of the error message you receive.
    >
    > I'm trying to access the drive by both mapping and simply using Windows
    > Explorer to find it under "My Network Places\Entire
    > Network\Workgroup\Main\Files. Note that "Main" is the name for the
    > desktop that has the drive attached and "Files" is the name of the shared
    > folder.
    >
    > The error message reads "\\Main\Files is not accessible. You might not
    > have permission to use this network resource. Contact the administrator
    > of this server to find out if you have access permissions. Not enough
    > server storage is available to process the command."
    >
    > I found some info regarding increasing the IRPStack size for LanmanServer
    > which I did on the "Main" desktop which the USB drive is connected to.
    > Actually, I had to create the registry entry and value. The drive itself
    > is 80 gigs with about 50% freespace.
    >
    >> You might also want to check out this link for some basic How-To info
    >> on sharing folders:
    >> http://support.microsoft.com/kb/304040
    >>
    >> Thanks
    >> Chris Gual [MSFT]
    >> --
    >> This posting is provided "AS IS" with no warranties, and confers no
    >> rights.
    >
    >
    >
  4. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    "Peter A. Stavrakoglou" wrote:
    > None of the computers use any passwords - could this be the problem? I know
    > that I cannot use "Remote Desktop" to any of the other XP Pro computers
    > unless I add a password for each, perhaps I need to do this for each
    > computer. I'll give that a try.

    Yes this is most likely reason. As you already know, accounts with
    blank password can't be acessed from network.
    You can also enable guest account, if all shares are read-only.

    --PA
  5. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    "Chris Gual [MSFT]" <cgual@online.microsoftt.comm> wrote in message
    news:OW0mVob%23EHA.608@TK2MSFTNGP15.phx.gbl...
    > Hi Peter,
    >
    > Looking at the full error message, it looks like the it might be the
    > IRPStackSize problem.
    >
    > There is a article about this in the knowledge base:
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;177078
    >
    > You might want to check the Event Viewer on your 'Main' computer to see
    > if the following event is in the log:
    >
    > Event ID : 2011
    > Source : Srv
    > Description: The Server's configuration parameter "IRPStackSize" is too
    > small for the server to use a local device. Please
    > increase the value of this parameter
    >
    > You can start the Event Viewer by clicking 'Start Menu -> Run' and then
    > typing 'eventvwr'. Once the Event Viewer starts, click on the 'System'
    > icon on the left hand pane. You can get details on event by double
    > clicking on any of the events in the right hand pane.
    >
    > The Event Viewer is described in more depth in the following article:
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;308427
    >
    > If this doesn't fix your problem, let me know!
    >
    > Thanks,
    > Chris Gual [MSFT]

    Many thanks Chris, problem solved! Prior to posting in this newsgroup. I
    had found a site that mentioned this registry problem, with a notation to
    add the value if it doesn't exist, just like the knowledge base article you
    linked noted, and assign a value of 15 which I did. That did not work.
    However the knowledge base article mentions to increase the value if
    needed - which the site I used did not mention. I increased the value by
    three to 18, no luck. I then increased it to 21 and I can now access the
    external drive from the other three computers in the house. Thanks again.
  6. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    "Pavel A." <pavel_a@NOwritemeNO.com> wrote in message
    news:1181B184-2E98-4F07-8060-BFE143EF70D2@microsoft.com...
    > "Peter A. Stavrakoglou" wrote:
    >> None of the computers use any passwords - could this be the problem? I
    >> know
    >> that I cannot use "Remote Desktop" to any of the other XP Pro computers
    >> unless I add a password for each, perhaps I need to do this for each
    >> computer. I'll give that a try.
    >
    > Yes this is most likely reason. As you already know, accounts with
    > blank password can't be acessed from network.
    > You can also enable guest account, if all shares are read-only.
    >
    > --PA

    It was an IRPStackSize problem in the registry. While I cannot make a
    Remote Desktop connection to a system that has no password I can access
    shared folders on those computers and I am. Now that I have corrected the
    IRPStackSize problem, the three other users in the house can access the
    external hard drive connected to my ("Main") PC. In any event, I appreciate
    your taking time to read my post and respond.
  7. Archived from groups: microsoft.public.windows.networking.wireless (More info?)

    The full analysis and solution for the problem at the following address:
    http://dly.free.fr/site/ecrire/articles.php3?id_article=34

    "Peter A. Stavrakoglou" <ntotrr@optonline.net> wrote in message news:<EBEFd.4935$%A.3960@fe10.lga>...
    > "Pavel A." <pavel_a@NOwritemeNO.com> wrote in message
    > news:1181B184-2E98-4F07-8060-BFE143EF70D2@microsoft.com...
    > > "Peter A. Stavrakoglou" wrote:
    > >> None of the computers use any passwords - could this be the problem? I
    > >> know
    > >> that I cannot use "Remote Desktop" to any of the other XP Pro computers
    > >> unless I add a password for each, perhaps I need to do this for each
    > >> computer. I'll give that a try.
    > >
    > > Yes this is most likely reason. As you already know, accounts with
    > > blank password can't be acessed from network.
    > > You can also enable guest account, if all shares are read-only.
    > >
    > > --PA
    >
    > It was an IRPStackSize problem in the registry. While I cannot make a
    > Remote Desktop connection to a system that has no password I can access
    > shared folders on those computers and I am. Now that I have corrected the
    > IRPStackSize problem, the three other users in the house can access the
    > external hard drive connected to my ("Main") PC. In any event, I appreciate
    > your taking time to read my post and respond.
Ask a new question

Read More

External USB Wireless Networking