48 bit LBA on K8N with SATA drive???

Archived from groups: alt.comp.periphs.mainboard.asus (More info?)

I just bought a WD 160 GB SATA drive (WD160JB) and plugged it into my
K8N mobo via SATA connector. The BIOS seems to recognize the 160GB
size (it reports the drive size as 160GB), but Windows 2000 does not.
When installing the hard drive, I disconnected my prior HD, booted
from W2k-SP4 CD-ROM, created a partition on the new HD, formatted it,
and installed W2K (slipstreamed with SP4). The drive works fine ...
but W2K never recognized the full capacity of the drive. Windows
(even when I was initially creating the partition) reports the size as
only 128 GB.

The WD support site has some troublehshooting steps for "drives larger
than 137 GB not recognized" ... mostly having to do with the BIOS not
using 48 bit LBA or else not running SP1 (for W2K).

I'm assuming my BIOS uses 48 bit LBA (since the BIOS reports the 160GB
size correctly) ... and I'm running SP4. I'm not sure if the fact
that this drive is SATA is causing my problem, or what. My BIOS is
reported as American Megatrends Inc v1004.005 (1/26/04).

So ... I'm trying to work my way throught this. If you have any ideas
about it, please let me know. Thanks.

Adam
3 answers Last reply
More about sata drive
  1. Archived from groups: alt.comp.periphs.mainboard.asus (More info?)

    And one other thing ...

    The following MS link
    (http://support.microsoft.com/default.aspx?scid=kb;en-us;305098)
    says that EVEN WITH SP3 (for W2k) I must manually create or modify the
    following registry key
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters\EnableBigLba
    setting its value to 1

    This modification is to enable "Windows to support ATAPI drives larger
    than 137 GB (128 binary)."

    So ........ my drive is SATA, not ATA. Do you think I still need to
    add this registry key? MS warns of dire consequences (data
    corruption) if you change this key and "the system / hardware does not
    support it."
  2. Archived from groups: alt.comp.periphs.mainboard.asus (More info?)

    Adam White schrieb:

    > And one other thing ...
    >
    > The following MS link
    > (http://support.microsoft.com/default.aspx?scid=kb;en-us;305098)
    > says that EVEN WITH SP3 (for W2k) I must manually create or modify the
    > following registry key
    > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters\EnableBigLba
    > setting its value to 1
    >
    > This modification is to enable "Windows to support ATAPI drives larger
    > than 137 GB (128 binary)."
    >
    > So ........ my drive is SATA, not ATA. Do you think I still need to
    > add this registry key?

    For southbridge-integrated SATA controllers, yes.

    > MS warns of dire consequences (data
    > corruption) if you change this key and "the system / hardware does not
    > support it."

    Well, it does in this case. The risk of data loss seems to be higher
    when using a drive formatted using 48 bit LBA in a system that does not
    support it software wise.

    Stephan
    --
    Home: http://stephan.win31.de/
    PC#6: i440BX, 2xP3-500E, 704 MiB, 18+80 GB, R9k AGP 64 MiB, 110W
  3. Archived from groups: alt.comp.periphs.mainboard.asus (More info?)

    A way around this is to create a partition of say 32mb for system, install
    W2K then fix the registry key.

    This of course means you won't have a large C drive - but for most of us we
    actually want this IE system is system, data goes elsewhere, all eggs in one
    bug basket = a messy big basket. Obviously this is not for everyone...

    You can extend the partition using say partition magic after the registry
    key is fixed. Just do not create / use a large partition with windows until
    the fix is in otherwise you may end up with a corrupt system. With XP you
    can extend the partition using the DISKPART / EXTEND command to extend the
    partition into adjacent free space - this works although it is not advised
    and of course I do realise you do not have XP...

    - Tim


    "Adam White" <adam.white@nospam.sbcglobal.net> wrote in message
    news:h3ng31li0pnsd7tblbv5av4q2u70s6q8l3@4ax.com...
    >
    > And one other thing ...
    >
    > The following MS link
    > (http://support.microsoft.com/default.aspx?scid=kb;en-us;305098)
    > says that EVEN WITH SP3 (for W2k) I must manually create or modify the
    > following registry key
    > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters\EnableBigLba
    > setting its value to 1
    >
    > This modification is to enable "Windows to support ATAPI drives larger
    > than 137 GB (128 binary)."
    >
    > So ........ my drive is SATA, not ATA. Do you think I still need to
    > add this registry key? MS warns of dire consequences (data
    > corruption) if you change this key and "the system / hardware does not
    > support it."
    >
    >
    >
Ask a new question

Read More

Asus SATA Western Digital Motherboards