Solved

Icons not displaying properly

Hi,

Some application icons and files that are use them to open aren't displaying their proper icon and are displaying a default windows icon.

This is happening in the taskbar, the desktop and the start menu.

I've tried deleting the iconcache.db file which didn't work.

I've attached some photos illustrating the problem.

Any ideas are extremely welcomed!!

Thanks a lot


Start Menu:




Taskbar:


21 answers Last reply Best Answer
More about icons displaying properly
  1. Have you tried getting up the shortcut properties and changing the shortcut there?
  2. DJ-Specter said:
    Hi,

    Some application icons and files that are use them to open aren't displaying their proper icon and are displaying a default windows icon.

    This is happening in the taskbar, the desktop and the start menu.

    I've tried deleting the iconcache.db file which didn't work.

    I've attached some photos illustrating the problem.

    Any ideas are extremely welcomed!!

    Thanks a lot


    Start Menu:


    http://milesmonty.com/icon%20display%201.png

    Taskbar:


    http://milesmonty.com/icon%20display%202.png


    What happened to the computer before this happened? Did you try a registry cleaner tool or something? Do the shortcuts work OK and just the icons are different? Did you try to roll back to a earlier restore point?
  3. The registry points to the icons which Windows 7 will use for "Office" documents. These icons are not the icons inside winword.exe, but some other icons, somewhere else. If, usually while "cleaning" the registry, you delete those references, you lose the icons for (the respective) "Office" documents.

    I cannot remember where these icons reside, neither am I sure how to reinstate them. However, the above may help someone else to shed some more light on the issue.

    Helladios
  4. Best answer
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.
  5. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    I know you posted this awhile ago, but I saw this thread come up on google, and just wanted to say thanks a bunch, it helped!
  6. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    Thanks, this worked
  7. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    Hi: tried exactly what you detailed in your instructions, but still the "office" apps come up with generic windows icons (I've got Office 2003, btw)...
  8. pastorccamacho said:
    bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    Hi: tried exactly what you detailed in your instructions, but still the "office" apps come up with generic windows icons (I've got Office 2003, btw)...


    You should seriously get the latest MS Office. Office 2003 isn't supported anymore. http://office.microsoft.com/en-ca/help/support-has-ended-for-office-2003-HA103306332.aspx
  9. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.



    This worked perfectly, thank you!
    Running Win7 64-bit.
  10. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    Found this thread thanks to Google (after many searching queries)...

    I registered just to thank you (and hopefully bring this thread higher in the search results for other people)

    Worked perfectly on Windows 8.1 64bits.
  11. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    wow this was a great solution, I've always wanted explorer to stop working completely. thumbs up
  12. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    This worked perfectly! Thank you so much!
  13. Hyunckel said:
    bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    Found this thread thanks to Google (after many searching queries)...

    I registered just to thank you (and hopefully bring this thread higher in the search results for other people)

    Worked perfectly on Windows 8.1 64bits.


    και για μένα δούλεψε τέλεια ευχαριστώ φίλε (σε Windows 8.1 64bits )
  14. hang-the-9 said:
    DJ-Specter said:
    Hi,

    Some application icons and files that are use them to open aren't displaying their proper icon and are displaying a default windows icon.

    This is happening in the taskbar, the desktop and the start menu.

    I've tried deleting the iconcache.db file which didn't work.

    I've attached some photos illustrating the problem.

    Any ideas are extremely welcomed!!

    Thanks a lot


    Start Menu:


    http://milesmonty.com/icon%20display%201.png

    Taskbar:


    http://milesmonty.com/icon%20display%202.png


    What happened to the computer before this happened? Did you try a registry cleaner tool or something? Do the shortcuts work OK and just the icons are different? Did you try to roll back to a earlier restore point?



    TO,

    DEAR BHADRI JI,

    I WOULD LIKE TO CONVEY MY SINCERE THANKS, AS I TOO DEVELOPED SIMILAR KIND OF TROUBLE
    IN WHICH FEW OF THE "ICONS" OF MY WIN7 ULTIMATE 64 BIT SYSTEM STOPPED AS WHAT THEY WERE
    SUPPOSED TO LOOK LIKE...

    I HAVE APPLIED YOUR TWEAK, AND SUCCESSFULLY TROUBLESHOOTED THE PROBLEM... AND NOW ALL
    ICONS ARE LOOKING NORMAL... :)

    THANKS A TON....

    Best of luck...

    Vinjamurie
  15. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    Yep, worked like a charm for me, too. Windows 7 32 bit. Thank you!
  16. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    Thanks SO much. This worked for me as well. Found by using Google!
  17. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    This worked for me as well! Thank you!
    Found this by using Google.
  18. bhadri said:
    Here's a slightly quicker version of the instructions.
    1. Press Ctrl-Shift-Escape to get the task manager.
    2. In the Processes tab, click on explorer.exe and click End Process. You'll get a confirmation dialog. Click "End Process" to confirm.
    3. From the File menu (still in the task manager), choose New Task (Run...).
    4. Copy/paste/enter the following command in the run box:
    Code:
    cmd /c del %userprofile%\AppData\Local\IconCache.db /a
    5. Open the Run box again with File --> New Task (Run...). This time, enter this command:
    Code:
    explorer.exe
    6. All should be okay now. Open the Start Menu and confirm that your icons are fixed now.




    you are one helpful mother fvcking, thank you!
  19. Awesome, It worked , Sooper.!!! Thanks Bhadri
  20. I tried twice,but for me (W7 Pro) it isn't working......
    Do you have other suggestions...
    Thank you for your help
  21. I case sophivan or anyone else is STILL stuck on this, as I was, having tried all the aboves, I discovered that something had eaten the contents of the windows/installer folder and removed nearly all the GUID folders. I copied them from another W64 machine and pasted in, and after a reboot and a few file association resets, all is now well.
Ask a new question

Read More

Taskbar Start Menu Icons Windows 7