Sign in with
Sign up | Sign in
Your question

No Autorun for Flash Reader

Tags:
  • Microsoft
  • CD-Rom
  • Windows XP
Last response: in Windows XP
Share
August 18, 2004 3:44:18 PM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware,microsoft.public.windowsxp.photos (More info?)

I have a 6-in-1 Flash Memory Reader and a while ago, autorun stopped working
when I insert a compact flash card. I can access the card normally through
Windows Explorer and the properties show autorun is set to work. Also, if I
insert a CD, autorun works properly.

I tried a different card reader and it also failed.

Is there a cure for this? I tried removing the driver and reinstalling but
that had no effect.

I'm running Windows XP Pro SP2.

Oh yes, when I insert a blank CD-R, autorun also does not run. It does work
with a CD-ROM or recorded CD-R or a DVD.

More about : autorun flash reader

Anonymous
August 18, 2004 6:35:02 PM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware,microsoft.public.windowsxp.photos (More info?)

When you insert a blank CD autorun does not start because there is nothing
on the CD. This is normal.

For your card reader, you can read below.

If you recently installed Real Player 10, this is the likely culprit.
Otherwise read on below.

Several ways to download your pictures, from your camera or card reader.





Before you connect your camera to your computer, make sure you have enough
battery power or better yet use your AC connector if your camera came with
one. After connecting, power the camera and wait about 15-20 seconds for XP
to recognize the camera, you will hear some sound "ding-dong" and the LCD
screen on your camera will change (the change is dependent on the type of
camera you have) and you are now ready to transfer, even if the Autoplay
window does not open automatically. If you do not hear a sound or the LCD
screen of your camera does not change, the connection with the USB port is
not correct. Go to the bottom of these directions to repair the USB
connection.



After you hear the sound:


1. Open My Computer, look under devices with removable storage. Your camera
(or card reader) will be listed there as an external drive (probably below
your CD drive). Right click on your camera listed as an external drive. A
menu will open, click on Autoplay listed on the opening menu. This should
open the Autoplay window to download your photos the same way as when the
Autoplay window opens automatically when you connect your camera.



Or



2. Open My Computer, look under devices with removable storage. Your camera
will be listed there as an external drive (probably below your CD drive).
Double click on it to open it.
You will see a folder, double click to open it, then another folder, double
click on it to open it and you will see the list of photo files. Select all
files
and copy to a folder on your hard drive. To select all the files, hold the
Ctrl key down and press the letter A. Or, click on Edit on your top bar and
then click on Select all on the opening menu. When files are selected, their
names are highlighted in blue. You can then look at the menu on the left
of the file names and click on Copy and then select the folder you want or
make a new folder.

If you want to repair the automatic Autoplay window you can try the
following.

Different ways to try to repair the Autoplay window for downloading from
either a camera or card reader. Also the same procedure can be used for a CD
drive Autoplay.

Go from steps I to V, although step V may not be needed.

I. Connect your camera (or card reader) to your computer, power it on and
make sure you have
pictures on your memory card. Make sure your batteries are good or better
yet, use your AC adapter if your camera came with one. If you are trying
with a card reader, just connect it with a memory card inserted and with
pictures on the memory card.

Click on My Computer and look under Device with Removable storage. Your
camera will be listed there and a drive letter will be assigned to it
(something like H, G, etc.) You will use this drive letter in a step below.
If you do not see your camera listed there you will need to repair your USB
connection (see below for repair) or you are on a network and the network
drive is Z and XP cannot
assign a drive letter to your camera so you will need to take care of this
first. The steps below will not work if XP cannot assign a drive letter for
your camera. In some cases, your camera may be listed but no drive letter.
Try the drive letter after you're the drive under which your camera is
listed.

II. Click on Start, click on Run and type the following in the textbox:
REGSVR32 SHIMGVW.DLL
and press Enter
Note that there is a space between ...32 and SHI...
This will take a few seconds to run.

III. Go to the following site:
http://www.bigblackglasses.com/staff/downloads/autofix....

(Note: just checked this site on July 11, 2004 and it was not available, so
go to the Microsoft site given below instead and don't forget to reboot
before trying your camera)

and download the autofix.exe file in one of your folder. Once done, double
click on this file. A window will open. Follow the directions on the screen.

Once done, turn off the camera and reboot.

IV. Power the camera on, wait 10-15 seconds for XP to recognize it, you
should hear some beeping sound and the window should now open giving you the
option of downloading photos from the camera.

V. You may have to set the options for this window.
Click on My Computer, your camera should be listed there under Devices with
Removable Storage. Right click on it and click on Properties. In the opening
window, click on the Autoplay tab and under Select, scroll to Pictures to
select it. Select the button Prompt me... Do the same thing for a CD drive.


You can also download the autofix.exe file from the site below if the above
site is not available. At this Microsoft site, you have the option of
downloading the autofix.exe file and proceed as above, or, let Microsoft
scan your computer and try to repair everything. If you decide to use this
site and let Microsoft try the repair, run the REGS...command given above
before going to this site.

http://www.microsoft.com/downloads/details.aspx?FamilyI...

To repair your USB connection:

Go to Control panel>Performance and maintenance>System>Hardware>Device
manager>Universal Serial Bus Controller, click on the + sign to see the list
of installed devices. If your camera is properly connected, it should be
listed there with a yellow flag ( the yellow flag indicates that although
the connection is there, it is not working properly).

Right click on it>Properties>Troubleshoot. See if the troubleshooter can
help. If not, click on Action on the top bar and then Uninstall. Leave your
camera connected and reboot. XP should automatically recognize the camera
and install it.

If after opening Control panel you do not see Performance and maintenance,
you should see System. Click on System and continue.



A solution posted by Bill using a Nikon camera:



I had the same problem with a nikon. Tried all the
things that yves suggested but they did not work. I then
installed the camera via the control panel add hardware
function. It went to a point and it required a file called
ptpusd.dll from service pack one. I found the file on my
hard drive via search. Typed the path in the window that
asked for it and it took. It now comes up automatically
again. Check your set up menu on the camera to see your
USB setting is PTP. Good luck Bill



Another possible solution posted here:



http://forums.us.dell.com/supportforums/board/message?b...



Also, check the software you use for photo editing. When you open the
software, click on File on the top bar. Look at the opening menu. You
probably have an option for downloading photos from a camera or scanner or
card reader.



Something else may be the problem (This is a more recent, June 2004,
problem) as reported here:

There are a lot of messages here about the camera wizard suddenly not
working. Same for me after having it work for at least a year. One of the
messages mentioned upgrading Real Player seemed to cause the problem. I
recently upgraded that also. Just uninstalled it and my camera wizard came
back immediately - this after weeks of trying to figure out what went wrong!
--
Brigit



(Note: some have reported that this works fine, others have reported that
they had to use the autofix.exe after removing Real Player. Real Player is
aware of the problem and working on a fix).



Another possible solution.

Click on Start, click on Run and type the following in the opening textbox:

cmd

and press the Enter key

A window will open (black and white) and will display the following:

C:\Documents and Settings\Your Name\

Type the following at the end of the above line after the \

Net start stisvc

And press the Enter key

You will get a message that service is already started (if so this does not
solve the problem) or that it is starting (if so this may solve the
problem). Then try connecting your camera after you close this window. To
close this window, type EXIT at the end of the displayed line and press the
Enter key.

"Johnny" <VROYLUAKAPCX@spammotel.com> wrote in message
news:uw01xoThEHA.556@tk2msftngp13.phx.gbl...
> I have a 6-in-1 Flash Memory Reader and a while ago, autorun stopped
working
> when I insert a compact flash card. I can access the card normally
through
> Windows Explorer and the properties show autorun is set to work. Also, if
I
> insert a CD, autorun works properly.
>
> I tried a different card reader and it also failed.
>
> Is there a cure for this? I tried removing the driver and reinstalling
but
> that had no effect.
>
> I'm running Windows XP Pro SP2.
>
> Oh yes, when I insert a blank CD-R, autorun also does not run. It does
work
> with a CD-ROM or recorded CD-R or a DVD.
>
>
>
August 20, 2004 1:42:23 PM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware,microsoft.public.windowsxp.photos (More info?)

"Yves Alarie" <rd50@@pitt.edu> wrote in message
news:uA3EUIVhEHA.3944@tk2msftngp13.phx.gbl...
> When you insert a blank CD autorun does not start because there is nothing
> on the CD. This is normal.
>
> For your card reader, you can read below.

> Another possible solution posted here:
>
>
>
> http://forums.us.dell.com/supportforums/board/message?b...

This is what did it. The solution was on the following page (page 3):
=================
hmmmm.... That should work. Not sure why it isn't. One more thing to
check:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\CancelAutoplay

see if there are any keys under this. there should only be a 'files' key.
entries here can block autoplay.

====================

I deleted the CLSID setting and autorun started working. I then imported
the CLSID setting from my laptop and it still works. Must be one of the
CLSID settings was bogus.

Thanks for your help.
Related resources
Anonymous
September 9, 2004 10:15:01 PM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware,microsoft.public.windowsxp.photos (More info?)

I searched out possible solutions for my Nikon View not automatically running
when the camera was plugged in. Your CLSID suggestion solved it on the spot.

Thanks!

"Johnny" wrote:

>
> "Yves Alarie" <rd50@@pitt.edu> wrote in message
> news:uA3EUIVhEHA.3944@tk2msftngp13.phx.gbl...
> > When you insert a blank CD autorun does not start because there is nothing
> > on the CD. This is normal.
> >
> > For your card reader, you can read below.
>
> > Another possible solution posted here:
> >
> >
> >
> > http://forums.us.dell.com/supportforums/board/message?b...
>
> This is what did it. The solution was on the following page (page 3):
> =================
> hmmmm.... That should work. Not sure why it isn't. One more thing to
> check:
>
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\CancelAutoplay
>
> see if there are any keys under this. there should only be a 'files' key.
> entries here can block autoplay.
>
> ====================
>
> I deleted the CLSID setting and autorun started working. I then imported
> the CLSID setting from my laptop and it still works. Must be one of the
> CLSID settings was bogus.
>
> Thanks for your help.
>
>
>
>
Anonymous
December 10, 2004 8:03:03 AM

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.hardware,microsoft.public.windowsxp.photos (More info?)

To those of you who have lost the use of the Camera Wizard I have confirmed
that there is a conflict between Real Player 10 and the Wizard preventing the
Wizard from running. However, I have found the cause and have a solution.

There is an incompatability between the Wizard and the file REALSCHED.EXE,
which runs on startup. Disable it with the Task Manager and the functionality
of the Wizard is restored. You can permanently disable REALSCHED from running
on startup using MSCONFIG. However, it will become active again any time Real
Player is started. But it is definitely NOT necessary to uninstall Real
Player to mitigate the conflict and get the Wizard working again.

I have confirmed that this file is the cause of the problem, but have no
idea just what purpose it serves other than taking up memory. It schedules
something or other. Perhaps it is the source of those %$#@@#$$# Real Player
pop-up messages!


"Johnny" wrote:

> I have a 6-in-1 Flash Memory Reader and a while ago, autorun stopped working
> when I insert a compact flash card. I can access the card normally through
> Windows Explorer and the properties show autorun is set to work. Also, if I
> insert a CD, autorun works properly.
>
> I tried a different card reader and it also failed.
>
> Is there a cure for this? I tried removing the driver and reinstalling but
> that had no effect.
>
> I'm running Windows XP Pro SP2.
>
> Oh yes, when I insert a blank CD-R, autorun also does not run. It does work
> with a CD-ROM or recorded CD-R or a DVD.
>
>
>
>
!