DVD drive, XP now doesnt recognise my old drive

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I got a n new DVD writer this morning. its running
perfect and installed like a charm.

My problem now though is, my computer doesn't recognise
my old drive, why?!

My old drive is connected with the power cable (the
usually white plastic holding red, yellow and black
cables) and also the ribbon connecter too. (the same
ribbon cable as my new drive. but obviously a different
port along it.)

So they are both connected the same, and the drive
physically works. I can open it, and it whirrs when discs
are in in, but no recognition from windows. Have tried
add new hardware etc but no joy.

Any advice? Feel free to email me at bravobro@msn.com
5 answers Last reply
More about drive doesnt recognise drive
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Recheck the jumper settings on both drives. The installation
    instructions should address the "master drive" "slave drive" issues.

    Lee wrote:

    > I got a n new DVD writer this morning. its running
    > perfect and installed like a charm.
    >
    > My problem now though is, my computer doesn't recognise
    > my old drive, why?!
    >
    > My old drive is connected with the power cable (the
    > usually white plastic holding red, yellow and black
    > cables) and also the ribbon connecter too. (the same
    > ribbon cable as my new drive. but obviously a different
    > port along it.)
    >
    > So they are both connected the same, and the drive
    > physically works. I can open it, and it whirrs when discs
    > are in in, but no recognition from windows. Have tried
    > add new hardware etc but no joy.
    >
    > Any advice? Feel free to email me at bravobro@msn.com
    >
  2. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Follow up to Bob's suggestion:

    Ideally, both drives should be set to CS (Cable Select). If that
    doesn't work, try setting the drive attached to the middle IDE ribbon
    connector to Slave, and the drive attached to the end IDE ribbon
    connector to Master.

    Recheck that all data and power cables are properly seated.

    In your box's BIOS make sure all IDE slots are set to AUTO (or
    whatever the equivalent is in your BIOS) and not NONE.

    Also - doubtful if you have a recent box, but I have seen this cause
    similar issues when new H/W is added: make sure your box's power
    supply is adequate for all the components you have installed.

    Good luck,

    ---
    Papaboojum
  3. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Hi there

    I appreciate you taking the time to help me.

    How do I go about making these slave etc changes? Are
    they physical switches on the drives/inside the case? Or
    changes made through some setting in windows?

    Thanks, Lee
    >-----Original Message-----
    >Follow up to Bob's suggestion:
    >
    >Ideally, both drives should be set to CS (Cable
    Select). If that
    >doesn't work, try setting the drive attached to the
    middle IDE ribbon
    >connector to Slave, and the drive attached to the end
    IDE ribbon
    >connector to Master.
    >
    >Recheck that all data and power cables are properly
    seated.
    >
    >In your box's BIOS make sure all IDE slots are set to
    AUTO (or
    >whatever the equivalent is in your BIOS) and not NONE.
    >
    >Also - doubtful if you have a recent box, but I have
    seen this cause
    >similar issues when new H/W is added: make sure your
    box's power
    >supply is adequate for all the components you have
    installed.
    >
    >Good luck,
    >
    >---
    >Papaboojum
    >
    >
    >.
    >
  4. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    First, I assume we're talking about ATA or IDE drives (not S-ATA,
    SCSI, etc). There are jumpers on the drive units - usually on the
    same end as the data and power connectors - that select whether they
    are the Master or Slave on the IDE channel they are attached to.
    These jumpers are typically labelled MS, SL and CS for Master, Slave
    and Cable Select. In the "Old Days"(tm) you had to specifically set
    the jumpers depending on which IDE connector you were attaching them
    (end connector = Master, middle connector = Slave). These days most
    controllers and drives support Cable Select which auto detects which
    position the drive is in.

    If you have a recent mobo and/or controller, I would recommend making
    sure all your IDE devices are set to Cable Select. That way you don't
    have to really worry if/when you move drives around.

    Both your hard drives and the DVD writer will have these jumpers,
    again assuming there all ATA/IDE.

    Also as I mentioned double check the BIOS settings.

    ---
    Papaboojum
  5. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Near where the power/data plugs connect on the rear of your drive you will
    find sets of pins on above the other. If you are fortunate they should be
    labeled with a "C", "S" and "M". The previous poster suggest using your
    small "jumper" (usually a plastic "U" shaped piece with copper internal
    connectors) to connect the two vertically aligned pins under "C" for Cable
    select.

    You can also use the "M" setting for your Master device (the one on the very
    end of the cable) and "S" setting for the one attached to the connector
    mid-way on the cable. Hopefully this is all you need to do! Your previous
    device was probably jumpered to master when it was by its self and it is
    possible that your new drive may be labeled the same. Although often times
    Optical Drives are factory jumpered as slave.

    Hopefully setting the jumpers correctly will solve the problem. Remember
    not to mix settings! If one drive is set as "C" then both drives must be.
    If one is set as "M" then the other must be "S".

    Good Luck,
    Len
    "Lee" <bravobro@msn.com> wrote in message
    news:021801c48ae7$702507d0$a601280a@phx.gbl...
    > Hi there
    >
    > I appreciate you taking the time to help me.
    >
    > How do I go about making these slave etc changes? Are
    > they physical switches on the drives/inside the case? Or
    > changes made through some setting in windows?
    >
    > Thanks, Lee
    >>-----Original Message-----
    >>Follow up to Bob's suggestion:
    >>
    >>Ideally, both drives should be set to CS (Cable
    > Select). If that
    >>doesn't work, try setting the drive attached to the
    > middle IDE ribbon
    >>connector to Slave, and the drive attached to the end
    > IDE ribbon
    >>connector to Master.
    >>
    >>Recheck that all data and power cables are properly
    > seated.
    >>
    >>In your box's BIOS make sure all IDE slots are set to
    > AUTO (or
    >>whatever the equivalent is in your BIOS) and not NONE.
    >>
    >>Also - doubtful if you have a recent box, but I have
    > seen this cause
    >>similar issues when new H/W is added: make sure your
    > box's power
    >>supply is adequate for all the components you have
    > installed.
    >>
    >>Good luck,
    >>
    >>---
    >>Papaboojum
    >>
    >>
    >>.
    >>
Ask a new question

Read More

Windows XP Cable DVD Drives