detection of correct sized hard drive

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hi

A new hard drive, Hitachi Deskstar 7K250 160GB, is being detected by
my bios (motherboard Elitegroup K7S5A, but only with appr. 32GB. Same
thing in windows drive administration - only 32GB.

Is it absoluttely necessary that the bios detects it properly or can I
"fix" this problem in windows (XP Pro, sp2)?

I have tried all sorts of both auto detect and user set up in the bios
but I am not able to change the size of the hard drive.

Any help is appreciated.

Kristian
8 answers Last reply
More about detection correct sized hard drive
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    That motherboard is not that old, so it should see drives over 32 GB. I
    would recommend updating the BIOS because Windows will not detect the
    drive size as larger than the BIOS detects it unless you use a Dynamic
    Drive Overlay which can get pretty complicated.

    Now if you formatted the drive FAT32 with Windows XP, that is the
    largest you can make a partition as FAT32 (with Windows XP) and I would
    hihgly recommend deleting that partition and formatting the whole thing
    as NTFS. That may be where your space has gone, but that doesn't
    explain why the BIOS only sees 32 GB.

    -----
    Nathan McNulty

    post@kristiankrogh.dk wrote:
    > Hi
    >
    > A new hard drive, Hitachi Deskstar 7K250 160GB, is being detected by
    > my bios (motherboard Elitegroup K7S5A, but only with appr. 32GB. Same
    > thing in windows drive administration - only 32GB.
    >
    > Is it absoluttely necessary that the bios detects it properly or can I
    > "fix" this problem in windows (XP Pro, sp2)?
    >
    > I have tried all sorts of both auto detect and user set up in the bios
    > but I am not able to change the size of the hard drive.
    >
    > Any help is appreciated.
    >
    > Kristian
  2. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Check the Hitachi website for software to setup hard drives. (Unless you got
    a CD with the the drive that has the software on it.)

    <post@kristiankrogh.dk> wrote in message
    news:37253c1f.0411051056.6daca598@posting.google.com...
    > Hi
    >
    > A new hard drive, Hitachi Deskstar 7K250 160GB, is being detected by
    > my bios (motherboard Elitegroup K7S5A, but only with appr. 32GB. Same
    > thing in windows drive administration - only 32GB.
    >
    > Is it absoluttely necessary that the bios detects it properly or can I
    > "fix" this problem in windows (XP Pro, sp2)?
    >
    > I have tried all sorts of both auto detect and user set up in the bios
    > but I am not able to change the size of the hard drive.
    >
    > Any help is appreciated.
    >
    > Kristian
  3. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    > post@kristiankrogh.dk wrote:
    >> Hi
    >>
    >> A new hard drive, Hitachi Deskstar 7K250 160GB, is being detected by
    >> my bios (motherboard Elitegroup K7S5A, but only with appr. 32GB. Same
    >> thing in windows drive administration - only 32GB.
    >>
    >> Is it absoluttely necessary that the bios detects it properly or can I
    >> "fix" this problem in windows (XP Pro, sp2)?
    >>
    >> I have tried all sorts of both auto detect and user set up in the bios
    >> but I am not able to change the size of the hard drive.
    >>
    >> Any help is appreciated.
    >>
    >> Kristian

    "Nathan McNulty" <newsgroups@msn.com> wrote in message
    news:%235n5io2wEHA.4004@tk2msftngp13.phx.gbl...
    > That motherboard is not that old, so it should see drives over 32 GB. I
    > would recommend updating the BIOS because Windows will not detect the
    > drive size as larger than the BIOS detects it unless you use a Dynamic
    > Drive Overlay which can get pretty complicated.
    >
    > Now if you formatted the drive FAT32 with Windows XP, that is the largest
    > you can make a partition as FAT32 (with Windows XP) and I would hihgly
    > recommend deleting that partition and formatting the whole thing as NTFS.
    > That may be where your space has gone, but that doesn't explain why the
    > BIOS only sees 32 GB.
    >
    > -----
    > Nathan McNulty

    Kristian:
    Assuming your Hitachi HDD is a Parallel-ATA model, it's possible that the
    jumper position has been incorrectly set to limit the drive capacity to 32
    GB. So check your jumper setting to see if this is the problem.

    Art
  4. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Hi - again - it took a while to flash my bios as I needed a new floppy
    drive. Well, it is done with the manufacturers newest bios installed
    and all guidelines observed. There is sadly no change in the outcome -
    my new hd is only recognized as a 32GB hd.

    My drives (both primary and slave) are partitioned as ntfs.

    Any other suggestion is appreciated.
    Kristian

    Nathan McNulty <newsgroups@msn.com> wrote in message news:<#5n5io2wEHA.4004@tk2msftngp13.phx.gbl>...
    > That motherboard is not that old, so it should see drives over 32 GB. I
    > would recommend updating the BIOS because Windows will not detect the
    > drive size as larger than the BIOS detects it unless you use a Dynamic
    > Drive Overlay which can get pretty complicated.
    >
    > Now if you formatted the drive FAT32 with Windows XP, that is the
    > largest you can make a partition as FAT32 (with Windows XP) and I would
    > hihgly recommend deleting that partition and formatting the whole thing
    > as NTFS. That may be where your space has gone, but that doesn't
    > explain why the BIOS only sees 32 GB.
    >
    > -----
    > Nathan McNulty
    >
    > post@kristiankrogh.dk wrote:
    > > Hi
    > >
    > > A new hard drive, Hitachi Deskstar 7K250 160GB, is being detected by
    > > my bios (motherboard Elitegroup K7S5A, but only with appr. 32GB. Same
    > > thing in windows drive administration - only 32GB.
    > >
    > > Is it absoluttely necessary that the bios detects it properly or can I
    > > "fix" this problem in windows (XP Pro, sp2)?
    > >
    > > I have tried all sorts of both auto detect and user set up in the bios
    > > but I am not able to change the size of the hard drive.
    > >
    > > Any help is appreciated.
    > >
    > > Kristian
  5. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Hi Art

    I would like to try it out - but which jumper settings are you
    referring to. I guess it is on the motherboard but it is not obvious
    to me which exact jumper to change. The only jumpers referred to in
    the mainboard's manual is audio, usb, cmos, keyboard nad various LED
    light things

    "Art" <noonehere@longone.net> wrote in message news:<#Hnd762wEHA.4028@TK2MSFTNGP15.phx.gbl>...
    > > post@kristiankrogh.dk wrote:
    > >> Hi
    > >>
    > >> A new hard drive, Hitachi Deskstar 7K250 160GB, is being detected by
    > >> my bios (motherboard Elitegroup K7S5A, but only with appr. 32GB. Same
    > >> thing in windows drive administration - only 32GB.
    > >>
    > >> Is it absoluttely necessary that the bios detects it properly or can I
    > >> "fix" this problem in windows (XP Pro, sp2)?
    > >>
    > >> I have tried all sorts of both auto detect and user set up in the bios
    > >> but I am not able to change the size of the hard drive.
    > >>
    > >> Any help is appreciated.
    > >>
    > >> Kristian
    >
    > "Nathan McNulty" <newsgroups@msn.com> wrote in message
    > news:%235n5io2wEHA.4004@tk2msftngp13.phx.gbl...
    > > That motherboard is not that old, so it should see drives over 32 GB. I
    > > would recommend updating the BIOS because Windows will not detect the
    > > drive size as larger than the BIOS detects it unless you use a Dynamic
    > > Drive Overlay which can get pretty complicated.
    > >
    > > Now if you formatted the drive FAT32 with Windows XP, that is the largest
    > > you can make a partition as FAT32 (with Windows XP) and I would hihgly
    > > recommend deleting that partition and formatting the whole thing as NTFS.
    > > That may be where your space has gone, but that doesn't explain why the
    > > BIOS only sees 32 GB.
    > >
    > > -----
    > > Nathan McNulty
    >
    > Kristian:
    > Assuming your Hitachi HDD is a Parallel-ATA model, it's possible that the
    > jumper position has been incorrectly set to limit the drive capacity to 32
    > GB. So check your jumper setting to see if this is the problem.
    >
    > Art
  6. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Kristian:
    See http://www.hitachigst.com/hdd/support/d7k250/d7k250jum.htm
    for information on jumper settings for your Hitachi hard drive. You'll see
    references to a jumper clip which limits the drive capacity down to 32 GB.
    We're talking about the jumper setting on your hard drive. It has nothing to
    do with your motherboard's jumper settings in this case.
    Art


    <post@kristiankrogh.dk> wrote in message
    news:37253c1f.0411091540.7e7c2241@posting.google.com...
    > Hi Art
    >
    > I would like to try it out - but which jumper settings are you
    > referring to. I guess it is on the motherboard but it is not obvious
    > to me which exact jumper to change. The only jumpers referred to in
    > the mainboard's manual is audio, usb, cmos, keyboard nad various LED
    > light things
    >
    > "Art" <noonehere@longone.net> wrote in message
    > news:<#Hnd762wEHA.4028@TK2MSFTNGP15.phx.gbl>...
    >> > post@kristiankrogh.dk wrote:
    >> >> Hi
    >> >>
    >> >> A new hard drive, Hitachi Deskstar 7K250 160GB, is being detected by
    >> >> my bios (motherboard Elitegroup K7S5A, but only with appr. 32GB. Same
    >> >> thing in windows drive administration - only 32GB.
    >> >>
    >> >> Is it absoluttely necessary that the bios detects it properly or can I
    >> >> "fix" this problem in windows (XP Pro, sp2)?
    >> >>
    >> >> I have tried all sorts of both auto detect and user set up in the bios
    >> >> but I am not able to change the size of the hard drive.
    >> >>
    >> >> Any help is appreciated.
    >> >>
    >> >> Kristian
    >>
    >> "Nathan McNulty" <newsgroups@msn.com> wrote in message
    >> news:%235n5io2wEHA.4004@tk2msftngp13.phx.gbl...
    >> > That motherboard is not that old, so it should see drives over 32 GB.
    >> > I
    >> > would recommend updating the BIOS because Windows will not detect the
    >> > drive size as larger than the BIOS detects it unless you use a Dynamic
    >> > Drive Overlay which can get pretty complicated.
    >> >
    >> > Now if you formatted the drive FAT32 with Windows XP, that is the
    >> > largest
    >> > you can make a partition as FAT32 (with Windows XP) and I would hihgly
    >> > recommend deleting that partition and formatting the whole thing as
    >> > NTFS.
    >> > That may be where your space has gone, but that doesn't explain why the
    >> > BIOS only sees 32 GB.
    >> >
    >> > -----
    >> > Nathan McNulty
    >>
    >> Kristian:
    >> Assuming your Hitachi HDD is a Parallel-ATA model, it's possible that the
    >> jumper position has been incorrectly set to limit the drive capacity to
    >> 32
    >> GB. So check your jumper setting to see if this is the problem.
    >>
    >> Art
  7. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    On 9 Nov 2004 15:40:09 -0800, post@kristiankrogh.dk wrote:

    >Hi Art
    >
    >I would like to try it out - but which jumper settings are you
    >referring to.

    http://www.hitachigst.com/hdd/support/d7k250/d7k250jum.htm

    > I guess it is on the motherboard but it is not obvious
    >to me which exact jumper to change. The only jumpers referred to in
    >the mainboard's manual is audio, usb, cmos, keyboard nad various LED
    >light things
    >
    >"Art" <noonehere@longone.net> wrote in message news:<#Hnd762wEHA.4028@TK2MSFTNGP15.phx.gbl>...
    >> > post@kristiankrogh.dk wrote:
    >> >> Hi
    >> >>
    >> >> A new hard drive, Hitachi Deskstar 7K250 160GB, is being detected by
    >> >> my bios (motherboard Elitegroup K7S5A, but only with appr. 32GB. Same
    >> >> thing in windows drive administration - only 32GB.
    >> >>
    >> >> Is it absoluttely necessary that the bios detects it properly or can I
    >> >> "fix" this problem in windows (XP Pro, sp2)?
    >> >>
    >> >> I have tried all sorts of both auto detect and user set up in the bios
    >> >> but I am not able to change the size of the hard drive.
    >> >>
    >> >> Any help is appreciated.
    >> >>
    >> >> Kristian
    >>
    >> "Nathan McNulty" <newsgroups@msn.com> wrote in message
    >> news:%235n5io2wEHA.4004@tk2msftngp13.phx.gbl...
    >> > That motherboard is not that old, so it should see drives over 32 GB. I
    >> > would recommend updating the BIOS because Windows will not detect the
    >> > drive size as larger than the BIOS detects it unless you use a Dynamic
    >> > Drive Overlay which can get pretty complicated.
    >> >
    >> > Now if you formatted the drive FAT32 with Windows XP, that is the largest
    >> > you can make a partition as FAT32 (with Windows XP) and I would hihgly
    >> > recommend deleting that partition and formatting the whole thing as NTFS.
    >> > That may be where your space has gone, but that doesn't explain why the
    >> > BIOS only sees 32 GB.
    >> >
    >> > -----
    >> > Nathan McNulty
    >>
    >> Kristian:
    >> Assuming your Hitachi HDD is a Parallel-ATA model, it's possible that the
    >> jumper position has been incorrectly set to limit the drive capacity to 32
    >> GB. So check your jumper setting to see if this is the problem.
    >>
    >> Art
  8. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Hi - thanks very for your help. Changing the jumper solved my problem. :-)

    "Art" <noonehere@longone.net> wrote in message news:<#Hnd762wEHA.4028@TK2MSFTNGP15.phx.gbl>...
    > > post@kristiankrogh.dk wrote:
    > >> Hi
    > >>
    > >> A new hard drive, Hitachi Deskstar 7K250 160GB, is being detected by
    > >> my bios (motherboard Elitegroup K7S5A, but only with appr. 32GB. Same
    > >> thing in windows drive administration - only 32GB.
    > >>
    > >> Is it absoluttely necessary that the bios detects it properly or can I
    > >> "fix" this problem in windows (XP Pro, sp2)?
    > >>
    > >> I have tried all sorts of both auto detect and user set up in the bios
    > >> but I am not able to change the size of the hard drive.
    > >>
    > >> Any help is appreciated.
    > >>
    > >> Kristian
    >
    > "Nathan McNulty" <newsgroups@msn.com> wrote in message
    > news:%235n5io2wEHA.4004@tk2msftngp13.phx.gbl...
    > > That motherboard is not that old, so it should see drives over 32 GB. I
    > > would recommend updating the BIOS because Windows will not detect the
    > > drive size as larger than the BIOS detects it unless you use a Dynamic
    > > Drive Overlay which can get pretty complicated.
    > >
    > > Now if you formatted the drive FAT32 with Windows XP, that is the largest
    > > you can make a partition as FAT32 (with Windows XP) and I would hihgly
    > > recommend deleting that partition and formatting the whole thing as NTFS.
    > > That may be where your space has gone, but that doesn't explain why the
    > > BIOS only sees 32 GB.
    > >
    > > -----
    > > Nathan McNulty
    >
    > Kristian:
    > Assuming your Hitachi HDD is a Parallel-ATA model, it's possible that the
    > jumper position has been incorrectly set to limit the drive capacity to 32
    > GB. So check your jumper setting to see if this is the problem.
    >
    > Art
Ask a new question

Read More

Detection Hard Drives Windows XP