Unrecognised file structure

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I have re-installed win XP pRO on my C: drive but now that it is running
again
my D: drive is not recognised.
I get a message saying that it needs formatting but all my data files are on
there so I don't want to do that.
Ontrack disk recovery sees the drive (as does Windows) but cannot recognise
the file structure which was NTFS.
Is there a non destructive way that I can re-format my drive and recover my
files?
6 answers Last reply
More about unrecognised file structure
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Try taking ownership of the files on that drive:
    Note, file ownership and permissions supersede administrator rights. How
    you resolve it depends upon which version of XP you are running.

    XP-Home

    Unfortunately, XP Home using NTFS is essentially hard wired for "Simple File
    Sharing" at system level.

    However, you can set XP Home permissions in Safe Mode. Reboot, and start
    hitting F8, a menu should eventually appear and one of the
    options is Safe Mode. Select it. Note, it will ask for the administrator's
    password. This is not your administrator account, rather it is the
    machine's administrator account for which users are asked to create a
    password during setup.

    If you created no such password, when requested, leave blank and press
    enter.

    Open Explorer, go to Tools and Folder Options, on the view tab, scroll to
    the bottom of the list, if it shows "Enable Simple File Sharing" deselect it
    and click apply and ok. If it shows nothing or won't let you make a change,
    move on to the next step.

    Navigate to the files, right click, select properties, go to the Security
    tab, click advanced, go to the Owner tab and select the user that was logged
    on when you were refused permission to access the files. Click apply and
    ok. Close the properties box, reopen it, click add and type in the name of
    the user you just enabled. If you wish to set ownership for everything in
    the folder, at the bottom of the Owner tab is the following selection:
    "Replace owner on subcontainers and objects," select it as well.

    Once complete, you should be able to do what you wish with these files when
    you log back on as that user.

    XP-Pro

    If you have XP Pro, temporarily change the limited account to
    administrative. First, go to Windows Explorer, go to Tools, select Folder
    Options, go to the View tab and be sure "Use Simple File Sharing" is not
    selected. If it is, deselect it and click apply and ok.

    If you wish everything in a specific folder to be accessible to a user,
    right click the folder, select properties, go to the Security tab, click
    Advanced, go to the Owner tab,
    select the user you wish to have access, at the bottom of the box, you
    should see a check box for "Replace owner on subcontainers and objects,"
    place a check in the box and click apply and ok.

    The user should now be able to perform necessary functions on files in the
    folder even as a limited account. If not, make it an admin account again,
    right click the folder, select Properties, go to the Security tab and be
    sure the user is listed in the user list. If not, click add and type the
    user name in the appropriate box, be sure the user has all the necessary
    permissions checked in the permission list below the user list, click apply
    and ok.

    That should do it and allow whatever access you desire for that folder even
    in a limited account.


    --
    Michael Solomon MS-MVP
    Windows Shell/User
    Backup is a PC User's Best Friend
    DTS-L.Org: http://www.dts-l.org/

    "Rob Sowerby" <robsowerby@PANTIESntlworld.com> wrote in message
    news:mVvkd.291$yO4.87@newsfe2-gui.ntli.net...
    >I have re-installed win XP pRO on my C: drive but now that it is running
    > again
    > my D: drive is not recognised.
    > I get a message saying that it needs formatting but all my data files are
    > on
    > there so I don't want to do that.
    > Ontrack disk recovery sees the drive (as does Windows) but cannot
    > recognise
    > the file structure which was NTFS.
    > Is there a non destructive way that I can re-format my drive and recover
    > my
    > files?
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Does ontrack EasyRecovery Professional see the files? If not, you will have
    to chose to use the "raw" scan mode under the data recovery tab. This is
    independent of the drive having any file system on it. I was able to recover
    99% of the files on a 40 gig drive when the same thing happened to me 2
    years ago.

    What ever you do - DON'T FORMAT THE DRIVE! Recover your files first. Then
    you can format the drive and start using it again.

    --

    Regards:

    Richard Urban

    aka Crusty (-: Old B@stard :-)


    "Rob Sowerby" <robsowerby@PANTIESntlworld.com> wrote in message
    news:mVvkd.291$yO4.87@newsfe2-gui.ntli.net...
    >I have re-installed win XP pRO on my C: drive but now that it is running
    > again
    > my D: drive is not recognised.
    > I get a message saying that it needs formatting but all my data files are
    > on
    > there so I don't want to do that.
    > Ontrack disk recovery sees the drive (as does Windows) but cannot
    > recognise
    > the file structure which was NTFS.
    > Is there a non destructive way that I can re-format my drive and recover
    > my
    > files?
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    There is no file structure on the drive - therefore there are no files to
    take ownership of!

    --

    Regards:

    Richard Urban

    aka Crusty (-: Old B@stard :-)


    "Michael Solomon (MS-MVP)" <user@#notme.com> wrote in message
    news:uDxXZD3xEHA.1956@TK2MSFTNGP14.phx.gbl...
    > Try taking ownership of the files on that drive:
    > Note, file ownership and permissions supersede administrator rights. How
    > you resolve it depends upon which version of XP you are running.
    >
    > XP-Home
    >
    > Unfortunately, XP Home using NTFS is essentially hard wired for "Simple
    > File Sharing" at system level.
    >
    > However, you can set XP Home permissions in Safe Mode. Reboot, and start
    > hitting F8, a menu should eventually appear and one of the
    > options is Safe Mode. Select it. Note, it will ask for the
    > administrator's
    > password. This is not your administrator account, rather it is the
    > machine's administrator account for which users are asked to create a
    > password during setup.
    >
    > If you created no such password, when requested, leave blank and press
    > enter.
    >
    > Open Explorer, go to Tools and Folder Options, on the view tab, scroll to
    > the bottom of the list, if it shows "Enable Simple File Sharing" deselect
    > it
    > and click apply and ok. If it shows nothing or won't let you make a
    > change,
    > move on to the next step.
    >
    > Navigate to the files, right click, select properties, go to the Security
    > tab, click advanced, go to the Owner tab and select the user that was
    > logged
    > on when you were refused permission to access the files. Click apply and
    > ok. Close the properties box, reopen it, click add and type in the name
    > of
    > the user you just enabled. If you wish to set ownership for everything in
    > the folder, at the bottom of the Owner tab is the following selection:
    > "Replace owner on subcontainers and objects," select it as well.
    >
    > Once complete, you should be able to do what you wish with these files
    > when
    > you log back on as that user.
    >
    > XP-Pro
    >
    > If you have XP Pro, temporarily change the limited account to
    > administrative. First, go to Windows Explorer, go to Tools, select Folder
    > Options, go to the View tab and be sure "Use Simple File Sharing" is not
    > selected. If it is, deselect it and click apply and ok.
    >
    > If you wish everything in a specific folder to be accessible to a user,
    > right click the folder, select properties, go to the Security tab, click
    > Advanced, go to the Owner tab,
    > select the user you wish to have access, at the bottom of the box, you
    > should see a check box for "Replace owner on subcontainers and objects,"
    > place a check in the box and click apply and ok.
    >
    > The user should now be able to perform necessary functions on files in the
    > folder even as a limited account. If not, make it an admin account again,
    > right click the folder, select Properties, go to the Security tab and be
    > sure the user is listed in the user list. If not, click add and type the
    > user name in the appropriate box, be sure the user has all the necessary
    > permissions checked in the permission list below the user list, click
    > apply
    > and ok.
    >
    > That should do it and allow whatever access you desire for that folder
    > even
    > in a limited account.
    >
    >
    >
    > --
    > Michael Solomon MS-MVP
    > Windows Shell/User
    > Backup is a PC User's Best Friend
    > DTS-L.Org: http://www.dts-l.org/
    >
    > "Rob Sowerby" <robsowerby@PANTIESntlworld.com> wrote in message
    > news:mVvkd.291$yO4.87@newsfe2-gui.ntli.net...
    >>I have re-installed win XP pRO on my C: drive but now that it is running
    >> again
    >> my D: drive is not recognised.
    >> I get a message saying that it needs formatting but all my data files are
    >> on
    >> there so I don't want to do that.
    >> Ontrack disk recovery sees the drive (as does Windows) but cannot
    >> recognise
    >> the file structure which was NTFS.
    >> Is there a non destructive way that I can re-format my drive and recover
    >> my
    >> files?
    >>
    >>
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    That may be the case or it may simply be that XP is not recognizing the
    files on the drive because now that the OP has reinstalled XP, file
    ownership has been lost. If he can take ownership using the root drive
    everything may become visible again. You may be right, the drive may be
    corrupt, in which case, this won't resolve the issue. However, I've seen
    this come up before and taking ownership of the drive resolved the issue and
    the circumstances were similar. It's worth a shot and may return access to
    the files on that drive.

    --
    Michael Solomon MS-MVP
    Windows Shell/User
    Backup is a PC User's Best Friend
    DTS-L.Org: http://www.dts-l.org/

    "Richard Urban" <richardurbanREMOVETHIS@hotmail.com> wrote in message
    news:uQCcvG4xEHA.3120@TK2MSFTNGP12.phx.gbl...
    > There is no file structure on the drive - therefore there are no files to
    > take ownership of!
    >
    > --
    >
    > Regards:
    >
    > Richard Urban
    >
    > aka Crusty (-: Old B@stard :-)
    >
    >
    > "Michael Solomon (MS-MVP)" <user@#notme.com> wrote in message
    > news:uDxXZD3xEHA.1956@TK2MSFTNGP14.phx.gbl...
    >> Try taking ownership of the files on that drive:
    >> Note, file ownership and permissions supersede administrator rights. How
    >> you resolve it depends upon which version of XP you are running.
    >>
    >> XP-Home
    >>
    >> Unfortunately, XP Home using NTFS is essentially hard wired for "Simple
    >> File Sharing" at system level.
    >>
    >> However, you can set XP Home permissions in Safe Mode. Reboot, and start
    >> hitting F8, a menu should eventually appear and one of the
    >> options is Safe Mode. Select it. Note, it will ask for the
    >> administrator's
    >> password. This is not your administrator account, rather it is the
    >> machine's administrator account for which users are asked to create a
    >> password during setup.
    >>
    >> If you created no such password, when requested, leave blank and press
    >> enter.
    >>
    >> Open Explorer, go to Tools and Folder Options, on the view tab, scroll to
    >> the bottom of the list, if it shows "Enable Simple File Sharing" deselect
    >> it
    >> and click apply and ok. If it shows nothing or won't let you make a
    >> change,
    >> move on to the next step.
    >>
    >> Navigate to the files, right click, select properties, go to the Security
    >> tab, click advanced, go to the Owner tab and select the user that was
    >> logged
    >> on when you were refused permission to access the files. Click apply and
    >> ok. Close the properties box, reopen it, click add and type in the name
    >> of
    >> the user you just enabled. If you wish to set ownership for everything
    >> in
    >> the folder, at the bottom of the Owner tab is the following selection:
    >> "Replace owner on subcontainers and objects," select it as well.
    >>
    >> Once complete, you should be able to do what you wish with these files
    >> when
    >> you log back on as that user.
    >>
    >> XP-Pro
    >>
    >> If you have XP Pro, temporarily change the limited account to
    >> administrative. First, go to Windows Explorer, go to Tools, select
    >> Folder Options, go to the View tab and be sure "Use Simple File Sharing"
    >> is not selected. If it is, deselect it and click apply and ok.
    >>
    >> If you wish everything in a specific folder to be accessible to a user,
    >> right click the folder, select properties, go to the Security tab, click
    >> Advanced, go to the Owner tab,
    >> select the user you wish to have access, at the bottom of the box, you
    >> should see a check box for "Replace owner on subcontainers and objects,"
    >> place a check in the box and click apply and ok.
    >>
    >> The user should now be able to perform necessary functions on files in
    >> the
    >> folder even as a limited account. If not, make it an admin account
    >> again,
    >> right click the folder, select Properties, go to the Security tab and be
    >> sure the user is listed in the user list. If not, click add and type the
    >> user name in the appropriate box, be sure the user has all the necessary
    >> permissions checked in the permission list below the user list, click
    >> apply
    >> and ok.
    >>
    >> That should do it and allow whatever access you desire for that folder
    >> even
    >> in a limited account.
    >>
    >>
    >>
    >> --
    >> Michael Solomon MS-MVP
    >> Windows Shell/User
    >> Backup is a PC User's Best Friend
    >> DTS-L.Org: http://www.dts-l.org/
    >>
    >> "Rob Sowerby" <robsowerby@PANTIESntlworld.com> wrote in message
    >> news:mVvkd.291$yO4.87@newsfe2-gui.ntli.net...
    >>>I have re-installed win XP pRO on my C: drive but now that it is running
    >>> again
    >>> my D: drive is not recognised.
    >>> I get a message saying that it needs formatting but all my data files
    >>> are on
    >>> there so I don't want to do that.
    >>> Ontrack disk recovery sees the drive (as does Windows) but cannot
    >>> recognise
    >>> the file structure which was NTFS.
    >>> Is there a non destructive way that I can re-format my drive and recover
    >>> my
    >>> files?
    >>>
    >>>
    >>
    >>
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "Rob Sowerby" <robsowerby@PANTIESntlworld.com> wrote in message
    news:mVvkd.291$yO4.87@newsfe2-gui.ntli.net...
    > I have re-installed win XP pRO on my C: drive but now that it is running
    > again
    > my D: drive is not recognised.
    > I get a message saying that it needs formatting but all my data files are
    on
    > there so I don't want to do that.
    > Ontrack disk recovery sees the drive (as does Windows) but cannot
    recognise
    > the file structure which was NTFS.
    > Is there a non destructive way that I can re-format my drive and recover
    my
    > files?

    There are two ways to restore your data:

    a) The easy way: Restore it from backup.

    b) The hard way: Use one of the following tools:
    http://www.restorer2000.com/r2k.htm (to restore NTFS partitions - seems to
    work well)
    http://www.hddrecovery.com.au
    http://bootmaster.filerecovery.biz (has NTFS undelete tools too)
    http://www.runtime.org/ (GetDataBack)
    www.acronis.com (RecoveryExpert)

    With respect to a): The iron rule of computing says that all important
    files must be backed up to at least one independent removable medium
    every week, and especially so before a major change such as
    re-installing an operating system. With many PC users it takes a big
    disaster to convince them that the rule makes sense. Backup media
    are cheap - a removable disk with a caddy costs less than $100.00.
  6. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    I used OnTrack's Easy Recovery in RAW mode and it has recovered all the
    files for me.
    I am now trying to decipher them and sort them out prior to renaming.
    Whew!
    Thanks for your help
    Rob

    "Rob Sowerby" <robsowerby@PANTIESntlworld.com> wrote in message
    news:mVvkd.291$yO4.87@newsfe2-gui.ntli.net...
    > I have re-installed win XP pRO on my C: drive but now that it is running
    > again
    > my D: drive is not recognised.
    > I get a message saying that it needs formatting but all my data files are
    on
    > there so I don't want to do that.
    > Ontrack disk recovery sees the drive (as does Windows) but cannot
    recognise
    > the file structure which was NTFS.
    > Is there a non destructive way that I can re-format my drive and recover
    my
    > files?
    >
    >
Ask a new question

Read More

Windows XP