Sign in with
Sign up | Sign in
Your question

Hard Disk DMA, advice ? help please.

Tags:
  • Windows XP
Last response: in Windows XP
Share
Anonymous
November 20, 2004 4:31:42 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I am running XPHome SP2 fully updated. I have 2 HDs, both set to Auto in the
BIOS for DMA detection.

HD C is correctly detected but D comes up as PIO in System Devices.
Can anyone tell me how I can set it for the DMA settings to be correctly
detected?

Motherboard:
CPU Type Intel Pentium
4, 1700 MHz (17 x 100)
Motherboard Name Gigabyte GA-8IDX (6
PCI, 1 AGP, 1 CNR, 3 DIMM, Audio)
Motherboard Chipset Intel Brookdale
i845
System Memory 1024 MB (SDRAM)
BIOS Type Award Modular
(09/16/02)
IDE Controller Intel(R) 82801BA
Ultra ATA Storage Controller - 244B
Disk Drive D SAMSUNG SP1203N (120
GB, 7200 RPM, Ultra-ATA/133)
Disk Drive C SAMSUNG SP0802N (80
GB, 7200 RPM, Ultra-ATA/133)


--
Paul Woodsford
Remove NOSPAM to reply.

More about : hard disk dma advice

Anonymous
November 20, 2004 4:31:43 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Put both HDDs on the same IDE channel.
November 20, 2004 4:31:43 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hi,

Connect both Hdds on primary IDE channel.
Set CS or auto select on both drives. C drive should be connected as master.
Make sure you are using a 80 wires 40 pin Shielded IDE cable.
Also check that the DMA mode is enabled in BIOS settings.
If your mobo support ATA133, both Hdds should be in Ultra DMA mode 6.
If the mobo only support ATA100, boths Hdds should be in UDMA mode 5.

Peter


"Paul Woodsford" wrote:

> I am running XPHome SP2 fully updated. I have 2 HDs, both set to Auto in the
> BIOS for DMA detection.
>
> HD C is correctly detected but D comes up as PIO in System Devices.
> Can anyone tell me how I can set it for the DMA settings to be correctly
> detected?
>
> Motherboard:
> CPU Type Intel Pentium
> 4, 1700 MHz (17 x 100)
> Motherboard Name Gigabyte GA-8IDX (6
> PCI, 1 AGP, 1 CNR, 3 DIMM, Audio)
> Motherboard Chipset Intel Brookdale
> i845
> System Memory 1024 MB (SDRAM)
> BIOS Type Award Modular
> (09/16/02)
> IDE Controller Intel(R) 82801BA
> Ultra ATA Storage Controller - 244B
> Disk Drive D SAMSUNG SP1203N (120
> GB, 7200 RPM, Ultra-ATA/133)
> Disk Drive C SAMSUNG SP0802N (80
> GB, 7200 RPM, Ultra-ATA/133)
>
>
> --
> Paul Woodsford
> Remove NOSPAM to reply.
>
>
>
Related resources
Anonymous
November 20, 2004 4:31:44 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Jetro wrote:
> Put both HDDs on the same IDE channel.
>
>

Hmmmm. Putting both HDs on the same IDE channel may be an interesting
experiment, but that does not usually lead to optimal performance. And,
remember to check the jumper settings on both HDs if and when you make
them share an IDE cable.

As a different experiment, swap the IDE cables between those HDs, so
that the 80GB HD is on the Primary IDE and the 120GB HD is on the
Secondary IDE -- then see how the BIOS displays their PIO/DMA state.

That Gigabyte GA-8IDX MB supports up to U/100 UDMA on both IDEs, so
one HD on each IDE seems best.
--
Cheers, Bob
Anonymous
November 20, 2004 4:31:45 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I guess the second disk is suppressed by CD-ROM drive etc etc etc. This is
not a performance question yet but rather configuration.
Anonymous
November 20, 2004 11:41:56 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Both HD's are on the same Primary IDE channel, C is set as Master, D as
slave using correct cable.
2nd IDE channel has a CD/DVD drive as master and a CDr/CDrw drive as slave
working perfectly.
All MB settings set to Auto.
C drive comes up as Ultra DMA mode 5
D drive comes up as PIO despite being set to use DMA.

--
Paul Woodsford
Remove NOSPAM to reply.
"Peter" <Peter@discussions.microsoft.com> wrote in message
news:FE96F1CB-1125-4806-96DD-A6B687AA6B15@microsoft.com...
> Hi,
>
> Connect both Hdds on primary IDE channel.
> Set CS or auto select on both drives. C drive should be connected as
> master.
> Make sure you are using a 80 wires 40 pin Shielded IDE cable.
> Also check that the DMA mode is enabled in BIOS settings.
> If your mobo support ATA133, both Hdds should be in Ultra DMA mode 6.
> If the mobo only support ATA100, boths Hdds should be in UDMA mode 5.
>
> Peter
>
>
> "Paul Woodsford" wrote:
>
>> I am running XPHome SP2 fully updated. I have 2 HDs, both set to Auto in
>> the
>> BIOS for DMA detection.
>>
>> HD C is correctly detected but D comes up as PIO in System Devices.
>> Can anyone tell me how I can set it for the DMA settings to be correctly
>> detected?
>>
>> Motherboard:
>> CPU Type Intel
>> Pentium
>> 4, 1700 MHz (17 x 100)
>> Motherboard Name Gigabyte GA-8IDX
>> (6
>> PCI, 1 AGP, 1 CNR, 3 DIMM, Audio)
>> Motherboard Chipset Intel Brookdale
>> i845
>> System Memory 1024 MB
>> (SDRAM)
>> BIOS Type Award Modular
>> (09/16/02)
>> IDE Controller Intel(R) 82801BA
>> Ultra ATA Storage Controller - 244B
>> Disk Drive D SAMSUNG SP1203N
>> (120
>> GB, 7200 RPM, Ultra-ATA/133)
>> Disk Drive C SAMSUNG SP0802N
>> (80
>> GB, 7200 RPM, Ultra-ATA/133)
>>
>>
>> --
>> Paul Woodsford
>> Remove NOSPAM to reply.
>>
>>
>>
Anonymous
November 21, 2004 1:12:30 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

This seems to be an XP problem.
A Samsung HD utility shows that both drives are set to UDMA 6 as they should
be. Everest Home Edition shows both drives capable of UDMA 6 mode AND both
drives are set to UDMA 5 mode.

I have read and tried all the suggestions to no avail. XP shows HD C in UDMA
5 mode and HD D in PIO mode.


--
Paul Woodsford
Remove NOSPAM to reply.
"Paul Woodsford" <paul.woodsford@NO SPAMvirgin.net> wrote in message
news:uziQhF0zEHA.3408@tk2msftngp13.phx.gbl...
> Both HD's are on the same Primary IDE channel, C is set as Master, D as
> slave using correct cable.
> 2nd IDE channel has a CD/DVD drive as master and a CDr/CDrw drive as slave
> working perfectly.
> All MB settings set to Auto.
> C drive comes up as Ultra DMA mode 5
> D drive comes up as PIO despite being set to use DMA.
>
> --
> Paul Woodsford
> Remove NOSPAM to reply.
> "Peter" <Peter@discussions.microsoft.com> wrote in message
> news:FE96F1CB-1125-4806-96DD-A6B687AA6B15@microsoft.com...
>> Hi,
>>
>> Connect both Hdds on primary IDE channel.
>> Set CS or auto select on both drives. C drive should be connected as
>> master.
>> Make sure you are using a 80 wires 40 pin Shielded IDE cable.
>> Also check that the DMA mode is enabled in BIOS settings.
>> If your mobo support ATA133, both Hdds should be in Ultra DMA mode 6.
>> If the mobo only support ATA100, boths Hdds should be in UDMA mode 5.
>>
>> Peter
>>
>>
>> "Paul Woodsford" wrote:
>>
>>> I am running XPHome SP2 fully updated. I have 2 HDs, both set to Auto in
>>> the
>>> BIOS for DMA detection.
>>>
>>> HD C is correctly detected but D comes up as PIO in System Devices.
>>> Can anyone tell me how I can set it for the DMA settings to be correctly
>>> detected?
>>>
>>> Motherboard:
>>> CPU Type Intel
>>> Pentium
>>> 4, 1700 MHz (17 x 100)
>>> Motherboard Name Gigabyte GA-8IDX
>>> (6
>>> PCI, 1 AGP, 1 CNR, 3 DIMM, Audio)
>>> Motherboard Chipset Intel Brookdale
>>> i845
>>> System Memory 1024 MB
>>> (SDRAM)
>>> BIOS Type Award
>>> Modular
>>> (09/16/02)
>>> IDE Controller Intel(R) 82801BA
>>> Ultra ATA Storage Controller - 244B
>>> Disk Drive D SAMSUNG SP1203N
>>> (120
>>> GB, 7200 RPM, Ultra-ATA/133)
>>> Disk Drive C SAMSUNG SP0802N
>>> (80
>>> GB, 7200 RPM, Ultra-ATA/133)
>>>
>>>
>>> --
>>> Paul Woodsford
>>> Remove NOSPAM to reply.
>>>
>>>
>>>
>
>
Anonymous
November 21, 2004 1:12:31 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Edit the registry:

HKLM\System\CCS\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

0000 - IDE controller itself,
0001 - primary channel,
0002 - secondary channel.

Both channels, dwords:
MasterDeviceTimingModeAllowed 0xFFFFFFFF
SlaveDeviceTimingModeAllowed 0xFFFFFFFF
UserMasterDeviceTimingModeAllowed 0xFFFFFFFF
UserSlaveDeviceTimingModeAllowed 0xFFFFFFFF
and
MasterDeviceTimingMode 0xFFFF or 0xFFFFF
SlaveDeviceTimingMode 0xFFFF or 0xFFFFF
or
for Multi-Word DMA Mode 2 and PIO4 (burners, very old HDDs...) - 0x0410
for Ultra ATA33 (CDROMs, DVDs, old HDDs...) - 0x2010
for Ultra ATA66 (just HDDs) - 0x8010
for Ultra ATA100 (modern HDDs) - 0x10010
for Ultra ATA133 (ultramodern HDDs) - 0x12010

If the drive performance is unstable, OS locks it in one of the lower DMA
modes or in the PIO mode at all. The values "User...ModeAllowed" should
overcome this default behaviour.

Install Intel Application Accelerator.
November 21, 2004 1:12:31 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

HI,

Boot in safe mode and lock in as administrator.
Go to device manager and uninstall the primary IDE channel.
Reboot and windows should found new hardware and reinstall the drivers.
Check the DMA mode again.

Pls post back to NG if you can't fix it.

Peter

"Paul Woodsford" wrote:

> This seems to be an XP problem.
> A Samsung HD utility shows that both drives are set to UDMA 6 as they should
> be. Everest Home Edition shows both drives capable of UDMA 6 mode AND both
> drives are set to UDMA 5 mode.
>
> I have read and tried all the suggestions to no avail. XP shows HD C in UDMA
> 5 mode and HD D in PIO mode.
>
>
> --
> Paul Woodsford
> Remove NOSPAM to reply.
> "Paul Woodsford" <paul.woodsford@NO SPAMvirgin.net> wrote in message
> news:uziQhF0zEHA.3408@tk2msftngp13.phx.gbl...
> > Both HD's are on the same Primary IDE channel, C is set as Master, D as
> > slave using correct cable.
> > 2nd IDE channel has a CD/DVD drive as master and a CDr/CDrw drive as slave
> > working perfectly.
> > All MB settings set to Auto.
> > C drive comes up as Ultra DMA mode 5
> > D drive comes up as PIO despite being set to use DMA.
> >
> > --
> > Paul Woodsford
> > Remove NOSPAM to reply.
> > "Peter" <Peter@discussions.microsoft.com> wrote in message
> > news:FE96F1CB-1125-4806-96DD-A6B687AA6B15@microsoft.com...
> >> Hi,
> >>
> >> Connect both Hdds on primary IDE channel.
> >> Set CS or auto select on both drives. C drive should be connected as
> >> master.
> >> Make sure you are using a 80 wires 40 pin Shielded IDE cable.
> >> Also check that the DMA mode is enabled in BIOS settings.
> >> If your mobo support ATA133, both Hdds should be in Ultra DMA mode 6.
> >> If the mobo only support ATA100, boths Hdds should be in UDMA mode 5.
> >>
> >> Peter
> >>
> >>
> >> "Paul Woodsford" wrote:
> >>
> >>> I am running XPHome SP2 fully updated. I have 2 HDs, both set to Auto in
> >>> the
> >>> BIOS for DMA detection.
> >>>
> >>> HD C is correctly detected but D comes up as PIO in System Devices.
> >>> Can anyone tell me how I can set it for the DMA settings to be correctly
> >>> detected?
> >>>
> >>> Motherboard:
> >>> CPU Type Intel
> >>> Pentium
> >>> 4, 1700 MHz (17 x 100)
> >>> Motherboard Name Gigabyte GA-8IDX
> >>> (6
> >>> PCI, 1 AGP, 1 CNR, 3 DIMM, Audio)
> >>> Motherboard Chipset Intel Brookdale
> >>> i845
> >>> System Memory 1024 MB
> >>> (SDRAM)
> >>> BIOS Type Award
> >>> Modular
> >>> (09/16/02)
> >>> IDE Controller Intel(R) 82801BA
> >>> Ultra ATA Storage Controller - 244B
> >>> Disk Drive D SAMSUNG SP1203N
> >>> (120
> >>> GB, 7200 RPM, Ultra-ATA/133)
> >>> Disk Drive C SAMSUNG SP0802N
> >>> (80
> >>> GB, 7200 RPM, Ultra-ATA/133)
> >>>
> >>>
> >>> --
> >>> Paul Woodsford
> >>> Remove NOSPAM to reply.
> >>>
> >>>
> >>>
> >
> >
>
>
>
November 21, 2004 6:55:01 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I hope your problem turns out to be as simple as mine.,
I had the same symptoms as you.
The previous post which recommended installing
Intel Application Accelerator prompted me to
remember that I had installed XPSP2 with IAA installed.
I uninstalled IAA rebooted and reinstalled it,
both my HDD's are now DMA and my speed has
gone back up to spec.

By the way, some PC suppliers install IAA, so you may not
know it is there.

HTH

Daniel


"Paul Woodsford" <paul.woodsford@NO SPAMvirgin.net> wrote in message
news:uQzCI40zEHA.3336@TK2MSFTNGP11.phx.gbl...
> This seems to be an XP problem.
> A Samsung HD utility shows that both drives are set to UDMA 6 as they
> should
> be. Everest Home Edition shows both drives capable of UDMA 6 mode AND
> both
> drives are set to UDMA 5 mode.
>
> I have read and tried all the suggestions to no avail. XP shows HD C in
> UDMA
> 5 mode and HD D in PIO mode.
>
>
> --
> Paul Woodsford
> Remove NOSPAM to reply.
> "Paul Woodsford" <paul.woodsford@NO SPAMvirgin.net> wrote in message
> news:uziQhF0zEHA.3408@tk2msftngp13.phx.gbl...
>> Both HD's are on the same Primary IDE channel, C is set as Master, D as
>> slave using correct cable.
>> 2nd IDE channel has a CD/DVD drive as master and a CDr/CDrw drive as
>> slave working perfectly.
>> All MB settings set to Auto.
>> C drive comes up as Ultra DMA mode 5
>> D drive comes up as PIO despite being set to use DMA.
>>
>> --
>> Paul Woodsford
>> Remove NOSPAM to reply.
>> "Peter" <Peter@discussions.microsoft.com> wrote in message
>> news:FE96F1CB-1125-4806-96DD-A6B687AA6B15@microsoft.com...
>>> Hi,
>>>
>>> Connect both Hdds on primary IDE channel.
>>> Set CS or auto select on both drives. C drive should be connected as
>>> master.
>>> Make sure you are using a 80 wires 40 pin Shielded IDE cable.
>>> Also check that the DMA mode is enabled in BIOS settings.
>>> If your mobo support ATA133, both Hdds should be in Ultra DMA mode 6.
>>> If the mobo only support ATA100, boths Hdds should be in UDMA mode 5.
>>>
>>> Peter
>>>
>>>
>>> "Paul Woodsford" wrote:
>>>
>>>> I am running XPHome SP2 fully updated. I have 2 HDs, both set to Auto
>>>> in the
>>>> BIOS for DMA detection.
>>>>
>>>> HD C is correctly detected but D comes up as PIO in System Devices.
>>>> Can anyone tell me how I can set it for the DMA settings to be
>>>> correctly
>>>> detected?
>>>>
>>>> Motherboard:
>>>> CPU Type Intel
>>>> Pentium
>>>> 4, 1700 MHz (17 x 100)
>>>> Motherboard Name Gigabyte
>>>> GA-8IDX (6
>>>> PCI, 1 AGP, 1 CNR, 3 DIMM, Audio)
>>>> Motherboard Chipset Intel
>>>> Brookdale
>>>> i845
>>>> System Memory 1024 MB
>>>> (SDRAM)
>>>> BIOS Type Award
>>>> Modular
>>>> (09/16/02)
>>>> IDE Controller Intel(R) 82801BA
>>>> Ultra ATA Storage Controller - 244B
>>>> Disk Drive D SAMSUNG SP1203N
>>>> (120
>>>> GB, 7200 RPM, Ultra-ATA/133)
>>>> Disk Drive C SAMSUNG SP0802N
>>>> (80
>>>> GB, 7200 RPM, Ultra-ATA/133)
>>>>
>>>>
>>>> --
>>>> Paul Woodsford
>>>> Remove NOSPAM to reply.
>>>>
>>>>
>>>>
>>
>>
>
>
Anonymous
November 23, 2004 4:51:31 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Have tried installing Intel Accelerator, correct version for my board.
It installs then on reboot I'm stuck on the Blue Caterpillar screen and
after 15 minutes chickened out , rebooted F8 and used last known
configuration that worked. Then I removed Intel Accelerator.

Can anyone give any advice on how to install this program?
Everything was closed down. Msconfig/Disable all Startup items/ Disable all
Non-MS services/ Reboot and then Install.

--
Paul Woodsford
Remove NOSPAM to reply.
"Peter" <Peter@discussions.microsoft.com> wrote in message
news:E7E04C41-E27F-4400-9942-C23421429853@microsoft.com...
> HI,
>
> Boot in safe mode and lock in as administrator.
> Go to device manager and uninstall the primary IDE channel.
> Reboot and windows should found new hardware and reinstall the drivers.
> Check the DMA mode again.
>
> Pls post back to NG if you can't fix it.
>
> Peter
>
> "Paul Woodsford" wrote:
>
>> This seems to be an XP problem.
>> A Samsung HD utility shows that both drives are set to UDMA 6 as they
>> should
>> be. Everest Home Edition shows both drives capable of UDMA 6 mode AND
>> both
>> drives are set to UDMA 5 mode.
>>
>> I have read and tried all the suggestions to no avail. XP shows HD C in
>> UDMA
>> 5 mode and HD D in PIO mode.
>>
>>
>> --
>> Paul Woodsford
>> Remove NOSPAM to reply.
>> "Paul Woodsford" <paul.woodsford@NO SPAMvirgin.net> wrote in message
>> news:uziQhF0zEHA.3408@tk2msftngp13.phx.gbl...
>> > Both HD's are on the same Primary IDE channel, C is set as Master, D as
>> > slave using correct cable.
>> > 2nd IDE channel has a CD/DVD drive as master and a CDr/CDrw drive as
>> > slave
>> > working perfectly.
>> > All MB settings set to Auto.
>> > C drive comes up as Ultra DMA mode 5
>> > D drive comes up as PIO despite being set to use DMA.
>> >
>> > --
>> > Paul Woodsford
>> > Remove NOSPAM to reply.
>> > "Peter" <Peter@discussions.microsoft.com> wrote in message
>> > news:FE96F1CB-1125-4806-96DD-A6B687AA6B15@microsoft.com...
>> >> Hi,
>> >>
>> >> Connect both Hdds on primary IDE channel.
>> >> Set CS or auto select on both drives. C drive should be connected as
>> >> master.
>> >> Make sure you are using a 80 wires 40 pin Shielded IDE cable.
>> >> Also check that the DMA mode is enabled in BIOS settings.
>> >> If your mobo support ATA133, both Hdds should be in Ultra DMA mode 6.
>> >> If the mobo only support ATA100, boths Hdds should be in UDMA mode 5.
>> >>
>> >> Peter
>> >>
>> >>
>> >> "Paul Woodsford" wrote:
>> >>
>> >>> I am running XPHome SP2 fully updated. I have 2 HDs, both set to Auto
>> >>> in
>> >>> the
>> >>> BIOS for DMA detection.
>> >>>
>> >>> HD C is correctly detected but D comes up as PIO in System Devices.
>> >>> Can anyone tell me how I can set it for the DMA settings to be
>> >>> correctly
>> >>> detected?
>> >>>
>> >>> Motherboard:
>> >>> CPU Type Intel
>> >>> Pentium
>> >>> 4, 1700 MHz (17 x 100)
>> >>> Motherboard Name Gigabyte
>> >>> GA-8IDX
>> >>> (6
>> >>> PCI, 1 AGP, 1 CNR, 3 DIMM, Audio)
>> >>> Motherboard Chipset Intel
>> >>> Brookdale
>> >>> i845
>> >>> System Memory 1024 MB
>> >>> (SDRAM)
>> >>> BIOS Type Award
>> >>> Modular
>> >>> (09/16/02)
>> >>> IDE Controller Intel(R)
>> >>> 82801BA
>> >>> Ultra ATA Storage Controller - 244B
>> >>> Disk Drive D SAMSUNG SP1203N
>> >>> (120
>> >>> GB, 7200 RPM, Ultra-ATA/133)
>> >>> Disk Drive C SAMSUNG SP0802N
>> >>> (80
>> >>> GB, 7200 RPM, Ultra-ATA/133)
>> >>>
>> >>>
>> >>> --
>> >>> Paul Woodsford
>> >>> Remove NOSPAM to reply.
>> >>>
>> >>>
>> >>>
>> >
>> >
>>
>>
>>
November 26, 2004 1:36:37 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Have you checked that it is not already installed?

Daniel
"Paul Woodsford" <paul.woodsford@NO SPAMvirgin.net> wrote in message
news:eVdcLOW0EHA.2600@TK2MSFTNGP09.phx.gbl...
> Have tried installing Intel Accelerator, correct version for my board.
> It installs then on reboot I'm stuck on the Blue Caterpillar screen and
> after 15 minutes chickened out , rebooted F8 and used last known
> configuration that worked. Then I removed Intel Accelerator.
>
> Can anyone give any advice on how to install this program?
> Everything was closed down. Msconfig/Disable all Startup items/ Disable
> all Non-MS services/ Reboot and then Install.
>
> --
> Paul Woodsford
> Remove NOSPAM to reply.
> "Peter" <Peter@discussions.microsoft.com> wrote in message
> news:E7E04C41-E27F-4400-9942-C23421429853@microsoft.com...
>> HI,
>>
>> Boot in safe mode and lock in as administrator.
>> Go to device manager and uninstall the primary IDE channel.
>> Reboot and windows should found new hardware and reinstall the drivers.
>> Check the DMA mode again.
>>
>> Pls post back to NG if you can't fix it.
>>
>> Peter
>>
>> "Paul Woodsford" wrote:
>>
>>> This seems to be an XP problem.
>>> A Samsung HD utility shows that both drives are set to UDMA 6 as they
>>> should
>>> be. Everest Home Edition shows both drives capable of UDMA 6 mode AND
>>> both
>>> drives are set to UDMA 5 mode.
>>>
>>> I have read and tried all the suggestions to no avail. XP shows HD C in
>>> UDMA
>>> 5 mode and HD D in PIO mode.
>>>
>>>
>>> --
>>> Paul Woodsford
>>> Remove NOSPAM to reply.
>>> "Paul Woodsford" <paul.woodsford@NO SPAMvirgin.net> wrote in message
>>> news:uziQhF0zEHA.3408@tk2msftngp13.phx.gbl...
>>> > Both HD's are on the same Primary IDE channel, C is set as Master, D
>>> > as
>>> > slave using correct cable.
>>> > 2nd IDE channel has a CD/DVD drive as master and a CDr/CDrw drive as
>>> > slave
>>> > working perfectly.
>>> > All MB settings set to Auto.
>>> > C drive comes up as Ultra DMA mode 5
>>> > D drive comes up as PIO despite being set to use DMA.
>>> >
>>> > --
>>> > Paul Woodsford
>>> > Remove NOSPAM to reply.
>>> > "Peter" <Peter@discussions.microsoft.com> wrote in message
>>> > news:FE96F1CB-1125-4806-96DD-A6B687AA6B15@microsoft.com...
>>> >> Hi,
>>> >>
>>> >> Connect both Hdds on primary IDE channel.
>>> >> Set CS or auto select on both drives. C drive should be connected as
>>> >> master.
>>> >> Make sure you are using a 80 wires 40 pin Shielded IDE cable.
>>> >> Also check that the DMA mode is enabled in BIOS settings.
>>> >> If your mobo support ATA133, both Hdds should be in Ultra DMA mode 6.
>>> >> If the mobo only support ATA100, boths Hdds should be in UDMA mode 5.
>>> >>
>>> >> Peter
>>> >>
>>> >>
>>> >> "Paul Woodsford" wrote:
>>> >>
>>> >>> I am running XPHome SP2 fully updated. I have 2 HDs, both set to
>>> >>> Auto in
>>> >>> the
>>> >>> BIOS for DMA detection.
>>> >>>
>>> >>> HD C is correctly detected but D comes up as PIO in System Devices.
>>> >>> Can anyone tell me how I can set it for the DMA settings to be
>>> >>> correctly
>>> >>> detected?
>>> >>>
>>> >>> Motherboard:
>>> >>> CPU Type Intel
>>> >>> Pentium
>>> >>> 4, 1700 MHz (17 x 100)
>>> >>> Motherboard Name Gigabyte
>>> >>> GA-8IDX
>>> >>> (6
>>> >>> PCI, 1 AGP, 1 CNR, 3 DIMM, Audio)
>>> >>> Motherboard Chipset Intel
>>> >>> Brookdale
>>> >>> i845
>>> >>> System Memory 1024 MB
>>> >>> (SDRAM)
>>> >>> BIOS Type Award
>>> >>> Modular
>>> >>> (09/16/02)
>>> >>> IDE Controller Intel(R)
>>> >>> 82801BA
>>> >>> Ultra ATA Storage Controller - 244B
>>> >>> Disk Drive D SAMSUNG
>>> >>> SP1203N
>>> >>> (120
>>> >>> GB, 7200 RPM, Ultra-ATA/133)
>>> >>> Disk Drive C SAMSUNG
>>> >>> SP0802N
>>> >>> (80
>>> >>> GB, 7200 RPM, Ultra-ATA/133)
>>> >>>
>>> >>>
>>> >>> --
>>> >>> Paul Woodsford
>>> >>> Remove NOSPAM to reply.
>>> >>>
>>> >>>
>>> >>>
>>> >
>>> >
>>>
>>>
>>>
>
>
!