Sign in with
Sign up | Sign in
Your question

GA-7VM400M rev 2, no DHCP for onboard NIC

Last response: in Motherboards
Share
Anonymous
a b U Graphics card
a b V Motherboard
March 31, 2005 8:03:59 PM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

For some strange reason DHCP doesn't work with the onboard LAN,
however assigning a static IP works fine. Latest bios already
intalled (FD) latest VIA 4-in-1's installed, latest NIC drivers
installed too. The onboard NIC is sharing an IRQ with the video card,
and despite changing options in the bios there's no way to change that
(both the video card and NIC take IRQ 11). I know the onboard nic
isn't defective, because it works fine once assigned a static IP. If
anyone has any ideas, please let me know. Thanks.

-GV
Anonymous
a b U Graphics card
a b V Motherboard
April 2, 2005 7:07:59 PM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

GlassVial wrote:
> For some strange reason DHCP doesn't work with the onboard LAN,

What are you using for a DHCP server?
Anonymous
a b U Graphics card
a b V Motherboard
April 2, 2005 10:21:58 PM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

>> For some strange reason DHCP doesn't work with the onboard LAN,
>
>What are you using for a DHCP server?

A linksys router. Any other machine on the network that needs an IP
gets it just fine from it.

-GV
Related resources
Anonymous
a b U Graphics card
a b V Motherboard
April 4, 2005 12:26:52 AM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

GlassVial wrote:
>>> For some strange reason DHCP doesn't work with the onboard LAN,

Got any software firewall filters installed? Perhaps the server isn't
receiving the DHCP REQUEST packet or the client isn't getting the OFFER
packet.
Anonymous
a b U Graphics card
a b V Motherboard
April 4, 2005 9:55:27 AM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

>Got any software firewall filters installed?

Nope just stock XP SP2, and I tried turning its own firewall off.

-GV
Anonymous
a b U Graphics card
a b V Motherboard
April 4, 2005 9:56:14 AM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

>Got any software firewall filters installed?

Oh and this problem was also happening with Windows 98SE, no software
firewall of any kind.

-GV
Anonymous
a b U Graphics card
a b V Motherboard
April 4, 2005 6:11:04 PM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

GlassVial wrote:
> Oh and this problem was also happening with Windows 98SE, no software
> firewall of any kind.

What is the default speed of the card, is it set to auto-negotiate? Try
setting it to 10mb/s and see if that changes anything.

You have sufficient IP addresses available in the DHCP server scope,
right?

When you boot your system with DHCP enabled does XP assign a APIPA
address (i.e. 169.254.x.x.) when it can't get a response from the DHCP
server?

Finally, try uninstalling and reinstalling the TCP protocol. Make SURE
you have an operable driver (not necessarily the lastest one...) for
that VIA network interface chip. Are you using this one?

http://www.giga-byte.com/Download/Download.asp?FileExtN...
Anonymous
a b U Graphics card
a b V Motherboard
April 4, 2005 6:35:09 PM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

>What is the default speed of the card, is it set to auto-negotiate? Try
>setting it to 10mb/s and see if that changes anything.

I believe it's set to auto with the viaset utility for the onboard
nic, I'm not sure offhand.

>You have sufficient IP addresses available in the DHCP server scope,
>right?

I have it set for giving out 5 IP's, all machines/devices on my
network are static IP's, the only reason for having those 5 is for
customers machines (like the one with this GB board)

>When you boot your system with DHCP enabled does XP assign a APIPA
>address (i.e. 169.254.x.x.) when it can't get a response from the DHCP
>server?

No it just keeps trying to get an IP address, the taskbar icon keeps
searching for one, and ipconfig /release just says it's already
released, and ipconfig /renew says access denied (and yes this account
is logged in with admin rights).

>Finally, try uninstalling and reinstalling the TCP protocol. Make SURE
>you have an operable driver (not necessarily the lastest one...) for
>that VIA network interface chip. Are you using this one?
>
>http://www.giga-byte.com/Download/Download.asp?FileExtN...

No I'm using the latest one from viaarena.com, and also this is a
fresh load of XP. I figured 98 wasn't working because it was a pretty
old load and had some problems, but I thought XP would pick it up,
especially on a fresh reload.

-GV
Anonymous
a b U Graphics card
a b V Motherboard
April 4, 2005 6:53:26 PM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

GlassVial wrote:
>> When you boot your system with DHCP enabled does XP assign a APIPA
>> address (i.e. 169.254.x.x.) when it can't get a response from the
>> DHCP server?
>
> No it just keeps trying to get an IP address, the taskbar icon keeps
> searching for one, and ipconfig /release just says it's already
> released, and ipconfig /renew says access denied (and yes this account
> is logged in with admin rights).

Are you sure there is ONLY ONE DHCP server on the network?
Anonymous
a b U Graphics card
a b V Motherboard
April 4, 2005 6:56:19 PM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

GlassVial wrote:
>> When you boot your system with DHCP enabled does XP assign a APIPA
>> address (i.e. 169.254.x.x.) when it can't get a response from the
>> DHCP server?
>
> No it just keeps trying to get an IP address, the taskbar icon keeps
> searching for one, and ipconfig /release just says it's already
> released, and ipconfig /renew says access denied (and yes this account
> is logged in with admin rights).

Is there anything useful in the XP Event Log?
Anonymous
a b U Graphics card
a b V Motherboard
April 5, 2005 9:08:48 AM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

>Are you sure there is ONLY ONE DHCP server on the network?

Quite :) 

-GV
Anonymous
a b U Graphics card
a b V Motherboard
April 5, 2005 9:09:31 AM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

>Is there anything useful in the XP Event Log?

Didn't check. Will do so next time the customer's machine is here,
but I doubt there will be anything useful.

-GV
Anonymous
a b U Graphics card
a b V Motherboard
April 14, 2005 5:54:16 PM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

i have the onboard lan problem too me thinks its service pack 2. How i
solved this problem using a static ip is disable the dhcp service on
both host and client machines, In control panel\admistrative
tools\services in the services (local) tree you will see dhcp client,
double click that and then change the automatic setting to disbled.
when setting the tcp gateway on the client machines right click on my
network places select properties, right click on local network
conection select properties double click on internet protocol tcp\ip,
you will see (use the following ip address) check that & type in
192.168.?.? the q mark equals any number between 1 and 255 (you can
use 0 on the first parameter ? but not on the second). set default
gateway to 192.168.0.1 ... now here is the important part preferred
dns put your default gateway address 192.168.0.1 ... reboot all the
machines logon and make sure you allow the client firewalls to allow
192.168.0.1 and the host to allow your new client ip address you
assigned i have found this to be stable and very secure as your host
is not broadcasting ip address's to any machine that tries to log on
and you dont have to allow an ip field on your host's firewall ie:
192.169.0.1-192.168.255.255 this confines your network to allow only
the ip's you define in your firewall and solves the problem of the
dhcp assigning your ics host bogus ip address's to your clients "its
rock stable"
Anonymous
a b U Graphics card
a b V Motherboard
April 14, 2005 6:41:02 PM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

I don't have an ICS machine giving out IP's. Besides, I already
posted the problem is that the ATI video card doesn't share it's IRQ,
and there's no way to disable "assign IRQ for VGA" in the BIOS of this
board (boo, gigabyte!). If I could do that, or if I had another video
card (ie NVidia) I'm sure DHCP would work fine.

>i have the onboard lan problem too me thinks its service pack 2. How i
>solved this problem using a static ip is disable the dhcp service on
>both host and client machines, In control panel\admistrative
>tools\services in the services (local) tree you will see dhcp client,
>double click that and then change the automatic setting to disbled.
>when setting the tcp gateway on the client machines right click on my
>network places select properties, right click on local network
>conection select properties double click on internet protocol tcp\ip,
>you will see (use the following ip address) check that & type in
>192.168.?.? the q mark equals any number between 1 and 255 (you can
>use 0 on the first parameter ? but not on the second). set default
>gateway to 192.168.0.1 ... now here is the important part preferred
>dns put your default gateway address 192.168.0.1 ... reboot all the
>machines logon and make sure you allow the client firewalls to allow
>192.168.0.1 and the host to allow your new client ip address you
>assigned i have found this to be stable and very secure as your host
>is not broadcasting ip address's to any machine that tries to log on
>and you dont have to allow an ip field on your host's firewall ie:
>192.169.0.1-192.168.255.255 this confines your network to allow only
>the ip's you define in your firewall and solves the problem of the
>dhcp assigning your ics host bogus ip address's to your clients "its
>rock stable"

-GV
Anonymous
a b U Graphics card
a b V Motherboard
April 15, 2005 5:41:04 AM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

its become clear to me this network is not an ics network and the
customers connect through a router. research has shown me the dhcp
service is security for customers at the expense of server security
Ie: to allow ease of automated connections & giving a new ip to
the clients when the client logs on so hackers cant harrass clients
on the same static ip ... hmm ,Its not clear to me what sought of
service you are running: isp ect so the advantages of running dhcp
cant be acertained. do you connect out to a different sevice ect
there are a lot more complications to the problem here other than
interupt requests. Please give more details
Anonymous
a b U Graphics card
a b V Motherboard
April 15, 2005 6:23:55 PM

Archived from groups: alt.comp.periphs.mainboard.gigabyte (More info?)

>its become clear to me this network is not an ics network and the
>customers connect through a router. research has shown me the dhcp
>service is security for customers at the expense of server security
>Ie: to allow ease of automated connections & giving a new ip to
>the clients when the client logs on so hackers cant harrass clients
>on the same static ip ... hmm ,Its not clear to me what sought of
>service you are running: isp ect so the advantages of running dhcp
>cant be acertained. do you connect out to a different sevice ect
>there are a lot more complications to the problem here other than
>interupt requests. Please give more details

None of that matters. The DHCP was for ease of use, the customer is
not technically minded. Again, it is/was a hardware conflict with the
ATI video card, which there is no way to resolve other than changing
to an NVidia card, as there's no option to disable "Assign IRQ to VGA"
on this board, as there IS on SO many other boards out there (why,
Gigabyte, why??). Anyway, a static IP works fine for their use and I
consider that case closed until the board or video card are changed.

-GV
!