KT3 Ultra Aru: NEC USB2

Archived from groups: alt.comp.periphs.mainboard.msi-microstar (More info?)

Hello.

This NEC USB-Controler cannot use USB2 Devices.
USB1 Devices work.

I have done tests in Windows XP, with USB-drivers installed.
It tells: "Highspeed USB devices with non highspeed interface"

I made efforts with Linux kernel 2.6.3, and the same problem:
With the difference...the kernel is talking, windows don't :)
The USB-Scanner doesn't apear at all in lsusb.

The NEC-Controler on the MSI-Board:

00:0b.0 USB Controller: NEC Corporation USB (rev 41)
00:0b.1 USB Controller: NEC Corporation USB (rev 41)
00:0b.2 USB Controller: NEC Corporation USB 2.0 (rev 02)

usb 7-3: new high speed USB device using address 2
usb 7-3: device not accepting address 2, error -71
usb 7-3: new high speed USB device using address 3
usb 7-3: device not accepting address 3, error -71
usb 7-2: new high speed USB device using address 4
usb 7-2: device not accepting address 4, error -71
usb 7-2: new high speed USB device using address 5
usb 7-2: device not accepting address 5, error -71
usb 4-2: new full speed USB device using address 2

I tested with the USB2 Scanner Epson 2450 Perfection Photo.
Now I had to install an usb pci card:

The new Controler:

00:0a.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0a.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0a.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
00:0a.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)

The scanner also has some problems with this Controler, but the device is
now listed in lsusb and it works most times.
Sometimes I have to reconnect the Scanner because of

kernel: usbfs: USBDEVFS_BULK failed dev 2 ep 0x81 len 6 ret -75
kernel: usbfs: USBDEVFS_BULK failed dev 2 ep 0x81 len 4 ret -75

I would prefer to use the internal USB2, because of IRQ-problems (other
Thread) and too many PCI-Cards.

Is there a possibility to disable the NEC-Controler? Only the VIAs can be
disabled in the bios.

sincerely,
Paolo
3 answers Last reply
More about ultra usb2
  1. Archived from groups: alt.comp.periphs.mainboard.msi-microstar (More info?)

    Hello Pablo,

    I have had the same problem, but there was a simple solution.
    The bracket connectet to the NEC -Chip has 4 Ports. One of them (the left
    one) is reserved for using an optional bluetooth module. There is a sticker
    with a label " Don't remove when using bluetooth module".
    If You remove this sticker and plug in an usb2-device it works with correct
    speed. Also the other ports are usb2 ports when the first port is in use.
    When its not in use You receive.
    I have seen this phenomenon at four different boards (all MSI KT3 Ultra ARU,
    Windows XP SP1).
    If You have the original windows xp version, you have to an update to SP1.

    Sincerely
    Wottny

    "Paolo Peruzzi" <brian@public-files.de> schrieb im Newsbeitrag
    news:2lipanFd8865U1@uni-berlin.de...
    > Hello.
    >
    > This NEC USB-Controler cannot use USB2 Devices.
    > USB1 Devices work.
    >
    > I have done tests in Windows XP, with USB-drivers installed.
    > It tells: "Highspeed USB devices with non highspeed interface"
    >
    > I made efforts with Linux kernel 2.6.3, and the same problem:
    > With the difference...the kernel is talking, windows don't :)
    > The USB-Scanner doesn't apear at all in lsusb.
    >
    > The NEC-Controler on the MSI-Board:
    >
    > 00:0b.0 USB Controller: NEC Corporation USB (rev 41)
    > 00:0b.1 USB Controller: NEC Corporation USB (rev 41)
    > 00:0b.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
    >
    > usb 7-3: new high speed USB device using address 2
    > usb 7-3: device not accepting address 2, error -71
    > usb 7-3: new high speed USB device using address 3
    > usb 7-3: device not accepting address 3, error -71
    > usb 7-2: new high speed USB device using address 4
    > usb 7-2: device not accepting address 4, error -71
    > usb 7-2: new high speed USB device using address 5
    > usb 7-2: device not accepting address 5, error -71
    > usb 4-2: new full speed USB device using address 2
    >
    > I tested with the USB2 Scanner Epson 2450 Perfection Photo.
    > Now I had to install an usb pci card:
    >
    > The new Controler:
    >
    > 00:0a.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
    > 00:0a.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
    > 00:0a.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
    > 00:0a.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
    >
    > The scanner also has some problems with this Controler, but the device is
    > now listed in lsusb and it works most times.
    > Sometimes I have to reconnect the Scanner because of
    >
    > kernel: usbfs: USBDEVFS_BULK failed dev 2 ep 0x81 len 6 ret -75
    > kernel: usbfs: USBDEVFS_BULK failed dev 2 ep 0x81 len 4 ret -75
    >
    > I would prefer to use the internal USB2, because of IRQ-problems (other
    > Thread) and too many PCI-Cards.
    >
    > Is there a possibility to disable the NEC-Controler? Only the VIAs can be
    > disabled in the bios.
    >
    > sincerely,
    > Paolo
  2. Archived from groups: alt.comp.periphs.mainboard.msi-microstar (More info?)

    Hello Pablo,

    I have had the same problem, but there was a simple solution.
    The bracket connectet to the NEC -Chip has 4 Ports. One of them (the left
    one) is reserved for using an optional bluetooth module. There is a sticker
    with a label " Don't remove when using bluetooth module".
    If You remove this sticker and plug in an usb2-device it works with correct
    speed. Also the other ports are usb2 ports when the first port is in use.
    When its not in use You receive "Highspeed USB devices with non highspeed
    interface".
    I have seen this phenomenon at four different boards (all MSI KT3 Ultra ARU,
    Windows XP SP1).
    If You have the original windows xp version, you have to an update to SP1.

    Sincerely
    Wottny

    "Paolo Peruzzi" <brian@public-files.de> schrieb im Newsbeitrag
    news:2lipanFd8865U1@uni-berlin.de...
    > Hello.
    >
    > This NEC USB-Controler cannot use USB2 Devices.
    > USB1 Devices work.
    >
    > I have done tests in Windows XP, with USB-drivers installed.
    > It tells: "Highspeed USB devices with non highspeed interface"
    >
    > I made efforts with Linux kernel 2.6.3, and the same problem:
    > With the difference...the kernel is talking, windows don't :)
    > The USB-Scanner doesn't apear at all in lsusb.
    >
    > The NEC-Controler on the MSI-Board:
    >
    > 00:0b.0 USB Controller: NEC Corporation USB (rev 41)
    > 00:0b.1 USB Controller: NEC Corporation USB (rev 41)
    > 00:0b.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
    >
    > usb 7-3: new high speed USB device using address 2
    > usb 7-3: device not accepting address 2, error -71
    > usb 7-3: new high speed USB device using address 3
    > usb 7-3: device not accepting address 3, error -71
    > usb 7-2: new high speed USB device using address 4
    > usb 7-2: device not accepting address 4, error -71
    > usb 7-2: new high speed USB device using address 5
    > usb 7-2: device not accepting address 5, error -71
    > usb 4-2: new full speed USB device using address 2
    >
    > I tested with the USB2 Scanner Epson 2450 Perfection Photo.
    > Now I had to install an usb pci card:
    >
    > The new Controler:
    >
    > 00:0a.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
    > 00:0a.1 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
    > 00:0a.2 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
    > 00:0a.3 USB Controller: ALi Corporation USB 2.0 Controller (rev 01)
    >
    > The scanner also has some problems with this Controler, but the device is
    > now listed in lsusb and it works most times.
    > Sometimes I have to reconnect the Scanner because of
    >
    > kernel: usbfs: USBDEVFS_BULK failed dev 2 ep 0x81 len 6 ret -75
    > kernel: usbfs: USBDEVFS_BULK failed dev 2 ep 0x81 len 4 ret -75
    >
    > I would prefer to use the internal USB2, because of IRQ-problems (other
    > Thread) and too many PCI-Cards.
    >
    > Is there a possibility to disable the NEC-Controler? Only the VIAs can be
    > disabled in the bios.
    >
    > sincerely,
    > Paolo
  3. Archived from groups: alt.comp.periphs.mainboard.msi-microstar (More info?)

    Sorry, nice hint, and I was so happy about it.
    This cover of the bluetooth port I have already removed.

    It did not help me.
    Windows Hardware Manager is reloading again and again.
    Sometimes with the scanner sometimes without it.
    The Linux kernel tells me what hes doing:

    kernel: usb 7-4: USB disconnect, address 44
    kernel: usb 7-4: new high speed USB device using address 45
    kernel: usb 7-4: USB disconnect, address 45
    kernel: usb 7-4: new high speed USB device using address 46
    kernel: usb 7-4: USB disconnect, address 46
    kernel: usb 7-4: new high speed USB device using address 47

    The only difference with this port: Linux has the scanner detected at all.

    Paolo

    Joerg Wollenhaupt wrote:

    > I have had the same problem, but there was a simple solution.
    > The bracket connectet to the NEC -Chip has 4 Ports. One of them (the left
    > one) is reserved for using an optional bluetooth module. There is a
    > sticker with a label " Don't remove when using bluetooth module".
    > If You remove this sticker and plug in an usb2-device it works with
    > correct speed. Also the other ports are usb2 ports when the first port is
    > in use. When its not in use You receive.
    > I have seen this phenomenon at four different boards (all MSI KT3 Ultra
    > ARU, Windows XP SP1).
    > If You have the original windows xp version, you have to an update to SP1.
Ask a new question

Read More

MSI-Microstar Controller USB Devices NEC Motherboards