Sign in with
Sign up | Sign in
Your question

DMA Settings

Last response: in Windows XP
Share
Anonymous
February 7, 2005 9:53:02 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I have a Gateway 700XL, 2.53gig.processor, 1gig RAM, the original Lite-On
CD-RW drive I added a LG GSA-4129B DVD writer (to replace the original DVD
writer), and a 100meg internal ZIP drive.
I was having some problems recently writing to DVD+RW disks for my backups.
I was able to make DVD-R disks OK and the CD-RW drive was functioning OK
also, both for cd-rw and CD-R disks. I'm using Nero InCD for packet writing
and the Nero OEM for writing to the DVD-R's.
When I called LG about the problems writing to DVD+RW disks they told me to
check in Device Manager , on the IDE/ATAPI controllers and make sure the
Secondary IDE Channel Advanced Settings tab had the transfer mode set to DMA.
I didn't have an Advanced Settings tab. I did a complete system restore and
reloaded everything again. I now have the Advanced Settings tab, can select
DMA if Available, but the current transfer mode is always showing PIO mode.
I found a Microsoft support article Number 817472 which pertains to this
type of problem, but I still can't get the mode to switch to DMA for either
CD or DVD drive. I've tried uninstalling the Secondary IDE channel driver,
deleting the channel itself, and after Windows restarts, the PIO mode is
selected as the default, so I have to change it back to DMA if available, but
it still says that it is in PIO mode.

More about : dma settings

February 8, 2005 12:05:06 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hi,

First, make sure both optical drives are jumpered and connected correctly.
I would suggest you to connect the fastest optical drive as master.
If you are using a 40Pin 80 wires flat ribbon cable, you can set both
optical drives to cable select. I suggest you to buy one if you are using the
40 wired cable. It is cheap, $3 to $5. Also, the maximum mode for slave
drive for the 40 wired cable is limited to UDMA mode 2 only.
Boot into BIOS and check the DMA mode for the secondary IDE channels.
Ensure UDMA mode is enabled.
BTY, for CD/RW and DVD/R/W, usually the DMA mode should be UDMA Mode 2.
For 52X CD rom and 16X DVD rom, the DMA mode should be UDMA mode 5.

Peter


"Dick Snow" wrote:

> I have a Gateway 700XL, 2.53gig.processor, 1gig RAM, the original Lite-On
> CD-RW drive I added a LG GSA-4129B DVD writer (to replace the original DVD
> writer), and a 100meg internal ZIP drive.
> I was having some problems recently writing to DVD+RW disks for my backups.
> I was able to make DVD-R disks OK and the CD-RW drive was functioning OK
> also, both for cd-rw and CD-R disks. I'm using Nero InCD for packet writing
> and the Nero OEM for writing to the DVD-R's.
> When I called LG about the problems writing to DVD+RW disks they told me to
> check in Device Manager , on the IDE/ATAPI controllers and make sure the
> Secondary IDE Channel Advanced Settings tab had the transfer mode set to DMA.
> I didn't have an Advanced Settings tab. I did a complete system restore and
> reloaded everything again. I now have the Advanced Settings tab, can select
> DMA if Available, but the current transfer mode is always showing PIO mode.
> I found a Microsoft support article Number 817472 which pertains to this
> type of problem, but I still can't get the mode to switch to DMA for either
> CD or DVD drive. I've tried uninstalling the Secondary IDE channel driver,
> deleting the channel itself, and after Windows restarts, the PIO mode is
> selected as the default, so I have to change it back to DMA if available, but
> it still says that it is in PIO mode.
Anonymous
February 8, 2005 12:20:53 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

To correct get DMA to work in XP, you need to add the motherboard chipset
drivers. These drivers normally would contain the DMA IDE drivers.

For VIA chipsets, install the VIA 4in1 Hyperion drivers
For Intel chipsets, install the Intel chipset driver and maybe the Intel
Application Acelerator.


"Peter" <Peter@discussions.microsoft.com> wrote in message
news:798BBF52-0F9D-4E7E-844C-865D74F9966E@microsoft.com...
> Hi,
>
> First, make sure both optical drives are jumpered and connected correctly.
> I would suggest you to connect the fastest optical drive as master.
> If you are using a 40Pin 80 wires flat ribbon cable, you can set both
> optical drives to cable select. I suggest you to buy one if you are using
> the
> 40 wired cable. It is cheap, $3 to $5. Also, the maximum mode for slave
> drive for the 40 wired cable is limited to UDMA mode 2 only.
> Boot into BIOS and check the DMA mode for the secondary IDE channels.
> Ensure UDMA mode is enabled.
> BTY, for CD/RW and DVD/R/W, usually the DMA mode should be UDMA Mode 2.
> For 52X CD rom and 16X DVD rom, the DMA mode should be UDMA mode 5.
>
> Peter
>
>
> "Dick Snow" wrote:
>
>> I have a Gateway 700XL, 2.53gig.processor, 1gig RAM, the original Lite-On
>> CD-RW drive I added a LG GSA-4129B DVD writer (to replace the original
>> DVD
>> writer), and a 100meg internal ZIP drive.
>> I was having some problems recently writing to DVD+RW disks for my
>> backups.
>> I was able to make DVD-R disks OK and the CD-RW drive was functioning OK
>> also, both for cd-rw and CD-R disks. I'm using Nero InCD for packet
>> writing
>> and the Nero OEM for writing to the DVD-R's.
>> When I called LG about the problems writing to DVD+RW disks they told me
>> to
>> check in Device Manager , on the IDE/ATAPI controllers and make sure the
>> Secondary IDE Channel Advanced Settings tab had the transfer mode set to
>> DMA.
>> I didn't have an Advanced Settings tab. I did a complete system restore
>> and
>> reloaded everything again. I now have the Advanced Settings tab, can
>> select
>> DMA if Available, but the current transfer mode is always showing PIO
>> mode.
>> I found a Microsoft support article Number 817472 which pertains to this
>> type of problem, but I still can't get the mode to switch to DMA for
>> either
>> CD or DVD drive. I've tried uninstalling the Secondary IDE channel
>> driver,
>> deleting the channel itself, and after Windows restarts, the PIO mode is
>> selected as the default, so I have to change it back to DMA if available,
>> but
>> it still says that it is in PIO mode.
Related resources
Anonymous
February 8, 2005 12:57:07 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Now I've figured out why the Advanced Settings tab disappeared. Intel's
Application Accelerator is the culprit. According to their web site, this is
a known issue with the software, so apparently, this is not an actual
problem. The remaining issue is, the Nero software reports, prior to
burning, that DMA mode is not active for either drive. According to the
Application Accelerator utility, it is, so now I'm confused as to whether
this is just a compatibility issue with Nero, or whether the drives are not
actually using DMA for the write procedure. I was also getting the message
prior to installing the Intel utility, so apparently, Nero doesn't think DMA
mode is in use. LG seems to think the computer isn't using DMA. Does
anybody have any other suggestions? DMA is set to Mode 2 in the BIOS.

"Yves Leclerc" wrote:

> To correct get DMA to work in XP, you need to add the motherboard chipset
> drivers. These drivers normally would contain the DMA IDE drivers.
>
> For VIA chipsets, install the VIA 4in1 Hyperion drivers
> For Intel chipsets, install the Intel chipset driver and maybe the Intel
> Application Acelerator.
>
>
> "Peter" <Peter@discussions.microsoft.com> wrote in message
> news:798BBF52-0F9D-4E7E-844C-865D74F9966E@microsoft.com...
> > Hi,
> >
> > First, make sure both optical drives are jumpered and connected correctly.
> > I would suggest you to connect the fastest optical drive as master.
> > If you are using a 40Pin 80 wires flat ribbon cable, you can set both
> > optical drives to cable select. I suggest you to buy one if you are using
> > the
> > 40 wired cable. It is cheap, $3 to $5. Also, the maximum mode for slave
> > drive for the 40 wired cable is limited to UDMA mode 2 only.
> > Boot into BIOS and check the DMA mode for the secondary IDE channels.
> > Ensure UDMA mode is enabled.
> > BTY, for CD/RW and DVD/R/W, usually the DMA mode should be UDMA Mode 2.
> > For 52X CD rom and 16X DVD rom, the DMA mode should be UDMA mode 5.
> >
> > Peter
> >
> >
> > "Dick Snow" wrote:
> >
> >> I have a Gateway 700XL, 2.53gig.processor, 1gig RAM, the original Lite-On
> >> CD-RW drive I added a LG GSA-4129B DVD writer (to replace the original
> >> DVD
> >> writer), and a 100meg internal ZIP drive.
> >> I was having some problems recently writing to DVD+RW disks for my
> >> backups.
> >> I was able to make DVD-R disks OK and the CD-RW drive was functioning OK
> >> also, both for cd-rw and CD-R disks. I'm using Nero InCD for packet
> >> writing
> >> and the Nero OEM for writing to the DVD-R's.
> >> When I called LG about the problems writing to DVD+RW disks they told me
> >> to
> >> check in Device Manager , on the IDE/ATAPI controllers and make sure the
> >> Secondary IDE Channel Advanced Settings tab had the transfer mode set to
> >> DMA.
> >> I didn't have an Advanced Settings tab. I did a complete system restore
> >> and
> >> reloaded everything again. I now have the Advanced Settings tab, can
> >> select
> >> DMA if Available, but the current transfer mode is always showing PIO
> >> mode.
> >> I found a Microsoft support article Number 817472 which pertains to this
> >> type of problem, but I still can't get the mode to switch to DMA for
> >> either
> >> CD or DVD drive. I've tried uninstalling the Secondary IDE channel
> >> driver,
> >> deleting the channel itself, and after Windows restarts, the PIO mode is
> >> selected as the default, so I have to change it back to DMA if available,
> >> but
> >> it still says that it is in PIO mode.
>
>
>
February 9, 2005 11:49:03 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hi,

You can remove/uninstall Intel Application Accerlerator or run the
accelerator to change the DMA mode.

Peter

"Dick Snow" wrote:

> Now I've figured out why the Advanced Settings tab disappeared. Intel's
> Application Accelerator is the culprit. According to their web site, this is
> a known issue with the software, so apparently, this is not an actual
> problem. The remaining issue is, the Nero software reports, prior to
> burning, that DMA mode is not active for either drive. According to the
> Application Accelerator utility, it is, so now I'm confused as to whether
> this is just a compatibility issue with Nero, or whether the drives are not
> actually using DMA for the write procedure. I was also getting the message
> prior to installing the Intel utility, so apparently, Nero doesn't think DMA
> mode is in use. LG seems to think the computer isn't using DMA. Does
> anybody have any other suggestions? DMA is set to Mode 2 in the BIOS.
>
> "Yves Leclerc" wrote:
>
> > To correct get DMA to work in XP, you need to add the motherboard chipset
> > drivers. These drivers normally would contain the DMA IDE drivers.
> >
> > For VIA chipsets, install the VIA 4in1 Hyperion drivers
> > For Intel chipsets, install the Intel chipset driver and maybe the Intel
> > Application Acelerator.
> >
> >
> > "Peter" <Peter@discussions.microsoft.com> wrote in message
> > news:798BBF52-0F9D-4E7E-844C-865D74F9966E@microsoft.com...
> > > Hi,
> > >
> > > First, make sure both optical drives are jumpered and connected correctly.
> > > I would suggest you to connect the fastest optical drive as master.
> > > If you are using a 40Pin 80 wires flat ribbon cable, you can set both
> > > optical drives to cable select. I suggest you to buy one if you are using
> > > the
> > > 40 wired cable. It is cheap, $3 to $5. Also, the maximum mode for slave
> > > drive for the 40 wired cable is limited to UDMA mode 2 only.
> > > Boot into BIOS and check the DMA mode for the secondary IDE channels.
> > > Ensure UDMA mode is enabled.
> > > BTY, for CD/RW and DVD/R/W, usually the DMA mode should be UDMA Mode 2.
> > > For 52X CD rom and 16X DVD rom, the DMA mode should be UDMA mode 5.
> > >
> > > Peter
> > >
> > >
> > > "Dick Snow" wrote:
> > >
> > >> I have a Gateway 700XL, 2.53gig.processor, 1gig RAM, the original Lite-On
> > >> CD-RW drive I added a LG GSA-4129B DVD writer (to replace the original
> > >> DVD
> > >> writer), and a 100meg internal ZIP drive.
> > >> I was having some problems recently writing to DVD+RW disks for my
> > >> backups.
> > >> I was able to make DVD-R disks OK and the CD-RW drive was functioning OK
> > >> also, both for cd-rw and CD-R disks. I'm using Nero InCD for packet
> > >> writing
> > >> and the Nero OEM for writing to the DVD-R's.
> > >> When I called LG about the problems writing to DVD+RW disks they told me
> > >> to
> > >> check in Device Manager , on the IDE/ATAPI controllers and make sure the
> > >> Secondary IDE Channel Advanced Settings tab had the transfer mode set to
> > >> DMA.
> > >> I didn't have an Advanced Settings tab. I did a complete system restore
> > >> and
> > >> reloaded everything again. I now have the Advanced Settings tab, can
> > >> select
> > >> DMA if Available, but the current transfer mode is always showing PIO
> > >> mode.
> > >> I found a Microsoft support article Number 817472 which pertains to this
> > >> type of problem, but I still can't get the mode to switch to DMA for
> > >> either
> > >> CD or DVD drive. I've tried uninstalling the Secondary IDE channel
> > >> driver,
> > >> deleting the channel itself, and after Windows restarts, the PIO mode is
> > >> selected as the default, so I have to change it back to DMA if available,
> > >> but
> > >> it still says that it is in PIO mode.
> >
> >
> >
!