Sign in with
Sign up | Sign in
Your question

disabling auto Add New Hardware Wizard ("ANHW") startup on..

Last response: in Windows XP
Share
Anonymous
February 18, 2005 10:42:39 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I installed a Lexmark T520 printer correctly, and the driver works
fine. Problem is that Win XP mistakenly doesn't think so. The XP ANHW
insists on asking for a file (LXT520xp.GPD) that doesn't exist in the
driver file/folder set.

Every time I start XP, the Add New Hardware Wizard appears asking for
this file. How can I get this Wizard to stop appearing? I do not get
any prompts in the Wizard that would allow me to check "do not appear
again", or words to that effect, instead it just keeps asking for the
LXt520xp.gpd file. I also checked to see if there was any way I could
go through the Add Printer function procedure to stop the undesired
on-boot-up start of the ANHW, to no avail - there is no other way to do
it than the way I did it.

The "Device Manager" does not include the printer in the list anywhere.
I originally used the Add Printer function to add the printer, and it
worked fine - I was able to select the make/model from the menu, and it
asked for the proper filename in the driver folder, which I gave it,
and it finished installing correctly.

But on boot-up it still keeps coming back and asking for the wrong
setup file (i.e., LXt520xp.gpd).

I ran Setup for the driver install before I connected the printer.
However, the driver install procedure never prompted for connection of
the printer.

I tried the procedure in KB Article 298370, it didn't correct the
problem.

It appears that Microsoft XP recognizes the printer, but has the
(currently) wrong setup file indicated for it in XP. I should be able
to at least keep the ANHW from starting on boot-up. How do I do this?
February 19, 2005 12:37:02 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I believe that Lexmark requires you to install software and then connet the
printer.

It appears that you haven't read the installation instructions and gone
headlong into conneting the printer.

Just review the steps you took and if necessary undo all the items
[uninstall or delete] and then follow the user guide recommended process.

"Tdub" wrote:

> I installed a Lexmark T520 printer correctly, and the driver works
> fine. Problem is that Win XP mistakenly doesn't think so. The XP ANHW
> insists on asking for a file (LXT520xp.GPD) that doesn't exist in the
> driver file/folder set.
>
> Every time I start XP, the Add New Hardware Wizard appears asking for
> this file. How can I get this Wizard to stop appearing? I do not get
> any prompts in the Wizard that would allow me to check "do not appear
> again", or words to that effect, instead it just keeps asking for the
> LXt520xp.gpd file. I also checked to see if there was any way I could
> go through the Add Printer function procedure to stop the undesired
> on-boot-up start of the ANHW, to no avail - there is no other way to do
> it than the way I did it.
>
> The "Device Manager" does not include the printer in the list anywhere.
> I originally used the Add Printer function to add the printer, and it
> worked fine - I was able to select the make/model from the menu, and it
> asked for the proper filename in the driver folder, which I gave it,
> and it finished installing correctly.
>
> But on boot-up it still keeps coming back and asking for the wrong
> setup file (i.e., LXt520xp.gpd).
>
> I ran Setup for the driver install before I connected the printer.
> However, the driver install procedure never prompted for connection of
> the printer.
>
> I tried the procedure in KB Article 298370, it didn't correct the
> problem.
>
> It appears that Microsoft XP recognizes the printer, but has the
> (currently) wrong setup file indicated for it in XP. I should be able
> to at least keep the ANHW from starting on boot-up. How do I do this?
>
>
Anonymous
February 19, 2005 12:03:52 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Wrong, I was on the phone with Lexmark, we did everything the way it
was supposed to be done, they advised contacting Microsoft, said it was
a bug in Microsoft XP.
Related resources
Anonymous
February 19, 2005 12:24:51 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

If you don't have anything helpful to offer, you should refain from
cluttering the forum with idle chatter. If someone is asking help here
it's assumed they followed the mfgr's instructions in installing their
particular device. You don't need to tell them to do this, especially
when you have no reason to believe they didn't do it, other than the
mere fact that their installation caused a problem. If you were asking
for help and someone responded the way you did, it would lessen the
urgency of your plea, is that what you would want done to you?
Anonymous
February 20, 2005 9:28:51 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Thanks, AT, but none of these work. I tried them all. The ANHW module I
am dealing with is just prompting for me to point it to the
LXt520xp.gpd file, and it does this every time I boot-up, regardless of
how I respond to it. I have to assume that the file requested was part
of a prior Lexmark driver that Win XP sp2 still asks for, even though
it has been replaced by Lexmark.
Anonymous
February 20, 2005 9:39:20 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Try the latest Windows XP drivers for the printer.

http://downloads.lexmark.com/cgi-perl/downloads.cgi?ccs...

OR

http://www.downloaddelivery.com/srfilecache/T1WNXP5E.ex...

If you printer is working fine except for the ANHW wizard, I suggest you
keep on clicking "Next" in the wizard. Windows XP will prompt that the
drivers are not installed correctly, just click "Finish". The wizard should
not appear on next startup. If you click Cancel on any step of the wizard,
the ANHW will keep coming up.

Let us know if that helps. [and don't get angry if you have already tried
these things ;)  ]



"Tdub" <gripshift5@email.com> wrote in message
news:1108832632.555927.209590@g14g2000cwa.googlegroups.com...
> Wrong, I was on the phone with Lexmark, we did everything the way it
> was supposed to be done, they advised contacting Microsoft, said it was
> a bug in Microsoft XP.
>
Anonymous
February 21, 2005 11:34:22 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I assume the printer is itself working fine. I could not locate the
LXt520xp.gpd file anywhere, so i feel Lexmark support is correct, "there is
no such file". A gpd(Generic Printer Driver) file is a script which defines
print driver properties. Since WinXP is unnecessarily looking for it, I
suggest you follow these three solutions in order:

1. Create a blank text file and rename it "LXt520xp.gpd". You need to have
"Hide extensions for known filetypes" unchecked in folder options. When
Windows asks for the file, simply show it the path to the file you have
created.

2. If the above does not work, uninstall the printer drivers. Now install
the printer driver using Add New Printer Wizard, instead of any Lexmark
installation routines. You may need Lexmark phone support help at this step
to indentify the correct inf file to choose within the add new printer
wizard.

3. Advanced solution. Investigate whether the printer driver's inf file
contains reference to LXt520xp.gpd. You need to completely remove any lines
which references the above file.

The gpd files are required for Microsoft Universal Printer Driver (Unidrv)
support and so you can also contact Microsoft support.



"Tdub" <gripshift5@email.com> wrote in message
news:1108952931.048677.5180@f14g2000cwb.googlegroups.com...
> Thanks, AT, but none of these work. I tried them all. The ANHW module I
> am dealing with is just prompting for me to point it to the
> LXt520xp.gpd file, and it does this every time I boot-up, regardless of
> how I respond to it. I have to assume that the file requested was part
> of a prior Lexmark driver that Win XP sp2 still asks for, even though
> it has been replaced by Lexmark.
>
Anonymous
February 23, 2005 6:18:54 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Thanks, AT. I tried #1 and 2. This did not solve it. Then I looked in
the driver's inf file for references to LXt520xp.gpd. There were none.
When I tried #1, above, it revealed additional information - that it
was also looking for lxopt52x.dll. But this file also was not
referenced in the driver inf file, or located anywhere on my boot
drive. I noticed that on boot up XP tries to create the unidriver print
driver - it adds a driver folder (parallel to the legitimate (and
working) one) by the name of "lexmark_internationa6036" with the
following files in it: STDNAMES.GPD, TTFSUB.GPD, UNIDRV.DLL,
UNIDRV.HLP, UNIDRVUI.DLL, UNIRES.DLL. So it does appear this is an
XP bug, in that it starts the process of creating the unidriver driver,
based on its communication with the Lexmark T520 printer hardware, and
is unable to complete the task, asking for files that Lexmark doesn't
have/support.
Anonymous
January 26, 2009 7:07:51 PM

I have been having a similar problem with a S9000 Canon Printer. The printer driver I downloaded is an exe file which unzips the actual driver files to a Temp file and then runs setup. This works, however, the auto add hardware program would run repeatedly telling me it can't find a file and was not installed properly.

Try this, it worked for me.

You will need the actual driver files (in my case, unzipped from the exe file I downloaded). I put them in a temp folder on my desktop.

1) Unplug printer USB cable
2) Remove the printer from the system by going to printers on the start up menu and select delete this printer,
3) Remove printer program using add/remove programs from control panel.
4) Select add hardware from the control panel. When it can,t find hardware it will ask if hardware is connected? SELECT YES
(even though hardware is not connected). Select next.
5) Computer will show a list of installed devices. Scroll to the bottom of the list and select "Add a new hardware device".
Select next and choose "Install the hardware I manually select from a list". Select next, and choose printers from the
list. Select next and choose a printer port (probably USB001, USB002, etc) depending if you have other USB printers hooked
up to your computer.
6) Select next and computer will show list of printers,
7) Select "Have Disk".
10) Select Browse and find folder where your printer drivers are and install.
11) Plug in printer USB cable and restart computer when install is complete.

Hope this helps.


Mark
Good Luck
March 8, 2010 6:05:31 PM

Ok, this is the easiest way to disable automatic printer installation in Windows XP (Home and Professional). It does require than you already have the printer drivers available either on CD or you hard drive.

1) Remove your printer from the system (delete from control panel/printers) and remove any specific software which may have been installed for the printer using Add/Remove programs).

2) Change folder options to display 'hidden' files.

3) Browse to C:\windows\inf

4) Locate file NTPRINT.INF and open it using Winfows Notebook. (It's just a text file format). This file contains the 'list' of all the printers XP has built in drivers for.

5) Search for your printer name withing NTPRINT.INF

6) Position the cursor at the beginning of the line containing your printer name and enter a semi-colon ';'. This will make XP ignore the line.

7) There may be more than one entry for your printer so search again and if necessary enter a semi-colon at the beginning of the line.

8) Where there are no more incidences of your printer name, save and close NTPRINT.INF

9) Reset folder options to 'hide' hidden files if this is your preference.

10) Now connect your printer and XP will fail to find an automatic installation and will go into the normal 'Found New Hardware' wizard. When prompted, browse to you printer driver (on CD or Hard drive).
The installation will now use the manufacturers drivers and you are set to go!!!

Hope this is of help. You can contact me arglet[at]lineone.net if you have any problems.

Good luck!

Tony Gillett
!