Sign in with
Sign up | Sign in
Your question

Sharp and fuzzy images in MAME32

Last response: in Video Games
Share
Anonymous
March 11, 2005 10:00:48 PM

Archived from groups: alt.games.mame (More info?)

Hi all,

I've been using MAME32 and MAME32Plus on a PC in my MAME cabinet for a while
using an old GeForce1 graphics card. The card's fan is failing however, and
I've been wanting to replace it for a while. I've now got hold of a free ATI
Rage 128 Pro card which I'm using instead.

The new card works fine for MAME but I've noticed a difference which is
slightly spoiling my enjoyment of the emulator. I was hoping someone might
be able to suggest a fix.

On the GeForce card (and also on an ATI Radeon 9800 Pro in another
computer), the picture is slightly blurry when it is displayed. This makes
it look very much more natural when playing (I'm using a standard PC
monitor, not an arcade monitor).

Since switching to the Rage Pro, the picture is absolutely perfectly
sharp -- each pixel is precisely square without the fuzziness that I was
previously experiencing. This makes the game look very blocky and low-res.

To clarify what I'm describing, here are two images:

http://adamdawes.com/private/BoblBoblFuzzy.gif
http://adamdawes.com/private/BoblBoblSharp.gif

The first (fuzzy) is from the 9800 Pro (and looks the same as the GeForce).
The second (sharp) is from the Rage Pro and I find it much less attractive.

I've looked all through the MAME32 settings and also through the Display
Control Panel properties for a way to configure this and have drawn a blank.
Is there anything I can do to make this card or MAME32 itself look like the
Fuzzy image from my other PC?

My thanks in advance for any help,

--

Adam.
www.adamdawes.com
Anonymous
March 12, 2005 1:54:43 AM

Archived from groups: alt.games.mame (More info?)

"Adam Dawes" <nospam@nospam.com> wrote in
news:AVlYd.11261$3A6.10604@newsfe1-gui.ntli.net:

> I've looked all through the MAME32 settings and also through the Display
> Control Panel properties for a way to configure this and have drawn a
> blank. Is there anything I can do to make this card or MAME32 itself
> look like the Fuzzy image from my other PC?

Have you tried Enable Hardware Stretch? When I first tried this, I ended up
with a fuzzy image... but that was not an intended effect at the time. :-)
Anonymous
March 12, 2005 2:16:38 AM

Archived from groups: alt.games.mame (More info?)

Hung N wrote:
> Have you tried Enable Hardware Stretch? When I first tried this, I
> ended up with a fuzzy image... but that was not an intended effect at
> the time. :-)

I have -- I'm using that already to make the image fill the screen
(otherwise I get big borders at the sides).

I assume that it's normally this feature combined with the graphics card
functionality that makes the image fuzzy. Perhaps it's just not something
the Rage Pro is able to do... :-/

--

Adam.
www.adamdawes.com
Related resources
Anonymous
March 12, 2005 2:16:39 AM

Archived from groups: alt.games.mame (More info?)

Adam Dawes wrote:
> Hung N wrote:
>
>>Have you tried Enable Hardware Stretch? When I first tried this, I
>>ended up with a fuzzy image... but that was not an intended effect at
>>the time. :-)
>
>
> I have -- I'm using that already to make the image fill the screen
> (otherwise I get big borders at the sides).
>
> I assume that it's normally this feature combined with the graphics card
> functionality that makes the image fuzzy. Perhaps it's just not something
> the Rage Pro is able to do... :-/

I believe the fuzziness you were seeing is ansiptropic filtering. MAME
leverages Direct3D to do filtering and other effects (like scanlines),
but the hardware has to support it. I'm pretty sure your Rage Pro is
too old to handle this. You should be able to find an older GeForce or
Radeon card for $30 or less that'll support all of the features that
MAME uses.

-D.
March 12, 2005 3:25:48 AM

Archived from groups: alt.games.mame (More info?)

Just remove stretch because it look too blurry. I like sharp image :) 
Anonymous
March 12, 2005 12:41:05 PM

Archived from groups: alt.games.mame (More info?)

Dave Malaguti wrote:
> I believe the fuzziness you were seeing is ansiptropic filtering.
> MAME leverages Direct3D to do filtering and other effects (like
> scanlines), but the hardware has to support it.

I suspect you're right about the anisotropic filtering... But your email got
me thinking. I had the "Use Direct3D" option switched off. Switching it on
gave me some more options to play with, and I found that setting Prescale to
None gave me an effect very close to the one I'm looking for -- quite close
enough that I'm happy to stick with it. :) 

Thanks for your help,

--

Adam.
www.adamdawes.com
Anonymous
March 14, 2005 2:01:39 PM

Archived from groups: alt.games.mame (More info?)

"Adam Dawes" <nospam@nospam.com> wrote in
news:AVlYd.11261$3A6.10604@newsfe1-gui.ntli.net:

> On the GeForce card (and also on an ATI Radeon 9800 Pro in another
> computer), the picture is slightly blurry when it is displayed. This
> makes it look very much more natural when playing (I'm using a
> standard PC monitor, not an arcade monitor).
>
> Since switching to the Rage Pro, the picture is absolutely perfectly
> sharp -- each pixel is precisely square without the fuzziness that I
> was previously experiencing. This makes the game look very blocky and
> low-res.

I had a similar problem, check the following for my solution:

http://tinyurl.com/6yqce

HTH
Wolfram
Anonymous
March 14, 2005 2:01:40 PM

Archived from groups: alt.games.mame (More info?)

Hi Wolfram,

> I had a similar problem, check the following for my solution:
>
> http://tinyurl.com/6yqce

You can also handle game specific changes with a game specific INI file.
For example, you could create ini\marble.ini and put a:

direct3d 0

option in it to override the main mame.ini...

Thanks,

SA Dev
!