K8N Neo2 strange behavior with SATA enable DMA transfers

Archived from groups: alt.comp.periphs.mainboard.msi-microstar (More info?)

K8N Neo2 with Maxtor 6B250S0 250GB SATA drive on SATA3 and Maxtor
6B200S0 200GB SATA drive on SATA4. No RAID. I use SATA3/4 because I
have read that SATA1/2 are not locked with the PCI bus. I do
overclock a bit. :-) I have SATA1/2 disabled in the bios.

The 250GB drive is for my applications, and the 200GB drive is for
holding backups. I use Drive Image 2002 to create image files of my
partitions. To create an image of my main partition, Drive Image
boots to DOS. I noticed that the drive performance under DOS was
slow. After a bit of testing, I discovered that enabling DMA
transfers for SATA fixes the problem. This makes sense, because under
Windows the IDE drivers provide DMA access, but under DOS the hardware
itself needs to provide DMA function. But here is what's strange... I
have to enable DMA for both SATA channels! So even though I am using
only one of the channels, and have the other disabled in the bios, I
have to enable DMA transfers for both channels in order to have good
performance under DOS.

This occurs under both 1.4 and 1.5 bios versions. This isn't a big
problem and appears to be just a bios bug of some sort, but I thought
I would post my findings here in case someone else is getting poor
performance under DOS.

BTW, does anyone know why these options default to disabled in the
bios?
4 answers Last reply
More about neo2 strange behavior sata enable transfers
  1. Archived from groups: alt.comp.periphs.mainboard.msi-microstar (More info?)

    Folk skrev:
    > K8N Neo2 with Maxtor 6B250S0 250GB SATA drive on SATA3 and Maxtor
    > 6B200S0 200GB SATA drive on SATA4. No RAID. I use SATA3/4 because I
    > have read that SATA1/2 are not locked with the PCI bus. I do
    > overclock a bit. :-) I have SATA1/2 disabled in the bios.
    >
    > The 250GB drive is for my applications, and the 200GB drive is for
    > holding backups. I use Drive Image 2002 to create image files of my
    > partitions. To create an image of my main partition, Drive Image
    > boots to DOS. I noticed that the drive performance under DOS was
    > slow. After a bit of testing, I discovered that enabling DMA
    > transfers for SATA fixes the problem. This makes sense, because under
    > Windows the IDE drivers provide DMA access, but under DOS the hardware
    > itself needs to provide DMA function. But here is what's strange... I
    > have to enable DMA for both SATA channels! So even though I am using
    > only one of the channels, and have the other disabled in the bios, I
    > have to enable DMA transfers for both channels in order to have good
    > performance under DOS.
    >
    > This occurs under both 1.4 and 1.5 bios versions. This isn't a big
    > problem and appears to be just a bios bug of some sort, but I thought
    > I would post my findings here in case someone else is getting poor
    > performance under DOS.
    >
    > BTW, does anyone know why these options default to disabled in the
    > bios?
    >
    >
    hi

    i think both devices must have dma enabled for dos to be able to use it! dos will see both
    drives and have to use the same access modes to both whenever you use on or both.

    coco
  2. Archived from groups: alt.comp.periphs.mainboard.msi-microstar (More info?)

    On Sun, 20 Mar 2005 21:51:42 GMT, CoCo <cocotmREMOVEremove@telia.com>
    wrote:

    >Folk skrev:
    >> K8N Neo2 with Maxtor 6B250S0 250GB SATA drive on SATA3 and Maxtor
    >> 6B200S0 200GB SATA drive on SATA4. No RAID. I use SATA3/4 because I
    >> have read that SATA1/2 are not locked with the PCI bus. I do
    >> overclock a bit. :-) I have SATA1/2 disabled in the bios.
    >>
    >> The 250GB drive is for my applications, and the 200GB drive is for
    >> holding backups. I use Drive Image 2002 to create image files of my
    >> partitions. To create an image of my main partition, Drive Image
    >> boots to DOS. I noticed that the drive performance under DOS was
    >> slow. After a bit of testing, I discovered that enabling DMA
    >> transfers for SATA fixes the problem. This makes sense, because under
    >> Windows the IDE drivers provide DMA access, but under DOS the hardware
    >> itself needs to provide DMA function. But here is what's strange... I
    >> have to enable DMA for both SATA channels! So even though I am using
    >> only one of the channels, and have the other disabled in the bios, I
    >> have to enable DMA transfers for both channels in order to have good
    >> performance under DOS.
    >>
    >> This occurs under both 1.4 and 1.5 bios versions. This isn't a big
    >> problem and appears to be just a bios bug of some sort, but I thought
    >> I would post my findings here in case someone else is getting poor
    >> performance under DOS.
    >>
    >> BTW, does anyone know why these options default to disabled in the
    >> bios?
    >>
    >>
    >hi
    >
    >i think both devices must have dma enabled for dos to be able to use it! dos will see both
    >drives and have to use the same access modes to both whenever you use on or both.
    >
    >coco

    You misunderstand. The drives are connected to SATA 3 and 4. SATA 1
    and 2 are disabled in the bios, so DOS or no other OS can see them.
    Yet I have to enable DMA transfers for SATA 1 and 2 (the disabled
    devices) and SATA 3 and 4 before I get DMA transfers on SATA3/4.
  3. Archived from groups: alt.comp.periphs.mainboard.msi-microstar (More info?)

    "Folk" <Folk@folk.com> wrote in message
    news:hc0u315dp4jvucpd36a3k98mlfft6m160d@4ax.com...
    On Sun, 20 Mar 2005 21:51:42 GMT, CoCo <cocotmREMOVEremove@telia.com>
    wrote:

    >Folk skrev:
    >> K8N Neo2 with Maxtor 6B250S0 250GB SATA drive on SATA3 and Maxtor
    >> 6B200S0 200GB SATA drive on SATA4. No RAID. I use SATA3/4 because I
    >> have read that SATA1/2 are not locked with the PCI bus. I do
    >> overclock a bit. :-) I have SATA1/2 disabled in the bios.
    >>
    >> The 250GB drive is for my applications, and the 200GB drive is for
    >> holding backups. I use Drive Image 2002 to create image files of my
    >> partitions. To create an image of my main partition, Drive Image
    >> boots to DOS. I noticed that the drive performance under DOS was
    >> slow. After a bit of testing, I discovered that enabling DMA
    >> transfers for SATA fixes the problem. This makes sense, because under
    >> Windows the IDE drivers provide DMA access, but under DOS the hardware
    >> itself needs to provide DMA function. But here is what's strange... I
    >> have to enable DMA for both SATA channels! So even though I am using
    >> only one of the channels, and have the other disabled in the bios, I
    >> have to enable DMA transfers for both channels in order to have good
    >> performance under DOS.
    >>
    >> This occurs under both 1.4 and 1.5 bios versions. This isn't a big
    >> problem and appears to be just a bios bug of some sort, but I thought
    >> I would post my findings here in case someone else is getting poor
    >> performance under DOS.
    >>
    >> BTW, does anyone know why these options default to disabled in the
    >> bios?
    >>
    >>
    >hi
    >
    >i think both devices must have dma enabled for dos to be able to use it!
    >dos will see both
    >drives and have to use the same access modes to both whenever you use on or
    >both.
    >
    >coco

    You misunderstand. The drives are connected to SATA 3 and 4. SATA 1
    and 2 are disabled in the bios, so DOS or no other OS can see them.
    Yet I have to enable DMA transfers for SATA 1 and 2 (the disabled
    devices) and SATA 3 and 4 before I get DMA transfers on SATA3/4.

    Folk, pmfji but I have the same setup but use SATA 1 2 with 3 4 disabled in
    bios but get 1 2 DMA. Have you at least tried this to see if it works?

    Beemer
  4. Archived from groups: alt.comp.periphs.mainboard.msi-microstar (More info?)

    On Tue, 22 Mar 2005 13:23:13 GMT, "Beemer" <Beemer@nowhere.com> wrote:

    >"Folk" <Folk@folk.com> wrote in message
    >news:hc0u315dp4jvucpd36a3k98mlfft6m160d@4ax.com...
    >On Sun, 20 Mar 2005 21:51:42 GMT, CoCo <cocotmREMOVEremove@telia.com>
    >wrote:
    >
    >>Folk skrev:
    >>> K8N Neo2 with Maxtor 6B250S0 250GB SATA drive on SATA3 and Maxtor
    >>> 6B200S0 200GB SATA drive on SATA4. No RAID. I use SATA3/4 because I
    >>> have read that SATA1/2 are not locked with the PCI bus. I do
    >>> overclock a bit. :-) I have SATA1/2 disabled in the bios.
    >>>
    >>> The 250GB drive is for my applications, and the 200GB drive is for
    >>> holding backups. I use Drive Image 2002 to create image files of my
    >>> partitions. To create an image of my main partition, Drive Image
    >>> boots to DOS. I noticed that the drive performance under DOS was
    >>> slow. After a bit of testing, I discovered that enabling DMA
    >>> transfers for SATA fixes the problem. This makes sense, because under
    >>> Windows the IDE drivers provide DMA access, but under DOS the hardware
    >>> itself needs to provide DMA function. But here is what's strange... I
    >>> have to enable DMA for both SATA channels! So even though I am using
    >>> only one of the channels, and have the other disabled in the bios, I
    >>> have to enable DMA transfers for both channels in order to have good
    >>> performance under DOS.
    >>>
    >>> This occurs under both 1.4 and 1.5 bios versions. This isn't a big
    >>> problem and appears to be just a bios bug of some sort, but I thought
    >>> I would post my findings here in case someone else is getting poor
    >>> performance under DOS.
    >>>
    >>> BTW, does anyone know why these options default to disabled in the
    >>> bios?
    >>>
    >>>
    >>hi
    >>
    >>i think both devices must have dma enabled for dos to be able to use it!
    >>dos will see both
    >>drives and have to use the same access modes to both whenever you use on or
    >>both.
    >>
    >>coco
    >
    >You misunderstand. The drives are connected to SATA 3 and 4. SATA 1
    >and 2 are disabled in the bios, so DOS or no other OS can see them.
    >Yet I have to enable DMA transfers for SATA 1 and 2 (the disabled
    >devices) and SATA 3 and 4 before I get DMA transfers on SATA3/4.
    >
    >Folk, pmfji but I have the same setup but use SATA 1 2 with 3 4 disabled in
    >bios but get 1 2 DMA. Have you at least tried this to see if it works?
    >
    >Beemer

    Do you have DMA enabled for both 1/2 *and* 3/4, or only 1/2?

    Keep in mind that this is not some insurmountable problem. I was able
    to achieve DMA transfers under DOS, but only by enabling DMA for
    *both* 1/2 and 3/4 channels. This seemed odd to me since I had to
    enable DMA transfers for a channel that I have disabled in the bios.
    I'm sure it's just some sort of minor bios bug, but I thought I would
    post my findings in case someone else had the same setup and was
    experiencing problems getting DMA speeds under DOS.

    It wouldn't surprise me if attaching the drives to 1/2 and enabling
    DMA for only 1/2 works. I figure the board designers assumed people
    would attach drives to the lower numbered channels first. I would
    too, except for reading in multiple places on the web that channels
    1/2 are not PCI locked, so using them could cause problems during
    overclocking. Does anyone know for sure if this is actually true, or
    is it just one of those OC forum rumors?
Ask a new question

Read More

MSI-Microstar SATA Motherboards