Sign in with
Sign up | Sign in
Your question

HyperThreading problem ...

Last response: in Windows XP
Share
Anonymous
March 18, 2005 8:55:01 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hi,

I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task Manager
with this hardware configuration. But it is not.
The processor is recognized correctly by Sandra 2005 SR1, but it shows :
Warning W234 - You are using a Hyper-Threaded system on an Operating System
that either does not support HT or does not support the total number of
logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
You may as well disable it.
Fix: Make sure you are using the right Hyper-Threading kernel or update your
Operating System for HT support (use Windows XP/2003 or later). Do note that
some Operating Systems and software have licensing limits that may prevent
you from using all CPUs or you may be in violation of your licence.

I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
And how can I enable HyperThreading if it is already enable in BIOS ?

More about : hyperthreading problem

Anonymous
March 18, 2005 10:56:23 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

"Thierry" <Thierry@discussions.microsoft.com> wrote in message
news:8E006269-99A8-4146-BF5B-72E510AF7BEE@microsoft.com...
> Hi,
>
> I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
> Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task
Manager
> with this hardware configuration. But it is not.
> The processor is recognized correctly by Sandra 2005 SR1, but it shows :
> Warning W234 - You are using a Hyper-Threaded system on an Operating
System
> that either does not support HT or does not support the total number of
> logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
> You may as well disable it.
> Fix: Make sure you are using the right Hyper-Threading kernel or update
your
> Operating System for HT support (use Windows XP/2003 or later). Do note
that
> some Operating Systems and software have licensing limits that may prevent
> you from using all CPUs or you may be in violation of your licence.
>
> I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
> And how can I enable HyperThreading if it is already enable in BIOS ?

Did you install clean with this exact system?

If you didn't, HT support was NOT installed.
Anonymous
March 19, 2005 1:08:06 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

At a guess, you don't have the correct HAL (hardware abstraction layer)
installed.

In Device Manager, click on Computer. Double-click on the entry that
appears. Update the driver.

http://support.microsoft.com/default.aspx?scid=kb;en-us;309283#kb2

"HAL Options After Windows XP or Windows Server 2003 Setup"

I'd verify the correct HAL, but I'm running an Athlon64 machine (no
hyperthreading). If memory serves, you probably want the ACPI Multprocessor
version. (That's available even on XP Home, for a single physical CPU.)

Address scrambled. Replace nkbob with bobkn.

"Thierry" <Thierry@discussions.microsoft.com> wrote in message
news:8E006269-99A8-4146-BF5B-72E510AF7BEE@microsoft.com...
> Hi,
>
> I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
> Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task
> Manager
> with this hardware configuration. But it is not.
> The processor is recognized correctly by Sandra 2005 SR1, but it shows :
> Warning W234 - You are using a Hyper-Threaded system on an Operating
> System
> that either does not support HT or does not support the total number of
> logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
> You may as well disable it.
> Fix: Make sure you are using the right Hyper-Threading kernel or update
> your
> Operating System for HT support (use Windows XP/2003 or later). Do note
> that
> some Operating Systems and software have licensing limits that may prevent
> you from using all CPUs or you may be in violation of your licence.
>
> I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
> And how can I enable HyperThreading if it is already enable in BIOS ?
Related resources
Anonymous
March 19, 2005 1:08:07 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

The device manager displays :
[-]Computer
- Advanced Configuration and Power Interface (ACPI) PC

Hum, seems that there is nothing else, no mention of multiprocessing, the
link you provide me is not very optimistic as well, it seems that I must
re-install XP and force another HAL manually, strange ...

"Bob Knowlden" wrote:

> At a guess, you don't have the correct HAL (hardware abstraction layer)
> installed.
>
> In Device Manager, click on Computer. Double-click on the entry that
> appears. Update the driver.
>
> http://support.microsoft.com/default.aspx?scid=kb;en-us;309283#kb2
>
> "HAL Options After Windows XP or Windows Server 2003 Setup"
>
> I'd verify the correct HAL, but I'm running an Athlon64 machine (no
> hyperthreading). If memory serves, you probably want the ACPI Multprocessor
> version. (That's available even on XP Home, for a single physical CPU.)
>
> Address scrambled. Replace nkbob with bobkn.
>
> "Thierry" <Thierry@discussions.microsoft.com> wrote in message
> news:8E006269-99A8-4146-BF5B-72E510AF7BEE@microsoft.com...
> > Hi,
> >
> > I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
> > Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task
> > Manager
> > with this hardware configuration. But it is not.
> > The processor is recognized correctly by Sandra 2005 SR1, but it shows :
> > Warning W234 - You are using a Hyper-Threaded system on an Operating
> > System
> > that either does not support HT or does not support the total number of
> > logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
> > You may as well disable it.
> > Fix: Make sure you are using the right Hyper-Threading kernel or update
> > your
> > Operating System for HT support (use Windows XP/2003 or later). Do note
> > that
> > some Operating Systems and software have licensing limits that may prevent
> > you from using all CPUs or you may be in violation of your licence.
> >
> > I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
> > And how can I enable HyperThreading if it is already enable in BIOS ?
>
>
>
Anonymous
March 19, 2005 1:12:29 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Thierry wrote:
| Hi,
|
| I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
| Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task
| Manager with this hardware configuration. But it is not.
| The processor is recognized correctly by Sandra 2005 SR1, but it
| shows : Warning W234 - You are using a Hyper-Threaded system on an
| Operating System that either does not support HT or does not support
| the total number of logical CPUs of the system. Thus Hyper-Threading
| is not properly utilised. You may as well disable it.
| Fix: Make sure you are using the right Hyper-Threading kernel or
| update your Operating System for HT support (use Windows XP/2003 or
| later). Do note that some Operating Systems and software have
| licensing limits that may prevent you from using all CPUs or you may
| be in violation of your licence.
|
| I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
| And how can I enable HyperThreading if it is already enable in BIOS ?

Just a shot in the dark...

Windows Task Manager >> Performance >> View >> CPU History
One graph per CPU.
Anonymous
March 19, 2005 7:55:57 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Do you know who and when installed XP on your machine?
Can it be that HT was initially off and enabled only after XP was installed?
--PA

"Thierry" <Thierry@discussions.microsoft.com> wrote in message news:8E006269-99A8-4146-BF5B-72E510AF7BEE@microsoft.com...
> Hi,
>
> I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
> Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task Manager
> with this hardware configuration. But it is not.
> The processor is recognized correctly by Sandra 2005 SR1, but it shows :
> Warning W234 - You are using a Hyper-Threaded system on an Operating System
> that either does not support HT or does not support the total number of
> logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
> You may as well disable it.
> Fix: Make sure you are using the right Hyper-Threading kernel or update your
> Operating System for HT support (use Windows XP/2003 or later). Do note that
> some Operating Systems and software have licensing limits that may prevent
> you from using all CPUs or you may be in violation of your licence.
>
> I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
> And how can I enable HyperThreading if it is already enable in BIOS ?
Anonymous
March 19, 2005 7:55:58 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Well I have installed XP myself, and previously it was on another P4C, but
I've never check task manager behavior until now. So I will ghost my drive
and try to install a clean version ...
But, maybe HT was disabled before the first install, but it's strange
because it is enabled by default on BIOS anyway ...

"Pavel A." wrote:

> Do you know who and when installed XP on your machine?
> Can it be that HT was initially off and enabled only after XP was installed?
> --PA
>
> "Thierry" <Thierry@discussions.microsoft.com> wrote in message news:8E006269-99A8-4146-BF5B-72E510AF7BEE@microsoft.com...
> > Hi,
> >
> > I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
> > Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task Manager
> > with this hardware configuration. But it is not.
> > The processor is recognized correctly by Sandra 2005 SR1, but it shows :
> > Warning W234 - You are using a Hyper-Threaded system on an Operating System
> > that either does not support HT or does not support the total number of
> > logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
> > You may as well disable it.
> > Fix: Make sure you are using the right Hyper-Threading kernel or update your
> > Operating System for HT support (use Windows XP/2003 or later). Do note that
> > some Operating Systems and software have licensing limits that may prevent
> > you from using all CPUs or you may be in violation of your licence.
> >
> > I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
> > And how can I enable HyperThreading if it is already enable in BIOS ?
>
>
>
Anonymous
March 19, 2005 11:51:44 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

No fixes here but just recently changed out the P4P800Dlx board on my system
and went 64bit AMD. During the year + that I used the intel board and a
2.4c running at 2.8MHz (memory issue) installed XP several times. At no
point did it ever not show as a Multiprocessor system in Device Manager.
This was also true with W2K as I had it installed as a back-up system on a
seperate drive.

The only thing I can think of is that you are running an older BIOS on your
MB which doesn't properly detect a 3.4C CPU. Obviously the P4P800Dlx came
out well before the 3.4c and it may have an an issue with this CPU and
Hyperthreading. Only a wild guess as HT is on by default even after a BIOS
flash and can see no reason it would have been changed except by human
intervention.

If you got the CPU from someone who is a gamer it was reported that certain
games did not do well under HT and some people disabled it for better game
play. If this was always your system then the chances of that happening are
nil.

Anyway, good luck, the P4P800 Dlx is a great board!

Len

"Thierry" <Thierry@discussions.microsoft.com> wrote in message
news:8E006269-99A8-4146-BF5B-72E510AF7BEE@microsoft.com...
> Hi,
>
> I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
> Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task
> Manager
> with this hardware configuration. But it is not.
> The processor is recognized correctly by Sandra 2005 SR1, but it shows :
> Warning W234 - You are using a Hyper-Threaded system on an Operating
> System
> that either does not support HT or does not support the total number of
> logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
> You may as well disable it.
> Fix: Make sure you are using the right Hyper-Threading kernel or update
> your
> Operating System for HT support (use Windows XP/2003 or later). Do note
> that
> some Operating Systems and software have licensing limits that may prevent
> you from using all CPUs or you may be in violation of your licence.
>
> I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
> And how can I enable HyperThreading if it is already enable in BIOS ?
Anonymous
March 19, 2005 7:07:42 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

On Fri, 18 Mar 2005 17:55:01 -0800, Thierry wrote:
>
> Hi,
>
> I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
> Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task Manager
> with this hardware configuration. But it is not.
> The processor is recognized correctly by Sandra 2005 SR1, but it shows :
> Warning W234 - You are using a Hyper-Threaded system on an Operating System
> that either does not support HT or does not support the total number of
> logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
> You may as well disable it.
> Fix: Make sure you are using the right Hyper-Threading kernel or update your
> Operating System for HT support (use Windows XP/2003 or later). Do note that
> some Operating Systems and software have licensing limits that may prevent
> you from using all CPUs or you may be in violation of your licence.
>
> I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
> And how can I enable HyperThreading if it is already enable in BIOS ?

If the CPU was a HT CPU when XP Pro was installed, it would have detected
the HT CPU, if it was an upgrade to a HT CPU, then you will have to
install the correct ACPI Multi-CPU driver.

--
spam999free@rrohio.com
remove 999 in order to email me
Anonymous
March 19, 2005 11:13:02 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I have the latest offcial BIOS (1019) and I've already tried the latest 1021
beta 2, but no differnece. But I've noticed something in my XP Pro CD (doing
F5 while installing), I cannot change/force the ACPI driver manually, there
is only "Standard PC" or "Other" available ... "Other" need a third party
driver I don't have. As imy CD came from MSDN subscribers download, is it
possible that there are limitations on these releases ?
Maybe I could try to download the Windows 2003 server and try it instead to
be sure ...

"Len Mattix" wrote:

> No fixes here but just recently changed out the P4P800Dlx board on my system
> and went 64bit AMD. During the year + that I used the intel board and a
> 2.4c running at 2.8MHz (memory issue) installed XP several times. At no
> point did it ever not show as a Multiprocessor system in Device Manager.
> This was also true with W2K as I had it installed as a back-up system on a
> seperate drive.
>
> The only thing I can think of is that you are running an older BIOS on your
> MB which doesn't properly detect a 3.4C CPU. Obviously the P4P800Dlx came
> out well before the 3.4c and it may have an an issue with this CPU and
> Hyperthreading. Only a wild guess as HT is on by default even after a BIOS
> flash and can see no reason it would have been changed except by human
> intervention.
>
> If you got the CPU from someone who is a gamer it was reported that certain
> games did not do well under HT and some people disabled it for better game
> play. If this was always your system then the chances of that happening are
> nil.
>
> Anyway, good luck, the P4P800 Dlx is a great board!
>
> Len
>
> "Thierry" <Thierry@discussions.microsoft.com> wrote in message
> news:8E006269-99A8-4146-BF5B-72E510AF7BEE@microsoft.com...
> > Hi,
> >
> > I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
> > Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task
> > Manager
> > with this hardware configuration. But it is not.
> > The processor is recognized correctly by Sandra 2005 SR1, but it shows :
> > Warning W234 - You are using a Hyper-Threaded system on an Operating
> > System
> > that either does not support HT or does not support the total number of
> > logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
> > You may as well disable it.
> > Fix: Make sure you are using the right Hyper-Threading kernel or update
> > your
> > Operating System for HT support (use Windows XP/2003 or later). Do note
> > that
> > some Operating Systems and software have licensing limits that may prevent
> > you from using all CPUs or you may be in violation of your licence.
> >
> > I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
> > And how can I enable HyperThreading if it is already enable in BIOS ?
>
>
>
Anonymous
March 20, 2005 6:30:23 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

On Sat, 19 Mar 2005 20:13:02 -0800, Thierry wrote:
>
> I have the latest offcial BIOS (1019) and I've already tried the latest 1021
> beta 2, but no differnece. But I've noticed something in my XP Pro CD (doing
> F5 while installing), I cannot change/force the ACPI driver manually, there
> is only "Standard PC" or "Other" available ... "Other" need a third party
> driver I don't have. As imy CD came from MSDN subscribers download, is it
> possible that there are limitations on these releases ?
> Maybe I could try to download the Windows 2003 server and try it instead to
> be sure ...

The only time I've seen it not have the Multi-CPU driver is when the user
was running Win XP Home edition - are you sure you're not using Home? Home
does not support 2 CPU's.


--
spam999free@rrohio.com
remove 999 in order to email me
Anonymous
March 20, 2005 6:30:24 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I've dowloaded the Windows XP Professional with SP2, I will try with the
no-SP2 version.
I've made a clean install of Windows 2003 Server and I have the good options
and the CPU HT is correctly installed, so there is a problem with XP Pro only.

And XP Home Edition should support HT as well (only limited to only 1
physical CPU not limited in logical CPUs).

"Leythos" wrote:

> On Sat, 19 Mar 2005 20:13:02 -0800, Thierry wrote:
> >
> > I have the latest offcial BIOS (1019) and I've already tried the latest 1021
> > beta 2, but no differnece. But I've noticed something in my XP Pro CD (doing
> > F5 while installing), I cannot change/force the ACPI driver manually, there
> > is only "Standard PC" or "Other" available ... "Other" need a third party
> > driver I don't have. As imy CD came from MSDN subscribers download, is it
> > possible that there are limitations on these releases ?
> > Maybe I could try to download the Windows 2003 server and try it instead to
> > be sure ...
>
> The only time I've seen it not have the Multi-CPU driver is when the user
> was running Win XP Home edition - are you sure you're not using Home? Home
> does not support 2 CPU's.
>
>
> --
> spam999free@rrohio.com
> remove 999 in order to email me
>
>
Anonymous
March 20, 2005 7:59:29 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

On Sun, 20 Mar 2005 08:09:02 -0800, Thierry wrote:
>
> I've dowloaded the Windows XP Professional with SP2, I will try with the
> no-SP2 version.

My versions of XP Prof with SP2 and without SP2 worked fine, even the MSDN
ISO Images.

> I've made a clean install of Windows 2003 Server and I have the good
> options and the CPU HT is correctly installed, so there is a problem
> with XP Pro only.

I would suspect that it's not a XP Pro/SP2 issue, that it's the way it was
installed if 2003 detects it properly.

> And XP Home Edition should support HT as well (only limited to only 1
> physical CPU not limited in logical CPUs).

I understand the difference between physical/logical and the MS website
for what Home supports seems to indicate that it does not support the
second virtual CPU in a HT computer.


> "Leythos" wrote:
>
>> On Sat, 19 Mar 2005 20:13:02 -0800, Thierry wrote:
>> >
>> > I have the latest offcial BIOS (1019) and I've already tried the
>> > latest 1021 beta 2, but no differnece. But I've noticed something in
>> > my XP Pro CD (doing F5 while installing), I cannot change/force the
>> > ACPI driver manually, there is only "Standard PC" or "Other"
>> > available ... "Other" need a third party driver I don't have. As imy
>> > CD came from MSDN subscribers download, is it possible that there are
>> > limitations on these releases ? Maybe I could try to download the
>> > Windows 2003 server and try it instead to be sure ...
>>
>> The only time I've seen it not have the Multi-CPU driver is when the
>> user was running Win XP Home edition - are you sure you're not using
>> Home? Home does not support 2 CPU's.


--
spam999free@rrohio.com
remove 999 in order to email me
March 20, 2005 9:14:20 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hi,

Just trying to help,

If I remember correctly, there is a setting in the BIOS for enable or
disable HT - it might be at the CPU setting section.

Did you go there and check if the BIOS level setting has been turned on?

Hope this helps.


"Thierry" <Thierry@discussions.microsoft.com> ¼¶¼g©ó¶l¥ó·s»D:8E006269-99A8-4146-BF5B-72E510AF7BEE@microsoft.com...
> Hi,
>
> I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
> Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task
> Manager
> with this hardware configuration. But it is not.
> The processor is recognized correctly by Sandra 2005 SR1, but it shows :
> Warning W234 - You are using a Hyper-Threaded system on an Operating
> System
> that either does not support HT or does not support the total number of
> logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
> You may as well disable it.
> Fix: Make sure you are using the right Hyper-Threading kernel or update
> your
> Operating System for HT support (use Windows XP/2003 or later). Do note
> that
> some Operating Systems and software have licensing limits that may prevent
> you from using all CPUs or you may be in violation of your licence.
>
> I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
> And how can I enable HyperThreading if it is already enable in BIOS ?
Anonymous
March 20, 2005 9:14:21 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Yes I know, it is set at ON, so maybe there is something else I don't know,
but thanks anyway.

"xfile" wrote:

> Hi,
>
> Just trying to help,
>
> If I remember correctly, there is a setting in the BIOS for enable or
> disable HT - it might be at the CPU setting section.
>
> Did you go there and check if the BIOS level setting has been turned on?
>
> Hope this helps.
>
>
> "Thierry" <Thierry@discussions.microsoft.com> ¼¶¼g©ó¶l¥ó·s»D:8E006269-99A8-4146-BF5B-72E510AF7BEE@microsoft.com...
> > Hi,
> >
> > I have an Intel 4C 3.4Ghz with an Asus P4P800 Deluxe motherboard.
> > Windows XP is supposed to display two graphs (CPU0 and CPU1) in Task
> > Manager
> > with this hardware configuration. But it is not.
> > The processor is recognized correctly by Sandra 2005 SR1, but it shows :
> > Warning W234 - You are using a Hyper-Threaded system on an Operating
> > System
> > that either does not support HT or does not support the total number of
> > logical CPUs of the system. Thus Hyper-Threading is not properly utilised.
> > You may as well disable it.
> > Fix: Make sure you are using the right Hyper-Threading kernel or update
> > your
> > Operating System for HT support (use Windows XP/2003 or later). Do note
> > that
> > some Operating Systems and software have licensing limits that may prevent
> > you from using all CPUs or you may be in violation of your licence.
> >
> > I have a licensed Windows XP Pro SP2 (from MSDN as I'm subscriber).
> > And how can I enable HyperThreading if it is already enable in BIOS ?
>
>
>
Anonymous
March 20, 2005 11:07:04 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Well I have installed both the same way ...
Under Windows Server installation when I press F5, I can choose the HAL I
want, under Windows XP Pro, F5 displayed only two choices:
-Standard PC with C-Step i486 (not sure of the exact terms)
-Other

So I cannot choose ACPI multiprocessors like under Windows Server 2003.

Do you have more options when you boot the installation CD of Windows XP Pro
(pressing F5 instead of F6) ?

"Leythos" wrote:

> On Sun, 20 Mar 2005 08:09:02 -0800, Thierry wrote:
> >
> > I've dowloaded the Windows XP Professional with SP2, I will try with the
> > no-SP2 version.
>
> My versions of XP Prof with SP2 and without SP2 worked fine, even the MSDN
> ISO Images.
>
> > I've made a clean install of Windows 2003 Server and I have the good
> > options and the CPU HT is correctly installed, so there is a problem
> > with XP Pro only.
>
> I would suspect that it's not a XP Pro/SP2 issue, that it's the way it was
> installed if 2003 detects it properly.
>
> > And XP Home Edition should support HT as well (only limited to only 1
> > physical CPU not limited in logical CPUs).
>
> I understand the difference between physical/logical and the MS website
> for what Home supports seems to indicate that it does not support the
> second virtual CPU in a HT computer.
>
>
Anonymous
March 21, 2005 1:49:06 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

On Sun, 20 Mar 2005 20:07:04 -0800, Thierry wrote:
>
> Well I have installed both the same way ...
> Under Windows Server installation when I press F5, I can choose the HAL I
> want, under Windows XP Pro, F5 displayed only two choices:
> -Standard PC with C-Step i486 (not sure of the exact terms)
> -Other
>
> So I cannot choose ACPI multiprocessors like under Windows Server 2003.
>
> Do you have more options when you boot the installation CD of Windows XP Pro
> (pressing F5 instead of F6) ?

I don't know, I've never pressed F5 during any install, ever. I've always
found that Windows 2000 Server/Prof, XP Prof, and 2003 have detected the
correct number of CPU's when doing the initial install. I'm going to
install XP Prof SP2 today, will post back what I see.


--
spam999free@rrohio.com
remove 999 in order to email me
Anonymous
March 21, 2005 1:49:07 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Great, let me know, thanks.

"Leythos" wrote:

> On Sun, 20 Mar 2005 20:07:04 -0800, Thierry wrote:
> >
> > Well I have installed both the same way ...
> > Under Windows Server installation when I press F5, I can choose the HAL I
> > want, under Windows XP Pro, F5 displayed only two choices:
> > -Standard PC with C-Step i486 (not sure of the exact terms)
> > -Other
> >
> > So I cannot choose ACPI multiprocessors like under Windows Server 2003.
> >
> > Do you have more options when you boot the installation CD of Windows XP Pro
> > (pressing F5 instead of F6) ?
>
> I don't know, I've never pressed F5 during any install, ever. I've always
> found that Windows 2000 Server/Prof, XP Prof, and 2003 have detected the
> correct number of CPU's when doing the initial install. I'm going to
> install XP Prof SP2 today, will post back what I see.
>
>
> --
> spam999free@rrohio.com
> remove 999 in order to email me
>
>
Anonymous
March 21, 2005 1:49:07 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Take a look at this :
http://board.iexbeta.com/index.php?s=d8a5668cf9ad39cd38...
I'm pretty disapointed, but I will try this, just have to scroll up into the
list as the items are not centered in the list and just displayed the last
two ...
I'll let you know if this solves my problem ...

"Leythos" wrote:

> On Sun, 20 Mar 2005 20:07:04 -0800, Thierry wrote:
> >
> > Well I have installed both the same way ...
> > Under Windows Server installation when I press F5, I can choose the HAL I
> > want, under Windows XP Pro, F5 displayed only two choices:
> > -Standard PC with C-Step i486 (not sure of the exact terms)
> > -Other
> >
> > So I cannot choose ACPI multiprocessors like under Windows Server 2003.
> >
> > Do you have more options when you boot the installation CD of Windows XP Pro
> > (pressing F5 instead of F6) ?
>
> I don't know, I've never pressed F5 during any install, ever. I've always
> found that Windows 2000 Server/Prof, XP Prof, and 2003 have detected the
> correct number of CPU's when doing the initial install. I'm going to
> install XP Prof SP2 today, will post back what I see.
>
>
> --
> spam999free@rrohio.com
> remove 999 in order to email me
>
>
Anonymous
March 21, 2005 1:49:07 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I've tried, and that's true, the list only displays the two last HAL and I
have to use the arrow key to go up to the ACPI multiprocessor .... crazy but
true, so my problem is solved ....

"Leythos" wrote:

> On Sun, 20 Mar 2005 20:07:04 -0800, Thierry wrote:
> >
> > Well I have installed both the same way ...
> > Under Windows Server installation when I press F5, I can choose the HAL I
> > want, under Windows XP Pro, F5 displayed only two choices:
> > -Standard PC with C-Step i486 (not sure of the exact terms)
> > -Other
> >
> > So I cannot choose ACPI multiprocessors like under Windows Server 2003.
> >
> > Do you have more options when you boot the installation CD of Windows XP Pro
> > (pressing F5 instead of F6) ?
>
> I don't know, I've never pressed F5 during any install, ever. I've always
> found that Windows 2000 Server/Prof, XP Prof, and 2003 have detected the
> correct number of CPU's when doing the initial install. I'm going to
> install XP Prof SP2 today, will post back what I see.
>
>
> --
> spam999free@rrohio.com
> remove 999 in order to email me
>
>
Anonymous
March 21, 2005 11:29:22 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

On Mon, 21 Mar 2005 10:19:03 -0800, Thierry wrote:
>
> I've tried, and that's true, the list only displays the two last HAL and I
> have to use the arrow key to go up to the ACPI multiprocessor .... crazy but
> true, so my problem is solved ....

So, you're saying that after installing the "ACPI Multi" that you now can
see all processors?



--
spam999free@rrohio.com
remove 999 in order to email me
Anonymous
March 21, 2005 11:29:23 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

No, what I said is that the installation CD is buggy. The list that display
the HAL options (when pressing F5 instead of F6 on a clean install from CD)
only displays the last two choices (only two lines in the list box):
Standard PC with C-Step i486
-Other
Compared to Windows Server 2003 that displays the whole list in one box. So
when the list is displayed during the Windows XP Pro installation, I must
scroll up using the arrow keys to select what is hidden. So I can install
Windows XP Pro now with ACPI multiprocessor instead of ACPI uniprocessor.

"Leythos" wrote:

> On Mon, 21 Mar 2005 10:19:03 -0800, Thierry wrote:
> >
> > I've tried, and that's true, the list only displays the two last HAL and I
> > have to use the arrow key to go up to the ACPI multiprocessor .... crazy but
> > true, so my problem is solved ....
>
> So, you're saying that after installing the "ACPI Multi" that you now can
> see all processors?
>
>
>
> --
> spam999free@rrohio.com
> remove 999 in order to email me
>
>
Anonymous
March 21, 2005 11:29:23 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

And yes I can see the two processors now after installing ACPI
multiprocessors HAL.

"Leythos" wrote:

> On Mon, 21 Mar 2005 10:19:03 -0800, Thierry wrote:
> >
> > I've tried, and that's true, the list only displays the two last HAL and I
> > have to use the arrow key to go up to the ACPI multiprocessor .... crazy but
> > true, so my problem is solved ....
>
> So, you're saying that after installing the "ACPI Multi" that you now can
> see all processors?
>
>
>
> --
> spam999free@rrohio.com
> remove 999 in order to email me
>
>
Anonymous
March 22, 2005 2:38:00 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

On Mon, 21 Mar 2005 15:37:02 -0800, Thierry wrote:
>
> And yes I can see the two processors now after installing ACPI
> multiprocessors HAL.

Great - glad we could help.


> "Leythos" wrote:
>
>> On Mon, 21 Mar 2005 10:19:03 -0800, Thierry wrote:
>> >
>> > I've tried, and that's true, the list only displays the two last HAL and I
>> > have to use the arrow key to go up to the ACPI multiprocessor .... crazy but
>> > true, so my problem is solved ....
>>
>> So, you're saying that after installing the "ACPI Multi" that you now can
>> see all processors?
>>
>>
>>
>> --
>> spam999free@rrohio.com
>> remove 999 in order to email me
>>
>>


--
spam999free@rrohio.com
remove 999 in order to email me
!