USB Drives

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I'm upgrading my department from Windows 2000 to Windows XP. One problem
In the upgrade I can not solve is that now users can not install/use USB
pen drives without an administrator install the device.

We have our users set to be Power Users and prefer not making them local
administrators. This was never a problem under Windows 2000, Power User
were able to use USB drives without the help of an administrator.

Any ideas, any policy I could set?

Thanks,
Mike
11 answers Last reply
More about drives
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    hi ,

    it seems that you dont want usb storage/pen drives to be used in your system

    here is the solution

    open c:\windows\inf

    search for usbstor.inf and usbstor.pnf

    right click each file and select the security tab and deny access to all
    other than administrator

    hope this solves your problem
    regards
    senthil
  2. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    I want Users (or people listed as Power Users) to be able to
    install/use USB drives.

    Mike

    On Wed, 23 Mar 2005 11:17:01 -0800, senthil kumar wrote:


    > hi ,
    >
    > it seems that you dont want usb storage/pen drives to be used in your
    > system
    >
    > here is the solution
    >
    > open c:\windows\inf
    >
    > search for usbstor.inf and usbstor.pnf
    >
    > right click each file and select the security tab and deny access to all
    > other than administrator
    >
    > hope this solves your problem
    > regards
    > senthil
  3. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    hi ,

    then add the power user group and users you want to exclude and give them
    full access

    regards
    senthil
  4. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Hi,

    Try this way:

    Go to Control Panel/Administrative Tools/Local Security Policy
    In the left pane, double click the Local Policy Folder, click Security Options
    In the right pane, Select Devices: Allowed to format and eject removable
    media,
    under the security setting, right click on the Administrators, click
    Properties, select Adminstrator and Power Users, click Apply and OK.
    Reboot the PC and check to ensure it works.

    BTW, take care as any one can now just plug in the USB drive and download
    data files. It is a security leakage.

    Peter


    "Mike Basinger" wrote:

    > I want Users (or people listed as Power Users) to be able to
    > install/use USB drives.
    >
    > Mike
    >
    > On Wed, 23 Mar 2005 11:17:01 -0800, senthil kumar wrote:
    >
    >
    > > hi ,
    > >
    > > it seems that you dont want usb storage/pen drives to be used in your
    > > system
    > >
    > > here is the solution
    > >
    > > open c:\windows\inf
    > >
    > > search for usbstor.inf and usbstor.pnf
    > >
    > > right click each file and select the security tab and deny access to all
    > > other than administrator
    > >
    > > hope this solves your problem
    > > regards
    > > senthil
    >
  5. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "Mike Basinger" wrote:

    > I'm upgrading my department from Windows 2000 to Windows XP. One problem
    > In the upgrade I can not solve is that now users can not install/use USB
    > pen drives without an administrator install the device.
    >
    > We have our users set to be Power Users and prefer not making them local
    > administrators. This was never a problem under Windows 2000, Power User
    > were able to use USB drives without the help of an administrator.
    >
    > Any ideas, any policy I could set?
    >
    > Thanks,
    > Mike
    >
  6. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "senthil kumar" wrote:

    >
    > hi ,
    >
    > then add the power user group and users you want to exclude and give them
    > full access
    >
    > regards
    > senthil
  7. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "Mike Basinger" wrote:

    > I want Users (or people listed as Power Users) to be able to
    > install/use USB drives.
    >
    > Mike
    >
    > On Wed, 23 Mar 2005 11:17:01 -0800, senthil kumar wrote:
    >
    >
    > > hi ,
    > >
    > > it seems that you dont want usb storage/pen drives to be used in your
    > > system
    > >
    > > here is the solution
    > >
    > > open c:\windows\inf
    > >
    > > search for usbstor.inf and usbstor.pnf
    > >
    > > right click each file and select the security tab and deny access to all
    > > other than administrator
    > >
    > > hope this solves your problem
    > > regards
    > > senthil
    >
  8. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "Peter" wrote:

    > Hi,
    >
    > Try this way:
    >
    > Go to Control Panel/Administrative Tools/Local Security Policy
    > In the left pane, double click the Local Policy Folder, click Security Options
    > In the right pane, Select Devices: Allowed to format and eject removable
    > media,
    > under the security setting, right click on the Administrators, click
    > Properties, select Adminstrator and Power Users, click Apply and OK.
    > Reboot the PC and check to ensure it works.
    >
    > BTW, take care as any one can now just plug in the USB drive and download
    > data files. It is a security leakage.
    >
    > Peter
    >
    >
    >
    > "Mike Basinger" wrote:
    >
    > > I want Users (or people listed as Power Users) to be able to
    > > install/use USB drives.
    > >
    > > Mike
    > >
    > > On Wed, 23 Mar 2005 11:17:01 -0800, senthil kumar wrote:
    > >
    > >
    > > > hi ,
    > > >
    > > > it seems that you dont want usb storage/pen drives to be used in your
    > > > system
    > > >
    > > > here is the solution
    > > >
    > > > open c:\windows\inf
    > > >
    > > > search for usbstor.inf and usbstor.pnf
    > > >
    > > > right click each file and select the security tab and deny access to all
    > > > other than administrator
    > > >
    > > > hope this solves your problem
    > > > regards
    > > > senthil
    > >
  9. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "senthil kumar" wrote:

    >
    > hi ,
    >
    > it seems that you dont want usb storage/pen drives to be used in your system
    >
    > here is the solution
    >
    > open c:\windows\inf
    >
    > search for usbstor.inf and usbstor.pnf
    >
    > right click each file and select the security tab and deny access to all
    > other than administrator
    >
    > hope this solves your problem
    > regards
    > senthil
    >
    >
    >
  10. Hi,

    You can try the USB Drive Monitor software its free.

    You can use the USB Drive Monitor to enable and disable USB Mass Storage Devices on your PC Manually or Automatically.

    There are many options in this program, sound and text alerts, Detailed Log File that saves information about the Foreign USB Drive inserted including a unique hardware identifier for each USB Drive, access time, file contents....etc.

    This program will allow you to use your Personal USB Drive as an access key to your PC (lock/unlock)

    There are more options, you can visit the website to know more write "USB Drive Monitor" in google.
  11. Using USB Drive Monitor, will allow you to configure one USB Drive to be used on each computer or for the entire network.

    You'll have control of USB Drives Access
Ask a new question

Read More

Windows 2000 Windows XP