cannot change second hard drive letter to (D)

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hi I installed a second hard drive in my computer which also has a cd rom
and dvd writer. It appears in my computer etc as drive (F). I have tried
changing the drive letter in Administrative Tools/Computer management/Disk
management but the only options available for that drive are, Convert to
Dynamic Disk, Properties and Help.

I changed the CD and DVD drive letters to (G) and (H) but I still cannot get
the drive changed from (F) to (D). I even removed the optical drives and the
second hard disk rebooted the computer, switched it off and reconnected the
second hard drive. When the computer had rebooted I still had the second
drive as (F) Both drives are NTFS formatted. When I reconnected the 2
optical drives they were also still assigned the drive letters (G) and (H)
Ay suggestions? Tricia
PS what does Convert to Dynamic Disk mean?
5 answers Last reply
More about cannot change hard drive letter
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Hi, Tricia.

    Pegasus made some good points. I'd like to add a couple...

    Disk Management can change any drive letters EXCEPT your System Partition
    and your Boot Volume; the only good way to change these is by reinstalling
    WinXP. See this KB article for changing the other drive letters:
    How to change drive letter assignments in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;307844&sd=tech

    This KB article tells how to change the System and Boot volume letters in
    Win2K. It applies generally to WinXP as well but I don't know the KB # for
    the same info for WinXP:
    Cannot Change System Volume Drive Letter After Setup
    http://support.microsoft.com/default.aspx?scid=kb;en-us;223769

    You know, of course, that a "drive" letter actually does not refer to a hard
    drive, but to a primary partition or a logical drive in an extended
    partition on that HD. You can create a partition covering the whole
    physical drive, but the "drive" letter still refers to just the partition,
    not the physical drive. If your first HD has been partitioned into multiple
    partitions, the letter D: is probably assigned to one of those partitions
    and is not available now, especially if D: is your boot volume.

    As it says in KB 223769 (revised for WinXP):
    NOTE: The boot volume is where the \Windows folder is located, the system
    volume is where the boot files (boot.ini, ntdetect.com, etc.) are located.

    I've never tried dynamic disks but, from what I've heard, I agree with
    Pegasus that you probably do NOT want that. For details, look in the Disk
    Management Help file; that file is quite extensive and can answer many of
    your questions.

    RC
    --
    R. C. White, CPA
    San Marcos, TX
    rc@corridor.net
    Microsoft Windows MVP

    "Tricia" <tricialal2000@yahoo.co.uk> wrote in message
    news:u3iHyD3OFHA.524@TK2MSFTNGP09.phx.gbl...
    > Hi I installed a second hard drive in my computer which also has a cd rom
    > and dvd writer. It appears in my computer etc as drive (F). I have tried
    > changing the drive letter in Administrative Tools/Computer management/Disk
    > management but the only options available for that drive are, Convert to
    > Dynamic Disk, Properties and Help.
    >
    > I changed the CD and DVD drive letters to (G) and (H) but I still cannot
    > get the drive changed from (F) to (D). I even removed the optical drives
    > and the second hard disk rebooted the computer, switched it off and
    > reconnected the second hard drive. When the computer had rebooted I still
    > had the second drive as (F) Both drives are NTFS formatted. When I
    > reconnected the 2 optical drives they were also still assigned the drive
    > letters (G) and (H)
    > Ay suggestions? Tricia
    > PS what does Convert to Dynamic Disk mean?
  2. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "Tricia" <tricialal2000@yahoo.co.uk> wrote in message
    news:u3iHyD3OFHA.524@TK2MSFTNGP09.phx.gbl...
    > Hi I installed a second hard drive in my computer which also has a cd rom
    > and dvd writer. It appears in my computer etc as drive (F). I have tried
    > changing the drive letter in Administrative Tools/Computer management/Disk
    > management but the only options available for that drive are, Convert to
    > Dynamic Disk, Properties and Help.
    >
    > I changed the CD and DVD drive letters to (G) and (H) but I still cannot
    > get the drive changed from (F) to (D). I even removed the optical drives
    > and the second hard disk rebooted the computer, switched it off and
    > reconnected the second hard drive. When the computer had rebooted I still
    > had the second drive as (F) Both drives are NTFS formatted. When I
    > reconnected the 2 optical drives they were also still assigned the drive
    > letters (G) and (H)
    > Ay suggestions? Tricia
    > PS what does Convert to Dynamic Disk mean?


    Tricia:
    Just to confirm what you've related...
    In Disk Management your second HD is reflected as drive F:. When you right
    click on the graphic of that drive, a sub-menu will open. Are you saying
    that the sub-menu reflects *only* those options you have listed, i.e.,
    Convert to Dynamic Disk, Properties, and Help? Something is amiss here. When
    you right-click on that drive, one of the options listed should be "Change
    Drive Letter and Paths..." There should be *no* reference to the Convert to
    ..... Do you get that Change Drive Letter ... option?

    Forget about that Dynamic Disk thing. It's of no relevance in your
    situation.
    Anna
  3. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "Tricia" <tricialal2000@yahoo.co.uk> wrote in message
    news:u3iHyD3OFHA.524@TK2MSFTNGP09.phx.gbl...
    > Hi I installed a second hard drive in my computer which also has a cd rom
    > and dvd writer. It appears in my computer etc as drive (F). I have tried
    > changing the drive letter in Administrative Tools/Computer management/Disk
    > management but the only options available for that drive are, Convert to
    > Dynamic Disk, Properties and Help.
    >
    > I changed the CD and DVD drive letters to (G) and (H) but I still cannot
    get
    > the drive changed from (F) to (D). I even removed the optical drives and
    the
    > second hard disk rebooted the computer, switched it off and reconnected
    the
    > second hard drive. When the computer had rebooted I still had the second
    > drive as (F) Both drives are NTFS formatted. When I reconnected the 2
    > optical drives they were also still assigned the drive letters (G) and (H)
    > Ay suggestions? Tricia
    > PS what does Convert to Dynamic Disk mean?
    >
    >

    The usual reason for being unable to change a drive letter is
    that the letter is already taken by another drive, perhaps
    below your current field of vision.

    If you're sure that this is not the case then you can do it via
    the registry editor. Navigate to
    HKLM\SYSTEM\MountedDevices, then rename
    \DosDevices\F: to DosDevices\D: (press F2). You
    must reboot for the change to become effective.

    Dynamic disks offer some extra facilities which I do not
    think you require. They also have some drawbacks.
    Since you cannot convert a dynamic disk back to a
    static disk, I recommend you stick to your current static
    disk.
  4. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "Anna" <myname@myisp.net> wrote in message
    news:uwCCIj7OFHA.1172@TK2MSFTNGP12.phx.gbl...
    >
    > "Tricia" <tricialal2000@yahoo.co.uk> wrote in message
    > news:u3iHyD3OFHA.524@TK2MSFTNGP09.phx.gbl...
    >> Hi I installed a second hard drive in my computer which also has a cd rom
    >> and dvd writer. It appears in my computer etc as drive (F). I have tried
    >> changing the drive letter in Administrative Tools/Computer
    >> management/Disk
    >> management but the only options available for that drive are, Convert to
    >> Dynamic Disk, Properties and Help.
    >>
    >> I changed the CD and DVD drive letters to (G) and (H) but I still cannot
    >> get the drive changed from (F) to (D). I even removed the optical drives
    >> and the second hard disk rebooted the computer, switched it off and
    >> reconnected the second hard drive. When the computer had rebooted I still
    >> had the second drive as (F) Both drives are NTFS formatted. When I
    >> reconnected the 2 optical drives they were also still assigned the drive
    >> letters (G) and (H)
    >> Ay suggestions? Tricia
    >> PS what does Convert to Dynamic Disk mean?
    >
    >
    > Tricia:
    > Just to confirm what you've related...
    > In Disk Management your second HD is reflected as drive F:. When you right
    > click on the graphic of that drive, a sub-menu will open. Are you saying
    > that the sub-menu reflects *only* those options you have listed, i.e.,
    > Convert to Dynamic Disk, Properties, and Help? Something is amiss here.
    > When you right-click on that drive, one of the options listed should be
    > "Change Drive Letter and Paths..." There should be *no* reference to the
    > Convert to .... Do you get that Change Drive Letter ... option?
    >
    No, I have altered the registry as already posted but still do not get the
    option to change drive letters. However my second drive now shows as drive
    D: which is what I wanted

    Thanks Tricia
  5. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    "Tricia" <tricialal2000@yahoo.co.uk> wrote in message
    news:uOezMsCPFHA.2432@TK2MSFTNGP10.phx.gbl...
    >
    >>
    >> "Tricia" <tricialal2000@yahoo.co.uk> wrote in message
    >> news:u3iHyD3OFHA.524@TK2MSFTNGP09.phx.gbl...
    >>> Hi I installed a second hard drive in my computer which also has a cd
    >>> rom
    >>> and dvd writer. It appears in my computer etc as drive (F). I have tried
    >>> changing the drive letter in Administrative Tools/Computer
    >>> management/Disk
    >>> management but the only options available for that drive are, Convert to
    >>> Dynamic Disk, Properties and Help.
    >>>
    >>> I changed the CD and DVD drive letters to (G) and (H) but I still cannot
    >>> get the drive changed from (F) to (D). I even removed the optical drives
    >>> and the second hard disk rebooted the computer, switched it off and
    >>> reconnected the second hard drive. When the computer had rebooted I
    >>> still
    >>> had the second drive as (F) Both drives are NTFS formatted. When I
    >>> reconnected the 2 optical drives they were also still assigned the drive
    >>> letters (G) and (H)
    >>> Ay suggestions? Tricia
    >>> PS what does Convert to Dynamic Disk mean?


    > "Anna" <myname@myisp.net> wrote in message
    > news:uwCCIj7OFHA.1172@TK2MSFTNGP12.phx.gbl...
    >> Tricia:
    >> Just to confirm what you've related...
    >> In Disk Management your second HD is reflected as drive F:. When you
    >> right >> click on the graphic of that drive, a sub-menu will open. Are
    >> you saying that the sub-menu reflects *only* those options you have
    >> listed, i.e., Convert to Dynamic Disk, Properties, and Help? Something is
    >> amiss here. When you right-click on that drive, one of the options listed
    >> should be "Change Drive Letter and Paths..." There should be *no*
    >> reference to the Convert to .... Do you get that Change Drive Letter ...
    >> option?
    >>

    Tricia responds...
    > No, I have altered the registry as already posted but still do not get
    > the option to change drive letters. However my second drive now shows as
    > drive D: which is what I wanted

    > Thanks Tricia


    Tricia:
    There's simply no need to "alter(ed) the registry" to accomplish your
    original objective. It's hard to tell what happened after you made a
    registry modification. If there's some way to undo what you did re the
    registry change, (perhaps you backed up the original registry before making
    the change - that would have been prudent), by all means revert to your
    original registry settings.

    Simply stated, you use the Disk Management utility to change drive letters
    for your optical drives. It's simple and relatively straightforward. In your
    situation, your optical drives are designated G: and H: and there's no drive
    that has been assigned the D: drive letter. Now you want to change the drive
    letter F: that has been assigned to your second drive to D:. There should be
    no problem in doing so. So at this point there are four drives connected to
    your machine - your booting HD C:, your second drive F:, and your two
    optical drives G: & H:. For some unexplained reason no drives are designated
    D: or E:

    Presumably, all you have to do is right-click on the F: drive graphic in
    Disk Management. A sub-menu will open and one of the options should be
    "Change Drive Letter and Paths..." Click on that option and you should be
    able to change that drive letter from F: to D:
    Anna
Ask a new question

Read More

Computers Hard Drives Windows XP