Hard disk PIO instead of DMA, why?

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

In device manager under IDE ATA/ATAPI controllers ->
Primary Controller for Device 0 under advanced settings
the transfer mode is set to: DMA if avaliable, the
Current Mode is: PIO Mode. I have other devices that are
in Ultra DMA Mode 2 on my computer. The hard drive is a
WD8000JB which is on its own ide cable connected
to the primary connector on the motehrboard. I am using
windows XP Professional and the PCChips Motherboard
that can support max of DMA 66 I think.

Also, when i start up my computer and it detects the
devices for the hard drive it says its in Ultra DMA Mode 4
or 5 I don't remember, but in windows it isnt.

Thank You for your time and help.

John
1 answer Last reply
More about hard disk
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    IDE ATA and ATAPI disks use PIO mode after multiple time-out or CRC errors occur
    http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

    --
    Carey Frisch
    Microsoft MVP
    Windows XP - Shell/User
    Microsoft Newsgroups

    Get Windows XP Service Pack 2 with Advanced Security Technologies:
    http://www.microsoft.com/athome/security/protect/windowsxp/choose.mspx

    -------------------------------------------------------------------------------------------

    "John" wrote:

    | In device manager under IDE ATA/ATAPI controllers ->
    | Primary Controller for Device 0 under advanced settings
    | the transfer mode is set to: DMA if avaliable, the
    | Current Mode is: PIO Mode. I have other devices that are
    | in Ultra DMA Mode 2 on my computer. The hard drive is a
    | WD8000JB which is on its own ide cable connected
    | to the primary connector on the motehrboard. I am using
    | windows XP Professional and the PCChips Motherboard
    | that can support max of DMA 66 I think.
    |
    | Also, when i start up my computer and it detects the
    | devices for the hard drive it says its in Ultra DMA Mode 4
    | or 5 I don't remember, but in windows it isnt.
    |
    | Thank You for your time and help.
    |
    | John
Ask a new question

Read More

DMA Hard Drives Devices Windows XP