Sign in with
Sign up | Sign in
Your question

Windows XP recognizes Scanner as unknown device

Last response: in Windows XP
Share
Anonymous
July 8, 2005 2:25:08 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Windows XP does not recognize my scanners correctly. It recognizes them as
Unknown devices. I have both an HP 5300C and a brand new Canon MP780. Both
scanners work perfectly on other computers and all the functions on the MP780
except the scanner function work. On the other computer running XP it works.
Same USB cable. I have even tried USB ports on the USB computer that is not
recognizing it. Please help. Thanks.

Tony
July 8, 2005 4:14:56 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Perhaps also there are mobo bios/drivers available for the problem system.
I assume you followed reccomended manu. procedure for installation of these
devices

"Tony Vega" <TonyVega@discussions.microsoft.com> wrote in message
news:808FDF5C-7105-46D5-87A8-B75C76C6D20B@microsoft.com...
> Windows XP does not recognize my scanners correctly. It recognizes them
as
> Unknown devices. I have both an HP 5300C and a brand new Canon MP780.
Both
> scanners work perfectly on other computers and all the functions on the
MP780
> except the scanner function work. On the other computer running XP it
works.
> Same USB cable. I have even tried USB ports on the USB computer that is
not
> recognizing it. Please help. Thanks.
>
> Tony
July 8, 2005 10:38:18 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Try loading vendor's drivers onto the problem system instead of using the
Windows XP ones, as I assume you are.
Damo

"Tony Vega" <TonyVega@discussions.microsoft.com> wrote in message
news:808FDF5C-7105-46D5-87A8-B75C76C6D20B@microsoft.com...
> Windows XP does not recognize my scanners correctly. It recognizes them
> as
> Unknown devices. I have both an HP 5300C and a brand new Canon MP780.
> Both
> scanners work perfectly on other computers and all the functions on the
> MP780
> except the scanner function work. On the other computer running XP it
> works.
> Same USB cable. I have even tried USB ports on the USB computer that is
> not
> recognizing it. Please help. Thanks.
>
> Tony
Related resources
Anonymous
July 8, 2005 10:38:19 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Tried that even with the support of Canon. The funny thing is that it was
working untill I mucked around inside the registry trying to remove old
drivers for the HP that would properly un-install. It has something to do
with Windows as the scanner function works perfectly on another computer
running windows XP. Thanks for your suggestion though.

"Damo" wrote:

> Try loading vendor's drivers onto the problem system instead of using the
> Windows XP ones, as I assume you are.
> Damo
>
> "Tony Vega" <TonyVega@discussions.microsoft.com> wrote in message
> news:808FDF5C-7105-46D5-87A8-B75C76C6D20B@microsoft.com...
> > Windows XP does not recognize my scanners correctly. It recognizes them
> > as
> > Unknown devices. I have both an HP 5300C and a brand new Canon MP780.
> > Both
> > scanners work perfectly on other computers and all the functions on the
> > MP780
> > except the scanner function work. On the other computer running XP it
> > works.
> > Same USB cable. I have even tried USB ports on the USB computer that is
> > not
> > recognizing it. Please help. Thanks.
> >
> > Tony
>
>
>
Anonymous
July 8, 2005 11:20:03 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Tony Vega <TonyVega@discussions.microsoft.com> wrote:

>Windows XP does not recognize my scanners correctly. It recognizes them as
>Unknown devices. I have both an HP 5300C and a brand new Canon MP780. Both
>scanners work perfectly on other computers and all the functions on the MP780
>except the scanner function work. On the other computer running XP it works.
> Same USB cable. I have even tried USB ports on the USB computer that is not
>recognizing it. Please help. Thanks.
>
>Tony

Make sure you have the drivers for the scanner in a folder on the hard
drive or on a CD. If on a CD insert it into the drive.

Open Control Panel - System - Hardware - Device Manage.

Locate the Scanner entry in the "other devices" category, right-click
on it and select Properties. Go to the Driver tab and click on the
"Update Driver" button. Let it search for the updated driver with
the "Install the sofware automatically" option on the first attempt.
If that doesn't work then use the "Install from a specific location"
option and browse to the driver files on the hard drive or CD.

Repeat for the second scanner.

Good luck



Ron Martell Duncan B.C. Canada
--
Microsoft MVP
On-Line Help Computer Service
http://onlinehelp.bc.ca

In memory of a dear friend Alex Nichol MVP
http://aumha.org/alex.htm
Anonymous
July 8, 2005 11:34:08 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Remove the Unknown device from the device manager, unplug the scanner,
reboot, plug in the scanner, what happens include error message.

--


The best live web video on the internet http://www.seedsv.com/webdemo.htm
NEW Embedded system W/Linux. We now sell DVR cards.
See it all at http://www.seedsv.com/products.htm
Sharpvision simply the best http://www.seedsv.com



"Tony Vega" <TonyVega@discussions.microsoft.com> wrote in message
news:808FDF5C-7105-46D5-87A8-B75C76C6D20B@microsoft.com...
> Windows XP does not recognize my scanners correctly. It recognizes them
> as
> Unknown devices. I have both an HP 5300C and a brand new Canon MP780.
> Both
> scanners work perfectly on other computers and all the functions on the
> MP780
> except the scanner function work. On the other computer running XP it
> works.
> Same USB cable. I have even tried USB ports on the USB computer that is
> not
> recognizing it. Please help. Thanks.
>
> Tony
Anonymous
July 8, 2005 11:34:09 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Tried that too. The error message is "Cannot communicate with scanner.
Scanner may be turnedd off, a cable may be diconnected. Please check the
status and try again. Scanner driver will be closed."

"pcbutts1" wrote:

> Remove the Unknown device from the device manager, unplug the scanner,
> reboot, plug in the scanner, what happens include error message.
>
> --
>
>
> The best live web video on the internet http://www.seedsv.com/webdemo.htm
> NEW Embedded system W/Linux. We now sell DVR cards.
> See it all at http://www.seedsv.com/products.htm
> Sharpvision simply the best http://www.seedsv.com
>
>
>
> "Tony Vega" <TonyVega@discussions.microsoft.com> wrote in message
> news:808FDF5C-7105-46D5-87A8-B75C76C6D20B@microsoft.com...
> > Windows XP does not recognize my scanners correctly. It recognizes them
> > as
> > Unknown devices. I have both an HP 5300C and a brand new Canon MP780.
> > Both
> > scanners work perfectly on other computers and all the functions on the
> > MP780
> > except the scanner function work. On the other computer running XP it
> > works.
> > Same USB cable. I have even tried USB ports on the USB computer that is
> > not
> > recognizing it. Please help. Thanks.
> >
> > Tony
>
>
>
Anonymous
July 29, 2005 6:57:06 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Tony ---

I purchased an MP780 last week, and I,too, am experiencing problems
with the scanner function...in fact, they sound exactly like yours!
All other functions work fine, but the big "yellow" triangle (meaning
problems!!) shows up by the MP780 listing under imaging devices when I
look under device managers. Did you ever come up with a solution. I
would certainly appreciate hearing from you if you found a way to
remedy the quirk. Thanks in advance.

Rocky Cooper (drrocky@insightbb.com)

Tony Vega wrote:
> *Windows XP does not recognize my scanners correctly. It recognizes
> them as
> Unknown devices. I have both an HP 5300C and a brand new Canon
> MP780. Both
> scanners work perfectly on other computers and all the functions on
> the MP780
> except the scanner function work. On the other computer running XP
> it works.
> Same USB cable. I have even tried USB ports on the USB computer that
> is not
> recognizing it. Please help. Thanks.
>
> Tony *



--
drrocky
------------------------------------------------------------------------
Posted via http://www.mcse.ms
------------------------------------------------------------------------
View this thread: http://www.mcse.ms/message1720376.html
Anonymous
July 29, 2005 10:56:36 PM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

And you installed all the Canon software BEFORE connecting the All in One to
the PC?
--
Cari (MS-MVP)
Printing & Imaging



"drrocky" <drrocky.1syeub@mail.mcse.ms> wrote in message
news:D rrocky.1syeub@mail.mcse.ms...
>
> Tony ---
>
> I purchased an MP780 last week, and I,too, am experiencing problems
> with the scanner function...in fact, they sound exactly like yours!
> All other functions work fine, but the big "yellow" triangle (meaning
> problems!!) shows up by the MP780 listing under imaging devices when I
> look under device managers. Did you ever come up with a solution. I
> would certainly appreciate hearing from you if you found a way to
> remedy the quirk. Thanks in advance.
>
> Rocky Cooper (drrocky@insightbb.com)
>
!