Empty Device Manager

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

Hi,

I have a problem with a workstation. It is not showing anything in the
Device Manager at all. I have checked the Plug and Play in the BIOS and it is
turned on.

Where else can I check? This is strange. I have never come across anything
like this before.

Please help.

Mil
7 answers Last reply
More about empty device manager
  1. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Milena wrote:

    > Hi,
    >
    > I have a problem with a workstation. It is not showing anything in the
    > Device Manager at all. I have checked the Plug and Play in the BIOS
    > and it is turned on.
    >
    > Where else can I check? This is strange. I have never come across
    > anything like this before.
    >
    > Please help.
    >
    > Mil

    Do hardware testing. Start with the RAM and the hard drive.

    1) Test the RAM - I like Memtest86+ from www.memtest.org. Obviously, you
    have to get the program from a working machine. You will either
    download the precompiled Windows binary to make a bootable floppy or
    the .iso to make a bootable cd. If you want to use the latter, you'll
    need to have third-party burning software on the machine where you
    download the file - XP's built-in burning capability won't do the job.
    In either case, boot with the media you made. The test will run
    immediately. Let the test run for an extended period of time - unless
    errors are seen immediately. If you get any errors, replace the RAM.

    2) Test the hard drive with a diagnostic utility from the mftr. Usually
    you will download the file and make a bootable floppy with it. Boot
    with the media and do a thorough test. If the drive has physical
    errors, replace it.

    If the hardware is healthy, do a Repair Install:
    http://www.michaelstevenstech.com/XPrepairinstall.htm

    Malke
    --
    Elephant Boy Computers
    www.elephantboycomputers.com
    "Don't Panic!"
    MS-MVP Windows - Shell/User
  2. Archived from groups: microsoft.public.windowsxp.hardware (More info?)

    Milena try this
    start
    run
    msconfig
    services
    make sure checkbox NOT selected in "hide all ms services" at bottom of
    dialog box
    check the rest of the services in dialogbox
    George


    "Milena" <Milena@discussions.microsoft.com> wrote in message
    news:958136AB-108E-47D2-9B7E-E774F5FB00D8@microsoft.com...
    > Hi,
    >
    > I have a problem with a workstation. It is not showing anything in the
    > Device Manager at all. I have checked the Plug and Play in the BIOS and it
    > is
    > turned on.
    >
    > Where else can I check? This is strange. I have never come across anything
    > like this before.
    >
    > Please help.
    >
    > Mil
  3. I have a partial resolution to my problem!

    Thanks to everyone who offered help.

    First option was check that PuNP was started - OK. Later I discovered that Universal PuNP must NOT be started!

    Second option was Aproposfix which I assume is to get rid of some specific spyware/adware/malware.

    Third was I tried editing some permissions in the registry but I didn't really understand what I was doing.

    Fourth was I ran sfc/scannow - whatever that is!

    Also system was hanging on startups and shutdowns, sometimes needing the big switch to get out of it. Now you can click on IE or My Computer or Control Panel and it takes ages for them to load. Usually I find myself with about five instances of each all loading at once.

    Frequently web links won't work. The only thing I can do is avoid a left click - use right clicks to save shortcut and then paste it into address bar. I have tpo switch back and forth betwen web browsers using teh Task Manager. OIften the Task Manager itself freezes with the button still "pressed down".

    I've also been using my SpeedUpMyPC utility which allows you to give CPU priority to a particular window. A combination of this, Task Manager and a hell of a lot of patience just about keeps me going

    Oh, and I updated all my chipset drivers along the way.

    MY DEVICE MANAGER WINDOW IS NOW FULLY POPULATED!!!!!

    Oh joy! The printer is working too. The solution? It was to do with permissions. I had to spend a lot more time and give a lot more thought to it. (I still don't understand it properly). It's in HKEY Local Machine "Enum"
    whatever that means?

    So many thanks to the Annoyances.org forum which first gave me the idea for that fix.

    BUT!!

    Some things are better like loading IE or My Computer or Control Panel. They're still slow though and I can still find myself with loads more browser windows open that I need. On IE though browsing still suffers froim the same problem. Links won't work. I have to copy shortcut and paste into another window.

    Java linlks often don't wprk eiuther. I uninstalled and re-installed Java. Maybe there's some slightimprovement but browsing is still a pain.

    So now it comes down to a performance problem, mainly in IE.

    Shall I uninstall and reinstall IE?

    Why has this happened. Could Malware/spyware viruses be reponsible?

    Any help gratefully received and because it's only fair, I'll make sure every forum gets a full report when it's all fixed (It will be won't it?)

    System Description

    INTEL P4 3.4GHz, socket 775
    ASUS P5GD1-VM motherboard, onboard LAN (Intel Pro 100), onboard graphics and audio disabled
    American Megatrends BIOS version 1010.005
    2 x 512MB PC3200 400MHz DDR
    200GB Maxtor serial ATA drive - C
    500GB Seagate serial ATA drive - D
    Samsung/Toshiba DVD writer - E
    Sony Q28A DVD writer - F
    Sony DRX-810UL external DVD writer on USB - G
    ATI All in Wonder X800XL graphics card
    Creative Soundblaster XFi Xtreme Music sound card
    Logitech Dinovo Media keyboard, seperate keyboard and numeric panel/remote with mouse on powered USB hub
    Logitech Communicate STX webcam

    I run Windows XP Home Service Pack, fully updated. I defragment with Perfect Disk at least once per week.

    I use the following security software:

    Norton Internet Security 2006
    Ad-Aware SE
    Spyware Doctor
    Spy Bot
    Microsoft Antispyware
    Spyware Blaster
    Spy Sweeper

    All are updated regularly and full scans performed at least every other day.

    I also use Registry Mechanic at least once per day. And this episode has added about a dozen other utilities to my amoury.
  4. You have so much, too much stuff running to protect yourself, that you are short on resources.

    You are way overboard on your spyware apps. Get "Pest Patrol" from Computer Associates. It will be all you need. It is BY FAR THE BEST spyware program of all, and the only one you'll need. After you buy it, and before you install it - delete all the others; Microsoft Anti-Spyware first. Be sure to reboot between each. Run Registry Mechanic; then install Pest Patrol.

    Norton, although a very capable app, is exremely ponderous and a tremendous resource hog and intrusive. There are other anti-virus apps that will serve you well & are much smaller & quieter. I use Zone Alarm, and have never been hurt. It also sets up its' own firewall.

    Another piece of advice; go up into your BIOS, and to the page that has the question of OS pnp? and answer it NO. Your hardware will be set up much cleaner this way.

    You should also be behind a hardware firewall (router) as well. A Linksys Cable/DSL router will be fine.

    If you still have operating issues after these improvements, contact the HiJackThis people and send them a report.
  5. Yeah, I would have to agree and have you post a log from hijakthis. My sister had a virusmalware that made it so I could not see the device manager. What I did since it was XP was logged on as admin, did all the spyware removal progs I could (in safe mode too). Then in the end I created a new profile for her. For some reason her porblem only affected that user profile. Good luck.
  6. Hi all, I had the same problem and now it is fixed, I found the solution thanks to Jazz in the Forum:

    http://www.softwaretipsandtricks.com/forum/windows-xp/15653-device-manager-blank.html

    Bellow you can find the solution, I copy/paste the post since I know that this could help more people:

    "The issue is security permissions in the registry. I cannot tell how they are lost
    but I can tell you how to fix it short of having to re-install Windows!

    You must use regedt32.exe in Windows 2000/XP (as I have not seen this problem posted
    for any other operating system). Be very carefull making changes in the regisrty!

    You must be logged on as a local administrator to perform this task:

    1. Go to "Start", "Run", and enter "regedt32"
    2. Maximize the "HKEY_LOCAL_MACHINE" window.
    3. Scroll down to "SYSTEM\CurrentControlSet\Enum"
    4. With "Enum" selected click the "Security", "Permissions" menu.

    Note: At this point you will probably notice there are no permissions on this key.

    5. Click "Add".
    6. Add the group "Everyone" and the user "SYSTEM".
    7. Select "Everyone" and check "Read" ONLY!
    8. Select "SYSTEM" and check "Full Control".
    9. Click the "Advanced" button at the bottom of the window.
    10. On the Advanced window check "Reset permissions on all child objects..."
    11. Click "OK"
    12. On the warning window click "Yes"
    13. Close REGEDT32

    You should now be able to see everything in Device Manager, Network Places Properties,
    and Printers."

    Good luck.......................
  7. yes changing the permissions works
Ask a new question

Read More

Hardware Device Manager Plug And Play Microsoft Windows XP