Sign in with
Sign up | Sign in
Your question
Solved

Can't find USB drivers

Last response: in Windows 7
Share
February 15, 2011 11:29:57 PM

I have been searching for the last week for two drivers that are missing in device manager.

Marvell 91xx Config ATA device
+
USB controller

Both are under "other devices" in device manager

I really need the usb ports to be working obviously. right now i can plug a usb key into my monitor and use it but when i plug in my zune hd or droid x is charges them but doesn't show any connection on the device or computer.

When i plug either device into the tower it shuts the device down and i have to restart. Device manager can't find the drivers and i dont really know where else to look. I have googled every variation of driver downloads and nothing has worked when i installed them through device manager.

Anyway heres my rig:

Asus p6X58D-E
core i7-950
6g tri channel ddr3 corsair (3x 2) ram
Lian-Li PC-7FN
Dell 20 in. monitor
sapphire radeon hd 5850
antec 550 basiq
120gb seagate barracude/1tb WD caviar blue
win 7 64-bit

Thanks in advance for the help

More about : find usb drivers

a b \ Driver
a b $ Windows 7
February 15, 2011 11:53:12 PM

GO to the Asus support site for board (here). Download the files you need. USB drivers are included in the X58 intel chipset utility. Check under "Utilities" for the USB3 and the Marvell drivers.
m
0
l
February 16, 2011 12:26:15 AM

OK i got the marvell driver working first try but the chipset utility did, as far as i know, nothing. I went through the install screens and after accepting everything it went straight to the finish installation part of the screen. It looked like it didn't do anything at all.

Still having the same device problems.

Thanks for the help
m
0
l
Related resources
a b \ Driver
a b $ Windows 7
February 16, 2011 12:35:51 AM

Did you download the USB3 Drivers that are in the utilities section? If so, check you BIOS settings to ensure the USB2 are set to "Hi-Speed" and the USB3 are on.
m
0
l
February 25, 2011 3:23:53 PM

Yes i downloaded the USB3 drivers and installed them to the best of my knowledge and BIOs has USB 2 and 3 enabled, USB2 on Hi-Speed and everything on as far as i could tell. The strange thing is I am running my mouse and keyboard off of the ports on the back of my computer and thats showing up in BIOS as working fine. Don't know what else to do.

Thanks for the help treefrog and sorry about the delay

Oh and i guess I was dumb enough to write what is probably the real problem here but I accidently deleted the "USB controller" driver in device manager, so now it is completely gone and i don't know how to get it back. If you can help me out with that one it would probably help a lot.
m
0
l

Best solution

a b \ Driver
a b $ Windows 7
February 25, 2011 8:37:05 PM

You're welcome.

Re-install the chipset drivers (Intel x58) from the CD that came with the motherboard, then shut-down and re-start the system. You should then have the USB controller(s).

If the back panel USB ports are working, then I'll assume your front panel ones (on the case are not). You have to connect the USB cables from the front panel to the USB pins on the motherboard. Open the case and look for the USB pins, they are usually on the bottom side of the board and will be labeled USB. As your manual says: Do Not attach USB cables to 1394 (firewire) pins. Those are labeled 1394 and are not usually co-located with the internal USB pins.
Share
March 10, 2011 7:46:31 PM

Best answer selected by msa1994.
m
0
l
March 10, 2011 7:49:45 PM

I know im a little slow but I finally got back to it and my usb ports are now working. all of them. My front panel ports weren't working because the usb plug was with the 1394 pins. So i switched them and everything worked fine right away. the only problem was my rooted droidx was dying on me and that was the cause of a lot of the misery when it came to not recognizing it when i plugged it in. Found that out and have a new one that is working.

Thanks again treefrog
m
0
l
a b \ Driver
a b $ Windows 7
March 10, 2011 7:53:41 PM

You're welcome. Please be careful on your next build - don't attach the USB connectors to the 1394 port - that can cause serious damage to your motherboard.
m
0
l
!