Sign in with
Sign up | Sign in
Your question

Can't get microphone to work -Windows cannot execute DpvSe..

Last response: in Windows XP
Share
Anonymous
September 30, 2005 10:47:50 AM

Archived from groups: microsoft.public.windowsxp.hardware (More info?)

I can't get my microphone to work. I think it is a directplay related
problem.
An error occurred during Directplay Voice setup. The error code is
0x80004005
Windows error message "Windows cannot execute DpvSetup.exe, use Add/Remove
Programs control panel to install"

I have XP prof. and DirectX 9.0c and all up to date drivers
Tried all the remedies suggested and I'm still stuck


XP Pro AMD P3200, 64, 1 Gb, MSI mb
System Model: AWRDACPI
BIOS: Phoenix - AwardBIOS v6.00PG
Processor: AMD Athlon(tm) 64 Processor 3200+, MMX, 3DNow,
~2.3GHz
Memory: 1024MB RAM
Page File: 345MB used, 2113MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: /Silent
DxDiag Version: 5.03.2600.2180 32bit UnicodeRoy
Help!



Google search indicates many many others with same problem but i cannot
locate a solution.

microsoft knowledge base resolution did NOT resolve??!!
Tried this too but no joy!

Tried all the advice below but I still haven't fixed the problem.

"The solution involves reconfiguring some advanced sound settings and
tweaking the Registry. Start by opening the Control Panel and selecting the
Sounds And Audio Devices icon (in the Sounds, Speech, And Audio Devices
category). Choose the Voice tab, locate the Voice Playback heading, and
click the Advanced button. From the Advanced Audio Properties dialog box,
choose its Performance tab and move the Hardware Acceleration slider to the
right. It doesn't matter how far to the right, as long as the Hardware
Acceleration slider is set to something other than None. Click OK to close
the dialog boxes.

Before continuing to the next phase of the solution, you must make sure
Dpvsetup.exe isn't open and running on your PC. Press the CTRL-ALT-DELETE
key combination to access the Task Manager and locate any references to
Dpvsetup.exe or DirectPlay Voice. End all of them and close the Task
Manager.

Now it's time to edit the Registry. Open the Start menu, select Run, type
regedit in the Open field, and click OK. In the Registry Editor, locate and
highlight HKEY_CURRENT_USER\SOFTWARE\MICROSOFT\DIRECTPLAY\VOICE\AUDIOCONFIG.
The AudioConfig key should include a pair of nested folders labeled with
hexadecimal numbers. Open both of them to reveal several Registry values,
including three labeled as FullDuplex, HalfDuplex, and MicDetected.

Right-click the FullDuplex value and select Modify from the pop-up menu. In
the resulting Edit DWORD Value dialog box, type 3 in the Value Data field
and click OK. Repeat the procedure for the HalfDuplex and MicDetected
values, setting the Edit Value fields to 3 for HalfDuplex and 2 for
MicDetected. Close the Registry Editor and reboot the computer. The
microphone should now work correctly. If it doesn't, you may have a
malfunctioning microphone or Game Voice control pad on your hands.
January 21, 2009 11:33:11 PM

hi
i do have the same problem and have tried everything all the things explained in previous post only my system is different intl c2d ..........what should i do ??????????????????????????
April 5, 2009 7:22:33 AM

In Volume control, check the advance contol for your microphone. the "1 Microphone Boost" need to be checked. close the sound properties window and now check if you are able to record your voice.
Related resources
Can't find your answer ? Ask !
April 21, 2009 2:34:55 AM

i cant click advanced setting the button is not highlited
May 17, 2011 2:44:26 PM

check your BIOS settings. Had same problem and the microphone was turned off in BIOS
September 3, 2011 5:32:43 PM

I connected my apex370 mic to mic-pre amp and then from there a guitar cable from pre-amp to usb socket in the computer, my mic was functioning properly. But when took away the guitar chord with usb and tried a pyle-pro microphone cable from pre-amp out to mic in in computer, i had direct voice play. I did not know why...i used the mic for a couple of mins and this error message mentioned in the article came when i tried to test the hardware in the sound and speeches audio properties. Then again I clikced the 'test hadware' tab, it came with the erro message.

I disconnected and tried in the front side socket of the computer same issue. I disconnected the cable from pre-amp and to mic in in computer and used the guitar cable and not its aky.

For any issues, the best easy solution for me is to go to the factory settings setting up in the safe mode and bring everything to factory system operating system...that is when starting the computer to click F10 and with pc doctor do the factory settings again and manually reload all the programs. Or safely copy all the programs and then load it back.

This should solve all the issues.

Star555
!