Sign in with
Sign up | Sign in
Your question
Solved

Maximizing windows w/ three Monitors

Last response: in Windows 7
Share
February 18, 2011 5:37:22 PM

So I just setup my Nvidia Surround setup, and I have a question and I am not sure where this would go.
Anyways whenver I maximize a window it goes across all three screens, now that is okay for video games but not so much for the internet or other programs. Whenever I open a program it is opened very small and I have to manually adjust to windows to each screen, and it kind of gets annoying.
So is there a way that I can change a setting or something that when I maximize my window it will only maximize on the screen that I have the window open on?
I am running Windows 7 btw.
February 18, 2011 6:10:32 PM

Hmm...have you tried playing with the resolution to see if any changes will get it closer to what your preference is?

-- Ryan
Windows Outreach Team
February 18, 2011 6:38:42 PM

I don't understand why I would need to change the resolution? Could you explain?
I had to create a custom resolution of 6028x1080 for bezel compensation. I just don't like having to resize my apps everytime I reopen them.
Related resources
a b C Monitor
a b $ Windows 7
February 18, 2011 7:38:24 PM

are you running the other monitors as extended desktops? in which case each monitor is seperate and maximising works fine. not sure how that works in games though, shouldn't the resolution be set in the game? i've only used twins and not gamed as a spanned game.
February 18, 2011 9:10:53 PM

Games work fine spanning across all the monitors, actually everything works fine. The only problem is I Open up lets say firefox and it opens one either all the monitors, or on one monitor 25% of the screen. So if I go to maximize the program it spreads across all the monitors.
a b C Monitor
a b $ Windows 7
February 19, 2011 2:18:25 AM

You can create separate cells within the displays of the spanned desktop using the Matrox PowerDesk program. It will allow you to maximize a window in a defined cell.

64-bit version

32-bit version
a b C Monitor
a b $ Windows 7
February 19, 2011 9:44:41 AM

oooen1gmaooo said:
Games work fine spanning across all the monitors, actually everything works fine. The only problem is I Open up lets say firefox and it opens one either all the monitors, or on one monitor 25% of the screen. So if I go to maximize the program it spreads across all the monitors.


can you screen shot your dualmonitor settings from control panel?

Best solution

February 19, 2011 2:43:20 PM
Share

Well, the problem is that you are running them as one screen. The driver is reporting to Windows that it only has a single screen attached, and Windows behaves as such.

I know in the ATI driver panel there is a setting you can enable that will try and maximize a window onto just one screen, but bezel compensation screws that up.

What you need to do is set a profile, one for Surround with bezel compensation (for gaming) and another profile for just running the two extra screens as extended desktops, thereby eliminating your problem.
February 19, 2011 5:10:57 PM

Yea that would probably work. I am getting used to it, plus some programs remember which screen I want them on and how big. I Really don't want to turn bezel compensation off even when not gaming, because it really annoys me how the lines don't match up. But thanks for the advice I might give it a try sometime. Of course the Jedi Master gives the best advice!
February 19, 2011 5:11:10 PM

Best answer selected by oooen1gmaooo.
February 20, 2011 7:40:32 PM

:)  I'm just glad I could help.

Also, turning bezel compensation off will not affect usage when you are using them as extended desktops, the driver won't even offer it since you won't be stretching windows across two or three displays, but as soon as you load up a Surround profile, bezel comp. should already be applied.
August 6, 2011 10:44:53 AM

jedimasterben said:
Well, the problem is that you are running them as one screen. The driver is reporting to Windows that it only has a single screen attached, and Windows behaves as such.

I know in the ATI driver panel there is a setting you can enable that will try and maximize a window onto just one screen, but bezel compensation screws that up.

What you need to do is set a profile, one for Surround with bezel compensation (for gaming) and another profile for just running the two extra screens as extended desktops, thereby eliminating your problem.


do u know how to enable bezel compensation in ati catalyst? i have ATI HD 3870, maybe u can help me..

btw, i don't think eyefinity will work
!