Sign in with
Sign up | Sign in
Your question
Solved

Mouse slowed down/lag/delayed in most games

Last response: in Windows 7
Share
February 20, 2011 5:50:28 PM

Hello. My pc specs are:

AMD Athlon II X3 445 3.1GHz
ATI Radeon HD 5670 (CCC 11.2, the newest)
MSI 870-C45 (tho everest detects 770-C35/C45)
4 GB ram
Windows 7 x64
The mouse is (if needed) Razer Diamondback 3G
LCD NEC V191W

I just bought my pc a few days ago. After installing all the drivers I decided to play Splinter Cell Conviction and the graphics ran perfect on max settings with max AA and AF, except the mouse felt like it was delayed a quarter/half second. So basically it became impossible to aim. Decided to try Quake Live - exactly the same, but it got fixed after turning vertical sync off. Checked on world of warcraft, at some areas it's more, at some less intense, but it definitely is there.
It feels like the cursor on the screen is delayed half/quarter a second compared to how I move the actual mouse.
In world of warcraft there in an option in video settings 'reduce input lag'. When turned on everything is perfect, but fps drops from ~60 to ~40.

It's the first time I use windows 7 x64 so I might have missed something, or maybe even installed some wrong/old drivers, or just don't know something.

Been trying to fix it for the past 2 days. Checked some topics on this forum, but didn't find any fix either. Really could use a hand.

If anyone has any questions I'd gladly answer them.
Thanks in advance.
February 21, 2011 9:17:53 AM

Wanted to add that there is an option "Reduce mouse lag' in Starcraft 2 and it also works, so what those options do is exactly what I need, but outside of the game cause it as well takes away frop fps.

Also bump.
m
0
l
a b $ Windows 7
February 21, 2011 12:58:25 PM

Some users notice mouse lag when they have an option called vsync enabled. You can try to turn that off in the game or CCC(both is you can).

Please note that with vsync off, there may be page tearing. one half of the screen may refresh faster as a result of your fps not being locked to the screens refresh. The card will be drawing frames faster then the screen displays them so the screen will show this in high action parts of the game. Some users are bugged by this and others are not. I generally prefer vsync, but it can cause mouse lag.

This is a image of vertical sync off or page tearing. It is simulated since you can not screen capture it. As far as the computer is concerned, it has the full image, its just the screen has not finished drawing it before moving to the next frame. look between the red lines. it is not always at the center either.

m
0
l
Related resources
a b $ Windows 7
February 21, 2011 2:15:47 PM

You can also try messing with your DPI settings... higher DPI usually results in a more responsive mouse.
m
0
l
February 21, 2011 5:42:47 PM

Vsync is off. It gets ridiculous with it on.
DPI is on max. (1800) and polling rate is 500hz = 2ms delay - standard mice have 125hz = 8 ms delay.
Maybe it's some CCC setting set wrong.
I'll also try installing some older graphics card drivers and reinstall motherboard drivers with downloaded ones instead of the ones from the disc.
m
0
l
a b $ Windows 7
February 21, 2011 6:43:24 PM

You know some screens also have a slight delay. More common in IPS and X-PVA ones. What screen are you running?

I doubt it since you say sc2's built in option fixes it.
m
0
l
February 21, 2011 7:17:57 PM

My screen is LCD NEC V191W (19'' I think).
EDIT: Also I used the same screen on XP with my old pc.
m
0
l
a b $ Windows 7
February 21, 2011 10:56:02 PM

that screen should not cause it. I am not sure what else it could be.

The mouse is not on a USB hub is it? That is about the last thing i can think of. had it with an old switching usb hub(it cut the inputs/sec low enough that i could see it in games.).
m
0
l
February 22, 2011 7:35:30 AM

The mouse is on usb straight on the back panel of my pc.
The weirdest thing is that those options 'Reduce mouse lag' and 'Reduce input lag' in those games fix it by the cost of 15-20 fps drop.

EDIT: Also I can't find how to uninstall motherboard drivers on windows 7. Is there a way? Or only a clean reinstall?
EDIT2: It also seems the lag/delay isn't constant, sometimes it's hardly noticeable, sometimes it's very evident.
m
0
l
a b $ Windows 7
February 22, 2011 1:23:47 PM

If your mouse allows you to set its inputs/sec to 125. Give it a try, there is a bit more overhead(processing) for 500/1000 and maybe that is the cause under different system loads.

Most drivers can be uninstalled with the ADD/REMOVE option in the control panel.
Windows has its own drivers for many parts as well. those install when windows was first installed on the system.

Do you have any option with your mouse for "Mouse Acceleration"(common for Logitech, may also be in razor's system) or "enhance pointer precision"(this is a windows option, at high speeds it increases the mouse speed and slow speeds it slows down for more accurate tracking. in games you can overshoot with this on.).

With those options disabled, your mouse will move at the same speed you move it on the pad, so it will feel slower if you are set to a lower dpi @ 1800, i think you will be ok. These are nice in windows, but kill in games for some users.

To be honest I just learned to ignore some of this since I have vsync and a S-PVA screen. No way for me to win.

Since games are rendered a few frames ahead(not sure if it can still be controled, not on ati at least), maybe lower the overall frame rate helps reduce mouse lag. I can not be sure. There used to be options for the number of frames to be rendered ahead in video control panels and it said high frame ahead = input lag.

Still looks to be on Nvidia cards. high pre-render = smoother graphics, but more input lag, lower = less smooth game play, but less input lag. I am not sure if there is a software for us ATI users.



You can also try to tweak the Catalyst AI settings try both disabled and Advanced to see if that helps?
m
0
l
February 23, 2011 9:19:18 AM

The default polling rate was 125hz, so I switched too 500hz for quicker response. Same lag on both.
Don't have any acceleration as it's way too annyoing in games :) 

I also found the 'frames rendered ahead' on ati cards. It's called 'Flip Queue Size' and requires Ati Tray Tools to change.
Sadly changing to 1 nor 5 had any effect. The lag stays exactly the same. Same with Catalyst AI on or off.

Which makes me think it's the motherboard drivers installed wrong, since the disk seemed like it was very scrached (tho it was brand new), even tho it didn't feel like it when u touched it.
Also everest detects a different motherboard than I really have as well as 3 graphics cards while I really have just one.

I'll try a full windows reinstall today installing newest drivers downlaoded from MSI and AMD websites.

Thanks for the help so far btw :) 
m
0
l
a b $ Windows 7
February 23, 2011 12:18:14 PM

You can ignore Everest showing 3 cards, its just because of the 3 video outputs on that card it self.

It also shows 770-C35/C45 because your board does in fact use the 770 chipset from AMD. I have no clue why they names that thing 870, its almost like a lie in itself as there is NO 870 chipset on that board.

Check the chipset
http://www.msi.com/product/mb/870-C45.html#/?div=Basic
m
0
l
February 23, 2011 7:29:28 PM

Oh, ok.

I'm using a dvi d-sub adapter/switch (no idea what it's called in english :p ) since I don't have a dvi output on the graphics card. Is it possible that the adapter/switch is causing the input lag?

EDIT: Is d-sub the same as VGA btw?
m
0
l

Best solution

a b $ Windows 7
February 24, 2011 3:10:54 AM

Is it a passive adapter? does it need power or is it just one of those DVI->VGA Adapters.

If its a DVI->VGA adapter, there should not be any lag since the card is doing the work and the adapter just connects the right wires for you.

If you have a box that is doing some kind of conversion, then there may be a lag. This is common on TV's(because they lag a bit while they enhance the image.) and some screens.

Do you actually have NO DVI on the card, or is it no VGA(D-sub is effectively the same for this case, but some will get technical about d-sub also used for many other things[many many things use d-sub variants]. it may also be called DB15 in this case) on the card and are running this?
http://www.dvitovga.org/

If so, that should not be the issue. If you have an old CRT(Tube) monitor to test on, you can check it as those have no lag.
Share
a b $ Windows 7
February 24, 2011 1:51:52 PM

Those adapters should not add lag.
m
0
l
February 24, 2011 10:11:10 PM

So I tried a CRT screen and the lag is gone, tho it also needs the adapter as it also has VGA input.
Seems I'll need to stick with that.

I only wonder if it's the actual adapter, or the graphics card. The LCD screen worked fine on my old pc with 7300GT, tho it was directly through VGA cable without any adapter. Guess I'll find out someday.

Thanks for all the help nukemaster!
m
0
l
February 24, 2011 10:16:47 PM

Best answer selected by Kripper.
m
0
l
a b $ Windows 7
February 25, 2011 12:58:17 AM

kripper said:
So I tried a CRT screen and the lag is gone, tho it also needs the adapter as it also has VGA input.
Seems I'll need to stick with that.

I only wonder if it's the actual adapter, or the graphics card. The LCD screen worked fine on my old pc with 7300GT, tho it was directly through VGA cable without any adapter. Guess I'll find out someday.

Thanks for all the help nukemaster!


Lag may be less noticeable at lower frame rates. This would also explain how the lag reduction the lowers frame rates and helps.

The lag must be in the screen it self, this is strange, but ALL LCD's lag to some extent(its called input lag).
m
0
l
!