Sign-in / Sign-up
Your question

Locking icons to desktop with windows 7 64 bit Pro

Tags:
  • Configuration
  • Windows 7
  • Desktops
  • Icons
Last response: in Windows 7
February 23, 2011 1:15:14 PM

I've asked this question before but haven't read a solution. Seems it a common problem. And yes, the auto arrange on the desktop is unchecked.

More about : locking icons desktop windows bit pro

a c 695 $ Windows 7
February 23, 2011 2:24:34 PM

What are you trying to do? Not have them move around when you move them? Keep them from being deleted? Have them restore their positions when you reboot?

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

Create Key "Explorer" if it's not there.

Add new DWORD value "NoSaveSettings" and set to 0

There are also some 3rd party tools to save icon locations.
m
0
l
February 23, 2011 7:48:33 PM

I like to arrange my Icons on the desktop in the order I want them. Been doing it for ten years. When I go to the desktop it's quick to find what I want. Now since I bought windows 7 64 bit Pro, everytime I reboot or restart or after an update that requires a reboot, windows rearranges the Icons the way they want them. There has to be a way to do this.
m
0
l
Related resources
Can't find your answer ? Ask !
March 5, 2011 3:52:48 AM

Seems there is no provision within Windows 7 64 bit Pro software to correct the problem. Suggestions to tweak the software are not what most users want to hear or even try. It should be a check or uncheck function to do this.
m
0
l
April 27, 2016 8:34:56 AM

upsetdave said:
Seems there is no provision within Windows 7 64 bit Pro software to correct the problem. Suggestions to tweak the software are not what most users want to hear or even try. It should be a check or uncheck function to do this.


You can absolutely do this with Win7 64-bit

I just upgraded to a 64-bit platform from Win7 32-bit

Same path: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies]

Instead of "Add new DWORD value "NoSaveSettings" and set to 0" <-- DWORD is a 32-bit value

Instead, do this:
"Add new QWORD (64-bit value) as "NoSaveSettings" and set to 0

I tested this shutting down and booting up using 3 monitors in all possible combinations with no icon shifting
e.g.
Shut down with 3 monitors, boot up with 1
Shutdown with 3, boot up with 2
etc...

Works perfectly.
m
0
l