Sign in with
Sign up | Sign in
Your question

no boot question

Last response: in Systems
Share
Anonymous
a b B Homebuilt system
October 3, 2004 7:28:59 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

I have a cdrom and a sata drive. I connected the cdrom the the ide2 slot and
the sata following the instructions of the mboard manual and western digital
writeup.

I have configured the bios so that the first boot disk is cdrom. However,
when I set the cdrom as slave, the system starts up and then gives the
following errors
PXE-E61 Media test failure - check cables
PXE-MOF Exiting NVidia boot
Disk Boot Failure, Insert System Disk and press enter

The Western Digital setup instructs to set the cdrom as the first boot drive
and put the setup cd in there so that the drive can be setup. But it never
gets to that stage.

When I set the cdrom jumper to master - still connecting it to the ide2
slot - after startup it shows the following message and just hangs there

Detecting ide drives....

Then I tried connecting the cdrom to ide1 - still as master, the system does
not hang while detecting the ide drives, but it produces the PXE-E61 error
message and reports disk boot failure.

What am I missing in the setup? Also the list of IDE devices does not show
the cdrom drive. It shows IDE1 Master None, IDE2 Slave None....etc..

I tried again doing the following:

1. Added a floppy drive to the system
2. Changed BIOS so that it first tries to boot from floppy then cdrom and
then hdd.
3. Created a boot disk from the western digital driver utility cd and
inserted it in the floppy.

When I started the system, this time it started reading from the floppy, and
printed messages that it is reading a DR DOS boot disk etc, but then just
hung there. The floppy drive light remained green throughout till I hit the
power button.

When I look at the diagnostic LED all the ligts are green indicating that
the system is booting.

My system info:
AMD Athlon 64 3200+ with the standard retail heatsink
MSI K8N Neo FSR mainboard BIOS v1.3
Antec TruPower 380 W PSU
Leadtek WinFast NVidia GeForce FX 5200 AGP Card
1 GB Patriot Ram
160GB SATA drive Western Digital
1 BTC 52241M CDROM drive
1 standard floppy drive

Thanks for any help.

Shantanu Sen

More about : boot question

Anonymous
a b B Homebuilt system
October 3, 2004 9:01:26 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

I would try the following:

1. If you are not intending to have a floppy drive in the system, remove it
and make sure that BIOS knows there is no drive - usually this is in the
section called "Basic BIOS Setup" or some similar name, i.e. the first page
in BIOS. Make sure that it has "none" for for drive A and drive B. Also
wherever the "seek floppy drive at boot" option is (often the next page) set
that to "No" to be sure.

2. Connect your CD-ROM to ATAPI/IDE channel 1, that is to say, the 'primary'
or 'first' channel, usually marked IDE1 on m/bs but sometimes 'PRI' or
"Primary" etc. Use a modern 80 connector (ATA-66/100/133) cable and set the
drive to Cable Select (CS) then connect it to the connector at the end of
the cable. This should be coloured black. The connector to the motherboard
should be red, green, blue or some colour other than grey or black. Though
it might be black as well. If you are unsure, the longest part of the cable
should be the stretch from the board to the SLAVE connector (grey).

3. Connect your power and SATA cables to the Western Digital HDD, this will
of course have no jumpers (or at least none you should need to touch). Then
make sure that in BIOS you have your SATA controller set to "BASE" or "IDE"
mode if you are using this drive singly and not as part of a RAID 0 / RAID 1
array.

If you have problems still, disable the SATA controller in BIOS and attempt
to boot something such as a Windows XP / Linux disc in the CD-ROM. This
will at least tell you that you have a bootable setup and the CD-ROM is
correctly set and recognized. We can take it from there...

John
Anonymous
a b B Homebuilt system
October 3, 2004 10:29:00 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

WOW....

I did the following with my bios settings

1st boot device cdrom
2nd boot device hard disk
3rd - disabled.

ide primary master none
ide primary slave none
ide sec master none
ide sec slave none
ide third master none
ide fourth master none
drive A none
video ega/vga

ide function setup->
onchip ide channel 1 enabled
sata3/sata4 dma transfer disabled
ide dma transfer access enabled

onboard device ->
sata3/sata4 disabled

then I rebooted and it started reading from the cdrom....read the windows xp
64bit beta that I had downloaded and at the end predictably told me that i
did not have any hdd installed...

I then got bolder...changed the bios again to enable the sata3/4 then
connected the sata drive, added the WD provided cdrom into the cdrom
drive - then started the system again...this time it started to read again
from the cdrom drive and then i see the following on the screen

cdrom device driver from ide/atapi ver 1.5....

device name: generic
transfer mode programmed i/o

unit 0 : port = 1F0 IRQ14 <master toshiba cd-rom xm-6602b 1017...
ide cd-rom device driver installed...

then it hung again there...

now the bios says primary master disk - cdrom - which is what I wanted.

I repeated the procedure again with sata3/4 dma transfer enabled (it was
disabled before) and keeping the onboard device->sata3/4 enabled

the same result....it again hung exactly at the same point

I tried again with different cables to the sata drive - so far I was using
the one integrated cable provided by WD, one end fit the sata3/4 connector
and the other end fit both the power connector and the data connector on the
hdd - this time I used 2 cables - one the data connector provided by msi and
the other, the power connector provided by the antec....

still the same hang....at the same place...

question1 :what is the trick about the cable mode settings of the cd-rom?
what is that mode? and when/why is it used?
question 2: does this mean that the mboard sata connector is bad or the hdd
is not compatible with the mboard?

In any case I cannot thank you ENOUGH for this break.....after a long and
frusturated day, I can see some progress.....


thanks again and again...:) 

Shantanu



"Gaidheal" <some.one@some.isp.net> wrote in message
news:cjo135$1gm$1@titan.btinternet.com...
> I would try the following:
>
> 1. If you are not intending to have a floppy drive in the system, remove
it
> and make sure that BIOS knows there is no drive - usually this is in the
> section called "Basic BIOS Setup" or some similar name, i.e. the first
page
> in BIOS. Make sure that it has "none" for for drive A and drive B. Also
> wherever the "seek floppy drive at boot" option is (often the next page)
set
> that to "No" to be sure.
>
> 2. Connect your CD-ROM to ATAPI/IDE channel 1, that is to say, the
'primary'
> or 'first' channel, usually marked IDE1 on m/bs but sometimes 'PRI' or
> "Primary" etc. Use a modern 80 connector (ATA-66/100/133) cable and set
the
> drive to Cable Select (CS) then connect it to the connector at the end of
> the cable. This should be coloured black. The connector to the
motherboard
> should be red, green, blue or some colour other than grey or black.
Though
> it might be black as well. If you are unsure, the longest part of the
cable
> should be the stretch from the board to the SLAVE connector (grey).
>
> 3. Connect your power and SATA cables to the Western Digital HDD, this
will
> of course have no jumpers (or at least none you should need to touch).
Then
> make sure that in BIOS you have your SATA controller set to "BASE" or
"IDE"
> mode if you are using this drive singly and not as part of a RAID 0 / RAID
1
> array.
>
> If you have problems still, disable the SATA controller in BIOS and
attempt
> to boot something such as a Windows XP / Linux disc in the CD-ROM. This
> will at least tell you that you have a bootable setup and the CD-ROM is
> correctly set and recognized. We can take it from there...
>
> John
>
>
Related resources
Can't find your answer ? Ask !
Anonymous
a b B Homebuilt system
October 3, 2004 10:38:25 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

Another thing I forgot to mention...I am using a MSI K8N Neo mboard...I did
not see any way I can specify the SATA controller set to BASE or IDE as you
mentioned...is it specified under any other name?

As I see, I can do the following:

1. Return the hdd and get a new sata drive of different make if my budget
permits. If that also fails, then it would mean that the problem is with the
mboard...right?
2. If the above is true, then I can replace the mboard if I am really hung
up on SATA...but as my mental state is at this point, I am thinking that
I'll go for a IDE udma/133 if that works.

Any comments on these observations?

Thanks again,
Shantanu


"Gaidheal" <some.one@some.isp.net> wrote in message
news:cjo135$1gm$1@titan.btinternet.com...
> I would try the following:
>
> 1. If you are not intending to have a floppy drive in the system, remove
it
> and make sure that BIOS knows there is no drive - usually this is in the
> section called "Basic BIOS Setup" or some similar name, i.e. the first
page
> in BIOS. Make sure that it has "none" for for drive A and drive B. Also
> wherever the "seek floppy drive at boot" option is (often the next page)
set
> that to "No" to be sure.
>
> 2. Connect your CD-ROM to ATAPI/IDE channel 1, that is to say, the
'primary'
> or 'first' channel, usually marked IDE1 on m/bs but sometimes 'PRI' or
> "Primary" etc. Use a modern 80 connector (ATA-66/100/133) cable and set
the
> drive to Cable Select (CS) then connect it to the connector at the end of
> the cable. This should be coloured black. The connector to the
motherboard
> should be red, green, blue or some colour other than grey or black.
Though
> it might be black as well. If you are unsure, the longest part of the
cable
> should be the stretch from the board to the SLAVE connector (grey).
>
> 3. Connect your power and SATA cables to the Western Digital HDD, this
will
> of course have no jumpers (or at least none you should need to touch).
Then
> make sure that in BIOS you have your SATA controller set to "BASE" or
"IDE"
> mode if you are using this drive singly and not as part of a RAID 0 / RAID
1
> array.
>
> If you have problems still, disable the SATA controller in BIOS and
attempt
> to boot something such as a Windows XP / Linux disc in the CD-ROM. This
> will at least tell you that you have a bootable setup and the CD-ROM is
> correctly set and recognized. We can take it from there...
>
> John
>
>
Anonymous
a b B Homebuilt system
October 3, 2004 12:06:11 PM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

Ok, first, a trivial 'Netiquette' point or two.. I mention so that you know
in case you did not, rather than to start a discussion on it:

Only quote a previous post if it is needed and then only quote the parts you
are responding to.

If you do quote an earlier post, your reply goes UNDER it. I.e. no "top
posting" please. This is because it is both logical and natural to have a
reply AFTER whatever elicited the reply. Thanks!

Anyway...

I am not familiar with your specific board and BIOS so this remains
'generic' advice for now..

I would alter your boot device settings so that your second boot device is
'SCSI' if that option is present. Often the on-board SATA controller is
treated as a SCSI device for the purposes of specifying it in BIOS. But
check that 'SATA' is not itself an option, as if it is you obviously want to
use that.

If your CD-ROM is connected to the IDE Primary channel I am surprised that
it is detected with that set at 'none' but it may be that it run a detection
routine for ATAPI optical drives anyway..

Keep DMA modes enable for all devices. There are no modern drives which do
not rely on it. They can all (to my knowledge) operate in PIO (Programmed
Input / Output) modes but this is VERY slow and not how they are designed to
be used.

Shouldn't your SATA port be SATA1? Or does your board only have two, but
label them 3 & 4? If it has ports 1 & 2 the drive ought to be on number 1.

"question1 :what is the trick about the cable mode settings of the cd-rom?
what is that mode? and when/why is it used?"

ATAPI devices use 'Cable Select' to determine whether they are master or
slave on the channel. All modern devices whether optical or hard-drives are
ATAPI compliant and use this. The 'master' and 'slave' settings should only
be used for compatibility with older controllers and cables. If you have an
80 connector cable (one connector will be black, another grey and the one at
the end of the long stretch could be any other colour, but blue is popular)
all devices on the cable should be jumpered for 'CS' which is 'Cable
Select'.

"question 2: does this mean that the mboard sata connector is bad or the hdd
is not compatible with the mboard?"

It could mean anything... most likely it is simply something you have
overlooked in setting up. Don't put that CD from WD in - I can see no
reason you need it at this point as the SATA controller should find the
drive just fine.

"Another thing I forgot to mention...I am using a MSI K8N Neo mboard...I did
not see any way I can specify the SATA controller set to BASE or IDE as you
mentioned...is it specified under any other name?"

It may not be necessary depending on how intelligent the controller is and
how you are supposed to set it up. Have you read the accompanying booklet /
chapter supplied by MSI on the SATA controller? There should be information
in that on how to prepare the system for a SATA drive.

"1. Return the hdd and get a new sata drive of different make if my budget
permits. If that also fails, then it would mean that the problem is with the
mboard...right?"

Not necessarily and that is somewhat drastic.. more accurately it would mean
the problem was NOT with the drive. But it could still mean it was a user
configuration problem, not a board fault.

"2. If the above is true, then I can replace the mboard if I am really hung
up on SATA...but as my mental state is at this point, I am thinking that
I'll go for a IDE udma/133 if that works."

Out of interest.. why do you want a SATA drive anyway? They are not faster,
only the interface is POTENTIALLY faster. Unless you have a very expensive
new drive it won't even 'fill' the ATA-133 interface that your on-board IDE
controller uses. Also, ATA-133 drives are much easier to work with as a
boot drive because they require no special OS drivers and no addition
BIOS/Firmware. I say this as a SATA-150 user, by the way, so it is not a
"Bash SATA" rant.

I shall now see what I can find on your board, since you are obviously
having real problems and I am limited in what I can advise 'blind'.

John
Anonymous
a b B Homebuilt system
October 3, 2004 12:12:13 PM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

Also.. take a look here

http://www.msicomputer.com/support/sup_tshoot.asp

Specifically the section on "No Boot (system does post) SATA configuration"
and make sure you have followed their guidelines.

John
Anonymous
a b B Homebuilt system
October 4, 2004 5:24:19 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

> I would alter your boot device settings so that your second boot device is
> 'SCSI' if that option is present. Often the on-board SATA controller is
> treated as a SCSI device for the purposes of specifying it in BIOS. But
> check that 'SATA' is not itself an option, as if it is you obviously want
to
> use that.
>
There is no SCSI option for this mboard - it is set to HDD

> Shouldn't your SATA port be SATA1? Or does your board only have two, but
> label them 3 & 4? If it has ports 1 & 2 the drive ought to be on number
1.
>
There is a higher version of their mboard - k8n neo platinum, that contains
all 4 SATA connectors.
For this one, there are only 2 and the other two are dummies. For some
inexplicable reason they
chose to keep the SATA3/4 connectors rather than 1/2 with this 'economy'
version of the board.
So the SATA1/2 are just labels on the board - there are no connectors.

> ATAPI devices use 'Cable Select' to determine whether they are master or
> slave on the channel. All modern devices whether optical or hard-drives
are
> ATAPI compliant and use this. The 'master' and 'slave' settings should
only
> be used for compatibility with older controllers and cables. If you have
an
> 80 connector cable (one connector will be black, another grey and the one
at
> the end of the long stretch could be any other colour, but blue is
popular)
> all devices on the cable should be jumpered for 'CS' which is 'Cable
> Select'.
>

In that case, if I want to connect 2 cdrom drives on the same channel,
should I set both as Cable Select?

>> "1. Return the hdd and get a new sata drive of different make if my
budget
>> permits. If that also fails, then it would mean that the problem is with
the
>> mboard...right?"
>
> Not necessarily and that is somewhat drastic.. more accurately it would
mean
> the problem was NOT with the drive. But it could still mean it was a user
> configuration problem, not a board fault.
>

Clearly it is user config error....clearly I did not get into details of
the sata settings....

> Out of interest.. why do you want a SATA drive anyway? They are not
faster,
> only the interface is POTENTIALLY faster. Unless you have a very
expensive
> new drive it won't even 'fill' the ATA-133 interface that your on-board
IDE
> controller uses. Also, ATA-133 drives are much easier to work with as a
> boot drive because they require no special OS drivers and no addition
> BIOS/Firmware. I say this as a SATA-150 user, by the way, so it is not a
> "Bash SATA" rant.
>

A simple reason actually - ignorance. I did not do enough research before
going to buy a hdd. Once
I was at the store, I relied on the numbers specified on the drives - using
the rule of the thumb that
udma100 is slower than ata 133 which is slower than sata 150. And also I
followed the 'general'
assumption that SATA is actually faster than IDE. This was clearly an
incorrect approach in choosing
a HDD.

BTW I finally got it to work - i.e. it can detect the hdd and load the OS
from the bootable CDROM. I did
this by enabling the RAID setting of the - in RAID config there are IDE
RAID,
SATA3 RAID, SATA4 RAID - I set them all to enabled, although I am not sure
that I need to set the IDE
RAID to be enabled or not....I'll experiment with disabling it and see what
happens.

I need to do more readings on the details of RAID and the various
configurations. If you know of any resource
off the top of your head, please post it here.

I have not installed the SATA driver provided by the mboard yet...will do
that as soon as I get the fdd back in,
since it requires a floppy to be there. Somehow the OS thinks that there is
only 152 GB of disk space while
actually it should be 160. I'll install the driver and get an update from
the BIOS to see if that helps.

Thanks for all your help.

Shantanu
Anonymous
a b B Homebuilt system
October 4, 2004 11:04:23 PM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

"In that case, if I want to connect 2 cdrom drives on the same channel,
should I set both as Cable Select?"

You should always use CS with 80 connector cables, the possible exception
being with a device that is old and does not have it or work properly with
it set. In your case this is basically not going to happen. So, in short,
'Yes'.

"Clearly it is user config error....clearly I did not get into details of
the sata settings...."

Welcome to the 'Learning Curve' ;¬)

"A simple reason actually - ignorance. I did not do enough research before
going to buy a hdd. Once
I was at the store, I relied on the numbers specified on the drives - using
the rule of the thumb that udma100 is slower than ata 133 which is slower
than sata 150. And also I followed the 'general' assumption that SATA is
actually faster than IDE. This was clearly an incorrect approach in choosing
a HDD."

They are marketted on these assumptions and the people actually selling in
the shop either don't know any better themselves (usually true) or else have
a vested interest in selling you the latest and greatest and will seek to do
so (often also true). There's nothing wrong with a SATA drive as a sole
drive, I use one myself, but I did so knowing that it was not inherently
faster, that it complicated installation of my OS and intending to add a
second drive later and make a RAID 0 array (which would still complicate OS
installation but was why I used SATA at all). In practice I have not
bothered with the latter. If you are happy with your drive once it is
working with OS installed SATA will be fine for you.

"BTW I finally got it to work - i.e. it can detect the hdd and load the OS
from the bootable CDROM. I did
this by enabling the RAID setting <snip>"

If you have only one drive RAID should be disabled as you cannot possibly be
using it. All RAID configurations involve AT LEAST two drives. In typical
home user machines RAID is limited to a maximum of two which allows RAID 0
and RAID 1 modes. These are "Two Drive Stripe" and "Mirror" respectively.
RAID 0 should be faster than an equivalent single drive of the same capacity
as the two drives combined. RAID 1 is no faster but provides an instant
online backup of data. All other RAID modes use more drives, e.g. RAID 5
uses 3 drives which allows for the data to be completely recovered in the
event one drive fails, whilst also being nearly as fast as RAID 0 and faster
than a single drive with the same effective capacity as the array. RAID 0
by the way is not strictly speaking RAID at all, since there is no
redundancy (data is not in anyway protected - lose a drive lose the data).

"Somehow the OS thinks that there is only 152 GB of disk space while
actually it should be 160. I'll install the driver and get an update from
the BIOS to see if that helps."

It won't and be careful updating BIOS. The OS is correct, '160 Gig' drives
are actually 152 Gb. It stems from an old practice of using thousands
instead of 1024. There are 1024 bytes in a kilobyte, 1024 kilobytes in a
Megabyte, 1024 Megabytes in a Gigabyte. Essentially it is a sales gimmick.

Good luck! John
Anonymous
a b B Homebuilt system
October 5, 2004 12:01:25 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

Gaidheal wrote:

<snip>
>
> It won't and be careful updating BIOS. The OS is correct, '160 Gig' drives
> are actually 152 Gb.

That's what Windows will say, yes.

> It stems from an old practice of using thousands
> instead of 1024.

Yes, the 200 year 'old practice' called the Metric System and the SI
International System of Units.

http://physics.nist.gov/cuu/Units/prefixes.html

Factor Name Symbol
10^24 yotta Y
10^21 zetta Z
10^18 exa E
10^15 peta P
10^12 tera T
10^9 giga G
10^6 mega M
10^3 kilo k
10^2 hecto h
10^1 deka da

Factor Name Symbol
10^-1 deci d
10^-2 centi c
10^-3 milli m
10^-6 micro µ
10^-9 nano n
10^-12 pico p
10^-15 femto f
10^-18 atto a
10^-21 zepto z
10^-24 yocto y

"Because the SI prefixes strictly represent powers of 10, they should not
be used to represent powers of 2. Thus, one kilobit, or 1 kbit, is 1000 bit
and not 2^10 bit = 1024 bit."

> There are 1024 bytes in a kilobyte, 1024 kilobytes in a
> Megabyte, 1024 Megabytes in a Gigabyte. Essentially it is a sales gimmick.

Essentially it's a 'software gimmick' because binary doesn't fit into
decimal. It is, however, an improper use of the prefixes but, when
computers were still 'mystical' things used by the 'select few', it was
simply 'understood' they were being used improperly: 'Our little secret'.

Then came the 'PC' and every Tom, Dick, and Harry, who didn't necessarily
'know', got into the game. The confusion caused by this 'software gimmick'
is real and there *is* a proposal to rectify the misuse of SI units. See here:

http://physics.nist.gov/cuu/Units/binary.html

So, actually, the hard drive manufacturers are entirely, and officially,
correct. You're just supposed to 'understand' that software uses the
prefixes incorrectly. But if you think 'mega' is always 1024 x 1024 in the
'computer world', think again.

From nist.gov:

"The result is that today "everybody" does not "know" what a megabyte is.
When discussing computer memory, most manufacturers use megabyte to mean
2^20 = 1 048 576 bytes, but the manufacturers of computer storage devices
usually use the term to mean 1 000 000 bytes. Some designers of local area
networks have used megabit per second to mean 1 048 576 bit/s, but all
telecommunications engineers use it to mean 10^6 bit/s. And if two
definitions of the megabyte are not enough, a third megabyte of 1 024 000
bytes is the megabyte used to format the familiar 90 mm (3 1/2 inch), "1.44
MB" diskette. The confusion is real, as is the potential for
incompatibility in standards and in implemented systems.

Faced with this reality, the IEEE Standards Board decided that IEEE
standards will use the conventional, internationally adopted, definitions
of the SI prefixes. Mega will mean 1 000 000, except that the base-two
definition may be used (if such usage is explicitly pointed out on a
case-by-case basis) until such time that prefixes for binary multiples are
adopted by an appropriate standards body."

So, in a nutshell, it is not the hard drive manufacturers who have to
'explain' their usage as it's entirely proper. It's those using one of the
'1024 gimmicks' who are required to 'explain' what it is and that their
usage is non standard.

>
> Good luck! John
>
>
Anonymous
a b B Homebuilt system
October 5, 2004 6:00:57 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

"Yes, the 200 year 'old practice' called the Metric System and the SI
International System of Units... <snip>"

Dave, whilst you are correct about the SI system and you list the confusions
that can and do arise because of changes of context, the manufacturers use
the larger number because it looks better, not because they are complying
with a standard. If you investigate the drive size, you will see it still
uses 1024 not 10^3 for kilobytes, so they are not even being consistent with
the choice of 'Binary' or 'SI' usage. Nice try! ;¬)

John
Anonymous
a b B Homebuilt system
October 5, 2004 6:00:58 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

Gaidheal wrote:

> "Yes, the 200 year 'old practice' called the Metric System and the SI
> International System of Units... <snip>"
>
> Dave, whilst you are correct about the SI system and you list the confusions
> that can and do arise because of changes of context, the manufacturers use
> the larger number because it looks better, not because they are complying
> with a standard.

Really? Did I miss the black hose under bright light beatings where they
'confessed'? Or did Spock do a mind meld?

Seriously, a hard drive is not inherently 'binary' (like, say, contiguous
system RAM is). It's data content is sectors per track over a number of
tracks per surface and a number of surfaces; none of which is dictated by a
'binary' relationship. e.g. 3 platters with 6 heads is not 'binary'. And
engineers will, quite normally and understandably, multiply perfectly fine
decimal numbers together to end up with a perfectly fine decimal result: X
bytes per sector times Y sectors per track (except this one varies) times A
tracks per surface times B surfaces. You end up with gigabytes: The REAL one.

That's not a 'marketing gimmick': it's simply the truth of the numbers.

> If you investigate the drive size, you will see it still
> uses 1024 not 10^3 for kilobytes, so they are not even being consistent with
> the choice of 'Binary' or 'SI' usage. Nice try! ;¬)

Investigate 'where' and with 'what'?

Windows WILL tell you the real number. Just do a properties on your drive,
or any file for that matter. It gives you the size in both '1024ese' and
the 'real' size.

This 120 Gig drive I'm using right now:
"Capacity 120,031,478,272bytes 111GB"

You will also note that 120,031,478,272 is NOT a power of two (nor is 111),
no matter how you look at it, nor is 40 gigabytes, nor 80 gigabytes, nor
160 gigabytes, nor most 'normal' drive sizes.

It's only a mystery if one doesn't know that 'GB' isn't really gigabytes.


>
> John
>
>
Anonymous
a b B Homebuilt system
October 5, 2004 8:35:18 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

On Mon, 04 Oct 2004 22:13:43 -0500, David Maynard
<dNOTmayn@ev1.net> wrote:


>Seriously, a hard drive is not inherently 'binary'

What number system does your use for data then?
Anonymous
a b B Homebuilt system
October 5, 2004 8:35:19 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

kony wrote:

> On Mon, 04 Oct 2004 22:13:43 -0500, David Maynard
> <dNOTmayn@ev1.net> wrote:
>
>
>
>>Seriously, a hard drive is not inherently 'binary'
>
>
> What number system does your use for data then?

Any number system that I feel like. The hard drive don't care. And I some
times get real fancy and store things like alpha characters on it =:o )
Anonymous
a b B Homebuilt system
October 5, 2004 9:05:42 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

Dave, if you didn't realize they still use 1024 in the kb they multiply up
from, just admit it. If you don't know how to investigate it, why pretend
to be an expert on the topic? It's really quite obvious how, actually.

Your first reply bordered on an attempt at flame, the second is just silly
as you obviously don't realize how they came up with the numbers and why
they don't make sense under either convention. As for it being a marketting
gimmick... if you think the engineers deliberately chose to use a mish-mash
of bases for giving the capacity you are free to think so. I know several
who say they would prefer it used the 1024=kilo ('Binary') system, but would
be happy to use SI. What noone likes and what is genuinely confusing and
can only be either incompetence or marketting, is using 1024=k for
determining kilobytes and then 1000 as the quantity on which successive
prefix are generated.

Next time, just admit you didn't know as much as you made out or actually
bother to do the maths so you don't embarass yourself.

John
Anonymous
a b B Homebuilt system
October 5, 2004 9:05:43 AM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

Gaidheal wrote:

> Dave, if you didn't realize they still use 1024 in the kb they multiply up
> from, just admit it. If you don't know how to investigate it, why pretend
> to be an expert on the topic? It's really quite obvious how, actually.

Then why didn't you 'explain' it when asked?


> Your first reply bordered on an attempt at flame, the second is just silly
> as you obviously don't realize how they came up with the numbers and why
> they don't make sense under either convention. As for it being a marketting
> gimmick... if you think the engineers deliberately chose to use a mish-mash
> of bases for giving the capacity you are free to think so. I know several
> who say they would prefer it used the 1024=kilo ('Binary') system, but would
> be happy to use SI. What noone likes and what is genuinely confusing and
> can only be either incompetence or marketting, is using 1024=k for
> determining kilobytes and then 1000 as the quantity on which successive
> prefix are generated.

I have no idea what you think lord knows who told you about what but since
you've as much as claimed I'm a math idiot, without having done so much as
multiply even two numbers together yourself, why don't you 'explain' it all
to us instead of just foot stomping 'they do it, they do it, they do it'?

>
> Next time, just admit you didn't know as much as you made out or actually
> bother to do the maths so you don't embarass yourself.

http://www.westerndigital.com/en/products/current/drive...

My WD 120 gigabyte drive has 234,441,648 sectors of 512 bytes each. That
multiplies out, in decimal, to 120,034,123,776, the the advertised "120
gigabytes," rounded, of course.

If they were doing as you claim, using 1024 as the 'base K', it would come
out as 117,220,824,000 and advertised as 117 gigabytes. That isn't what
they're doing with MY drive and it isn't what windows is doing.

Now, if YOU'VE got a drive doing this '1024 base K' thingie then it sure as
heck isn't a very good 'marketing gimmick', now is it?

Your turn. Let's see some numbers.


>
> John
>
>
Anonymous
a b B Homebuilt system
October 5, 2004 12:24:32 PM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

"Gaidheal" <some.one@some.isp.net> wrote in message
news:cjs6rm$amq$1@hercules.btinternet.com...
> If you have only one drive RAID should be disabled as you cannot possibly
be
> using it. All RAID configurations involve AT LEAST two drives. In
typical
> home user machines RAID is limited to a maximum of two which allows RAID 0
> and RAID 1 modes. These are "Two Drive Stripe" and "Mirror" respectively.
> RAID 0 should be faster than an equivalent single drive of the same
capacity
> as the two drives combined. RAID 1 is no faster but provides an instant
> online backup of data. All other RAID modes use more drives, e.g. RAID 5
> uses 3 drives which allows for the data to be completely recovered in the
> event one drive fails, whilst also being nearly as fast as RAID 0 and
faster
> than a single drive with the same effective capacity as the array. RAID 0
> by the way is not strictly speaking RAID at all, since there is no
> redundancy (data is not in anyway protected - lose a drive lose the data).
>

Yes, I finally installed the supplied SATA drivers for win XP and disabled
the RAID settings. It is booting fine now and
looking at the CDROM as the first bootable drive.

I have another issue now though, but I'll post that on a separate topic.

Thanks for all the help.

Shantanu
Anonymous
a b B Homebuilt system
October 5, 2004 1:14:49 PM

Archived from groups: alt.comp.hardware.homebuilt (More info?)

<plonk>
!