How to troubleshoot jerky video output?

Archived from groups: alt.comp.hardware.homebuilt (More info?)

I have a LeadTek WinFast A 340T AGP Video card (nVidia GeForce FX5200) on a
system that I recently built. I just bought a Samsung 16x DVD ROM drive and
tried testing the video. I am seeing that the video output is slightly
jerky. It is clearly noticeable when watching flowing water - after every
3/4 seconds there is a fraction of a second pause before it continues again.
It is also noticeable when the camera is panning a scene, when a person is
running etc.

Can someone suggest how can I troubleshoot this? I un-installed all video
card related software (including the dirvers) and installed the latest
direct x from the micorsoft website. Then I re-installed the video card
driver again. Then I installed power dvd.

I still see the same problem. Can it be related to the dvd rom drive? What
else should I check?

Tried moving the windows hardware acceleration down one notch - did not
help.
Tried setting AGB FastWrite in BIOS to disabled - did not help.

Here is my system info:
AMD Athlon 64 3200+ with the standard retail heatsink on socket 754
MSI K8N Neo FSR mainboard BIOS v1.4
Antec TruPower 380 W PSU and Antec Sonata case
Leadtek WinFast NVidia GeForce FX 5200 AGP Card
1 GB Patriot Ram
160GB SATA drive Western Digital
1 Samsung 16X TS-H352A DVD ROM Drive hooked on to IDE1
1 standard floppy drive
Windows XP


Thanks,
Shantanu Sen
7 answers Last reply
More about troubleshoot jerky video output
  1. Archived from groups: alt.comp.hardware.homebuilt (More info?)

    Shantanu Sen wrote:
    >
    > I have a LeadTek WinFast A 340T AGP Video card (nVidia GeForce FX5200) on a
    > system that I recently built. I just bought a Samsung 16x DVD ROM drive and
    > tried testing the video. I am seeing that the video output is slightly
    > jerky. It is clearly noticeable when watching flowing water - after every
    > 3/4 seconds there is a fraction of a second pause before it continues again.
    > It is also noticeable when the camera is panning a scene, when a person is
    > running etc.
    >
    > Can someone suggest how can I troubleshoot this? I un-installed all video
    > card related software (including the dirvers) and installed the latest
    > direct x from the micorsoft website. Then I re-installed the video card
    > driver again. Then I installed power dvd.
    >
    > I still see the same problem. Can it be related to the dvd rom drive? What
    > else should I check?
    >
    > Tried moving the windows hardware acceleration down one notch - did not
    > help.
    > Tried setting AGB FastWrite in BIOS to disabled - did not help.
    >
    > Here is my system info:
    > AMD Athlon 64 3200+ with the standard retail heatsink on socket 754
    > MSI K8N Neo FSR mainboard BIOS v1.4
    > Antec TruPower 380 W PSU and Antec Sonata case
    > Leadtek WinFast NVidia GeForce FX 5200 AGP Card
    > 1 GB Patriot Ram
    > 160GB SATA drive Western Digital
    > 1 Samsung 16X TS-H352A DVD ROM Drive hooked on to IDE1
    > 1 standard floppy drive
    > Windows XP
    >
    > Thanks,
    > Shantanu Sen


    Hi,

    Why would you want to watch water flowing? Sorry, just kidding :)!!

    It sounds like your DVD drive is set for "PIO" instead of "UDMA". Check
    your Properties for Primary or Secondary IDE Channel (wherever your DVD
    drive is connected) in Device Manager (right click My Computer ->
    Properties -> Device Manager). Once in Properties, click the "Advanced
    Settings" tab, and make sure that you have "DMA if available" selected
    in the dropdown box. Click OK, etc., and you may need to reboot. Then
    go back into Properties again and see what the grayed-out "Current
    Transfer Mode" says. It should be "Ultra DMA" or something similar. If
    it says "PIO", you'll need to figure out how to get the IDE channel into
    PIO mode, possibly need new drivers for the chipset, etc.

    Jim
  2. Archived from groups: alt.comp.hardware.homebuilt (More info?)

    > > Here is my system info:
    > > AMD Athlon 64 3200+ with the standard retail heatsink on socket 754
    > > MSI K8N Neo FSR mainboard BIOS v1.4
    > > Antec TruPower 380 W PSU and Antec Sonata case
    > > Leadtek WinFast NVidia GeForce FX 5200 AGP Card
    > > 1 GB Patriot Ram
    > > 160GB SATA drive Western Digital
    > > 1 Samsung 16X TS-H352A DVD ROM Drive hooked on to IDE1
    > > 1 standard floppy drive
    > > Windows XP
    > >
    > > Thanks,
    > > Shantanu Sen
    >
    >
    > Hi,
    >
    > Why would you want to watch water flowing? Sorry, just kidding :)!!
    >
    > It sounds like your DVD drive is set for "PIO" instead of "UDMA". Check
    > your Properties for Primary or Secondary IDE Channel (wherever your DVD
    > drive is connected) in Device Manager (right click My Computer ->
    > Properties -> Device Manager). Once in Properties, click the "Advanced
    > Settings" tab, and make sure that you have "DMA if available" selected
    > in the dropdown box. Click OK, etc., and you may need to reboot. Then
    > go back into Properties again and see what the grayed-out "Current
    > Transfer Mode" says. It should be "Ultra DMA" or something similar. If
    > it says "PIO", you'll need to figure out how to get the IDE channel into
    > PIO mode, possibly need new drivers for the chipset, etc.
    >
    > Jim

    I looked at the primary IDE channel (that is where the DVD drive is
    connected). It said 'Let BIO select transfer mode' and the Transfer
    mode showed Ultra DMA2 - Ultra 33'.

    I changed it to Ultra-DMA 1 - but that did not help. The other options
    in the transfer mode for this drive are Ultra DMA 0, MultiWord DMA
    2/1/0 and PIO Mode.

    In my BIOS settings in the IDE function setup it shows the following:
    Onchip IDE Channel 0 Enabled
    Primary Master PIO Auto (the other values here are Mode 0/1/2 - no
    diable)
    Primary Slave PIO Auto
    Primary Master UDMA Auto
    Primary Slage UDMA Auto

    Anything else I can experiment with?

    Thanks,
    Shantanu
  3. Archived from groups: alt.comp.hardware.homebuilt (More info?)

    "Shantanu Sen" wrote:
    >
    > Anything else I can experiment with?

    I would start by disabling as many background applications as possible, disabling
    "Indexing Service" and "System Restore", and see if the problem goes away. Look at
    the Task Manager under the "Performance" tab and see if the CPU usage history shows
    usage in the frequency you describe, to find out if it is an application causing the
    issue..

    Jon
  4. Archived from groups: alt.comp.hardware.homebuilt (More info?)

    Shantanu Sen wrote:

    > I looked at the primary IDE channel (that is where the DVD drive is
    > connected). It said 'Let BIO select transfer mode' and the Transfer
    > mode showed Ultra DMA2 - Ultra 33'.
    >
    > I changed it to Ultra-DMA 1 - but that did not help. The other options
    > in the transfer mode for this drive are Ultra DMA 0, MultiWord DMA
    > 2/1/0 and PIO Mode.
    >
    > In my BIOS settings in the IDE function setup it shows the following:
    > Onchip IDE Channel 0 Enabled
    > Primary Master PIO Auto (the other values here are Mode 0/1/2 - no
    > diable)
    > Primary Slave PIO Auto
    > Primary Master UDMA Auto
    > Primary Slage UDMA Auto
    >
    > Anything else I can experiment with?

    What does it say in the Device Manager?
  5. Archived from groups: alt.comp.hardware.homebuilt (More info?)

    Ruel Smith wrote:

    > Shantanu Sen wrote:
    >
    >
    >>I looked at the primary IDE channel (that is where the DVD drive is
    >>connected). It said 'Let BIO select transfer mode' and the Transfer
    >>mode showed Ultra DMA2 - Ultra 33'.
    >>
    >>I changed it to Ultra-DMA 1 - but that did not help. The other options
    >>in the transfer mode for this drive are Ultra DMA 0, MultiWord DMA
    >>2/1/0 and PIO Mode.
    >>
    >>In my BIOS settings in the IDE function setup it shows the following:
    >>Onchip IDE Channel 0 Enabled
    >>Primary Master PIO Auto (the other values here are Mode 0/1/2 - no
    >>diable)
    >>Primary Slave PIO Auto
    >>Primary Master UDMA Auto
    >>Primary Slage UDMA Auto
    >>
    >>Anything else I can experiment with?
    >
    >
    > What does it say in the Device Manager?
    >
    You should also have DMA Settings in the BIOS. You should be able to
    choose DMA 5 for the hard drive at least. I would force the auto
    settings to the highest.

    You should have a chipset driver disk for your motherboard. If you do
    not download it from the manufacturer. This is suppose to be used after
    XP is installed. If this is an Nforce 3 board install the Nvidia
    drivers. If this is a VIA Motherboard try installing your 4-in-1
    drivers or whatever via is using.
  6. Archived from groups: alt.comp.hardware.homebuilt (More info?)

    Last Boy Scout <eggbtr@charter.net> wrote in message news:<10n2eoodjrmt8f5@corp.supernews.com>...
    > Ruel Smith wrote:
    >
    > > Shantanu Sen wrote:
    > >
    > >
    > >>I looked at the primary IDE channel (that is where the DVD drive is
    > >>connected). It said 'Let BIO select transfer mode' and the Transfer
    > >>mode showed Ultra DMA2 - Ultra 33'.
    > >>
    > >>I changed it to Ultra-DMA 1 - but that did not help. The other options
    > >>in the transfer mode for this drive are Ultra DMA 0, MultiWord DMA
    > >>2/1/0 and PIO Mode.
    > >>
    > >>In my BIOS settings in the IDE function setup it shows the following:
    > >>Onchip IDE Channel 0 Enabled
    > >>Primary Master PIO Auto (the other values here are Mode 0/1/2 - no
    > >>diable)
    > >>Primary Slave PIO Auto
    > >>Primary Master UDMA Auto
    > >>Primary Slage UDMA Auto
    > >>
    > >>Anything else I can experiment with?
    > >
    > >
    > > What does it say in the Device Manager?
    > >
    > You should also have DMA Settings in the BIOS. You should be able to
    > choose DMA 5 for the hard drive at least. I would force the auto
    > settings to the highest.
    >
    > You should have a chipset driver disk for your motherboard. If you do
    > not download it from the manufacturer. This is suppose to be used after
    > XP is installed. If this is an Nforce 3 board install the Nvidia
    > drivers. If this is a VIA Motherboard try installing your 4-in-1
    > drivers or whatever via is using.


    I had installed the drivers that came in with the board after
    installing XP. Then I reinstalled after pulling the upgraded drivers
    from the msi web site.

    I would always see that my CPU was working at 13% even though I was
    doing nothing - the taskmanager would show the System Idle Process
    hogging that 13%. I have no clue what was the problem.

    Anyway, 2/3 days after posting my last post here, when I was
    absolutely decided on returning the card, I started the system one
    evening and the problem was gone! The CPU no longer hogs 13% any more
    when I do nothing. The graphics has no jerks any more. Till date the
    problem has no reappeared again.

    To this day, I have no clue what the real problem was. I'll be
    re-installing the os and repartitioning the disk for hosting multiple
    OS in the near future - I hope I do not hit the problem again. Clearly
    it is a driver issue, but I am not sure what...

    Thanks,
    Shantanu
  7. Archived from groups: alt.comp.hardware.homebuilt (More info?)

    > I had installed the drivers that came in with the board after
    > installing XP. Then I reinstalled after pulling the upgraded drivers
    > from the msi web site.
    >
    > I would always see that my CPU was working at 13% even though I was
    > doing nothing - the taskmanager would show the System Idle Process
    > hogging that 13%. I have no clue what was the problem.
    >
    > Anyway, 2/3 days after posting my last post here, when I was
    > absolutely decided on returning the card, I started the system one
    > evening and the problem was gone! The CPU no longer hogs 13% any more
    > when I do nothing. The graphics has no jerks any more. Till date the
    > problem has no reappeared again.
    >
    > To this day, I have no clue what the real problem was. I'll be
    > re-installing the os and repartitioning the disk for hosting multiple
    > OS in the near future - I hope I do not hit the problem again. Clearly
    > it is a driver issue, but I am not sure what...
    >
    > Thanks,
    > Shantanu

    System Idle Process should be high. Mine's at 99%. It runs when
    nothing else is running, to give your CPU something to do.

    I know what you mean, though. I hate it when some driver chews up
    20% or 30% of my CPU cycles, for nothing. Has happened to me a few
    times. Iomega ZIP Drive software was bad -- never install it, you
    don't need it, even if you use a ZIP drive. Once, I downloaded an
    upgrade for my nVidia video driver, and the CPU use went up to 70%
    on one of the processes! It slowed everything down. I was lucky
    enough to be able to downgrade the driver and get things back to
    normal that time. Sometmes, it's almost impossible to recover CPU
    cycles wasted by bad code, and they put a drag on performance.
Ask a new question

Read More

Homebuilt Video Systems