How to install tascam us 122 on window 8

I know that drivers for tascam us-122 are not available on windows 8 but is there any way I can install them?
32 answers Last reply
More about install tascam window
  1. kitandrew said:
    I know that drivers for tascam us-122 are not available on windows 8 but is there any way I can install them?

    Not available means, not available, ie not supported under windows 8.
    PS: You triple posted this. Refrain from doing that in the future, please !
  2. Hey, it IS possible! There is no Windows 8 driver because it is not needed. Windows 8 has a special feature for program compatibility. I just installed Tascam US-122 on my Windows 8 HP Pavilion g6 laptop.

    1) Go to http://tascam.com/product/us-122/downloads/ and download Windows Drivers v.3.40 Windows Vista and XP driver. Unzip it.

    2) In Control Panel/Programs/Programs and Features choose Run Programs Made for Previous Versions of Windows. It will open Program Compatibility Troubleshooter. Click Next.

    3) Your US-122 driver will not be listed there, so choose Not Listed and browse for it your downloads folder. You need the .exe file - in my case it did not show .exe extension, but it will show up once you choose it (remember, upzip first!).

    4) Program Compatibility Troubleshooter will ask you to select Troubleshooting Option. Click on Troubleshoot Program.

    5) When asked "What problems do you experience?" click on first - "The program worked in earlier versions of Windows but won't install or run now."

    6) When asked for previous version of windows, choose "I don't know". Another window opens, asking your permission to install Tascam.

    7) You will then have to install Tascam. Click Yes throughout.

    8) Finally, it is time to plug it in! After you have plugged USB into laptop, go to Control Panel/Hardware and Sound/Sound/Manage audio devices. Choose US-122 as your default device for playback and recording, click Apply, then - OK. Done! :sol:
  3. Blackadder75 said:
    Hey, it IS possible! There is no Windows 8 driver because it is not needed. Windows 8 has a special feature for program compatibility. I just installed Tascam US-122 on my Windows 8 HP Pavilion g6 laptop.

    1) Go to http://tascam.com/product/us-122/downloads/ and download Windows Drivers v.3.40 Windows Vista and XP driver. Unzip it.

    2) In Control Panel/Programs/Programs and Features choose Run Programs Made for Previous Versions of Windows. It will open Program Compatibility Troubleshooter. Click Next.

    3) Your US-122 driver will not be listed there, so choose Not Listed and browse for it your downloads folder. You need the .exe file - in my case it did not show .exe extension, but it will show up once you choose it (remember, upzip first!).

    4) Program Compatibility Troubleshooter will ask you to select Troubleshooting Option. Click on Troubleshoot Program.

    5) When asked "What problems do you experience?" click on first - "The program worked in earlier versions of Windows but won't install or run now."

    6) When asked for previous version of windows, choose "I don't know". Another window opens, asking your permission to install Tascam.

    7) You will then have to install Tascam. Click Yes throughout.

    8) Finally, it is time to plug it in! After you have plugged USB into laptop, go to Control Panel/Hardware and Sound/Sound/Manage audio devices. Choose US-122 as your default device for playback and recording, click Apply, then - OK. Done! :sol:
  4. hi blackadder75! i'm from mexico. i got a Tascam us-2000 with cubase le5 included and i have the same problem kitandrew has. my computer is a dell inspiron windows 8 (64bits). i know there's no drivers for windows8 in this moment, the us-122 took my atantion. what do you think? could i resolve this problem with my us-2000? if it is possible, what is the step by step? i'm really interested about it and waiting for your suggestions. Greetings from México City...of chaos!
  5. Hello mate,

    I don't know about us-200 exactly, as I have the us-122. I would imagine it would work the same way. Have tried following the steps I've given in the first post?

    The idea behind not having Windows 8 drivers is simple - THEY ARE NOT NEEDED. Windows 8 allows your computer to work with older software and/hardware as if it were a Windows 7 or older. I am not sure how universal this rule is, but generally that is the case. Try doing the same I did on mine, and let us know.

    Hail from UK!

    :hello:
  6. Hello over there man!

    Thanks a lot! I'll do it and notice you later. I hope it will works, we will see.
  7. I inform you that follow each of the steps for the installation of the Tascam US-122 but it did not help as I still see Can not install on this version of windows .. I went to troubleshooter and follow each of the steps, seeing that not work look more about how to operate the plant and found that the properties could find compatibility settings and appeared windows vista, windows 7, windows xp , service pack 1, 2 and 3 .. I tested each and every one of them but it did not work, I have a Hp Pavilion G4 Notebook PC with windows 8 .. I'm a musician and I need to work this program Tascam US-122 to work on home projects I have in mind in addition to some more projects, I hope your answer soon .. Greetings from Mexico, SumGLAM


    Blackadder75 said:
    Hey, it IS possible! There is no Windows 8 driver because it is not needed. Windows 8 has a special feature for program compatibility. I just installed Tascam US-122 on my Windows 8 HP Pavilion g6 laptop.

    1) Go to http://tascam.com/product/us-122/downloads/ and download Windows Drivers v.3.40 Windows Vista and XP driver. Unzip it.

    2) In Control Panel/Programs/Programs and Features choose Run Programs Made for Previous Versions of Windows. It will open Program Compatibility Troubleshooter. Click Next.

    3) Your US-122 driver will not be listed there, so choose Not Listed and browse for it your downloads folder. You need the .exe file - in my case it did not show .exe extension, but it will show up once you choose it (remember, upzip first!).

    4) Program Compatibility Troubleshooter will ask you to select Troubleshooting Option. Click on Troubleshoot Program.

    5) When asked "What problems do you experience?" click on first - "The program worked in earlier versions of Windows but won't install or run now."

    6) When asked for previous version of windows, choose "I don't know". Another window opens, asking your permission to install Tascam.

    7) You will then have to install Tascam. Click Yes throughout.

    8) Finally, it is time to plug it in! After you have plugged USB into laptop, go to Control Panel/Hardware and Sound/Sound/Manage audio devices. Choose US-122 as your default device for playback and recording, click Apply, then - OK. Done! :sol:
  8. Blackadder75 said:
    Hey, it IS possible! There is no Windows 8 driver because it is not needed. Windows 8 has a special feature for program compatibility. I just installed Tascam US-122 on my Windows 8 HP Pavilion g6 laptop.

    1) Go to http://tascam.com/product/us-122/downloads/ and download Windows Drivers v.3.40 Windows Vista and XP driver. Unzip it.

    2) In Control Panel/Programs/Programs and Features choose Run Programs Made for Previous Versions of Windows. It will open Program Compatibility Troubleshooter. Click Next.

    3) Your US-122 driver will not be listed there, so choose Not Listed and browse for it your downloads folder. You need the .exe file - in my case it did not show .exe extension, but it will show up once you choose it (remember, upzip first!).

    4) Program Compatibility Troubleshooter will ask you to select Troubleshooting Option. Click on Troubleshoot Program.

    5) When asked "What problems do you experience?" click on first - "The program worked in earlier versions of Windows but won't install or run now."

    6) When asked for previous version of windows, choose "I don't know". Another window opens, asking your permission to install Tascam.

    7) You will then have to install Tascam. Click Yes throughout.

    8) Finally, it is time to plug it in! After you have plugged USB into laptop, go to Control Panel/Hardware and Sound/Sound/Manage audio devices. Choose US-122 as your default device for playback and recording, click Apply, then - OK. Done! :sol:


    gess sanx said:
    Blackadder75 said:
    Hey, it IS possible! There is no Windows 8 driver because it is not needed. Windows 8 has a special feature for program compatibility. I just installed Tascam US-122 on my Windows 8 HP Pavilion g6 laptop.

    1) Go to http://tascam.com/product/us-122/downloads/ and download Windows Drivers v.3.40 Windows Vista and XP driver. Unzip it.

    2) In Control Panel/Programs/Programs and Features choose Run Programs Made for Previous Versions of Windows. It will open Program Compatibility Troubleshooter. Click Next.

    3) Your US-122 driver will not be listed there, so choose Not Listed and browse for it your downloads folder. You need the .exe file - in my case it did not show .exe extension, but it will show up once you choose it (remember, upzip first!).

    4) Program Compatibility Troubleshooter will ask you to select Troubleshooting Option. Click on Troubleshoot Program.

    5) When asked "What problems do you experience?" click on first - "The program worked in earlier versions of Windows but won't install or run now."

    6) When asked for previous version of windows, choose "I don't know". Another window opens, asking your permission to install Tascam.

    7) You will then have to install Tascam. Click Yes throughout.

    8) Finally, it is time to plug it in! After you have plugged USB into laptop, go to Control Panel/Hardware and Sound/Sound/Manage audio devices. Choose US-122 as your default device for playback and recording, click Apply, then - OK. Done! :sol:




    This instruction worked for me!!! It was a little confusing but after I got used to the stupid Windows 8 software I managed to get my Tascam working and recording. I'm using Sony recording software with it and everything works great. I used to use Magix recording software but I switched this time. I was so relieved when it was working I wanted to cry. Thank you sooooo much for your help!!!! My name is Nicole
  9. This instruction worked for me!!! It was a little confusing but after I got used to the stupid Windows 8 software I managed to get my Tascam working and recording. I'm using Sony recording software with it and everything works great. I used to use Magix recording software but I switched this time. I was so relieved when it was working I wanted to cry. Thank you sooooo much for your help!!!! My name is Nicole

    1) Go to http://tascam.com/product/us-122/downloads/ and download Windows Drivers v.3.40 Windows Vista and XP driver. Unzip it.

    2) In Control Panel/Programs/Programs and Features choose Run Programs Made for Previous Versions of Windows. It will open Program Compatibility Troubleshooter. Click Next.

    3) Your US-122 driver will not be listed there, so choose Not Listed and browse for it your downloads folder. You need the .exe file - in my case it did not show .exe extension, but it will show up once you choose it (remember, upzip first!).

    4) Program Compatibility Troubleshooter will ask you to select Troubleshooting Option. Click on Troubleshoot Program.

    5) When asked "What problems do you experience?" click on first - "The program worked in earlier versions of Windows but won't install or run now."

    6) When asked for previous version of windows, choose "I don't know". Another window opens, asking your permission to install Tascam.

    7) You will then have to install Tascam. Click Yes throughout.

    8) Finally, it is time to plug it in! After you have plugged USB into laptop, go to Control Panel/Hardware and Sound/Sound/Manage audio devices. Choose US-122 as your default device for playback and recording, click Apply, then - OK. Done! :sol:
  10. I tried to follow the method above on an i7 running Win 8 in 64 bit, but it didn't seem to be getting me anywhere. I kept getting messages that the software was an incorrect version. With nothing to lose, I thought perhaps the process most likely to work was to use the Vista compatibility settings (on the expectation that not that much has changed since then, but a lot has changed since XP). It worked! So it seems that it's worth messing about. Thanks for letting me know it was possible - I mightn't have persevered without that!
  11. Hi all
    My problem was not solved with ANY "us-122" drivers in ANY compatibility mode.

    But what DID actually work was installing the driver :

    US-122mkII & US-144mkII Drivers for Windows 7, Vista, XP driver ver 2.03 (64-bit) - 1.76 MB

    at the page :

    http://tascam.com/product/us-122mkii/downloads/


    This is the driver for the model US-122MKII.
    As always: Download, unzip, right click the app file called "Setup" and go to "properties" of file.
    Then to second tab, the"compatibility" tab.
    I checked the box "run as administrator" and also the box "run this program in compatibility mode for".
    There I chose Vista, because the file i downloaded (tascam_us_122_144mk2_win64_203) said it was for vista. (Oh..... I have 64b Windows. If you have 32b download the 32b driver instead)


    And luckily it works! My friend who has the 144 model also used the equivalent driver.
    The system recognizes the card as "us-122" not as mk2, so my guess is that TASCAM obviously made this driver to work for this card as well, but never bothered to state it on their site.....

    Hope it helps others :)
  12. Blackadder75 said:
    Hey, it IS possible! There is no Windows 8 driver because it is not needed. Windows 8 has a special feature for program compatibility. I just installed Tascam US-122 on my Windows 8 HP Pavilion g6 laptop.

    1) Go to http://tascam.com/product/us-122/downloads/ and download Windows Drivers v.3.40 Windows Vista and XP driver. Unzip it.

    2) In Control Panel/Programs/Programs and Features choose Run Programs Made for Previous Versions of Windows. It will open Program Compatibility Troubleshooter. Click Next.

    3) Your US-122 driver will not be listed there, so choose Not Listed and browse for it your downloads folder. You need the .exe file - in my case it did not show .exe extension, but it will show up once you choose it (remember, upzip first!).

    4) Program Compatibility Troubleshooter will ask you to select Troubleshooting Option. Click on Troubleshoot Program.

    5) When asked "What problems do you experience?" click on first - "The program worked in earlier versions of Windows but won't install or run now."

    6) When asked for previous version of windows, choose "I don't know". Another window opens, asking your permission to install Tascam.

    7) You will then have to install Tascam. Click Yes throughout.

    8) Finally, it is time to plug it in! After you have plugged USB into laptop, go to Control Panel/Hardware and Sound/Sound/Manage audio devices. Choose US-122 as your default device for playback and recording, click Apply, then - OK. Done! :sol:


    THANK YOU SO MUCH!

    This absolutely worked for me, with one minor change. I am running Windows 8.1 Pro and wanted to install a TASCAM US-224. I followed the instructions substituting only the 224 drivers, and I did have to specify when Windows asked that it was "Windows Vista" and not "I don't know" otherwise it would not work. Other than that--perfect! Thanks again
  13. ksiemb said:
    kitandrew said:
    I know that drivers for tascam us-122 are not available on windows 8 but is there any way I can install them?

    Not available means, not available, ie not supported under windows 8.
    PS: You triple posted this. Refrain from doing that in the future, please !


    Dont be so negative. The following post is a working option. I was successfully able to get my old US122 working with Audacity on my Windows 8 laptop. Thank you Blackladder75 for the links. Thats what I was missing.
  14. Ok, new method:

    - Go to .exe and right click, properties, compatibility, run as administrator

    - Same page, compatibility mode -> Vista SP2

    - OK, run .exe

    - when done, Plug in the interface

    - the usb light should come on after ~1-3mins

    - if the windows installing new device window pops up just close it

    - you should now have the device available in playback devices
  15. Blackadder75 said:
    Hey, it IS possible! There is no Windows 8 driver because it is not needed. Windows 8 has a special feature for program compatibility. I just installed Tascam US-122 on my Windows 8 HP Pavilion g6 laptop.

    1) Go to http://tascam.com/product/us-122/downloads/ and download Windows Drivers v.3.40 Windows Vista and XP driver. Unzip it.

    2) In Control Panel/Programs/Programs and Features choose Run Programs Made for Previous Versions of Windows. It will open Program Compatibility Troubleshooter. Click Next.

    3) Your US-122 driver will not be listed there, so choose Not Listed and browse for it your downloads folder. You need the .exe file - in my case it did not show .exe extension, but it will show up once you choose it (remember, upzip first!).

    4) Program Compatibility Troubleshooter will ask you to select Troubleshooting Option. Click on Troubleshoot Program.

    5) When asked "What problems do you experience?" click on first - "The program worked in earlier versions of Windows but won't install or run now."

    6) When asked for previous version of windows, choose "I don't know". Another window opens, asking your permission to install Tascam.

    7) You will then have to install Tascam. Click Yes throughout.

    8) Finally, it is time to plug it in! After you have plugged USB into laptop, go to Control Panel/Hardware and Sound/Sound/Manage audio devices. Choose US-122 as your default device for playback and recording, click Apply, then - OK. Done! :sol:

    hi, this kind of old topic but i found it on the web and all that work for me, except the part when you have to choose one older version of windows when you have the option to choose "i don´t know" it doesn´t work for me, but i try with the "windows vista(service pack 2)" option and it went great... i have a sony vaio running windows 8
  16. Hi everyone! Thanks to your help I was able to run my Tascam US122 on my desktop Dell Windows 8.1. But now I have another problem, the pc now is much slower in the start-up and shutdown operations (expecially shut down, now it takes 4-5 mins to power off, instead of 10 seconds of yesterday). Looking at the Control Panel I found this:



    Can anyone give some suggestions?
    Thanks!
  17. Somebody can help me?
  18. gess sanx said:
    Blackadder75 said:
    Hey, it IS possible! There is no Windows 8 driver because it is not needed. Windows 8 has a special feature for program compatibility. I just installed Tascam US-122 on my Windows 8 HP Pavilion g6 laptop.

    1) Go to http://tascam.com/product/us-122/downloads/ and download Windows Drivers v.3.40 Windows Vista and XP driver. Unzip it.

    2) In Control Panel/Programs/Programs and Features choose Run Programs Made for Previous Versions of Windows. It will open Program Compatibility Troubleshooter. Click Next.

    3) Your US-122 driver will not be listed there, so choose Not Listed and browse for it your downloads folder. You need the .exe file - in my case it did not show .exe extension, but it will show up once you choose it (remember, upzip first!).

    4) Program Compatibility Troubleshooter will ask you to select Troubleshooting Option. Click on Troubleshoot Program.

    5) When asked "What problems do you experience?" click on first - "The program worked in earlier versions of Windows but won't install or run now."

    6) When asked for previous version of windows, choose "I don't know". Another window opens, asking your permission to install Tascam.

    7) You will then have to install Tascam. Click Yes throughout.

    8) Finally, it is time to plug it in! After you have plugged USB into laptop, go to Control Panel/Hardware and Sound/Sound/Manage audio devices. Choose US-122 as your default device for playback and recording, click Apply, then - OK. Done! :sol:



    Hi I just did this and its saying cannot install on my version of windows :(
  19. ksiemb said:
    kitandrew said:
    I know that drivers for tascam us-122 are not available on windows 8 but is there any way I can install them?

    Not available means, not available, ie not supported under windows 8.
    PS: You triple posted this. Refrain from doing that in the future, please !


    you fail. everything is possible... Before giving "advice" you should check yourself because now you just look like a moron. /claps
  20. Thanks - threads getting even older... but yes on both Windows 8.1 Pro and Home editions the VistaServicePack2 worked for me. You can also try the "recommended setting" - that thought for a while and came back with Vista SP2 as well.

    A big thank you to everyone who contributed here - I was so depressed when I thought I'd lost the USB122 when I finally got rid of my old XP box that I used for recording....
  21. holy f*cking sh*t, i LOVE you.

    how did you even find that, in the back of the control panel there, you clever little cookie. I spent 3 hours messing with this today to no avail and you've solved all of the problems i encountered with one flick of your tail. Yikes!
  22. Robbitybob said:


    Thanks - threads getting even older... but yes on both Windows 8.1 Pro and Home editions the VistaServicePack2 worked for me. You can also try the "recommended setting" - that thought for a while and came back with Vista SP2 as well.

    A big thank you to everyone who contributed here - I was so depressed when I thought I'd lost the USB122 when I finally got rid of my old XP box that I used for recording....


    I am about to try to connect new Dell Inspiron laptop to my US-122. Previously, I connected it to old Dell tower PC. I know I can connect the laptop to US-122 via a USB port, as I did for old Dell tower. But where / how do I connect the LINES OUT which presently are connected to back of old Dell which has RCA ports. Thanks.
  23. I'm now trying to install my Tascam US-122 on Windows 10 and when I tried the steps below it said "Cannot install on this version of Windows". Any suggestions?

    Blackadder75 said:
    Hey, it IS possible! There is no Windows 8 driver because it is not needed. Windows 8 has a special feature for program compatibility. I just installed Tascam US-122 on my Windows 8 HP Pavilion g6 laptop.

    1) Go to http://tascam.com/product/us-122/downloads/ and download Windows Drivers v.3.40 Windows Vista and XP driver. Unzip it.

    2) In Control Panel/Programs/Programs and Features choose Run Programs Made for Previous Versions of Windows. It will open Program Compatibility Troubleshooter. Click Next.

    3) Your US-122 driver will not be listed there, so choose Not Listed and browse for it your downloads folder. You need the .exe file - in my case it did not show .exe extension, but it will show up once you choose it (remember, upzip first!).

    4) Program Compatibility Troubleshooter will ask you to select Troubleshooting Option. Click on Troubleshoot Program.

    5) When asked "What problems do you experience?" click on first - "The program worked in earlier versions of Windows but won't install or run now."

    6) When asked for previous version of windows, choose "I don't know". Another window opens, asking your permission to install Tascam.

    7) You will then have to install Tascam. Click Yes throughout.

    8) Finally, it is time to plug it in! After you have plugged USB into laptop, go to Control Panel/Hardware and Sound/Sound/Manage audio devices. Choose US-122 as your default device for playback and recording, click Apply, then - OK. Done! :sol:
  24. I've worked out the solution to my question:

    Download the driver for XP & Vista from Tascam -> right click on Driver application file -> choose Troubleshoot compatibility -> choose Troubleshoot programs -> choose first option "The program worked in earlier versions of Windows but won't install or run now." -> click on Windows Vista option -> test program. It worked.

    I found that at the point where I had to choose the previous version of Windows, I tried every one until one worked. In other posts I've read, different computers worked with different options ticked. Mine only worked with Vista.
  25. emkw78 said:
    I've worked out the solution to my question:

    Download the driver for XP & Vista from Tascam -> right click on Driver application file -> choose Troubleshoot compatibility -> choose Troubleshoot programs -> choose first option "The program worked in earlier versions of Windows but won't install or run now." -> click on Windows Vista option -> test program. It worked.

    I found that at the point where I had to choose the previous version of Windows, I tried every one until one worked. In other posts I've read, different computers worked with different options ticked. Mine only worked with Vista.



    You just prevented me from spending $250 or near. Thanks bro! soundcloud.com/kabrapdubstep
  26. Kab___ said:
    emkw78 said:
    I've worked out the solution to my question:

    Download the driver for XP & Vista from Tascam -> right click on Driver application file -> choose Troubleshoot compatibility -> choose Troubleshoot programs -> choose first option "The program worked in earlier versions of Windows but won't install or run now." -> click on Windows Vista option -> test program. It worked.

    I found that at the point where I had to choose the previous version of Windows, I tried every one until one worked. In other posts I've read, different computers worked with different options ticked. Mine only worked with Vista.



    You just prevented me from spending $250 or near. Thanks bro! soundcloud.com/kabrapdubstep

  27. I tried all the suggestions to get a driver to work for the US-122 on Windows 10 and couldn't get any of them to work on my Dell Laptop. The drivers installation fails and the USB light doesn't light when I plug it into the USB slot. My suggestion is to think hard about a purchase of a US-122 if you are going to install in on a Windows 10 machine.
  28. HonestAbe999 said:
    I tried all the suggestions to get a driver to work for the US-122 on Windows 10 and couldn't get any of them to work on my Dell Laptop. The drivers installation fails and the USB light doesn't light when I plug it into the USB slot. My suggestion is to think hard about a purchase of a US-122 if you are going to install in on a Windows 10 machine.

    I had my us-122 for 13 years, still going strong on windows 10 haha
  29. Thank for the helpful info.
  30. I did each step just as you described. I have an HP desktop running windows 10 and it worked like magic! You MUST follow each step exactly and it WILL work. Got it on my first try on this forum. Now I am gonna try it on my Laptop! Thanks a million! You are a grand wizard of helpful knowledge! Now to start recording! AGAIN< THANKS!!!
    Kab___ said:
    emkw78 said:
    I've worked out the solution to my question:

    Download the driver for XP & Vista from Tascam -> right click on Driver application file -> choose Troubleshoot compatibility -> choose Troubleshoot programs -> choose first option "The program worked in earlier versions of Windows but won't install or run now." -> click on Windows Vista option -> test program. It worked.

    I found that at the point where I had to choose the previous version of Windows, I tried every one until one worked. In other posts I've read, different computers worked with different options ticked. Mine only worked with Vista.



    You just prevented me from spending $250 or near. Thanks bro! soundcloud.com/kabrapdubstep

  31. This is the step by step that I used to make it work on Windows 10. Make sure the Tascam US-224 or whichever Tascam unit you are using is plugged in via USB cable and turned ON. ->Download the driver for XP & Vista from Tascam -> Unzip folder into your download folder -> Open folder. -> right click on Driver application file -> choose Troubleshoot compatibility -> make sure at this point you select Troubleshoot programs -> choose first option "The program worked in earlier versions of Windows but won't install or run now." -> click on Windows Vista option -> click Test Program and the USB light should come on on your unit. -> Go through installation choosing language and setup. At this point your unit should work! ->Then you may have to adjust your input and outputs on whichever recording software you are using. -> But then it worked perfect. I did this first on my Desktop and immediately following on my laptop and have test recorded on both using my N-Track Studio 8 and it works flawlessly! If it is not working for you, then you are either skipping a step or not following the instructions exactly as described. I promise you if you do, it WILL work! 9/9/2016
  32. It did work out at my Windows 8.1 System too. I took the latest driver for Tascam US 122-L which is the same like the one mentioned by you: http://www.tascam.eu/sw/us-122l/TASCAM_USB2_x64_v202.zip
    papa kaliatis said:
    Hi all
    My problem was not solved with ANY "us-122" drivers in ANY compatibility mode.

    But what DID actually work was installing the driver :

    US-122mkII & US-144mkII Drivers for Windows 7, Vista, XP driver ver 2.03 (64-bit) - 1.76 MB

    at the page :

    http://tascam.com/product/us-122mkii/downloads/


    This is the driver for the model US-122MKII.
    As always: Download, unzip, right click the app file called "Setup" and go to "properties" of file.
    Then to second tab, the"compatibility" tab.
    I checked the box "run as administrator" and also the box "run this program in compatibility mode for".
    There I chose Vista, because the file i downloaded (tascam_us_122_144mk2_win64_203) said it was for vista. (Oh..... I have 64b Windows. If you have 32b download the 32b driver instead)


    And luckily it works! My friend who has the 144 model also used the equivalent driver.
    The system recognizes the card as "us-122" not as mk2, so my guess is that TASCAM obviously made this driver to work for this card as well, but never bothered to state it on their site.....

    Hope it helps others :)
Ask a new question

Read More

Drivers Windows 8