Another Read-Only Issue

Archived from groups: microsoft.public.windowsme.general (More info?)

I just had to do a complete system re-install. The OS, applications and
peripherals all seem to be working perfectly. My issue is that when I try to
copy all my files (mainly spreadsheets, word docs and photos) from the
back-up CDs I created before the re-install process, everything (folders and
files) shows up in Windows Explorer as read-only. Files also have that
designation when opened in their respective applications.

How can I get my folders and files so they appear "normally?" I am not sure
if the earlier post about read-only issues also answers my question and I was
reluctant to try it because I don't know enough to fool around with registry
settings unless I absolutely have to.

Also, will I have to recopy all my files from the back-up CDs or will the
above solution, or any new one, automatically fix all the read-only files I
have already transferred?

Thanks for the help!
14 answers Last reply
More about another read only issue
  1. Archived from groups: microsoft.public.windowsme.general (More info?)

    Google this: "ATTRIB -R *.* /S"

    John

    Ham wrote:

    > I just had to do a complete system re-install. The OS, applications and
    > peripherals all seem to be working perfectly. My issue is that when I try to
    > copy all my files (mainly spreadsheets, word docs and photos) from the
    > back-up CDs I created before the re-install process, everything (folders and
    > files) shows up in Windows Explorer as read-only. Files also have that
    > designation when opened in their respective applications.
    >
    > How can I get my folders and files so they appear "normally?" I am not sure
    > if the earlier post about read-only issues also answers my question and I was
    > reluctant to try it because I don't know enough to fool around with registry
    > settings unless I absolutely have to.
    >
    > Also, will I have to recopy all my files from the back-up CDs or will the
    > above solution, or any new one, automatically fix all the read-only files I
    > have already transferred?
    >
    > Thanks for the help!
  2. Archived from groups: microsoft.public.windowsme.general (More info?)

    What you are seeing is a feature of the Joliet/ISO filing system used when
    mastering CDs. This filing system knows nothing about file
    permissions/attributes and by convention all files restored from CD media
    are marked as read only. This is not an operating system issue but a
    consequence of the ISO standard.
    --
    Mike Maltby MS-MVP
    mike.maltby@gmail.com


    Ham <Ham@discussions.microsoft.com> wrote:

    > I just had to do a complete system re-install. The OS, applications
    > and peripherals all seem to be working perfectly. My issue is that
    > when I try to copy all my files (mainly spreadsheets, word docs and
    > photos) from the back-up CDs I created before the re-install process,
    > everything (folders and files) shows up in Windows Explorer as
    > read-only. Files also have that designation when opened in their
    > respective applications.
    >
    > How can I get my folders and files so they appear "normally?" I am
    > not sure if the earlier post about read-only issues also answers my
    > question and I was reluctant to try it because I don't know enough to
    > fool around with registry settings unless I absolutely have to.
    >
    > Also, will I have to recopy all my files from the back-up CDs or will
    > the above solution, or any new one, automatically fix all the
    > read-only files I have already transferred?
    >
    > Thanks for the help!
  3. Archived from groups: microsoft.public.windowsme.general (More info?)

    Files on CD's (though not necessarily CDRW discs) are Read-only. To remove
    the read-only attribute, r-click, select Properties, clear the Read-only
    check box and apply. You can do this to multiple files simultaneously, or
    you can do it to folders (whereupon you get the option to change just the
    folder's attributes or all the files within also). You can also do it from a
    command prompt but that isn't likkely to be required.

    Shane


    "Ham" <Ham@discussions.microsoft.com> wrote in message
    news:F98F810A-FD78-45C9-BE6C-888C0487EE75@microsoft.com...
    > I just had to do a complete system re-install. The OS, applications and
    > peripherals all seem to be working perfectly. My issue is that when I try
    to
    > copy all my files (mainly spreadsheets, word docs and photos) from the
    > back-up CDs I created before the re-install process, everything (folders
    and
    > files) shows up in Windows Explorer as read-only. Files also have that
    > designation when opened in their respective applications.
    >
    > How can I get my folders and files so they appear "normally?" I am not
    sure
    > if the earlier post about read-only issues also answers my question and I
    was
    > reluctant to try it because I don't know enough to fool around with
    registry
    > settings unless I absolutely have to.
    >
    > Also, will I have to recopy all my files from the back-up CDs or will the
    > above solution, or any new one, automatically fix all the read-only files
    I
    > have already transferred?
    >
    > Thanks for the help!
  4. Archived from groups: microsoft.public.windowsme.general (More info?)

    I copied my files onto a CDRW disc before I did my system re-installation, so
    I am assuming they should have whatever properties are normally associated
    with that format. Does this change your solution?

    I never really paid attention before, but are files copied this way always
    read-only?

    "Shane" wrote:

    > Files on CD's (though not necessarily CDRW discs) are Read-only. To remove
    > the read-only attribute, r-click, select Properties, clear the Read-only
    > check box and apply. You can do this to multiple files simultaneously, or
    > you can do it to folders (whereupon you get the option to change just the
    > folder's attributes or all the files within also). You can also do it from a
    > command prompt but that isn't likkely to be required.
    >
    > Shane
    >
    >
    > "Ham" <Ham@discussions.microsoft.com> wrote in message
    > news:F98F810A-FD78-45C9-BE6C-888C0487EE75@microsoft.com...
    > > I just had to do a complete system re-install. The OS, applications and
    > > peripherals all seem to be working perfectly. My issue is that when I try
    > to
    > > copy all my files (mainly spreadsheets, word docs and photos) from the
    > > back-up CDs I created before the re-install process, everything (folders
    > and
    > > files) shows up in Windows Explorer as read-only. Files also have that
    > > designation when opened in their respective applications.
    > >
    > > How can I get my folders and files so they appear "normally?" I am not
    > sure
    > > if the earlier post about read-only issues also answers my question and I
    > was
    > > reluctant to try it because I don't know enough to fool around with
    > registry
    > > settings unless I absolutely have to.
    > >
    > > Also, will I have to recopy all my files from the back-up CDs or will the
    > > above solution, or any new one, automatically fix all the read-only files
    > I
    > > have already transferred?
    > >
    > > Thanks for the help!
    >
    >
    >
  5. Archived from groups: microsoft.public.windowsme.general (More info?)

    Shane,

    Rather than files written to CDRW I suspect you meant files written to
    disk (both R and RW) with packet software using the UDF format (Universal
    Disk Format) such as Roxio's DirectCD and Ahead's InCD.
    --
    Mike Maltby MS-MVP
    mike.maltby@gmail.com


    Shane <arthursixpence@hotmail.com> wrote:

    > Files on CD's (though not necessarily CDRW discs) are Read-only. To
    > remove the read-only attribute, r-click, select Properties, clear the
    > Read-only check box and apply. You can do this to multiple files
    > simultaneously, or you can do it to folders (whereupon you get the
    > option to change just the folder's attributes or all the files within
    > also). You can also do it from a command prompt but that isn't
    > likkely to be required.
  6. Archived from groups: microsoft.public.windowsme.general (More info?)

    Ham <Ham@discussions.microsoft.com> wrote:

    > I copied my files onto a CDRW disc before I did my system
    > re-installation, so I am assuming they should have whatever
    > properties are normally associated with that format. Does this
    > change your solution?
    >
    > I never really paid attention before, but are files copied this way
    > always read-only?

    Whether the files have retained their attributes of not depends entirely
    on the filing system used on the disk rather than the type of disk and
    that filing system depends on the application used.

    Files written to CDR/RW using mastering software and hence to the
    ISO/Joliet standard have no attributes associated with them and will
    always be restored as read only.
    Files written to CDR/RW using packet software and therefore using the UDF
    format will retain their attributes.

    Note that disks written using the UDF system should not be considered
    suitable for archive or back up use due to the frequent problems
    encountered when attempting to read the resulting disks on systems other
    than that on which the CD was initially written.
    --
    Mike Maltby MS-MVP
    mike.maltby@gmail.com
  7. Archived from groups: microsoft.public.windowsme.general (More info?)

    Indeed, Mike, thanks for the correction.

    Shane


    "Mike M" <No_Spam@Corned_Beef.Only> wrote in message
    news:%23ii8rwuCFHA.2540@TK2MSFTNGP09.phx.gbl...
    > Shane,
    >
    > Rather than files written to CDRW I suspect you meant files written to
    > disk (both R and RW) with packet software using the UDF format (Universal
    > Disk Format) such as Roxio's DirectCD and Ahead's InCD.
    > --
    > Mike Maltby MS-MVP
    > mike.maltby@gmail.com
    >
    >
    > Shane <arthursixpence@hotmail.com> wrote:
    >
    > > Files on CD's (though not necessarily CDRW discs) are Read-only. To
    > > remove the read-only attribute, r-click, select Properties, clear the
    > > Read-only check box and apply. You can do this to multiple files
    > > simultaneously, or you can do it to folders (whereupon you get the
    > > option to change just the folder's attributes or all the files within
    > > also). You can also do it from a command prompt but that isn't
    > > likkely to be required.
    >
  8. Archived from groups: microsoft.public.windowsme.general (More info?)

    As Mike says, Ham. It is, rather, the application you copied them with - one
    for ISO/Joliet as against UDF.


    Shane


    "Ham" <Ham@discussions.microsoft.com> wrote in message
    news:05AD2006-6B0E-42B7-9E52-AFC01C0D1DF4@microsoft.com...
    > I copied my files onto a CDRW disc before I did my system re-installation,
    so
    > I am assuming they should have whatever properties are normally associated
    > with that format. Does this change your solution?
    >
    > I never really paid attention before, but are files copied this way always
    > read-only?
    >
    > "Shane" wrote:
    >
    > > Files on CD's (though not necessarily CDRW discs) are Read-only. To
    remove
    > > the read-only attribute, r-click, select Properties, clear the Read-only
    > > check box and apply. You can do this to multiple files simultaneously,
    or
    > > you can do it to folders (whereupon you get the option to change just
    the
    > > folder's attributes or all the files within also). You can also do it
    from a
    > > command prompt but that isn't likkely to be required.
    > >
    > > Shane
    > >
    > >
    > > "Ham" <Ham@discussions.microsoft.com> wrote in message
    > > news:F98F810A-FD78-45C9-BE6C-888C0487EE75@microsoft.com...
    > > > I just had to do a complete system re-install. The OS, applications
    and
    > > > peripherals all seem to be working perfectly. My issue is that when I
    try
    > > to
    > > > copy all my files (mainly spreadsheets, word docs and photos) from the
    > > > back-up CDs I created before the re-install process, everything
    (folders
    > > and
    > > > files) shows up in Windows Explorer as read-only. Files also have
    that
    > > > designation when opened in their respective applications.
    > > >
    > > > How can I get my folders and files so they appear "normally?" I am
    not
    > > sure
    > > > if the earlier post about read-only issues also answers my question
    and I
    > > was
    > > > reluctant to try it because I don't know enough to fool around with
    > > registry
    > > > settings unless I absolutely have to.
    > > >
    > > > Also, will I have to recopy all my files from the back-up CDs or will
    the
    > > > above solution, or any new one, automatically fix all the read-only
    files
    > > I
    > > > have already transferred?
    > > >
    > > > Thanks for the help!
    > >
    > >
    > >
  9. Archived from groups: microsoft.public.windowsme.general (More info?)

    Shane,

    I hope you don't mind but I commented because:
    a) I often write to CDRW disks using Nero (ISO/Joliet), mainly to test
    video encodes to check that they will play in my standalone DVD player
    that supports DivX and XviD.
    b) Whilst DirectCD I think only supports CDRW I'm not sure the same is
    true of Ahead's InCD which I think can also write to CDR. I know that the
    late lamented CeQuadrat (Roxio have a lot to answer for) had a UDF
    application, which I think was called PacketCD, which could be used with
    both CDR and CDRW media.
    --
    Mike


    Shane <arthursixpence@hotmail.com> wrote:

    > Indeed, Mike, thanks for the correction.
  10. Archived from groups: microsoft.public.windowsme.general (More info?)

    Mike,

    > I hope you don't mind but I commented because:

    No, not at all. Actually I wonder if I'll *ever* stop making that error.

    > b) Whilst DirectCD I think only supports CDRW I'm not sure the same is
    > true of Ahead's InCD which I think can also write to CDR. I know that the

    I just checked InCD's Help documentation and it's quite emphatic that it
    cannot be used with CDRs.


    Shane
  11. Archived from groups: microsoft.public.windowsme.general (More info?)

    > I just checked InCD's Help documentation and it's quite emphatic that
    > it cannot be used with CDRs.

    Thanks for checking that Shane since I don't have InCD installed or any
    other packet software come to that. I wonder if this has changed at some
    time as I thought InCD could write to CDR at one stage. I know that
    packet writing to CDR and CDRW is/was done differently with, I think, CDRW
    being written using fixed length blocks whereas when writing to CDR
    variable length blocks can/are(?) used. I can see variable length blocks
    being a potential cause of problems.
    --
    Mike
    (Who's decided on an early night with a book <g>)


    Shane <arthursixpence@hotmail.com> wrote:

    > I just checked InCD's Help documentation and it's quite emphatic that
    > it cannot be used with CDRs.
  12. Archived from groups: microsoft.public.windowsme.general (More info?)

    > Mike
    > (Who's decided on an early night with a book <g>)
    >

    Don't blame you, Mike! I've managed an improved book-computer ratio myself
    lately. But right now I've had to get up again, despite taking a Nytol an
    hour ago. Now I'm back to bed to try again!

    Hope it's a good book!


    Shane
  13. Archived from groups: microsoft.public.windowsme.general (More info?)

    "Ham" wrote:

    > I just had to do a complete system re-install. The OS, applications and
    > peripherals all seem to be working perfectly. My issue is that when I try to
    > copy all my files (mainly spreadsheets, word docs and photos) from the
    > back-up CDs I created before the re-install process, everything (folders and
    > files) shows up in Windows Explorer as read-only. Files also have that
    > designation when opened in their respective applications.
    >
    > How can I get my folders and files so they appear "normally?" I am not sure
    > if the earlier post about read-only issues also answers my question and I was
    > reluctant to try it because I don't know enough to fool around with registry
    > settings unless I absolutely have to.
    >
    > Also, will I have to recopy all my files from the back-up CDs or will the
    > above solution, or any new one, automatically fix all the read-only files I
    > have already transferred?
    >
    > Thanks for the help!
  14. Archived from groups: microsoft.public.windowsme.general (More info?)

    All my CD-RW discs became read only after I updated Windows Media Player.
    I read the InCD manual and did as they suggested. Uninstall InCD and then
    reinstall it and I have had no problem since.


    "Ham" wrote:

    > I just had to do a complete system re-install. The OS, applications and
    > peripherals all seem to be working perfectly. My issue is that when I try to
    > copy all my files (mainly spreadsheets, word docs and photos) from the
    > back-up CDs I created before the re-install process, everything (folders and
    > files) shows up in Windows Explorer as read-only. Files also have that
    > designation when opened in their respective applications.
    >
    > How can I get my folders and files so they appear "normally?" I am not sure
    > if the earlier post about read-only issues also answers my question and I was
    > reluctant to try it because I don't know enough to fool around with registry
    > settings unless I absolutely have to.
    >
    > Also, will I have to recopy all my files from the back-up CDs or will the
    > above solution, or any new one, automatically fix all the read-only files I
    > have already transferred?
    >
    > Thanks for the help!
Ask a new question

Read More

Windows Explorer Read Only Windows