enforce screen saver password

Archived from groups: microsoft.public.win2000.general,microsoft.public.windowsnt.domain (More info?)

Hi,

I am trying to enforce screen saver password to certain users in my domain.

I created a pwd.reg file which contains
REGEDIT4

[HKEY_CURRENT_USER\Control Panel\Desktop]
"SCRNSAVE.EXE"="C:\\WINNT\\system32\\logon.scr"
"ScreenSaveActive"="1"
"ScreenSaveTimeOut"="120"
"ScreenSaverIsSecure"="1"

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control
Panel\Desktop]
"ScreenSaverIsSecure"=dword:00000001

I added this line in the login script "regedit /s \\{server}\pwd.reg"

But I got this error during login "Cannot import \\{server}\pwd.reg : error
accessing regisrty"

Any way to get around this without giving users admin permission?
What is the "regedit /r" parameter used for? I tried adding the "/r"
parameter and pointed it to %username% and did not get the error, but it did
not change the registry as well.

Thanks.
3 answers Last reply
More about enforce screen saver password
  1. Archived from groups: microsoft.public.win2000.general,microsoft.public.windowsnt.domain (More info?)

    Use Group Policy.

    The settings for the screensaver are here

    User Configuration--Administrative Templates--Control Panel--Display

    Regards
    Mark Dormer


    "Eugene" <@> wrote in message news:eKUK1zVkEHA.3648@TK2MSFTNGP09.phx.gbl...
    > Hi,
    >
    > I am trying to enforce screen saver password to certain users in my
    > domain.
    >
    > I created a pwd.reg file which contains
    > REGEDIT4
    >
    > [HKEY_CURRENT_USER\Control Panel\Desktop]
    > "SCRNSAVE.EXE"="C:\\WINNT\\system32\\logon.scr"
    > "ScreenSaveActive"="1"
    > "ScreenSaveTimeOut"="120"
    > "ScreenSaverIsSecure"="1"
    >
    > [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control
    > Panel\Desktop]
    > "ScreenSaverIsSecure"=dword:00000001
    >
    > I added this line in the login script "regedit /s \\{server}\pwd.reg"
    >
    > But I got this error during login "Cannot import \\{server}\pwd.reg :
    > error
    > accessing regisrty"
    >
    > Any way to get around this without giving users admin permission?
    > What is the "regedit /r" parameter used for? I tried adding the "/r"
    > parameter and pointed it to %username% and did not get the error, but it
    > did
    > not change the registry as well.
    >
    > Thanks.
    >
    >
    >
    >
  2. Archived from groups: microsoft.public.win2000.general,microsoft.public.windowsnt.domain (More info?)

    Hi Mark,

    Thank for the quick reply.

    Sorry, I forgot to mention I'm using a NT PDC. I using a mix environment.

    I'm not familiar with NT policies. I tried using the System policy on my DC
    but I can only prevent password from being remove, not enforcing it.

    Thanks.

    "Mark Dormer" <markd@mvpsx.org> wrote in message
    news:uIJUlDWkEHA.1252@TK2MSFTNGP14.phx.gbl...
    > Use Group Policy.
    >
    > The settings for the screensaver are here
    >
    > User Configuration--Administrative Templates--Control Panel--Display
    >
    > Regards
    > Mark Dormer
    >
    >
    > "Eugene" <@> wrote in message
    news:eKUK1zVkEHA.3648@TK2MSFTNGP09.phx.gbl...
    > > Hi,
    > >
    > > I am trying to enforce screen saver password to certain users in my
    > > domain.
    > >
    > > I created a pwd.reg file which contains
    > > REGEDIT4
    > >
    > > [HKEY_CURRENT_USER\Control Panel\Desktop]
    > > "SCRNSAVE.EXE"="C:\\WINNT\\system32\\logon.scr"
    > > "ScreenSaveActive"="1"
    > > "ScreenSaveTimeOut"="120"
    > > "ScreenSaverIsSecure"="1"
    > >
    > > [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control
    > > Panel\Desktop]
    > > "ScreenSaverIsSecure"=dword:00000001
    > >
    > > I added this line in the login script "regedit /s \\{server}\pwd.reg"
    > >
    > > But I got this error during login "Cannot import \\{server}\pwd.reg :
    > > error
    > > accessing regisrty"
    > >
    > > Any way to get around this without giving users admin permission?
    > > What is the "regedit /r" parameter used for? I tried adding the "/r"
    > > parameter and pointed it to %username% and did not get the error, but it
    > > did
    > > not change the registry as well.
    > >
    > > Thanks.
    > >
    > >
    > >
    > >
    >
    >
  3. Archived from groups: microsoft.public.win2000.general,microsoft.public.windowsnt.domain (More info?)

    just in case anyone is interested...

    I used a system policy to enforce the screen saver password instead.

    you can find more info at MS KB article - 195655

    "Eugene" <@> wrote in message news:eKagHUWkEHA.1252@TK2MSFTNGP14.phx.gbl...
    > Hi Mark,
    >
    > Thank for the quick reply.
    >
    > Sorry, I forgot to mention I'm using a NT PDC. I using a mix environment.
    >
    > I'm not familiar with NT policies. I tried using the System policy on my
    DC
    > but I can only prevent password from being remove, not enforcing it.
    >
    > Thanks.
    >
    > "Mark Dormer" <markd@mvpsx.org> wrote in message
    > news:uIJUlDWkEHA.1252@TK2MSFTNGP14.phx.gbl...
    > > Use Group Policy.
    > >
    > > The settings for the screensaver are here
    > >
    > > User Configuration--Administrative Templates--Control Panel--Display
    > >
    > > Regards
    > > Mark Dormer
    > >
    > >
    > > "Eugene" <@> wrote in message
    > news:eKUK1zVkEHA.3648@TK2MSFTNGP09.phx.gbl...
    > > > Hi,
    > > >
    > > > I am trying to enforce screen saver password to certain users in my
    > > > domain.
    > > >
    > > > I created a pwd.reg file which contains
    > > > REGEDIT4
    > > >
    > > > [HKEY_CURRENT_USER\Control Panel\Desktop]
    > > > "SCRNSAVE.EXE"="C:\\WINNT\\system32\\logon.scr"
    > > > "ScreenSaveActive"="1"
    > > > "ScreenSaveTimeOut"="120"
    > > > "ScreenSaverIsSecure"="1"
    > > >
    > > > [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control
    > > > Panel\Desktop]
    > > > "ScreenSaverIsSecure"=dword:00000001
    > > >
    > > > I added this line in the login script "regedit /s \\{server}\pwd.reg"
    > > >
    > > > But I got this error during login "Cannot import \\{server}\pwd.reg :
    > > > error
    > > > accessing regisrty"
    > > >
    > > > Any way to get around this without giving users admin permission?
    > > > What is the "regedit /r" parameter used for? I tried adding the "/r"
    > > > parameter and pointed it to %username% and did not get the error, but
    it
    > > > did
    > > > not change the registry as well.
    > > >
    > > > Thanks.
    > > >
    > > >
    > > >
    > > >
    > >
    > >
    >
    >
Ask a new question

Read More

Domain Desktops Microsoft Windows